Subject: RE: [Sipping-emergency] proposed charter, new wg on emergency calling and routing

From: "Marc Linsner" <[email-masked]>
Date: Mon, 27 Sep 2004 15:52:08 -0400

A point I tried to make wrt your example was to say that even current MSAG
architectures allow jurisdictional lines to split streets in many different
configurations without requiring exotic things to happen (like ERC overlay
naming, etc.).

In VoIP, pre-validation of civil location prevents call routing failures.
Yes, for this reason, validation is a good thing.  I also would submit that
if the VoIP call got routed to an ERC, then it's most likely dispatchable
(so we may be able to quit using that argument).  I would purpose to the
user(s), that in areas where ERC jurisdictional lines are grossly different
from civil address lines, then loose routing based solely on city/town
would/should not be implemented.  VoIP makes it almost impossible to
'default route' due to VPN tunnels, etc. as compared to legacy mechanisms.

-Marc-

> -----Original Message-----
> From: Brian Rosen [mailto:[email-masked]] 
> Sent: Monday, September 27, 2004 3:20 PM
> To: 'Marc Linsner'; [email-masked]
> Subject: RE: [Sipping-emergency] proposed charter,new wg on 
> emergency calling and routing
> 
> 
> Agreed that you COULD change the way the system works now to 
> have a translation from postal address to dispatch address.  
> They don't do that now, but they could.  In that regard, 
> maybe a bad example.  If you were to propose that the system 
> have a translation, then some kind of spec would have to be 
> written that said that, which might be a new deliverable.
> 
> Misspellings, missing or extra directionals (North, 
> Southwest, ..), confusion between Main Street and Main Drive, 
> etc. are better examples. The point is to make sure that the 
> call will be routed correctly, and responders will be 
> dispatched correctly BEFORE the location is needed to do so, 
> and the only way we know how to do that is to compare the 
> address against some kind of master list.
> 
> Brian
> 
> > -----Original Message-----
> > From: Marc Linsner [mailto:[email-masked]]
> > Sent: Monday, September 27, 2004 3:09 PM
> > To: 'Brian Rosen'; [email-masked]
> > Subject: RE: [Sipping-emergency] proposed charter,new wg on 
> emergency 
> > calling and routing
> > 
> > In-line.....
> > 
> > > -----Original Message-----
> > > From: [email-masked]
> > > [mailto:[email-masked]] On Behalf Of 
> Brian Rosen
> > > Sent: Monday, September 27, 2004 12:04 PM
> > > To: 'James M. Polk'; 'Peterson, Jon'; [email-masked]
> > > Cc: [email-masked]
> > > Subject: RE: [Sipping-emergency] proposed charter,new wg on 
> > > emergency calling and routing
> > > Importance: Low
> > >
> > >
> > > When you place an emergency call, the location is used to 
> determine 
> > > where to send the call, and it is used to dispatch 
> responders.  If 
> > > the location you supply does not match anything the call center 
> > > recognizes, the wrong thing may happen.  What you want to 
> do is to 
> > > compare the address you have against a list maintained by the 
> > > emergency response system to make sure they know where that is.
> > >
> > > An example is illustrative.  If you ask me my home 
> address, I'd tell 
> > > you that it is 470 Conrad Drive, Mars, PA.  However, that 
> is NOT the 
> > > address that should be used to determine where to send an 
> emergency 
> > > call from my home.  That is because the post office 
> boundary is not 
> > > the same as the emergency call system boundary.
> > 
> > So?  As long as '470 Conrad Drive, Mars, PA.' is unique, 
> modern data 
> > processing can handle it.
> > 
> > If you were to determine the
> > > serving ERC without validation, you would send my 
> emergency call to 
> > > the Butler County ERC, which serves Mars, rather than to 
> the NEWCOM 
> > > center that serves Pine Township, where I live.
> > 
> > Validation and routing are 2 separate issues.  If in fact, 470 
> > Conrad....., is a good address, the routing function (which will be 
> > based on data from the ERC entities) better get it right 
> and send the 
> > call the NEWCOM center as
> > you describe.  All that validation *may* offer is to verify 
> that you (the
> > end-user) didn't spell Conrad as Conard (or put Street 
> instead of Drive,
> > etc.)!  I realize there are locales that utilize a 
> different 'location'
> > address for emergency purposes than the postal address, but 
> the IETF can't
> > fix this.
> > 
> > I'm not against validation, but your example isn't the real 
> reason for 
> > validation.
> > 
> > >
> > [snip]
> > 
> > -Marc Linsner-
> > 
> > 
> 
> 
> 
> 

_______________________________________________
Sipping-emergency mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sipping-emergency

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 27 Sep 2004 16:12:38 -0400

I changed the subject, as we are off the subject of a new charter,
as we agree validation should be in that charter.

Agree that boundaries are irregular in many strange and wonderous ways and
we probably have to live with that rather than demand that they change their
service boundaries to make routing easier.

I do think that if we can answer the call as VoIP in the ERC, then we can
transfer the call, with location, to the correct ERC in the case of a
routing failure, which is a Very Good Thing (tm).  I further propose that
civic address is hierarchical, and "default" routing can be hierarchical.
If you have a valid municipality name, but an invalid street, you can route
to a default for that municipality.  If you have a valid state, but an
invalid county or municipality name, you can route to a default for that
state, etc.  Of course, in many countries, there is only one ERC for the
country, so default routing is easier for them.

Brian

> Sent: Monday, September 27, 2004 3:52 PM
> Subject: RE: [Sipping-emergency] proposed charter,new wg on emergency
> calling and routing
>