Subject: RE: [Sipping-emergency] RE: Civil location syntax validation - wa s RE: How to handle Validation failures

From: "Peterson, Jon" <[email-masked]>
Date: Tue, 28 Sep 2004 19:50:06 -0400

So, just to make sure I understand, validation uses the same network
operation, basically, that would be used for a route query?

Agreed that it should be possible for a route query to return 'I didn't
understand your address format', 'I understand your address and it isn't
actually valid', and so on beyond just the sunny-day case of returning the
route. Also, plus or minus some authorization and operational issues, I
agree that an ordinary user should be able to launch this sort of query
outside the context of an emergency call.

To be clear, what I want to avoid is specifying exactly what happens in the
backend of the server that causes responses like 'your address isn't
actually valid'. I don't think we have the expertise to address that.

Provided that the essence of the proposed requirement is that it be possible
to use the route query mechanism as a validation mechanism, I have no
problem with this. The question is, are there any differences in
architecture/network messaging/security model/etc that I'm missing, here,
which result from this requirement? If not, is this requirement inert (i.e.,
does it fail to have any impact on our protocol design)?

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: Brian Rosen [mailto:[email-masked]]
> Sent: Tuesday, September 28, 2004 6:02 AM
> To: 'Marc Linsner'; 'Peterson, Jon'; [email-masked]
> Subject: [Sipping-emergency] RE: Civil location syntax 
> validation - was
> RE: How to handle Validation failures
> 
> 
> Yeah, that's the way I see it. 
> 
> Validation is a requirement.
> Validation is the first part of determining a route:
> A query using the location information as the key.
> 
> Any answer is validation.  The answer is the route.
> 
> You can do the validation query without needing the route.
> You do that as an independent verification that the
> location information is valid.  Validation is
> automatically performed when you determine the route,
> either during a test operation as Henning describes,
> or for the actual call (not implying whether route
> determination is done prior to or at the time of 
> an emergency call).
> 
> Jon, is that sufficient information to consider validation
> within the charter?
> 
> Brian
> 
> > -----Original Message-----
> > From: Marc Linsner [mailto:[email-masked]]
> > Sent: Tuesday, September 28, 2004 8:54 AM
> > To: 'Peterson, Jon'; 'Brian Rosen'; [email-masked]
> > Subject: Civil location syntax validation - was RE: How to handle
> > Validation failures
> > 
> > Changed the subject line to more correctly describe the function.
> > 
> > Civil location syntax validation could be considered as a 
> requirement when
> > determining the routing design.  If routing is designed properly,
> > validation
> > will simply be a routing query that utilizes the response 
> differently.
> > Validation, in this context, does not include the 
> verification that the
> > device is actually located where it claims to be, it is 
> simply a process
> > that verifies that the syntax/value of the location 
> provided describes a
> > valid location known by all.  A simple routing query that produces a
> > routing
> > result is validation in this context.
> > 
> > 
> > -Marc Linsner-
> > 
> > 
> > 
> > 
> > 
> > > -----Original Message-----
> > > From: Peterson, Jon [mailto:[email-masked]]
> > > Sent: Monday, September 27, 2004 7:42 PM
> > > To: 'Brian Rosen'; 'Marc Linsner'; [email-masked]
> > > Subject: RE: How to handle Validation failures was RE:
> > > [Sipping-emergency] proposed charter, new wg on emergency
> > >
> > >
> > >
> > > > I changed the subject, as we are off the subject of a new
> > > charter, as
> > > > we agree validation should be in that charter.
> > > >
> > >
> > > Brian,
> > >
> > > I'm not sure that everyone on this distribution agrees that
> > > validation should be in the scope of this proposed working
> > > group. In fact, until I read your mail, I had gotten the
> > > sense that several voices (including James, Marc and Nate)
> > > were questioning this idea.
> > >
> > > I think validation as such is probably outside of the core
> > > expertise of the IETF, whereas routing is more likely to be a
> > > place where we can do some solid work. The expertise of the
> > > IETF does not lie in subjects like whether Conrad St is in
> > > Butler County or Pine Township, nor in recommending how you
> > > might figure something like that out. Moreover, this seems to
> > > be a back-end application issue, not a protocol issue, as I
> > > think a number of people have already pointed out.
> > >
> > > I think that validation is a separable operation from
> > > routing, even if it is a prerequisite in some operational
> > > models. An umbrella specification that described everything
> > > you needed to do in order to provide emergency services might
> > > include validation, but that doesn't mean that the routing
> > > protocol should change in any way because validation was or
> > > was not performed. But I don't think the IETF has the breadth
> > > to tackle that whole umbrella.
> > >
> > > Jon Peterson
> > > NeuStar, Inc.
> > >
> > 
> > 
> 
> 
> 
> 
> _______________________________________________
> Sipping-emergency mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sipping-emergency
> 

_______________________________________________
Sipping-emergency mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sipping-emergency

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 28 Sep 2004 23:04:12 -0400

inline.

> outside the context of an emergency call.

I'm not so sure of that.

It seems that there is a lot of very useful information in this database 
- which addresses exist, which do not, and information on the relative 
proximity of civil addresses to each other (two addresses that map to 
the same ERC would be "close" in some way). As a result, I feel that 
there are probably privacy implications of allowing worldwide open 
access to this database. Seems like it would be mined by spammers to 
validate mailing addresses, and used for all sorts of other nefarious 
purposes.

Along those lines, I think it might be a good idea to sprinkle some nice 
words into the charter about taking into consideration privacy concerns, 
and properly balancing them with the needs of emergency call routing.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: "James M. Polk" <[email-masked]>
Date: Tue, 28 Sep 2004 22:52:10 -0500

>and properly balancing them with the needs of emergency call routing.

this is what I was referring to when I made the quip about being steered.

I see this being a tracking capability.

The phone (or multimedia device in general) has to obtain an address given 
by the network and test its deliverability to a government service before 
that device will potentially ever be used for any service (not just 
911).  This means to me that "the system" always knows where the device is 
(because it always delivers an accurate and valid address to it, and that 
device test pings for reachability and accuracy of the location it is 
given, on an ongoing basis).

The periodic test ping/no-op packets ensuring a PSAP can be reached if a 
911-type session is attempted has to reveal the return addressing, 
including each user's URI.

This has huge hijacking and misuse potential written all over it, as 
Jonathan pointed out; not only in the database, but in the gleaning of 
packets to and from targets.

>-Jonathan R.

cheers,
James

                                *******************
                 Truth is not to be argued... it is to be presented

---

From: "Marc Linsner" <[email-masked]>
Date: Wed, 29 Sep 2004 09:30:40 -0400

Jonathan,

In-line.....

> > Agreed that it should be possible for a route query to return 'I
> > didn't understand your address format', 'I understand your 
> address and
> > it isn't actually valid', and so on beyond just the
> sunny-day case of
> > returning the route. Also, plus or minus some authorization and
> > operational issues, I agree that an ordinary user should be able to 
> > launch this sort of query outside the context of an emergency call.
> 
> I'm not so sure of that.
> 

If you don't open up the ability to view the civil address routing
information, including the ability to 'mine' the address information, the
alternative would be to create a for-fee service to gain access to this
public information.  I suggest you look at and play with:

http://zip4.usps.com/zip4/welcome.jsp

In your example, spammers would love this site.

Street addresses are already public information that is freely available.

-Marc Linsner-