Subject: RE: [Ecrit] I3, I4, I8

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Fri, 27 May 2005 10:22:58 -0400

Henning,

I must have missed something that was not posted to the mail list.

Is the ESRP a substitute for the Selective Router, once the TDM
components are gone?

That is, a route server (proxy) serving the calling party routes calls
to the ESRP that can terminate to the called PSAP?

Mike

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Henning Schulzrinne
> Sent: Wednesday, May 25, 2005 10:36 PM
> To: Andrew Newton; [email-masked]
> Subject: Re: [Ecrit] I3, I4, I8
> 
> Andrew Newton wrote:
> > 
> 
> > I don't think this is a terminology issue.  The statement should be 
> > about some high level function that the protocol 
> MUST/SHOULD support, 
> > and I doubt that high-level function is incremental URL 
> resolution.  
> > If the requirement is that the a mapping server for a large 
> geographic 
> > area should be able to refer clients to mapping servers responsible 
> > for subsets of the geographic area, then let's say that.  However, a
> 
> Works for me.
> 
> 
> > statement that speaks of passing around URL's so that they may be 
> > reiteratively invoked seems to be speaking to a solution and not a 
> > functional requirement.
> > 
> > Its possible we did agree on that, and I just zoned it out.  What 
> > exactly is it suppose to do and which protocol is related 
> to?  Is it 
> > to speak the same language as the mapping protocol or is it more 
> > specific to a using protocol? What are the properties 
> associated with 
> > its proxy function?
> 
> It's the logical entity that routes call signaling and is one 
> of the logical entities invoking the mapping protocol as well 
> as an entity that would be identified (by URL, presumably) as 
> the output of the mapping protocol.
> 
> In SIP terms: it's a proxy server. Could be the proxy server 
> for a whole emergency services region (county, country, 
> state) or for a single PSAP.
> 
> 
> 
> > 
> > -andy
> 
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit
> 

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 27 May 2005 10:34:53 -0400

> Is the ESRP a substitute for the Selective Router, once the TDM

I'm somewhat loath to use TDM analogies as they never quite fit, but in 
some very rough sense, yes.

> to the ESRP that can terminate to the called PSAP?

Not quite. The ESRP is the call routing entity that invokes the 
location-to-URL mapping, which in turn may return either the URL for 
another ESRP or the PSAP. In a SIP system, the ESRP would typically be a 
SIP proxy, but I suspect it could also be a B2BUA if you subscribe to 
that particular religion.

(To avoid needless "but" messages: We all recognize that the end system 
can also invoke the mapping function.)