Subject: RE: [Ecrit] ECRIT requirements: R5 reprise

From: "Roger Marshall" <[email-masked]>
Date: Wed, 12 Oct 2005 16:40:13 -0700

All:
ECRIT Requirements, outstanding issues. Back to finishing up the easy
stuff before the next draft revision.

[Compare with existing R5 in
http://www.ietf.org/internet-drafts/draft-ietf-ecrit-requirements-00.txt
]

See the thread. Per the contribution below, I propose that we replace
the original R5 with Ted's version of the text, since I think that the
language "SHOULD allow" already protects which equates to "SHOULD NOT
inhibit".  Besides, I generally like stating requirements in the
positive, rather than what ought not to be (where possible).

A. R5(Ted's): Alternate Mapping Sources: The mapping protocol 
SHOULD allow for alternative redundant sources of mapping information, 
possibly of different degrees of currency.

B. R5(Andy's): The mapping protocol SHOULD NOT inhibit the deployment of

alternative redundant sources of mapping information, possibly of 
different degrees of currency.

Motivation: This provides the possibility of having available 
alternative sources of mapping information when the normal source  is 
unavailable or unreachable, without specifying the means by  which 
the alternative source is created or updated.

Andy, can you live with req. form A?  Any others object to form A?

Roger Marshall

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] 
>On Behalf Of Tom-PT Taylor
>Sent: Monday, September 19, 2005 11:46 AM
>To: Andrew Newton
>Cc: [email-masked]
>Subject: Re: [Ecrit] ECRIT requirements: R5 reprise
>
>I'll buy your tweak, and I do apologize: it was Ted, not Marc.
>
>Andrew Newton wrote:
>> 
>> On Sep 19, 2005, at 1:52 PM, Tom-PT Taylor wrote:
>> 
>>> We had a fair-sized discussion on R5 at the beginning of 
>July.   Marc 
>>> formulated an alternative statement that seemed to hold  promise.  
>>> Andrew ignored it and quarelled with Henning instead.  I  
>suggest we 
>>> go with Marc's formulation with a slight tweak:
>> 
>> 
>> I did not see Marc's message, and still do not see it in my local  
>> copy or the IETF archives (I'm not doubting it was sent, I'm just  
>> curious why I missed it).
>> 
>> BTW, I was not the only one with objections to R5.  Ted proposed an 
>> alternative as well.
>> 
>>> "R5: The mapping protocol should allow for alternative redundant 
>>> sources of mapping information, possibly of different degrees of 
>>> currency.
>>>
>>> "Motivation: This provides the possibility of having available 
>>> alternative sources of mapping information when the normal 
>source  is 
>>> unavailable or unreachable, without specifying the means by  which 
>>> the alternative source is created or updated."
>>>
>>> I think this proposition has concrete implications for protocol 
>>> design, hence should be stated.
>> 
>> 
>> Well, I like this much better than the current version.  Perhaps a 
>> slight tweak:
>> 
>> R5: The mapping protocol should not inhibit the deployment of 
>> alternative redundant sources of mapping information, possibly of 
>> different degrees of currency."
>> 
>> -andy
>> 
>> 
>
>
>_______________________________________________
>Ecrit mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ecrit
>

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Andrew Newton <[email-masked]>
Date: Thu, 13 Oct 2005 15:27:34 -0400

On Oct 12, 2005, at 7:40 PM, Roger Marshall wrote:

> Andy, can you live with req. form A?

Yes.

-andy