Subject: RE: [Ecrit] ECRIT requirements: R5 reprise

From: "Abbott, Nadine B" <[email-masked]>
Date: Thu, 13 Oct 2005 08:17:45 -0400

Any chance we could change this to refer to "repositories of mapping
information" (or "stores" or something else equivalent) instead of
"sources of mapping information"?
For North America, the local/regional E9-1-1 jurisdictional authorities
intend to be able to designate an authoritative "source" of the "mapping
information."  
It was my impression that this requirement was trying to get at allowing
for it to be stored redundantly? 

Nadine

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Roger Marshall
Sent: Wednesday, October 12, 2005 7:40 PM
To: Tom-PT Taylor; Andrew Newton
Cc: [email-masked]
Subject: RE: [Ecrit] ECRIT requirements: R5 reprise

All:
ECRIT Requirements, outstanding issues. Back to finishing up the easy
stuff before the next draft revision.

[Compare with existing R5 in
http://www.ietf.org/internet-drafts/draft-ietf-ecrit-requirements-00.txt
]

See the thread. Per the contribution below, I propose that we replace
the original R5 with Ted's version of the text, since I think that the
language "SHOULD allow" already protects which equates to "SHOULD NOT
inhibit".  Besides, I generally like stating requirements in the
positive, rather than what ought not to be (where possible).

A. R5(Ted's): Alternate Mapping Sources: The mapping protocol 
SHOULD allow for alternative redundant sources of mapping information, 
possibly of different degrees of currency.

B. R5(Andy's): The mapping protocol SHOULD NOT inhibit the deployment of

alternative redundant sources of mapping information, possibly of 
different degrees of currency.

Motivation: This provides the possibility of having available 
alternative sources of mapping information when the normal source  is 
unavailable or unreachable, without specifying the means by  which 
the alternative source is created or updated.

Andy, can you live with req. form A?  Any others object to form A?

Roger Marshall

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]
>On Behalf Of Tom-PT Taylor
>Sent: Monday, September 19, 2005 11:46 AM
>To: Andrew Newton
>Cc: [email-masked]
>Subject: Re: [Ecrit] ECRIT requirements: R5 reprise
>
>I'll buy your tweak, and I do apologize: it was Ted, not Marc.
>
>Andrew Newton wrote:
>> 
>> On Sep 19, 2005, at 1:52 PM, Tom-PT Taylor wrote:
>> 
>>> We had a fair-sized discussion on R5 at the beginning of
>July.   Marc 
>>> formulated an alternative statement that seemed to hold  promise.
>>> Andrew ignored it and quarelled with Henning instead.  I  
>suggest we
>>> go with Marc's formulation with a slight tweak:
>> 
>> 
>> I did not see Marc's message, and still do not see it in my local
>> copy or the IETF archives (I'm not doubting it was sent, I'm just  
>> curious why I missed it).
>> 
>> BTW, I was not the only one with objections to R5.  Ted proposed an
>> alternative as well.
>> 
>>> "R5: The mapping protocol should allow for alternative redundant
>>> sources of mapping information, possibly of different degrees of 
>>> currency.
>>>
>>> "Motivation: This provides the possibility of having available
>>> alternative sources of mapping information when the normal 
>source  is
>>> unavailable or unreachable, without specifying the means by  which
>>> the alternative source is created or updated."
>>>
>>> I think this proposition has concrete implications for protocol
>>> design, hence should be stated.
>> 
>> 
>> Well, I like this much better than the current version.  Perhaps a
>> slight tweak:
>> 
>> R5: The mapping protocol should not inhibit the deployment of
>> alternative redundant sources of mapping information, possibly of 
>> different degrees of currency."
>> 
>> -andy
>> 
>> 
>
>
>_______________________________________________
>Ecrit mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ecrit
>

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Roger Marshall" <[email-masked]>
Date: Thu, 13 Oct 2005 10:04:01 -0700

Nadine:
Are you trying to distinguish between the use of the term "sources of
mapping info" as relating to the data itself as opposed to which entity
supplies that data (e.g. machines vs. people)?

Would it be clearer if reworded as follows?:

R5: Alternate Mapping: The mapping protocol SHOULD allow for 
alternative redundant sources of mapping services, possibly 
containing mapping information of different degrees of 
currency.

Comments requested.

Roger Marshall.

>On Behalf Of Abbott, Nadine B
>Sent: Thursday, October 13, 2005 5:18 AM
>To: [email-masked]
>Any chance we could change this to refer to "repositories of 
>mapping information" (or "stores" or something else 
>equivalent) instead of "sources of mapping information"?
>For North America, the local/regional E9-1-1 jurisdictional 
>authorities intend to be able to designate an authoritative 
>"source" of the "mapping information."  
>It was my impression that this requirement was trying to get 
>at allowing for it to be stored redundantly? 
>
>Nadine
>
>On Behalf Of Roger Marshall
>ECRIT Requirements, outstanding issues. Back to finishing up 
>the easy stuff before the next draft revision.
>
>See the thread. Per the contribution below, I propose that we 
>replace the original R5 with Ted's version of the text, since 
>I think that the language "SHOULD allow" already protects 
>which equates to "SHOULD NOT inhibit".  Besides, I generally 
>like stating requirements in the positive, rather than what 
>ought not to be (where possible).
>
>SHOULD allow for alternative redundant sources of mapping 
>information, possibly of different degrees of currency.
>
>alternative redundant sources of mapping information, possibly 
>of different degrees of currency.
>
>source  is unavailable or unreachable, without specifying the 
>means by  which the alternative source is created or updated.
>

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Thu, 13 Oct 2005 13:08:51 -0400

I thought the issue was that "source" implies it is authoritative, i.e.
the master source.

Perhaps providers of mapping services would avoid the question of being
authoritative.

Mike

> Sent: Thursday, October 13, 2005 1:04 PM
> To: Abbott, Nadine B; [email-masked]
> Are you trying to distinguish between the use of the term 
> "sources of mapping info" as relating to the data itself as 
> opposed to which entity supplies that data (e.g. machines vs. people)?
> 
> containing mapping information of different degrees of currency.
> 
> Comments requested.
> 
> Roger Marshall.
> 
> >information" (or "stores" or something else
> authorities 
> >intend to be able to designate an authoritative "source" of the 
> >"mapping information."
> >It was my impression that this requirement was trying to get at 
> >allowing for it to be stored redundantly?
> >
> >Nadine
> >
> >A. R5(Ted's): Alternate Mapping Sources: The mapping protocol SHOULD 
> >allow for alternative redundant sources of mapping information, 
> >B. R5(Andy's): The mapping protocol SHOULD NOT inhibit the 
> deployment 
> >of
> >
> >unavailable or unreachable, without specifying the means by  
> which the 
> >alternative source is created or updated.
> >

---

From: "Roger Marshall" <[email-masked]>
Date: Thu, 13 Oct 2005 15:00:18 -0700

Michael:
This makes me question how a master source (which itself implies a sole
entity) could be required to be redundant, with variant levels of
currency.  I take the term source as "copies" of data used for mapping.

Roger.

>From: Michael Hammer (mhammer) [mailto:[email-masked]] 
>Sent: Thursday, October 13, 2005 10:09 AM
>To: Roger Marshall; Abbott, Nadine B; [email-masked]
>Perhaps providers of mapping services would avoid the question 
>of being authoritative.
>
>Mike
> 
>
>"sources of 
>> mapping info" as relating to the data itself as opposed to which 
>> entity supplies that data (e.g. machines vs. people)?
>> 
>containing 
>> mapping information of different degrees of currency.
>> 
>> Comments requested.
>> 
>> Roger Marshall.
>>