Subject: RE: [Ecrit] LUMP and mapping architecture documents

From: "Winterbottom, James" <[email-masked]>
Date: Tue, 25 Oct 2005 19:36:05 -0500

Hi Henning,

I will have more comments on this draft later.
But for now there is a clear mistake in the XML in that your geo option
is using a type of "ca:civicAddress"

*8)

Cheers
James 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Henning Schulzrinne
> Sent: Wednesday, 26 October 2005 10:18 AM
> To: [email-masked]'
> Subject: [Ecrit] LUMP and mapping architecture documents
> 
>
http://www.cs.columbia.edu/sip/draft/lump-arch/draft-schulzrinne-ecrit-
> mapping-arch-00.html
> 
> describes an overall architecture that allows fully distributed
mapping.
>    It is relatively protocol-agnostic, although it clearly wouldn't
work
> (or be needed) for a DNS-based solution. In its simplest incarnation,
it
> consists of a single server, but I was trying to come up with
something
> that can scale to global deployment. It separates the problem into
four
> roles (queriers, authoritative servers, forest guides and resolvers),
> each with a distinct set of responsibilities, even though the number
of
> protocol operations is not as large. The split was motivated by my
> desire to allow for a system that is operated by a variety of parties
> and requiring minimal cooperation and turf fights. (I think that's one
> of the strengths of the DNS, for example, except for the "who owns the
> root" fight breaking out between Oceania and Eurasia.)
> 
> The protocol pieces are now in
> 
>
http://www.cs.columbia.edu/sip/draft/lump/draft-schulzrinne-ecrit-lump-
> 01.html
> 
> This is essentially just a commented WSDL and XML schema description,
> with two requests, to get a mapping and to get a region. This covers
> some of the interfaces described in the architecture document and is
> sufficient for the querier-resolver or resolver-authoritative server
> component, but not for the inter-forest-guide protocol machinery.
> 
> This is not yet complete, but eventually, one should be able to
> automatically generate the protocol machinery from the WSDL file,
e.g.,
> using the GLUE, WebSphere or Apache AXIS server (or .NET).
> 
> I've only described a SOAP binding in the document, but any web
services
> binding would work, including (but not very usefully...) email and,
more
> usefully, a simple REST-style HTTP GET operation.
> 
> Comments would be particularly appreciated.
> 
> 
> Henning
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 25 Oct 2005 21:37:45 -0400

Thanks - yes, the dangers of relying too much on XMLspy rather than 
validation by human inspection :-)

More seriously: What would be the appropriate XML object for geo only? 
gml:position?

Thanks.

Henning