Subject: RE: [Ecrit] Re: Summary ecrit-requirements-00 section 6: Emergency Identifier

From: "Roger Marshall" <[email-masked]>
Date: Thu, 13 Oct 2005 19:33:44 -0700

Henning:
Subj: continuation of Tom's initial comments to the requirements draft,
section 6 - Emergency identifier.

See comments in-line.

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] 
>On Behalf Of Henning Schulzrinne
>Sent: Monday, September 26, 2005 6:07 PM
>To: Tom-PT Taylor
>Cc: ECRIT
>Subject: [Ecrit] Re: Summary ecrit-requirements-00 section 
>6:Emergency Identifier
>
>Some comments inline.
>
>Tom-PT Taylor wrote:
>
>> 
>> A1b: original formulation is seen as redundant, DELETED.  
>New requirement:
>> 
>> A1b': the mapping protocol also needs an emergency indication.
>> 
>> Motivation: this allows reuse of the mapping protocol and 
>the mapping 
>> servers for non-emergency purposes.
>
>To avoid having two requirements that are essentially 
>supersets of one another, we might simply say that it needs to 
>indicate the emergency service (such as "fire") in 
>jurisdictions where more than a single emergency service 
>contact is provided.

I agree that the original 1a and 1b were mostly duplicative, so in
trying to pull out what is suggested here by Henning, I offer the
following replacement requirement for the original 1b:

A1b.  Universal Identifier Resolution:"> Where multiple 
emergency service types exist, it MUST be possible to treat each 
emergency identifier separately, based on the specific type of 
emergency help requested.

Motivation: Some jurisdictions may have multiple types of emergency 
services available at the same level, (e.g. fire, police, ambulance), in

which case it is important that any one could be selected directly.

Is this close to what you were suggesting?

>
>
>
>> A4. Minimal configuration.  Any local logical emergency addresses 
>> should be configured into user terminals automatically, 
>without user intervention.
>> 
>> Motivation: a new user terminal "unofficially imported" into an 
>> organization from elsewhere should have the same emergency 
>> capabilities as one officially installed.

I'm not sure what the impact of the proposed change here is.  Other than
we've already relegated the term "address" to not much more than IP
address (now using identifier), I don't think that "local logical..."
sheds much light over "local...".

>
>I think one distinction getting a bit lost is between the 
>digits or symbols dialed by a user placing an emergency call 
>and the call signaling emitted. The configuration is only 
>necessary for the digits/symbols, as then the device can 
>automatically translate into the "logical identifier". By 
>using examples such as 911, the distinction between dial 
>strings and identifiers is getting blurred. We had lots of 
>problem with that in the 2806bis discussion and it would be 
>unhelpful to muddy the waters again.

The example that I'm thinking of is either,

A. 9, 1, 1 <Send> is translated in the device as:
urn:sos.service.emergency
Or
B. [Help! Button] is translated in the device as:
urn:sos.service.emergency

Is this what you are referring to?

Roger Marshall.

>
>
>Btw, the discussion here addresses ECRIT charter item "A BCP 
>describing how to identify a session set-up request is to an 
>emergency response center".
>
>Henning
>
>
>
>
>
>
>
>
>_______________________________________________
>Ecrit mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ecrit
>

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 13 Oct 2005 22:46:06 -0400

> Is this close to what you were suggesting?

Close enough.

> Is this what you are referring to?

Yes.

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Sat, 15 Oct 2005 15:58:43 -0400

Roger, I'm a bit concerned with what you say below about the limited 
scope of the term "emergency address".  We need a term that covers URIs 
as well as IP addresses, at the very least.  I thought "emergency 
address" was it, according to the definition in the Terminology section.

> section 6 - Emergency identifier.
...

> sheds much light over "local...".
...