Subject: RE: [Ecrit] Terminology section - directory/directory svc.

From: "Roger Marshall" <[email-masked]>
Date: Fri, 21 Oct 2005 14:23:56 -0700

I guess I don't see a difference.  Didn't know if anyone had a
super-significant reason for the term "directory".

The only real difference I see is between a "server" as opposed to a
"service".

I.E. "mapping service", a (distributed?) network service which is
comprised of one or more mapping servers, and which utilizes the mapping
protocol to exchange data.

Roger.

>-----Original Message-----
>From: Henning Schulzrinne [mailto:[email-masked]] 
>Sent: Friday, October 21, 2005 2:14 PM
>To: Roger Marshall
>Cc: [email-masked]
>Subject: Re: [Ecrit] Terminology section - directory/directory svc.
>
>How does this differ from the mapping service?
>
>Roger Marshall wrote:
>> All:
>> I noticed that in the current requirements draft, there is a 
>reference 
>> to "directory" within the basic actors, (section 3).  Since 
>there was 
>> no definition for this term in the Terminology section, I 
>have changed 
>> the term to "Directory Service", and have supplied the 
>following text 
>> in hopes that it matches current thought:
>> 
>> Directory Service: A network service which uses a distributed 
>> directory protocol to provide information about the PSAP, or 
>> intermediary which knows about the PSAP, and is used to assist in 
>> routing an emergency call.
>> 
>> The security draft makes a reference to "directory" pointing to this 
>> doc, so I want something listed here as a basis.
>> 
>> Comments welcome.
>> 
>> Roger Marshall.
>> 
>> _______________________________________________
>> Ecrit mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/ecrit
>

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 21 Oct 2005 17:32:27 -0400

> super-significant reason for the term "directory".

Given that the term directory probably elicits recollections of X.500, 
LDAP and "411" in many people, I'd avoid the term.

I would thus drop references to "directory". Mapping, since we're 
talking about geographic regions as well as a 'mapping' between two 
different data items, seems sufficient.

> protocol to exchange data.

That distinction makes sense to me.

---

From: Andrew Newton <[email-masked]>
Date: Sat, 22 Oct 2005 09:11:58 -0400

On Oct 21, 2005, at 5:32 PM, Henning Schulzrinne wrote:

> Given that the term directory probably elicits recollections of X. 
> 500, LDAP and "411" in many people, I'd avoid the term.

I agree.

> different data items, seems sufficient.

It is a mapping service. Why not use the LCMS term?

-andy