Subject: RE: [ECRIT]: Caller Identity requirements: replacement textforemptysection in ECRIT req doc.

From: "Tim Dunn" <[email-masked]>
Date: Thu, 20 Oct 2005 12:12:54 -0600

Marc-

The definition from NENA Master Glossary (available at
http://www.nena.org/9-1-1TechStandards/Standards_PDF/Master%20Glossary.pdf)
and the way it is used in this context:

Call Back - The capability to recontact the calling party
Call Back Number - A number used by the PSAP to re-contact the location from
which the 9-1-1 call was placed. The number may or may not be the number of
the station used to originate the 9-1-1 call.

Tim Dunn

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Marc Linsner
Sent: Thursday, October 20, 2005 11:34 AM
To: 'Roger Marshall'; 'Ted Hardie'; 'Michael Hammer (mhammer)'; 'ECRIT'
Subject: RE: [ECRIT]: Caller Identity requirements: replacement
textforemptysection in ECRIT req doc.

Sorry for not following this close enough.

What is the definition of "call-back" in this context?

Thanks,

-Marc-

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Roger Marshall
> Sent: Thursday, October 20, 2005 12:33 PM
> To: Ted Hardie; Michael Hammer (mhammer); ECRIT
> Subject: RE: [ECRIT]: Caller Identity requirements: 
> replacement text foremptysection in ECRIT req doc.
> 
> Ted:
> This is a good clarification, which (I think) meets all cases.  
> 
> Requirement is reworded as follows:
> 
> Req-X.  call-back uri. Req1: A "call-back" number MUST be 
> supplied within the call signaling for each emergency call 
> sent to the PSAP.  The ECRIT protocol should provide this 
> number in the form of a URI appropriate to the method used to 
> contact the PSAP.
> 
> Thanks.
> 
> Roger Marshall.
> 
> >-----Original Message-----
> >From: Ted Hardie [mailto:[email-masked]]
> >Sent: Wednesday, October 19, 2005 3:53 PM
> >To: Roger Marshall; Michael Hammer (mhammer); ECRIT
> >Subject: RE: [ECRIT]: Caller Identity requirements: 
> >replacement text for emptysection in ECRIT req doc.
> >
> >At 10:56 AM -0700 10/19/05, Roger Marshall wrote:
> >>Michael:
> >>Henning suggests using SIP:URI alone.  I like this, since 
> it makes it 
> >>avoids the issue of IP Address specifically, (and yet doesn't
> >preclude
> >>it, since I've written it as "should be in the form of a sip:uri".
> >
> >I would strongly prefer "in the form of a URI appropriate to 
> the method 
> >used to contact the PSAP".  We've already seen cases where non-voice 
> >methods have been successful in reach emergency workers 
> where voice did 
> >not get through; if those were to use, say, an sms: URI then an sms: 
> >URI would be the appropriate contact for the reverse.
> >
> >A very recent U.S. example found here: 
> >
> >http://www.nwanews.com/story.php?paper=adg&section=News&story
> id=133545
> >
> >				Ted
> >
> >
> >
> >
> >>Given no objection, I've deleted my orig. req-2 (req-1 covers
> >it), and
> >>for 1 & 3, we now have:
> >>
> >>Req1.  call-back uri. Req1: A "call-back" number MUST be supplied 
> >>within the call signaling for each emergency call sent to the PSAP.
> >>The ECRIT protocol should provide this number in the form of
> >a sip:uri.
> >>
> >>Req3.  call identity parameters. The ECRIT protocol MUST 
> support the 
> >>transport of parameters which can be used by PSAPs to associate 
> >>individual call location information with external caller identity 
> >>records.
> >>
> >>
> >>Roger Marshall.
> >>
> >>>-----Original Message-----
> >>>From: Michael Hammer (mhammer) [mailto:[email-masked]]
> >>>Sent: Wednesday, October 19, 2005 10:36 AM
> >>>To: Roger Marshall; ECRIT
> >>>Subject: RE: [ECRIT]: Caller Identity requirements:
> >>>replacement text for emptysection in ECRIT req doc.
> >>>
> >>>Yes, that helps.  It could also be an IP address embedded in 
> >a sip URI 
> >>>in the form of a Contact, but I didn't want to presume too 
> much.  I 
> >>>don't know if the call-back types need to be enumerated here 
> >or these 
> >>>are just used as examples.
> >>>
> >>>Mike
> >>>
> >>>> -----Original Message-----
> >>>> From: Roger Marshall [mailto:[email-masked]]
> >>>> Sent: Wednesday, October 19, 2005 1:09 PM
> >>>> To: Michael Hammer (mhammer); ECRIT
> >>>> Subject: RE: [ECRIT]: Caller Identity requirements:
> >>>> replacement text for emptysection in ECRIT req doc.
> >>>>
> >>>> Michael:
> >>>> It seems that the PSAP needs to know which type of service
> >>>> (application) that the caller could be used to contact the call 
> >>>> initiator.  For example, if the ECRIT protocol provided an
> >>>IP Address
> >>>> as the "call-back"
> >>>> number, the protocol SHOULD (or MUST?) provide an 
> indicator as to 
> >>>> which application is to be used to target this IP Address 
> >(e.g. IM, 
> >>>> email, VoIP, etc.).
> >>>>
> >>>> Does this get close to addressing the question you're asking?
> >>>>
> >>>> Roger Marshall.
> >>>>
> >>>> >-----Original Message-----
> >>>> >From: Michael Hammer (mhammer) [mailto:[email-masked]]
> >>>> >Sent: Wednesday, October 19, 2005 8:43 AM
> >>>> >To: Roger Marshall; ECRIT
> >>>> >Subject: RE: [ECRIT]: Caller Identity requirements:
> >>>> >replacement text for emptysection in ECRIT req doc.
> >>>> >
> >>>> >Roger,
> >>>> >
> >>>> >In Req-1, you mention an IP address as a call-back number. 
> >>>Is there
> >>>> >some assumed higher level protocol that will be used 
> with that IP 
> >>>> >address?  What will the PSAP operator do with it?
> >>>> >
> >>>> >Mike
> >>>> >
> >>>> >> -----Original Message-----
> >>>> >> From: [email-masked] [mailto:[email-masked]]
> >>>> >On Behalf
> >>>> >> Of Roger Marshall
> >>>> >> Sent: Tuesday, October 18, 2005 7:42 PM
> >>>> >> To: ECRIT
> >>>> >> Subject: [ECRIT]: Caller Identity requirements:
> >>>> replacement text for
> >>>> >> emptysection in ECRIT req doc.
> >>>> >>
> >>>> >> All:
> >>>> >> There has been a placeholder within the ECRIT 
> >requirements draft 
> >>>> >> titled, "Emergency Caller Identification".  Since this
> >>>section was
> >>>> >> requested back on 8/09, I guess I'll take a crack at
> >>>> submitting some
> >>>> >> (proposed) text for it (below):
> >>>> >>
> >>>> >>
> >>>> >> "When a person places an emergency call to a PSAP, existing
> >>>> >emergency
> >>>> >> service messaging conveys associated caller information in
> >> >> >addition to
> >>>> >> receiving the caller's voice.
> >>>> >> This additional information typically consists of a
> >>>> >call-back number,
> >>>> >> and the caller's location (referred to as ANI and ALI, 
> >for North 
> >>>> >> American systems)."
> >>>> >>
> >>>> >> "Some systems use the received callback number to perform
> >>>> a identity
> >>>> >> lookup via a database lookup service, and then use 
> the location 
> >>>> >> information received to help verify the caller's identity
> >>>> presented
> >>>> >> both via voice, as well as the external data 
> presented from the 
> >>>> >> identity database query.  These external mechanisms are
> >>>> >important for
> >>>> >> many reasons, including helping callers who cannot, or will
> >>>> >not speak,
> >>>> >> to prevent false information from impeding 
> appropriate dispatch 
> >>>> >> instructions and procedures, and ultimately to enable faster
> >>>> >response
> >>>> >> in the offering of help."
> >>>> >>
> >>>> >> "IP-based emergency systems in the future may be able to
> >>>> offer even
> >>>> >> more information about the caller, to help establish personal 
> >>>> >> identity, but also for today, for near-term
> >>>> implementations, need to
> >>>> >> provide the same minimum level of identitifcation support
> >>>> as in the
> >>>> >> existing legacy emergency systems."
> >>>> >>
> >>>> >> "Req1: A "Call-back" number MUST be supplied within the call
> >>>> >signaling
> >>>> >> for each emergency call sent to the PSAP.  The ECRIT 
> >protocol may 
> >>>> >> provide this number in the form of a tel:uri, a 
> sip:uri, or an 
> >>>> >> IP-Address."
> >>>> >>
> >>>> >> "Req2: The ECRIT protocol MUST support the ability for
> >>>the PSAP to
> >>>> >> perform caller identity lookup based on the tel:uri,
> >>>> sip:uri, or IP
> >>>> >> Address provided with call signaling.  (A variety of 
> competing 
> >>>> >> directory lookup services may exist, but is not discussed
> >>>> in detail
> >>>> >> here, as it is out of scope of this document.)"
> >>>> >>
> >>>> >> "Req3:  The ECRIT protocol MUST support the ability to 
> >associate 
> >>>> >> individual call location information with external caller
> >>>identity
> >>>> >> records."
> >>>> >>
> >>>> >>
> >>>> >>
> >>>> >> I have attempted to steer clear of obvious privacy 
> >>>> >> concerns/objections, modeling this after what's available
> >>>> >today in ES,
> >>>> >> but there are more details that some may want to tease out.
> >>>> >>
> >>>> >> Comments?
> >>>> >>
> >>>> >> Roger Marshall.
> >>>> >>
> >>>> >> _______________________________________________
> >>>> >> Ecrit mailing list
> >>>> >> [email-masked]
> >>>> >> https://www1.ietf.org/mailman/listinfo/ecrit
> >>>> >>
> >>>> >
> >>>>
> >>>
> >>
> >>_______________________________________________
> >>Ecrit mailing list
> >>[email-masked]
> >>https://www1.ietf.org/mailman/listinfo/ecrit
> >
> >
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Roger Marshall" <[email-masked]>
Date: Thu, 20 Oct 2005 14:51:27 -0700

Given the charter language (as I read it), it does seem that focusing on
a mechanism for a PSAP to exercise call-back may be out scope for this
set of goals.

I plan to reserve this section on call-back for another (future) draft.

Roger Marshall. 
Editor

>On Behalf Of Marc Linsner
>Sent: Thursday, October 20, 2005 2:06 PM
>To: 'Tim Dunn'; [email-masked]
>Cc: 'ECRIT'
>replacement textforemptysection in ECRIT req doc.
>
>Tim,
>
>I'm not saying that "call-back" is not a requirement.  I'm 
>stating that it is not a requirement that ECRIT must solve.  I 
>agree that Caller Identity
>requirement(s) are necessary for proper emergency calling operations.
>
>ECRIT is narrowly chartered and I interpret ECRIT's charter as 
>2 things:
>
>1) Identify an emergency call.
>
>2) Given location information, resolve to a PSAP URI.
>
>There will be a future document from ECRIT that outlines 
>various emergency calling requirements that ECRIT did not/will 
>not handle.  I suspect Caller Identity requirement should be 
>in that document.
>
>-Marc-
>
>> From: Tim Dunn [mailto:[email-masked]]
>> Sent: Thursday, October 20, 2005 4:19 PM
>> To: 'Marc Linsner'; [email-masked]
>> Cc: 'ECRIT'
>> I'm assuming the charter is at:
>> http://www.ietf.org/html.charters/ecrit-charter.html
>> 
>> A very limited view read of the charter is:
>> 
>> "Internet technologies available to describe location and to manage 
>> call routing."
>> 
>> The only item explicitly out of scope is:
>> 
>> "... the question of pre-emption or prioritization of emergency 
>> services traffic."
>> 
>> I would argue that the tying the location of the caller to a way to 
>> re-contact that caller (especially if the call disconnects and the 
>> caller cannot be located) is a part of the native existing processes 
>> of "...special call centers equipped to manage emergency response."
>> 
>> The charter does say "While this group anticipates a close working 
>> relationship with groups such as NENA and ETSI EMTEL, any solution 
>> presented must be useful regardless of jurisdiction..."  I'll argue 
>> that NENA, ETSI EMTEL or any jurisdiction that manages a 
>"special call 
>> center" would want to know why there's no standardized method to 
>> provide a call back number associated with a caller's 
>location.  What 
>> you are proposing by eliminating a call back number is a 
>solution that 
>> could be considered out of scope because it is not useful.
>> 
>> Tim Dunn
>> 
>> 
>> 
>> Of Marc Linsner
>> Sent: Thursday, October 20, 2005 1:45 PM
>> To: [email-masked]
>> Cc: 'ECRIT'
>> OK, I believe I have found the source of the "call-back' 
>> thread (with a little bumping from Roger).
>> 
>> Brian,
>> 
>> After looking over ecrit's charter again, I can't find where ecrit 
>> needs to worry about caller identity.  I sympothize with your 
>> requirement, but I just can't find a place for it in ecrit.
>> 
>> Does anybody have a different opinion??
>> 
>> Caller Identity going once, going twice,.........
>> 
>> -Marc-
>> 
>> > From: [email-masked]
>> [mailto:[email-masked]] On Behalf
>> > Of Roger Marshall
>> > Subject: [ECRIT]: Caller Identity requirements: replacement
>> text for
>> > There has been a placeholder within the ECRIT requirements draft 
>> > titled, "Emergency Caller Identification".  Since this section was 
>> > and the caller's location (referred to as ANI and ALI, for North 
>> > American systems)."
>> > 
>> > "Some systems use the received callback number to perform a
>> identity
>> > lookup via a database lookup service, and then use the location 
>> > both via voice, as well as the external data presented from the 
>> > to prevent false information from impeding appropriate dispatch 
>> > instructions and procedures, and ultimately to enable
>> faster response
>> > "Req1: A "Call-back" number MUST be supplied within the
>> call signaling
>> > for each emergency call sent to the PSAP.  The ECRIT protocol may 
>> > provide this number in the form of a tel:uri, a sip:uri, or an 
>> > IP-Address."
>> > 
>> > "Req2: The ECRIT protocol MUST support the ability for the PSAP to 
>> > Address provided with call signaling.  (A variety of competing 
>> > "Req3:  The ECRIT protocol MUST support the ability to associate