Subject: RE: [Ecrit] Issue 5: Recognition of every Universal Identifier

From: "Roger Marshall" <[email-masked]>
Date: Tue, 13 Dec 2005 14:05:25 -0800

Henning:

Less "flex"... I agree in this case.  So, in are you in support of 
limiting flexibility via use of the following new requirement as
written, 
or leaving it out?

1st, earlier proposed requirement:
"Idx.  Universal identifier(s), MUST be universally recognizable by 
any network element which supports the ECRIT protocol."

Additionally, to your follow-on point (below), I've included a stab at 
an additional second new requirement.  Does this come close?

2nd Proposed requirement:
"Idxx.  A call MUST be recognized as emergency call even if the specific

emergency service requested is not recognized."

"Motivation: In order to have a robust system that supports incremental 
Service deployment while still maintaining a fallback capability."

Comments please.

Thanks.

Roger.

>-----Original Message-----
>From: Henning Schulzrinne [mailto:[email-masked]] 
>Sent: Thursday, December 08, 2005 4:56 PM
>To: Roger Marshall
>Cc: [email-masked]
>Subject: Re: [Ecrit] Issue 5: Recognition of every Universal Identifier
>
>Roger Marshall wrote:
>>  
>>>From Issue 5 of the issue tracker, (ref. www.ietf-ecrit.org issues)
>> 
>> Requirements A1a (Id1) and A1b (Id2) specify a universal identifier.
>> Both requirements
>> specify "one or more" but there are no requirements 
>regarding protocol 
>> actions when more than one is used.  If there are to be more 
>than one 
>> universal identifier, do all network elements have to 
>recognize all of 
>> them?
>> 
>> I don't think Andy's question was ever answered...
>> 
>> If this were clarified within a new requirement, it might read as:
>> 
>> "Idx.  Universal identifier(s), MUST be universally recognizable by 
>> any network element which supports the ECRIT protocol."
>
>Since we want to build robust systems, and since calls will 
>get routed to strange places on occasion, I have a hard time 
>seeing why we would want to encourage diversity or, worse, 
>have identifiers that are recognizable in some places or not 
>in others. I don't see any advantage to this "flexibility".
>
>There is a related requirement, namely that one should be able 
>to recognize a request as an emergency call even if one cannot 
>recognize the specific emergency service requested. The 
>motivation is, again, robustness and the ability to deploy new 
>services incrementally, while still maintaining a fallback capability.
>
>Henning
>

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 13 Dec 2005 17:09:10 -0500

> any network element which supports the ECRIT protocol."

Yes - short and to the point...

> emergency service requested is not recognized."

This indeed captures my concern.