Subject: RE: [Ecrit] Issue 28: NENA Comments ondraft-ietf-ecrit-requirements-00 -Alternate Routes

From: "Winterbottom, James" <[email-masked]>
Date: Mon, 5 Dec 2005 20:34:09 -0600

Change ESGW to "a PSTN gateway" or the such like and I am happy with
this.
ESGW has very specific meaning (at least to some of us), where in some
countries there is no true separate emergency network it is all PSTN.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> James M. Polk
> Sent: Tuesday, 6 December 2005 12:49 PM
> To: Roger Marshall; [email-masked]; [email-masked]
> Subject: RE: [Ecrit] Issue 28: NENA Comments ondraft-ietf-ecrit-
> requirements-00 -Alternate Routes
> 
> A tel:uri has nothing to do with the receiver, and is not a routable
uri
> scheme because it has no domain side of the URI.  If the PSAP is not
IP
> enabled, something is going to have to get the emeregency call to a
ESGW,
> and a tel:uri is not that something that fixes this in the routing
> process.
> 
> I can right now direct a SIP message with a Request-URI at a GW that
will
> get to a SR to a phase 0 PSAP (the phase 0 comment is to elicit the
fact
> that the PSAP is ancient).  That Request URI may be a tel uri with the
> sequence 9999999999 or it could be [email-masked]
> 
> What matters is how the SIP element that has to route the message
based on
> whatever URI decides where that message should go.  If this is a known
> destination based a configured address, it still gets to that ESGW and
SR
> and PSAP.
> 
> I recommend the text below be rewritten to something like:
> 
> "Ideally, the mapping protocol would yield a SIPS-URI which would
allow an
> emergency call to be completed using IP end-to-end (via the
> Internet).  However, securing the signaling path may cause unwanted
> failures, therefore a SIP URI map be the best attainable in some
> situations.  If a tel:url is returned, this will require either prior
> knowledge of where to route this message, or to do an additional
> translation to a routable SIP or SIPS URI to forward towards the PSAP
> directly, or to the ESGW for non-IP-enabled PSAPs."
> 
> At 03:56 PM 12/5/2005 -0800, Roger Marshall wrote:
> >NOTE: prior issue tracker url was wrong - should be:
> >http://www.ietf-ecrit.org:8080/ecrit-req/
> >
> >Brian:
> >
> >Issue 28 talks about some new proposed text to be placed at the end
of
> >the Introduction section.  I've changed the text slightly from what
you
> >originally had, and is listed below:
> >
> >PROPOSED NEW TEXT (at end of Introduction):
> >Ideally, the mapping protocol would yield a URI which would allow an
> >emergency call to be completed using IP end-to-end (via the
Internet).
> >However, not all PSAPs may have IP based connectivity.  Thus the URI
> >scheme cannot be fixed, and in fact may end up being a tel uri to
allow
> >calls to be completed over the PSTN.
> >
> >Editor's Comment: This seems to be consistent with the definition of
> >"emergency address" (see Terminology section), which lists tel:uri as
> >one potential uri scheme.
> >
> >Objections? Please send to the list, along with new proposed text.
This
> >issue will be marked resolved after 10 days if no comments are
received.
> >
> >
> >
> >Roger Marshall
> >
> >
> > >-----Original Message-----
> > >From: Brian Rosen [mailto:[email-masked]]
> > >Sent: Tuesday, November 08, 2005 6:50 PM
> > >To: Roger Marshall; [email-masked]
> > >Subject: RE: [Ecrit] NENA Comments on
> > >draft-ietf-ecrit-requirements-00 -Alternate Routes
> > >
> > >Consider adding the following paragraph to the introductory
> > >text on mapping:
> > >
> > >Ideally, the mapping protocol would yield a URI which would
> > >allow an emergency call to be completed on the Internet.
> > >However, not all PSAPs may have IP based connectivity.  Thus
> > >the URI scheme cannot be fixed, and in fact may end up being a
> > >tel uri to allow calls to be completed on the PSTN.
> > >
> >
> >
> >_______________________________________________
> >Ecrit mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/ecrit
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "James M. Polk" <[email-masked]>
Date: Mon, 05 Dec 2005 20:41:28 -0600

>Change ESGW to "a PSTN gateway" or the such like and I am happy with

I'm ok with this change, as that was what I basically meant

BTW - in my suggested text -- the word "map" needs to be changed to 
"may".... I don't know how I fat-figured that one  ;-)

>countries there is no true separate emergency network it is all PSTN.

no problem