Subject: Re: [Ecrit] Unclear about tel:uris solving old PSAP connectivity...?

From: "Stastny Richard" <[email-masked]>
Date: Thu, 8 Dec 2005 20:23:35 +0100

James,

I have to apologize not to follow the thread on issue #28, 
but my attention was reased by your ref and so synced
 
We will nedd the tel URI IN ADDITION.
 
You are correct that tel URIs are only required for i2 solutions
and this is the reason why we need the tel URI IN ADDITION
to the SIP URI in the response of the database query:
 
We are planning the folloowing:
For migration scenarios: a query to the mapping database
will return always a SIP URI (and in addition sometimes
a tel URI). Normal clients or servers will NEVER look
at this Tel URI because of the special context (see below)

The SIP URI will either point to the PSAP or to a 
national ESRP.

The national ESRP may either query a national datebase,
but it may also query the global database again and now
look for the tel URI.
 
The tel URI is NOT a global (E.164 number), it has always
a national context, or even a context only usable and to be interpreted
by the national ESRP(s). 

so the tel URI will look e.g.
tel:01133;phone-context=esrp.at
 
This Tel URI will be used by the ESRP to feed the
emergency call into the national emergency system,
depending on how it works.
 
regards
Richard

________________________________

Von: [email-masked] im Auftrag von James M. Polk
Gesendet: Do 08.12.2005 19:48
An: [email-masked]
Betreff: [Ecrit] Unclear about tel:uris solving old PSAP connectivity...?

I'm unclear why some one us think a tel:uri scheme will aid an emergency
INVITE message in getting to a PSAP that isn't IP enabled?  How does the
tel:uri help the tradictional infrastructure?

This is analogous to the NENA i2 solution, in which the Selective Router
and PSAP do not have to have any modifications in order for an IP based
phone/device to be able to call said PSAP with a nationally generic
emergency number sequence (like "911").

How will a tel:uri accomplish something in this scenario that a SIP or SIPS
URI doesn't?

This is related to the current thread on Issue #28.

cheers,
James

                                 *******************
                 Truth is not to be argued... it is to be presented.

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Roger Marshall" <[email-masked]>
Date: Thu, 8 Dec 2005 11:31:18 -0800

James:
Based on both Marc & Tom's responses, while I agree that the (Intro)
paragraph doesn't address your extended concern, I think the text is
valuable in saying that a TEL URI CAN be used.  However, I'm not so
eager to stipulate exactly HOW (or HOW NOT) to use a TEL URI at this
time.

Anybody else?  Please weigh in if so.

Roger.

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] 
>On Behalf Of Tom-PT Taylor
>Sent: Thursday, December 08, 2005 11:08 AM
>To: James M. Polk
>Cc: [email-masked]
>Subject: Re: [Ecrit] Unclear about tel:uris solving old PSAP 
>connectivity...?
>
>You are totally convincing when you say that it is pointless 
>for the mapping protocol to return "tel:911". But I cannot see 
>why there should be a problem with needing a second mapping 
>for an E.164 number or even an enterprise emergency centre 
>number suitably constrained by "phone-context". The "P" in 
>"ESRP" stands for "Proxy", and it's an ordinary part of a 
>Proxy's job description to perform such routings (subject, of 
>course, to operator policy).
>
>The need for a separate mapping operation is a separate issue 
>from whether it is possible to use an ordinary telephone 
>number to reach the desired PSAP. Maybe it's this latter 
>concern that has you so upset.
>
>James M. Polk wrote:
>> I'm unclear why some one us think a tel:uri scheme will aid an 
>> emergency INVITE message in getting to a PSAP that isn't IP 
>enabled?  
>> How does the tel:uri help the tradictional infrastructure?
>> 
>> This is analogous to the NENA i2 solution, in which the Selective 
>> Router and PSAP do not have to have any modifications in 
>order for an 
>> IP based phone/device to be able to call said PSAP with a nationally 
>> generic emergency number sequence (like "911").
>> 
>> How will a tel:uri accomplish something in this scenario 
>that a SIP or 
>> SIPS URI doesn't?
>>

---

From: "McCalmont, Patti" <[email-masked]>
Date: Thu, 8 Dec 2005 14:29:48 -0600

I agree with Roger's statement and am in agreement on how the paragraph
that Roger sent out many emails ago.

Patti

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Roger Marshall
Sent: Thursday, December 08, 2005 1:31 PM
To: Tom-PT Taylor; James M. Polk
Cc: [email-masked]
Subject: RE: [Ecrit] Unclear about tel:uris solving old PSAP
connectivity...?

James:

Roger.

---

From: "Stastny Richard" <[email-masked]>
Date: Fri, 9 Dec 2005 00:02:36 +0100

>It would seem that this is not a protocol requirements issue but a 
>deployment considerations issue.

The protocol requirement is simly that tel URIs are allowed

Richard

Von: Andrew Newton [mailto:[email-masked]]
Gesendet: Do 08.12.2005 23:46
An: Marc Linsner; Stastny Richard
Cc: ECRIT
Betreff: Re: [Ecrit] Unclear about tel:uris solving old PSAP connectivity...?

Based on these two quotes:

On Dec 8, 2005, at 2:23 PM, Stastny Richard wrote:
> to the SIP URI in the response of the database query

On Dec 8, 2005, at 3:54 PM, Marc Linsner wrote:
> So, within an enterprise domain, tel:911 should be a
> perfectly valid response to a ecrit mapping query.  This would tell 
> the VoIP
> routing device to utilize it's preprogrammed gateway mechanism to 
> reach the
> intended e.164 identifier on the PSTN.  If the domain is global/
> public,
> since tel:911 would not be unique, words covering the obvious may be
> warranted.

It would seem that this is not a protocol requirements issue but a 
deployment considerations issue.

-andy

---

From: "Stastny Richard" <[email-masked]>
Date: Fri, 9 Dec 2005 00:03:56 +0100

>E.164 numbers all have 15 digits, beginning with a country code.  The first tel: uri is therefore incomplete.

Huh?

max 15 digits

an US E.164 number has only 11 digits
+1 222 333 4444

Richard

Von: [email-masked] im Auftrag von Thomson, Martin
Gesendet: Do 08.12.2005 23:37
An: Marc Linsner; Henning Schulzrinne
Cc: [email-masked]
Betreff: RE: [Ecrit] Unclear about tel:uris solving old PSAP connectivity...?

E.164 numbers all have 15 digits, beginning with a country code.  The first tel: uri is therefore incomplete.
4

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Marc Linsner
> Sent: Friday, 9 December 2005 9:31 AM
> To: 'Henning Schulzrinne'
> Cc: [email-masked]
> But it is a valid nanpa number.....interesting...
>
> -Marc-
>
> > From: Henning Schulzrinne [mailto:[email-masked]]
> > Sent: Thursday, December 08, 2005 5:27 PM
> > To: Marc Linsner
> > Cc: [email-masked]
> > The former is not an E.164 number since you can't dial it
> > from anywhere else except the US.
> >
> > Marc Linsner wrote:
> > > So, it would be either:
> > >
> > > tel:+1-911
> > >
> > > or
> > >
> > > tel:911;phone-context=example.com
> > >
>

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information. 
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Thu, 8 Dec 2005 18:36:28 -0500

From:  http://www.nanpa.com/number_resource_info/n11_codes.html

"N11 codes, more formally known as service codes, are used to provide
three-digit dialing access to special services."

Probably good to make a distinction between a service code and a
telephone number.  Closer to speed dialing that gets translated to a
real telephone number.

If tel: starts with "+" it better be an E.164 number.
If not, then must have a phone-context.

So for NANP, all numbers have the form:  tel:+1-xxx-xxx-xxxx

Keep in mind the NANP also accounts for prefix digits in dial strings.

Mike

> On Behalf Of Marc Linsner (mlinsner)
> Sent: Thursday, December 08, 2005 5:31 PM
> > The former is not an E.164 number since you can't dial it from 
> > anywhere else except the US.
> > 
> > Marc Linsner wrote:
> > > So, it would be either:
> > > 
> > > tel:+1-911
> > > 
> > > or
> > >