Subject: RE: [Ecrit] RE: [issue21] Re7 (Relays): Propose eliminating relaysbyrequiring PSAP to support all reasonable modes

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 28 Dec 2005 21:08:12 -0600

So you are talking implementation then Brian?
I just wanted to be sure

> -----Original Message-----
> From: Brian Rosen [mailto:[email-masked]]
> Sent: Thursday, 29 December 2005 1:58 PM
> To: Winterbottom, James; 'Roger Marshall'; [email-masked]; 'Rohan
Mahy'
> Subject: RE: [Ecrit] RE: [issue21] Re7 (Relays): Propose eliminating
> relaysbyrequiring PSAP to support all reasonable modes
> 
> No, relays are a reality.  Support for them may be required in an
> emergency
> call scenario involving a hearing impaired person.
> 
> The only impact this has on routing is that a relay service may have
to
> get
> a call routed on behalf of a caller to the relay service.  This is an
> instance of 3rd party origination.  An entity (which a relay service
is an
> example, others include a telematics call center and a central alarm
> monitoring service) routes an emergency call where the location is
that of
> its client, not the service.
> 
> When a 3rd party originated call is connected to the emergency
service,
> the
> desired media effect is a conference all among the person needing
> assistance, the service company and the PSAP.  That is clearly beyond
the
> ecrit charter, but has to be dealt with somewhere.
> 
> Brian
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Winterbottom, James
> Sent: Wednesday, December 28, 2005 7:46 PM
> To: Roger Marshall; [email-masked]; Rohan Mahy
> Subject: RE: [Ecrit] RE: [issue21] Re7 (Relays): Propose eliminating
> relaysbyrequiring PSAP to support all reasonable modes
> 
> I am not sure why this has to be a relay function.
> Surely the motivation is more:
> 
> " It should be possible to establish a direct flow of media to the
> emergency service.  In addition, it should be possible to convey
> telemetry data, such as data from automobile crash sensors."
> 
> Relay implies an architectural solution.
> 
> Cheers
> James
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of
> > Roger Marshall
> > Sent: Thursday, 29 December 2005 11:39 AM
> > To: [email-masked]; Rohan Mahy
> > Subject: [Ecrit] RE: [issue21] Re7 (Relays): Propose eliminating
> relays
> > byrequiring PSAP to support all reasonable modes
> >
> > Rohan:
> > Currently, we've still got the following requirement, but no
> discussion
> > that I've seen on the request to delete it, nor any other discussion
> of
> > how this would work.
> >
> > "Re7.  Relay Services: It SHOULD be possible to involve
> > relay services in the call for translation between different modes."
> >
> > "Motivation: It should be possible to connect the relay service so
> that
> > the direct flow of media to the emergency service is maintained.  In
> > addition, it should be possible to convey telemetry data, such as
data
> > from automobile crash sensors."
> >
> > Is there any objection (comments from the list) to removing this
> > requirement as suggested?
> >
> >
> > Roger Marshall
> >
> >
> > >-----Original Message-----
> > >From: Rohan Mahy [mailto:[email-masked]]
> > >Sent: Monday, November 07, 2005 2:09 PM
> > >To: Roger Marshall
> > >Subject: [issue21] Re7 (Relays): Propose eliminating relays by
> > >requiring PSAP to support all reasonable modes
> > >
> > >
> > >New submission from Rohan Mahy <[email-masked]>:
> > >
> > >Relays are required in Re7, but not really well motivated.  If
> > >the PSAP needs to accept "calls" in all the modes listed
> > >(voice, video, text chat, and IM), then I don't think we need
> > >relays.  Eliminating relays would simplify the architecture,
> > >especially wrt to security.
> > >
> > >----------
> > >assignedto: roger
> > >messages: 34
> > >nosy: roger, rohan
> > >priority: urgent
> > >status: unread
> > >title: Re7 (Relays): Propose eliminating relays by requiring
> > >PSAP to support all reasonable modes
> > >
> > >________________________________________________________
> > >ECRIT Requirements Draft <[email-masked]>
> > ><http://www.ietf-ecrit.org:8080/ecrit-req/issue21>
> > >________________________________________________________
> > >
> >
> > _______________________________________________
> > Ecrit mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ecrit
> 
>
------------------------------------------------------------------------
--
> --
> --------------------
> This message is for the designated recipient only and may
> contain privileged, proprietary, or otherwise private information.
> If you have received it in error, please notify the sender
> immediately and delete the original.  Any unauthorized use of
> this email is prohibited.
>
------------------------------------------------------------------------
--
> --
> --------------------
> [mf2]
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit
> 
> 

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Brian Rosen" <[email-masked]>
Date: Wed, 28 Dec 2005 22:31:27 -0500

Huh?

Supporting relays is a requirement in the general sense.  A relay is not an
implementation detail, relay's exist, and must be taken into account within
the requirements.

The relevant requirement is that the mapping function work for 3rd party
origination, where routing is dependent on the location of the person in
need, rather than the entity (the 3rd party) that actually places the call.
A relay service is among the many entities who may have to invoke mapping.

There is a requirement about media (that the caller, the 3rd party, and the
PSAP) be connected so everyone knows about, and can converse with each
other, but that is not an ecrit requirement given its charter.

There are some other requirements for support of relays that are also
outside the current charter.

Where is the implementation part?

Brian

-----Original Message-----
From: Winterbottom, James [mailto:[email-masked]] 
Sent: Wednesday, December 28, 2005 10:08 PM
To: [email-masked]; Roger Marshall; [email-masked]; Rohan Mahy
Subject: RE: [Ecrit] RE: [issue21] Re7 (Relays): Propose eliminating

Mahy'
to
is an
that of
service,
the
Of
Behalf
data

----------------------------------------------------------------------------
--------------------
----------------------------------------------------------------------------
--------------------
[mf2]