Subject: RE: [Ecrit] RE: [issue21] Re7 (Relays): Propose eliminating relays byrequiring PSAP to support all reasonable modes

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 28 Dec 2005 18:45:55 -0600

I am not sure why this has to be a relay function.
Surely the motivation is more:

" It should be possible to establish a direct flow of media to the
emergency service.  In addition, it should be possible to convey
telemetry data, such as data from automobile crash sensors."

Relay implies an architectural solution.

Cheers
James

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Roger Marshall
> Sent: Thursday, 29 December 2005 11:39 AM
> To: [email-masked]; Rohan Mahy
> Subject: [Ecrit] RE: [issue21] Re7 (Relays): Propose eliminating
relays
> byrequiring PSAP to support all reasonable modes
> 
> Rohan:
> Currently, we've still got the following requirement, but no
discussion
> that I've seen on the request to delete it, nor any other discussion
of
> how this would work.
> 
> "Re7.  Relay Services: It SHOULD be possible to involve
> relay services in the call for translation between different modes."
> 
> "Motivation: It should be possible to connect the relay service so
that
> the direct flow of media to the emergency service is maintained.  In
> addition, it should be possible to convey telemetry data, such as data
> from automobile crash sensors."
> 
> Is there any objection (comments from the list) to removing this
> requirement as suggested?
> 
> 
> Roger Marshall
> 
> 
> >-----Original Message-----
> >From: Rohan Mahy [mailto:[email-masked]]
> >Sent: Monday, November 07, 2005 2:09 PM
> >To: Roger Marshall
> >Subject: [issue21] Re7 (Relays): Propose eliminating relays by
> >requiring PSAP to support all reasonable modes
> >
> >
> >New submission from Rohan Mahy <[email-masked]>:
> >
> >Relays are required in Re7, but not really well motivated.  If
> >the PSAP needs to accept "calls" in all the modes listed
> >(voice, video, text chat, and IM), then I don't think we need
> >relays.  Eliminating relays would simplify the architecture,
> >especially wrt to security.
> >
> >----------
> >assignedto: roger
> >messages: 34
> >nosy: roger, rohan
> >priority: urgent
> >status: unread
> >title: Re7 (Relays): Propose eliminating relays by requiring
> >PSAP to support all reasonable modes
> >
> >________________________________________________________
> >ECRIT Requirements Draft <[email-masked]>
> ><http://www.ietf-ecrit.org:8080/ecrit-req/issue21>
> >________________________________________________________
> >
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Brian Rosen" <[email-masked]>
Date: Wed, 28 Dec 2005 21:58:25 -0500

No, relays are a reality.  Support for them may be required in an emergency
call scenario involving a hearing impaired person.

The only impact this has on routing is that a relay service may have to get
a call routed on behalf of a caller to the relay service.  This is an
instance of 3rd party origination.  An entity (which a relay service is an
example, others include a telematics call center and a central alarm
monitoring service) routes an emergency call where the location is that of
its client, not the service.  

When a 3rd party originated call is connected to the emergency service, the
desired media effect is a conference all among the person needing
assistance, the service company and the PSAP.  That is clearly beyond the
ecrit charter, but has to be dealt with somewhere.

Brian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Winterbottom, James
Sent: Wednesday, December 28, 2005 7:46 PM
To: Roger Marshall; [email-masked]; Rohan Mahy
Subject: RE: [Ecrit] RE: [issue21] Re7 (Relays): Propose eliminating
relaysbyrequiring PSAP to support all reasonable modes

Cheers
James

Of
relays
discussion
of
that
> >especially wrt to security.

----------------------------------------------------------------------------
--------------------
----------------------------------------------------------------------------
--------------------
[mf2]

---

From: "Henning" <[email-masked]>
Date: Thu, 29 Dec 2005 11:39:51 +0100

I agree that conferencing and media relaying are important considerations 
for any viable IP-based emergency calling system, but I'm confused as to why 
this impacts call routing and in particular the mapping protocol. Clearly, a 
node anywhere needs to be able to obtain a mapping for any other geographic 
location, including those far away, but that doesn't seem to be the issue.

----- Original Message ----- 
From: "Brian Rosen" <[email-masked]>
To: "'Winterbottom, James'" <[email-masked]>; "'Roger 
Marshall'" <[email-masked]>; <[email-masked]>; "'Rohan Mahy'" 
<[email-masked]>
Sent: Thursday, December 29, 2005 3:58 AM
Subject: RE: [Ecrit] RE: [issue21] Re7 (Relays): Propose 
eliminatingrelaysbyrequiring PSAP to support all reasonable modes

---

From: "Brian Rosen" <[email-masked]>
Date: Thu, 29 Dec 2005 09:12:38 -0500

I have just looked through the current draft.  No where is there a
requirement that mapping can be done by any entity, using anyone's notion of
location.  

While I believe any entity along a path from a caller to the PSAP must be
able to map, it's not absolutely necessary to broaden that to any entity at
all.  Similarly, location can come from the caller (directly or indirectly)
or from an authorized third party (as in a telematics call), but it isn't
necessary that it come from just any entity.  

If you want to make the requirements broad, by saying explicitly that
mapping can be accomplished by any entity regardless of their relationship
to an emergency caller, and that any location can be used for mapping, then
that would cover the relay and other 3rd party call originatos.  However,
the requirements, as currently expressed in the draft, are insufficient.  

You could have some problems with very broad language because it could open
the door to more abuse.  

Lack of an overall architecture is again causing problems.

Brian

-----Original Message-----
From: Henning [mailto:[email-masked]] 
Sent: Thursday, December 29, 2005 5:40 AM
To: [email-masked]; 'Winterbottom, James'; 'Roger Marshall';
[email-masked]; 'Rohan Mahy'
Subject: Re: [Ecrit] RE: [issue21] Re7 (Relays): Propose
eliminatingrelaysbyrequiring PSAP to support all reasonable modes

---

From: "Henning" <[email-masked]>
Date: Thu, 29 Dec 2005 21:19:41 +0100

While there may be administrative and policy reasons that a particular 
server will not answer queries from a particular region or querier, it seems 
to be rather difficult to anticipate these in a protocol design. Thus, from 
a protocol design perspective, the protocol should make it possible to allow 
queries from anywhere. It is easy to picture scenarios where this is needed, 
for example when delayed location availability causes the call to be routed 
to some default location and that call center then needs to lookup the right 
PSAP when the location information shows up later. The number of such places 
is essentially unbounded, as it could be one for each VSP (including 
corporations).

Therefore, I think there is a need to state as a protocol design objective 
that queries can indeed come from anywhere.

----- Original Message ----- 
From: "Brian Rosen" <[email-masked]>
To: "'Henning'" <[email-masked]>; "'Winterbottom, James'" 
<[email-masked]>; "'Roger Marshall'" 
<[email-masked]>; <[email-masked]>; "'Rohan Mahy'" 
<[email-masked]>
Sent: Thursday, December 29, 2005 3:12 PM
Subject: RE: [Ecrit] RE: [issue21] Re7 (Relays): Propose 
eliminatingrelaysbyrequiring PSAP to support all reasonable modes

---

From: "Henning" <[email-masked]>
Date: Thu, 29 Dec 2005 21:19:48 +0100