Subject: [Ecrit] draft-rosen-ecrit-premature-disconnect-rqmts-00.txt: Implementations?

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Wed, 29 Oct 2008 15:06:37 +0200

Are there any attempts to come up with some prototyping implementations
to see how complicated some of the proposed mechanisms are? This would
give us valuable insights, I believe. Maybe someone has a spare student.

I am asking because we hear all the time that end host manufacturers are
unwilling to make changes to their SIP stack, to add new location
protocols, to implement dial string recognition, to implement Phone BCP,
etc. 

How do we convince them to implement these mechanisms? (particularly if
they are more challenging implementation-wise)

Ciao
Hannes
_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

---

From: "DRAGE, Keith \(Keith\)" <[email-masked]>
Date: Wed, 29 Oct 2008 14:13:51 +0100

We are discussing the requirements still, not the implementation, AND
THEY DO NOT YET have consensus.

I have repeatedly asked for an updated version that reflects my comments
made back in July and it so far has not appeared.

I see little progress being made in this direction of discussion unless
we know what the requirements are first, and they are agreed.

Regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Tschofenig, Hannes (NSN - FI/Espoo)
> Sent: Wednesday, October 29, 2008 1:07 PM
> To: ECRIT
> Subject: [Ecrit] 
> draft-rosen-ecrit-premature-disconnect-rqmts-00.txt:Implementations?
> 
> Are there any attempts to come up with some prototyping 
> implementations to see how complicated some of the proposed 
> mechanisms are? This would give us valuable insights, I 
> believe. Maybe someone has a spare student.
> 
> I am asking because we hear all the time that end host 
> manufacturers are unwilling to make changes to their SIP 
> stack, to add new location protocols, to implement dial 
> string recognition, to implement Phone BCP, etc. 
> 
> How do we convince them to implement these mechanisms? 
> (particularly if they are more challenging implementation-wise)
> 
> Ciao
> Hannes

---

From: <[email-masked]>
Date: Wed, 29 Oct 2008 11:59:56 -0400

Hannes,

I wonder if some cable company could provide such info. I understand that CableLabs has issued a SIP-Based Residential Telephony specification back in 2006 that includes some mechanisms involving the UE for controlling premature disconnects, signal hook status and provide ringback.

Just a thought.

Guy
-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Tschofenig, Hannes (NSN - FI/Espoo)
Envoyé : 29 octobre 2008 09:07
À : ECRIT
Objet : [Ecrit] draft-rosen-ecrit-premature-disconnect-rqmts-00.txt: Implementations?

Ciao
Hannes