Subject: [Ecrit] Speech Quality Aspects in emergency calls

From: "Christian Hoene" <[email-masked]>
Date: Thu, 27 May 2010 12:48:58 +0200

Hello Cullen,
dear ECRIT experts,

>I think that the bulk of the people that work on emergency calls in the ECRIT WG and much of the IESG
>are going to be very strong supporters of exactly what Brian is saying here. 

I agree that the support of emergency call are important, also in the IETF WG Codec. However, at this point of time it is not clear
to me what the service requirements of an emergency call are going to be. Which speech/audio quality requirements do the emergency
agencies have?

Brian is suggesting a technical solution to become a requirement. But, don't we have to listen to the users, first? Only then, we
can develop a technical solutions that might affect our work in the Codec WG.

> The implications aren't a
>big deal for the CODEC WG, just that you need to be able to use SDP to signal no VAD. 

Are you sure that this is the only requirement? I think that there are other important things in case of emergency calls. Do they
need audio quality? Do they need ultra-low-delay or is any transmission delay fine? What shall happen, if the transmission quality
is bad? Push-to-talk?

> No one thinks an
>end user is going to go and change the configuration in their phone before making an emergency call.

No, he does know VAD and he does not care about. Some part of the system must take care of. However, the user does know that he
wants to make a emergency call and the phone might have a button called "emergency call".

>If you want the CODEC chairs to go ask the ECRIT WG Chairs if they think this is a requirement for an
>internet codec, it's easy to make that happen but they are going to tell us the same thing Brian is.

Good idea, I carbon-copied this email to the ECRIT mailing list, if you do not mind.

With best regards,

 Christian

>
>
>
>On May 24, 2010, at 12:20 PM, Brian Rosen wrote:
>
>> Okay, you asked for it :)
>>
>> In any country, the codes used in another country for emergency numbers are
>> used as service invocations for other services.  You have to know what
>> country you are in to know what emergency numbers are.  It is roughly
>> impossible (today) to know that with sufficient reliability.
>>
>> You can place an emergency call to an e.164 in many countries.  This may
>> depend on which service.
>>
>> The emergency call center (PSAP) can call you back.
>>
>> A call placed to a call center can be transferred or upgraded to an
>> emergency call.  This happens with relay centers used by disabled
>> individuals.
>>
>> In all of these circumstances, VAD must be disabled.  Emergency calling
>> systems are filled with a lot of complexity that handle seldom occurring
>> circumstances.  However, when it comes to saving lives, seldom occurring
>> circumstances are important.
>>
>> Brian
>>
>> ps - I have been working in this field for a number of years.  You can learn
>> a bit more about emergency calling from draft-ietf-ecrit-framework.  The
>> inability to turn off VAD in VoIP systems believed to have caused actual
>> harm according to some of my associates who work in PSAPs.
>>
>>
>>
>>
>> On 5/24/10 1:37 PM, "Christian Hoene" <[email-masked]> wrote:
>>
>>> Hi Brian,
>>>
>>>> I'll be happy to go into the details, but phones may not know they are in an
>>>> emergency call.  No phone knows this today.  There is some proposed
>>>> signaling that would tell them, IF the phone, and the service provider
>>>> implement it, but even then, there are circumstances where the phone won't
>>>> know.
>>>
>>> If(called.number==112 || called.number==911 || called.number=XYZ)
>>> EmergencyCall();
>>>
>>> See more at http://en.wikipedia.org/wiki/1-1-2
>>> It is so easy to know... I do not get your arguments.
>>>
>>> With best regards,
>>>
>>> Christian
>>>
>>>
>>>
>>
>>
>> _______________________________________________
>> codec mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/codec

---

From: Brian Rosen <[email-masked]>
Date: Thu, 27 May 2010 09:14:56 -0400

Generally, high fidelity is a good thing for emergency calls.  This has to
be balanced against how many codecs each PSAP implements, but at least in
the evolving North American standards, which are currently believed to be
the most advanced, it is recommended that PSAPs implement one or two
wideband codecs.  Graceful fallback in cases of congestion would be nice,
but not a hard requirement.

Delay below 150ms is unlikely to be of much use.  Sometimes, an emergency
call can have audio+video and the delays must match (lip sync).  Frame time
really doesn't matter much independent of its effect on delay.  I personally
think delay over 150ms is not acceptable, but we've had this discussion and
there are some who persist in believing you can get good quality with 250
ms.  In an emergency call, stress is a big factor, and social skills are not
nuanced.  This means turn taking is an issue, and anything that gets in the
way of an interruption is bad.  All of my testing indicates that turn
taking, especially argument, is impaired above around 150 ms.

All of the above doesn't really rise to hard requirements other than the
soft requirement that delay doesn't impair turn taking.  The ability to
disable VAD is a hard requirement.

I believe that is it with respect to codec.  See ietf-ecrit-phonebcp for the
actual requirements.

Brian

On 5/27/10 6:48 AM, "Christian Hoene" <[email-masked]> wrote:

> I agree that the support of emergency call are important, also in the IETF WG
> Codec. However, at this point of time it is not clear
> to me what the service requirements of an emergency call are going to be.
> Which speech/audio quality requirements do the emergency
> agencies have?
> 
> Brian is suggesting a technical solution to become a requirement. But, don't
> we have to listen to the users, first? Only then, we
> Are you sure that this is the only requirement? I think that there are other
> important things in case of emergency calls. Do they
> need audio quality? Do they need ultra-low-delay or is any transmission delay
> fine? What shall happen, if the transmission quality
> is bad? Push-to-talk?
> 
>> No one thinks an
> No, he does know VAD and he does not care about. Some part of the system must
> take care of. However, the user does know that he