Subject: [Ecrit] phone-bcp changes and location-conveyance

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 14 Jul 2010 10:15:24 +0800

There look to be a lot of changes in phone-bcp, some of which are dependent on the latest	 sipcore-location-conveyance draft.  However, a lot of the document has been rendered invalid.

This is no longer applicable:

  ED-43/SP-22 When there are multiple Geolocation header field values
	provided, the "used-for-routing" parameter MUST be set to the	
	location that was chosen for routing.

Because you can't have multiple values any more.

The inserted-by recommendations and so on, also need to be fixed.

I wonder if the new behaviour recommended for the 424 response (in particular, the one with a recommended location) has any implications for emergency routing.  I suspect that there is at least one new requirement on intermediaries, even if this is a MUST NOT reject and include a recommended location.

--Martin

---

From: "James M. Polk" <[email-masked]>
Date: Tue, 13 Jul 2010 21:54:54 -0500

At 09:15 PM 7/13/2010, Thomson, Martin wrote:
>There look to be a lot of changes in phone-bcp, some of which are 
>dependent on the latest       sipcore-location-conveyance 
>draft.  However, a lot of the document has been rendered invalid.
>

there's also no "used-for-routing" parameter in conveyance-03

>The inserted-by recommendations and so on, also need to be fixed.

err, or eliminated -- as at least this one needs to be because there 
is no "inserted-by" parameter any more, nor these parameters:

- inserter
- host-id
- node-id

>I wonder if the new behaviour recommended for the 424 response (in 
>particular, the one with a recommended location) has any 
>implications for emergency routing.  I suspect that there is at 
>least one new requirement on intermediaries, even if this is a MUST 
>NOT reject and include a recommended location.

yes - I haven't scrubbed phonebcp for to parallel the changes to conveyance-03.

I believe that hit is on me

James (P)

>--Martin
>
>_______________________________________________
>Ecrit mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ecrit

---

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 14 Jul 2010 13:10:07 +0800

> yes - I haven't scrubbed phonebcp for to parallel the changes to

I get the impression that the changes to conveyance were recent enough that phone-bcp didn't get updated in time.

The close dependency on conveyance makes it hard to say that phone-bcp is going to be correct if it is published soon.  Given how important it is, it makes conveyance even more important.

--Martin

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 14 Jul 2010 08:48:12 -0400

We will put out an update of -phonebcp and -framework that aligns it with -conveyance as soon as the window opens again.  I'm working on the text now.

Brian