Subject: Re: [Ecrit] Erratum report on erratum 2511 to RFC 5222 (LoST: A Location-to-Service Translation Protocol)

From: Robert Sparks <[email-masked]>
Date: Mon, 6 Dec 2010 16:50:00 -0600

This sounds like "Hold For Document Update" then?

RjS

On Nov 24, 2010, at 3:49 PM, Thomson, Martin wrote:

> On 2010-11-25 at 01:35:58, Worley, Dale R (Dale) wrote:
>> Unfortunately, I think this problem is beyond "errata" but rather is an
>> inconsistency in the design, and there is no clearly correct
>> resolution.  Hence my desire to return it to the WG.
> 
> I can't argue with that.  We definitely need to discuss this further.  Probably discuss along with the resolution to the GEOPRIV question.
> 
> --Martin
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit

---

From: Brian Rosen <[email-masked]>
Date: Mon, 6 Dec 2010 18:09:12 -0500

Sorry, hold what?

This is an erratum to an erratum.  Can you hold an erratum?

We're probably going to need an update to 5222.  Not sure which document will do that, but I agree with Martin that whatever we do with "local-civic", this issue fits into that discussion.

We do need to discuss and agree on a solution, and then write text.  But right now, I don't think there is anything to hold, is there?

Brian

---

From: Robert Sparks <[email-masked]>
Date: Mon, 6 Dec 2010 17:16:02 -0600

Hold for Document Update is one of the states we can resolve a reported erratum into.

Hold for Document Update - The erratum is not a necessary update to the RFC. However, any future update of the document might consider this erratum, and determine whether it is correct and merits including in the update. 

See <http://www.ietf.org/iesg/statement/errata-processing.html> for more information.

To be a little more verbose about what I sent before, what I'm hearing is that errata 2511 should resolve to "Hold for Document Update"
and we'll be figuring out separately what document does that updating.

RjS

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Tue, 7 Dec 2010 11:29:39 -0500

First, my erratum report needs to be edited to fix an error Martin pointed out.  The text

> But the schema in the RFC explicitly says that the elements
> are QNames.  Now that latter may be an error (and the schema is
> labeled non-normative), and also all LocalParts are QNames.

should be changed to:

> But the schema in the RFC (section 15) explicitly says that the
> elements are QNames.  Now all LocalParts are QNames.

In regard to how to classify the erratum, I consider "Hold for document update" to mean that the erratum is not necessary input for someone who wants to implement the RFC and so the erratum can be archived until the document is revised for some other reason.  But in this case, the erratum is a warning of an implementation pitfall, a pitfall whose resolution is not at all clear.  So I would classify it as "Verified", not in the sense of "this is a necessary correction to the text of the RFC" but in the sense of "this is a necessary warning to implementers".

Though that is just my opinion, and it may not align with the established use of these categories.

Dale