Subject: [Ecrit] Scope of the Work

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 18 Sep 2011 19:32:07 +0300

Hi all, 

in earlier discussions we had always listed the school shooting scenario as a use case to summarize a cluster of solutions that use existing protocols, such as XMPP or SIP, to convey the alerts in a point-to-point fashion (using a subscribe/notify paradigm). 
A few of us had worked on these solutions, such as http://xmpp.org/extensions/xep-0127.html or http://tools.ietf.org/html/draft-rosen-sipping-cap-04. These writeups should give you more background about the characteristics of the provided solution (in case the scenario description isn't so good).

These solutions are not suitable for mass delivery (aka Tsunami warning case) but work fine in various other use cases. I had a short writeup of the scenario in the architecture mail I distributed yesterday. 

Now, in off-list discussions for the virtual interim meeting the question was raised whether this use case is something that should not be dealt with in the group but instead the focus be spent on the mass delivery. From a requirements point of view these two cases are obviously quite different and the mass delivery case would make use of multicast/broadcast delivery instead. 

I would need feedback from the rest of the group. There are two choices, I believe:

1) Focus on the mass alert delivery work, 

2) In addition to the mass delivery work also address the school shooting scenario (based on how I described it in my architectural writeup, see http://www.ietf.org/mail-archive/web/atoca/current/msg00536.html, that would lead to a point-to-point alert delivery.  

What would you prefer? 

Ciao
Hannes

---

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 19 Sep 2011 07:56:12 +0800

This is a good question.  Sent to the wrong WG :)

If anyone has any thoughts on this topic, I'd be interested to hear them.

On 2011-09-19 at 02:32:07, Hannes Tschofenig wrote:
> Hi all,
> 
> in earlier discussions we had always listed the school shooting 
> scenario as a use case to summarize a cluster of solutions that use 
> existing protocols, such as XMPP or SIP, to convey the alerts in a 
> point-to-point fashion (using a subscribe/notify paradigm).
> A few of us had worked on these solutions, such as 
> http://xmpp.org/extensions/xep-0127.html or 
> http://tools.ietf.org/html/draft-rosen-sipping-cap-04. These writeups 
> should give you more background about the characteristics of the 
> provided solution (in case the scenario description isn't so good).
> 
> These solutions are not suitable for mass delivery (aka Tsunami 
> warning
> case) but work fine in various other use cases. I had a short writeup 
> of the scenario in the architecture mail I distributed yesterday.
> 
> Now, in off-list discussions for the virtual interim meeting the 
> question was raised whether this use case is something that should not 
> be dealt with in the group but instead the focus be spent on the mass 
> delivery. From a requirements point of view these two cases are 
> obviously quite different and the mass delivery case would make use of 
> multicast/broadcast delivery instead.
> 
> 2) In addition to the mass delivery work also address the school 
> shooting scenario (based on how I described it in my architectural 
> writeup, see http://www.ietf.org/mail- 
> archive/web/atoca/current/msg00536.html, that would lead to a 
> point-to- point alert delivery.
> 
> What would you prefer?
> 
> Ciao
> Hannes
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit