Subject: Re: [Ecrit] car-crash & ecrit-ecall drafts

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 03 Mar 2015 09:00:32 +0100

Hi Keith,

if 3GPP wants to use the work then that's great. If they don't then
that's OK as well.

The documents illustrate how you can re-use existing functionality for
placing an emergency call from a car. We have developed lots of building
blocks in ECRIT, GEOPRIV and other IETF groups that can be re-used (as
you can see from the references in the documents).

Given there is always a lot of excitement in re-building everything from
scratch I believe that's a pretty solid story we have created here.

Ciao
Hannes

On 02/19/2015 03:21 PM, DRAGE, Keith (Keith) wrote:
> I believe the only realistic use case is where it is used through a
> 3GPP access.
> 
> Unless you are saying you have an over the top use case where the
> 3GPP aspect is not an emergency call, then you have an underlying
> dependency on 3GPP, and in particular the successful use of the new
> URN values.
> 
> Of particular criticality is what happens when the underlying system
> does not understand the new URN, and therefore ignores the subtypes.
> 3GPP needs to tell you whether it is appropriate that that is always
> delivered to an ordinary PSAP. Also an issue is whether service
> continuity is meant to operate on such a call, and if so, how.
> 
> Unfortunately, you do not seem to have created sufficient interest in
> the 3GPP community for anyone to start a related work item. That
> implies to me that there is not yet consensus behind getting this
> right as a capability.
> 
> Keith
> 
>> -----Original Message----- From: Ecrit
>> [mailto:[email-masked]] On Behalf Of Hannes Tschofenig 
>> Sent: 17 February 2015 16:44 To: [email-masked] Subject: [Ecrit]
>> car-crash & ecrit-ecall drafts
>> 
>> FWIW, I would like to see these two documents to advance: 
>> https://datatracker.ietf.org/doc/draft-ietf-ecrit-car-crash/ 
>> https://datatracker.ietf.org/doc/draft-ietf-ecrit-ecall/
>> 
>> I see no need to create a dependency on 3GPP work since there are
>> other customers for these documents.
>> 
>> Ciao Hannes
>>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 3 Mar 2015 11:06:13 +0000

So answer the question I posed - do you intend this usage to occur as an emergency call in a 3GPP network, do you intend this usage to occur as an ordinary call in a 3GPP network, or do you intend this to use some other network other that a 3GPP network, and if so what?

Keith 

> -----Original Message-----
> From: Hannes Tschofenig [mailto:[email-masked]] 
> Sent: 03 March 2015 08:01
> To: DRAGE, Keith (Keith); [email-masked]
> Subject: Re: [Ecrit] car-crash & ecrit-ecall drafts
> 
> Hi Keith,
> 
> if 3GPP wants to use the work then that's great. If they 
> don't then that's OK as well.
> 
> The documents illustrate how you can re-use existing 
> functionality for placing an emergency call from a car. We 
> have developed lots of building blocks in ECRIT, GEOPRIV and 
> other IETF groups that can be re-used (as you can see from 
> the references in the documents).
> 
> Given there is always a lot of excitement in re-building 
> everything from scratch I believe that's a pretty solid story 
> we have created here.
> 
> Ciao
> Hannes
> 
> > Unless you are saying you have an over the top use case 
> where the 3GPP 
> > aspect is not an emergency call, then you have an underlying

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 03 Mar 2015 13:47:10 +0100

Hi Keith,

the document leaves both options possible. I envision it to be used in
both scenarios.

If you look at what car manufacturers do then you can easily see that
there is a lot of work ongoing already in that area.

Ciao
Hannes

---

From: Ivo Sedlacek <[email-masked]>
Date: Wed, 4 Mar 2015 08:42:15 +0000

Hello,

draft-ietf-ecrit-ecall-01 states:
-----------
   NG-eCall is a **3GPP** **IMS** emergency call with additional elements
   identifying the call as an eCall and as carrying eCall data and with
   mechanisms for carrying the data.
-----------

3GPP has not stated requirements for such service yet. When 3GPP states requirements, the solution in the draft will not necessarily fit.

Given that the NG-eCall is "3GPP IMS emergency call" and given that 3GPP has not stated requirements for such service yet, then IMO it is too early to progress this draft.

Kind regards

Ivo Sedlacek

This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer 

-----Original Message-----
From: Ecrit [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
Sent: 3. března 2015 13:47
To: DRAGE, Keith (Keith); [email-masked]
Subject: Re: [Ecrit] car-crash & ecrit-ecall drafts

Hi Keith,

the document leaves both options possible. I envision it to be used in both scenarios.

If you look at what car manufacturers do then you can easily see that there is a lot of work ongoing already in that area.

Ciao
Hannes

On 03/03/2015 12:06 PM, DRAGE, Keith (Keith) wrote:
>> The documents illustrate how you can re-use existing functionality 
>> for placing an emergency call from a car. We have developed lots of 
>> building blocks in ECRIT, GEOPRIV and other IETF groups that can be 
>> re-used (as you can see from the references in the documents).
>>
>> Given there is always a lot of excitement in re-building everything 
>> from scratch I believe that's a pretty solid story we have created 
>> here.
>>
>> Ciao
>> Hannes
>>

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 04 Mar 2015 09:44:44 +0100

Hi Ivo,

thanks for pointing this out. I will work with my co-authors to suggest
an appropriate wording.

Ciao
Hannes

---

From: Randall Gellens <[email-masked]>
Date: Wed, 4 Mar 2015 17:00:04 -0800

At 2:21 PM +0000 2/19/15, Keith (Keith) DRAGE wrote:

>  Of particular criticality is what happens when the underlying 
> system does not understand the new URN, and therefore ignores the 
> subtypes. 3GPP needs to tell you whether it is appropriate that 
> that is always delivered to an ordinary PSAP. Also an issue is 
> whether service continuity is meant to operate on such a call, and 
> if so, how.

The correct routing of emergency calls is usually handled by local 
agreements between the emergency authorities and the network 
operators, but in any event is out of scope of this document. 
Likewise, service continuity questions are out of scope of the IETF.

>  Unfortunately, you do not seem to have created sufficient interest 
> in the 3GPP community for anyone to start a related work item. That 

I'd disagree with this.  My understanding is that there is interest, 
and a general expectation that the work will start shortly, and that 
the CEN document lays out the direction, but that there are details 
to be worked out regarding progressing the work.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
1.  People to whom you are attracted invariably think you
    remind them of someone else.
2.  The love letter you finally got the courage to send will
    be delayed in the mail long enough for you to make a fool
    of yourself in person.