Subject: [Ecrit] WGLC for draft-ietf-ecrit-lost-planned-changes - end date April 8

From: Az Mankin <[email-masked]>
Date: Sun, 25 Mar 2018 10:49:57 +0100

This starts WGLC for  draft-ietf-ecrit-lost-planned-changes-01, Validation
of Locations Around a Planned Change

Please send both comments and messages that you support advancement to this
mailing list before April 8.

Roger and Allison

---

From: "Caron, Guy" <[email-masked]>
Date: Thu, 29 Mar 2018 21:52:20 +0000

This draft is in good shape. I have a few editorial comments below for consideration. I would like to thank the author for going the extra mile of providing an XML schema instead of keeping it in RelaxNG.

I did not review the XML schemas as I understand it will be reviewed by Peter St-André.

Thanks,

Guy

//////////// START ///////////

GENERAL
Consider capitalizing the first letter of “client”/”clients” and “server”/”servers” when referring to the LoST Client and Lost Server.

Consider adding an “Acknowledgments” section, if applicable.

ABSTRACT
Missing period at the end of the paragraph.

SECTION 1
1st paragraph: “This document describes an update to the LoST protocol + which allows”
Either replace the “+” by a reference to RFC522 or delete.

3rd paragraph: Missing period at the end of the paragraph.

6th paragraph: “When it is not practical or advisable for the LIS to maintain stable URIs for all of its records, periodic revalidation can be still used to maintain the data in the LIS.”
Change to “When it is not practical or advisable for the LIS to maintain stable URIs for all of its records, periodic revalidation can still be used to maintain the data in the LIS.”

SECTION 3
1st paragraph: “To minimize storage requirements of at the server”…
Change to: “To minimize storage requirements at the server”…

SECTION 6
4th paragraph: …“, since that would cause a large spike in traffic at the change time.”
Change to: …“, since that would cause a large spike in traffic at the time of the change.”

SECTION 9
1st paragraph: … ”, when sent the locationInvalidated object could trigger something untoward.”
Change to: … ”, when sent the <locationInvalidated> object could trigger something untoward.”

1st paragraph: “The server MUST NOT accept any data from the client in response to POSTing the locationInvalidated.”
Change to: “The server MUST NOT accept any data from the client in response to the POST with the <locationInvalidated> object.”

2nd paragraph: “When sending the locationInvalidated object to the URI stored,” …
Change to: “When sending the <locationInvalidated> object to the URI stored,” …

3rd paragraph: … “the URI and the sending of the 'locationInvalidated' object.”
Change to: … “the URI and the sending of the <locationInvalidated> object.”

3rd paragraph: “For example, a public safety system operating the LoST server may have a credential traceable to a well known Certificate Authority known to provide credentials for public safety agencies.”
Change to: “For example, a public safety system operating the LoST server may have a credential traceable to a well-known Certificate Authority responsible to provide credentials for public safety agencies.”

3rd paragraph: … “its policy MAY limit the use of this feature beyond what it would limit a client it recognized.”
Change to: … “its policy MAY limit the use of this feature beyond what it would normally limit a client it recognizes.”

SECTION 10.1
Title: “Replacement Schema Registration”
Change to: ““ LoST Schema Replacement Registration”

2nd paragraph: Change the referenced section 5 to section 7.

SECTION 10.2
Title: “Replacement Schema Registration”
Question: Is this a replacement of an existing schema or the addition of a new one? If the latter, change the title accordingly.

1st paragraph: “URI:  urn:ietf:params:xml:schema:lostPlannedChange1”
Question: In version 00 it was “URI:  urn:ietf:params:xml:schema:lost-PlanedChange1” [dash between “lost” and “Planned”]. Ignoring the obvious typo in “Planed” that has been corrected, is the deletion of the dash intentional? I note that the namespace has the dash.

2nd paragraph: Change the referenced section 6 to section 8.

///////////// END ////////////////

De : Ecrit <[email-masked]> De la part de Az Mankin
Envoyé : 25 mars 2018 05:50
À : [email-masked]
Cc : [email-masked]; [email-masked]
Objet : [Ecrit] WGLC for draft-ietf-ecrit-lost-planned-changes - end date April 8

This starts WGLC for  draft-ietf-ecrit-lost-planned-changes-01, Validation of Locations Around a Planned Change

Please send both comments and messages that you support advancement to this mailing list before April 8.
Roger and Allison