Subject: Re: [Ecrit] [Editorial Errata Reported] RFC8148 (6500)

From: "Randall Gellens" <[email-masked]>
Date: Mon, 29 Mar 2021 08:58:28 -0700

This does seem like an obvious typo that was missed before publication.  
I'm not sure if an errata is the best way of addressing it, rather than 
having IANA update the MIME Media Type Registration for 
application/EmergencyCall.VEDS+xml.

--Randall

On 29 Mar 2021, at 1:37, RFC Errata System wrote:

> The following errata report has been submitted for RFC8148,
> "Next-Generation Vehicle-Initiated Emergency Calls".
>
> --------------------------------------
> You may review the report below and at:
> https://www.rfc-editor.org/errata/eid6500
>
> --------------------------------------
> Type: Editorial
> Reported by: Lars Eggert <[email-masked]>
>
> Section: 14.1
>
> Original Text
> -------------
>       Change controller:  The IESG <[email-masked]>
>
>
> Corrected Text
> --------------
>       Change controller:  The IESG <[email-masked]>
>
>
> Notes
> -----
> The current text has the email address of the "IETF discuss" list for 
> the IESG, which is incorrect.
>
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party
> can log in to change the status and edit the report, if necessary.
>
> --------------------------------------
> RFC8148 (draft-ietf-ecrit-car-crash-23)
> --------------------------------------
> Title               : Next-Generation Vehicle-Initiated Emergency 
> Calls
> Publication Date    : May 2017
> Author(s)           : R. Gellens, B. Rosen, H. Tschofenig
> Category            : PROPOSED STANDARD
> Source              : Emergency Context Resolution with Internet 
> Technologies
> Area                : Applications and Real-Time
> Stream              : IETF
> Verifying Party     : IESG

---

From: Lars Eggert <[email-masked]>
Date: Mon, 29 Mar 2021 19:35:05 +0300

I didn’t see the change controller listed on the IANA page, which is why I filed the errata.

-- 
Sent from a mobile device; please excuse typos.

> On Mar 29, 2021, at 18:58, Randall Gellens <[email-masked]> wrote:
> 
> This does seem like an obvious typo that was missed before publication.  I'm not sure if an errata is the best way of addressing it, rather than having IANA update the MIME Media Type Registration for application/EmergencyCall.VEDS+xml.
> 
> --Randall
> 
>> The current text has the email address of the "IETF discuss" list for the IESG, which is incorrect.
>> 
>> Instructions:
>> -------------
>> Title               : Next-Generation Vehicle-Initiated Emergency Calls
>> Source              : Emergency Context Resolution with Internet Technologies

---

From: "Randall Gellens" <[email-masked]>
Date: Mon, 29 Mar 2021 09:59:11 -0700

My point is just that I do not know if an errata is sufficient to cause 
IANA to make the change.  If it is, that's fine; if it isn't, what is 
the procedure?  An email to IANA perhaps?

--Randall

On 29 Mar 2021, at 9:35, Lars Eggert wrote:

>> On Mar 29, 2021, at 18:58, Randall Gellens 
>> <[email-masked]> wrote:
>>
>> This does seem like an obvious typo that was missed before 
>> publication.  I'm not sure if an errata is the best way of addressing 
>> it, rather than having IANA update the MIME Media Type Registration 
>> for application/EmergencyCall.VEDS+xml.
>>
>> --Randall
>>

---

From: Brian Rosen <[email-masked]>
Date: Mon, 29 Mar 2021 13:05:21 -0400

I’ll ask.  This is a simple problem.

Brian

> On Mar 29, 2021, at 12:59 PM, Randall Gellens <[email-masked]> wrote:
> 
> My point is just that I do not know if an errata is sufficient to cause IANA to make the change.  If it is, that's fine; if it isn't, what is the procedure?  An email to IANA perhaps?
> 
> --Randall
>

---

From: Brian Rosen <[email-masked]>
Date: Mon, 29 Mar 2021 16:55:10 -0400

Approve the errata.  IANA will fix it.  I asked, they responded promptly.

Brian

> On Mar 29, 2021, at 1:05 PM, Brian Rosen <[email-masked]> wrote:
>

---

From: "Randall Gellens" <[email-masked]>
Date: Mon, 29 Mar 2021 13:59:10 -0700

Great, thanks.

--Randall

On 29 Mar 2021, at 13:55, Brian Rosen wrote:

>>> On Mar 29, 2021, at 12:59 PM, Randall Gellens 
>>> My point is just that I do not know if an errata is sufficient to 
>>> cause IANA to make the change.  If it is, that's fine; if it isn't, 
>>> what is the procedure?  An email to IANA perhaps?
>>>
>>> --Randall
>>>
>>>>> publication.  I'm not sure if an errata is the best way of 
>>>>> addressing it, rather than having IANA update the MIME Media Type 
>>>>> Registration for application/EmergencyCall.VEDS+xml.
>>>>>
>>>>> --Randall
>>>>>

---

From: Brian Rosen <[email-masked]>
Date: Mon, 29 Mar 2021 17:15:29 -0400

Lars

We now know how to fix this, but I’m confused by this email.

https://www.iana.org/assignments/media-types/media-types.xhtml <https://www.iana.org/assignments/media-types/media-types.xhtml>
Has the following line for VEDS:
EmergencyCallData.VEDS+xml	application/EmergencyCallData.VEDS+xml <https://www.iana.org/assignments/media-types/application/EmergencyCallData.VEDS+xml>           	[RFC8148 <https://www.iana.org/go/rfc8148>]

The link for application/EmergencyCallData.VEDS+xml leads to
https://www.iana.org/assignments/media-types/application/EmergencyCallData.VEDS+xml <https://www.iana.org/assignments/media-types/application/EmergencyCallData.VEDS+xml>

Which contains (at the bottom):
Change controller: The IESG <ietf&ietf.org>

Noting that it’s the same as the RFC, and therefore incorrect.

What IANA page were you looking at?

Brian

> On Mar 29, 2021, at 12:35 PM, Lars Eggert <[email-masked]> wrote:
>

---

From: Lars Eggert <[email-masked]>
Date: Tue, 30 Mar 2021 09:54:35 +0300

Hi,

On 2021-3-30, at 0:15, Brian Rosen <[email-masked]> wrote:
> https://www.iana.org/assignments/media-types/application/EmergencyCallData.VEDS+xml
> 

that one, but I must have missed this. (Maybe it was strategically below the fold on my phone screen...)

Thanks,
Lars