Subject: [Ecrit] draft-ietf-ecrit-lost-planned-changes-05

From: Victor Burton <[email-masked]>
Date: Tue, 26 Oct 2021 21:20:49 +0000

3. Planned Change Poll Interface

... The client would poll omitting the changeSetId in the poll query, and it response, the
   server returns all the ChangeSets it knows about. ...
Should it be?

... The client would poll omitting the changeSetId in the poll query, and in the response, the
   server returns all the ChangeSets it knows about. ...
whoose TO whose

6. Replacement XML schema

exected TO expected

Curiosity Question:

Should draft-ietf-ecrit-lost-planned-changes-05 include a reference to draft-ietf-ecrit-similar-location-12 or vice versa? Is it necessary to acknowledge because I'm assuming, that it is allowed for a <findService> request for validation to include the parameters for date for the server to perform revalidation, as well for "complete location" and/or "similar location" to be include in the <findService> response.

Thanks,

Victor

NOTICE TO RECIPIENT: This email, including attachments, may contain information which is confidential, proprietary, attorney-client privileged and / or controlled under U.S. export laws and regulations and may be restricted from disclosure by applicable State and Federal law. Nothing in this email shall create any legal binding agreement between the parties unless expressly stated herein and provided by an authorized representative of Comtech Telecommunications Corp. or its subsidiaries. If you are not the intended recipient of this message, be advised that any dissemination, distribution, or use of the contents of this message is strictly prohibited. If you received this message in error, please notify us immediately by return email and permanently delete all copies of the original email and any attached documentation from any computer or other media.

---

From: Brian Rosen <[email-masked]>
Date: Tue, 26 Oct 2021 20:40:36 -0400

Yah. Typos, and I will fix them.  
It’s certainly possible to use any combination of extensions.  They are independent though, and I don’t think it’s necessary or even wise to link them.

Brian

> On Oct 26, 2021, at 5:20 PM, Victor Burton <[email-masked]> wrote:
> 
> … The client would poll omitting the changeSetId in the poll query, and it response, the
>    server returns all the ChangeSets it knows about. …
> 
> Should it be?
> … The client would poll omitting the changeSetId in the poll query, and in the response, the
>    server returns all the ChangeSets it knows about. …
> 
> whoose TO whose
>  
> Should draft-ietf-ecrit-lost-planned-changes-05 include a reference to draft-ietf-ecrit-similar-location-12 or vice versa? Is it necessary to acknowledge because I’m assuming, that it is allowed for a <findService> request for validation to include the parameters for date for the server to perform revalidation, as well for “complete location” and/or “similar location” to be include in the <findService> response.
>  
> Thanks,
> Victor
> NOTICE TO RECIPIENT: This email, including attachments, may contain information which is confidential, proprietary, attorney-client privileged and / or controlled under U.S. export laws and regulations and may be restricted from disclosure by applicable State and Federal law. Nothing in this email shall create any legal binding agreement between the parties unless expressly stated herein and provided by an authorized representative of Comtech Telecommunications Corp. or its subsidiaries. If you are not the intended recipient of this message, be advised that any dissemination, distribution, or use of the contents of this message is strictly prohibited. If you received this message in error, please notify us immediately by return email and permanently delete all copies of the original email and any attached documentation from any computer or other media. _______________________________________________
> Ecrit mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ecrit <https://www.ietf.org/mailman/listinfo/ecrit>

---

From: Brandon Abley <[email-masked]>
Date: Wed, 27 Oct 2021 23:09:01 +0000

I gave this a good read today. Some notes—

  *   Throughout, changeSet should be camel case? It is an object and not a method or class. The OpenAPI markup is inconsistent with this also.
  *   Section 3: The text says “versions” is two integers separated by a period. But in OpenAPI it is an object with two integers. The text implies it is a string with a specific format.

I know this is re-litigating mostly settled stuff, but polling has scalability issues? I know that there is a relatively small amount of traffic since there is just polling to see if there have been changes, but in the future of the global community of LoST servers for emergency services there is I feel like there is an open potential vulnerability to poll the PlannedChangePoll interface to death, such as with malicious use of changeSetIds. Though in the emergency services space we do have things like a PKI to mitigate this and the RFC notes this as well as other security implications. I would really prefer a push mechanism, but for reasons already discussed, I can stand by the RFC as currently drafted with the polling interface.

Assuming correction of typos and other stylistic things as noted in the email thread, I support advancing this RFC.

Brandon Abley
Director of Technology
NENA: The 9-1-1 Association
[email-masked]<mailto:[email-masked]>
m: +1.202.618.4401

From: Ecrit <[email-masked]> On Behalf Of Brian Rosen
Sent: Tuesday, October 26, 2021 5:41 PM
To: Victor Burton <[email-masked]>
Cc: [email-masked]
Subject: Re: [Ecrit] draft-ietf-ecrit-lost-planned-changes-05

Brian

On Oct 26, 2021, at 5:20 PM, Victor Burton <[email-masked]<mailto:[email-masked]>> wrote:

exected TO expected

Curiosity Question:

Thanks,

Victor
NOTICE TO RECIPIENT: This email, including attachments, may contain information which is confidential, proprietary, attorney-client privileged and / or controlled under U.S. export laws and regulations and may be restricted from disclosure by applicable State and Federal law. Nothing in this email shall create any legal binding agreement between the parties unless expressly stated herein and provided by an authorized representative of Comtech Telecommunications Corp. or its subsidiaries. If you are not the intended recipient of this message, be advised that any dissemination, distribution, or use of the contents of this message is strictly prohibited. If you received this message in error, please notify us immediately by return email and permanently delete all copies of the original email and any attached documentation from any computer or other media. _______________________________________________
Ecrit mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ecrit

---

From: Brian Rosen <[email-masked]>
Date: Thu, 28 Oct 2021 09:11:29 -0400

I’ll fix the simple stuff.

Yes, polling theoretically has scaling issues.  Like any HTTP interface, it can be DDoSed.  I think the advocates of polling aren’t realizing how big of a load it will be.  I’m guessing the number of LIS’s polling will end up being hundreds of thousands because I suspect every enterprise with any facility in the state will attempt to keep its data accurate.  It may be that intermediaries continue to make money providing services that don’t need intermediaries, but I suspect that won’t be the case long term.  But, still, a few hundred thousand queries every few minutes is, oh, one virtual server, or less.  And if there were ever a service designed to be in some AWS like, autoscaled environment, it would be this one. So, meh.

Brian

> On Oct 27, 2021, at 7:09 PM, Brandon Abley <[email-masked]> wrote:
> 
> Throughout, changeSet should be camel case? It is an object and not a method or class. The OpenAPI markup is inconsistent with this also.
> Section 3: The text says “versions” is two integers separated by a period. But in OpenAPI it is an object with two integers. The text implies it is a string with a specific format.
>  
> [email-masked] <mailto:[email-masked]>
> m: +1.202.618.4401
>  
>  
>  
> On Oct 26, 2021, at 5:20 PM, Victor Burton <[email-masked] <mailto:[email-masked]>> wrote:
>