Subject: [Ecrit] TIMELY: Please answer: What to do with the planned-changes draft

From: "Randall Gellens" <[email-masked]>
Date: Tue, 14 Dec 2021 09:22:23 -0800

WG Members,

In order to resolve the key open issue and move forward with the 
planned-changes draft, the chairs and author need to understand how much 
consensus we have. I've created a Doodle poll to help do this. Please 
pick one of the first three choices, and, if applicable, either of the 
3d and 4th choices and add a comment.

The first three choices are:

-Either mechanism (polling or notification) is OK with me.
-I prefer the notification mechanism.
-I prefer the polling mechanism.

If you prefer polling or notification but can live with the other, 
please vote "Yes" for the one you prefer and vote "Yes, if need be" (by 
double-clicking) on the other.

If you have a technical objection to either mechanism, please vote for 
the 3d or 4th choice and enter a comment.

The 3d and 4th choices are:

-I have a technical objection to the polling mechanism.
-I have a technical objection to the notification mechanism.

The poll URL:

https://doodle.com/poll/3krg2xh2yk3iww8r?utm_source=poll&utm_medium=link

As a reminder, it's perfectly fine to vote for the first choice (no 
preference) and leave it at that.

--Randall

---

From: "Caron, Guy" <[email-masked]>
Date: Tue, 14 Dec 2021 19:05:31 +0000

Corporate Security policy blocks access to Doodle.

In any event, I'm totally against this drastic change of operation for this draft.

I will remind the WG that lost-planned-changes as a *notification mechanism* has been around in IETF ECRIT since November 2013, was turned into a WG item in July 2016 and went through at least two WGLCs. That means that lost-planned-changes as a *notification mechanism* has been out there undisputed for 8 years.

More importantly, it has been *normatively referenced as a mandatory requirement* in at least one published standard since 2016. Such a change on the mechanism at this time will likely make some implementations stranded and no longer standards-compliant.

Also, the late coming proposal to change from a push notification to a pull does not resolve anything; the notification mechanism as in -04 works with a few tweaks discussed on the list.

Finally, the original request that initiate this draft in the first place was to move away from blind polling of a LoST Server for validation requests. The new proposal moves us right back where we started.

A simple matter of taste cannot propel such a drastic change of direction. Only significant flaws in the existing mechanism could drive that, and I haven't seen any of that on the list.

It is news to me that the IETF uses formal polls to achieve consensus. I'm not sure this fits well with the Tao.

Guy

-----Message d'origine-----
De : Ecrit <[email-masked]> De la part de Randall Gellens
Envoyé : 14 décembre 2021 12:22
À : ECRIT <[email-masked]>
Objet : [EXT][Ecrit] TIMELY: Please answer: What to do with the planned-changes draft

WG Members,

In order to resolve the key open issue and move forward with the planned-changes draft, the chairs and author need to understand how much consensus we have. I've created a Doodle poll to help do this. Please pick one of the first three choices, and, if applicable, either of the 3d and 4th choices and add a comment.

If you prefer polling or notification but can live with the other, please vote "Yes" for the one you prefer and vote "Yes, if need be" (by
double-clicking) on the other.

If you have a technical objection to either mechanism, please vote for the 3d or 4th choice and enter a comment.

The poll URL:

--Randall

_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit
------------------------------------------------------------------------------
External Email: Please use caution when opening links and attachments / Courriel externe: Soyez prudent avec les liens et documents joints

---

From: "Randall Gellens" <[email-masked]>
Date: Tue, 14 Dec 2021 14:38:57 -0800

> Corporate Security policy blocks access to Doodle.

I'll be happy to fill in your entry for you.

> I will remind the WG that lost-planned-changes as a *notification 
> mechanism* has been around in IETF ECRIT since November 2013, was 
> turned into a WG item in July 2016 and went through at least two 
> WGLCs. That means that lost-planned-changes as a *notification 
> mechanism* has been out there undisputed for 8 years.
>
> More importantly, it has been *normatively referenced as a mandatory 
> requirement* in at least one published standard since 2016. Such a 
> change on the mechanism at this time will likely make some 
> implementations stranded and no longer standards-compliant.
>
> Also, the late coming proposal to change from a push notification to a 
> pull does not resolve anything; the notification mechanism as in -04 
> works with a few tweaks discussed on the list.
>
> Finally, the original request that initiate this draft in the first 
> place was to move away from blind polling of a LoST Server for 
> validation requests. The new proposal moves us right back where we 
> started.
>
> A simple matter of taste cannot propel such a drastic change of 
> direction. Only significant flaws in the existing mechanism could 
> drive that, and I haven't seen any of that on the list.

Thanks for sharing your views, I appreciate it. It's clear that you are 
prefer the notification mechanism. For the other part of the question, 
do you have a technical objection to the polling mechanism, and what 
could be done to alleviate it?

> It is news to me that the IETF uses formal polls to achieve consensus. 
> I'm not sure this fits well with the Tao.

This is clearly not a formal poll nor will or can it be used to declare 
consensus. It's an informal mechanism to gauge WG sentiment, which is a 
precursor to determining consensus. I tried to make that clear in my 
email, and am sorry I wasn't successful.

> planned-changes draft, the chairs and author need to understand how 
> much consensus we have. I've created a Doodle poll to help do this. 
> Please pick one of the first three choices, and, if applicable, either 
> of the 3d and 4th choices and add a comment.
>
> External Email: Please use caution when opening links and attachments 
> / Courriel externe: Soyez prudent avec les liens et documents joints

---

From: "Caron, Guy" <[email-masked]>
Date: Wed, 15 Dec 2021 15:14:57 +0000

"do you have a technical objection to the polling mechanism, and what could be done to alleviate it?"

In procedural fairness, I would think the onus is on the proponent of the late coming polling proposal to raise technical objections to the notification mechanism that makes it inoperable.

I made my objections clear in my response.

Guy

-----Message d'origine-----
De : Randall Gellens <[email-masked]> 
Envoyé : 14 décembre 2021 17:39
À : Caron, Guy <[email-masked]>
Cc : ECRIT <[email-masked]>
Objet : [EXT]Re: [Ecrit] TIMELY: Please answer: What to do with the planned-changes draft

> drive that, and I haven't seen any of that on the list.

Thanks for sharing your views, I appreciate it. It's clear that you are prefer the notification mechanism. For the other part of the question, do you have a technical objection to the polling mechanism, and what could be done to alleviate it?

> I'm not sure this fits well with the Tao.

This is clearly not a formal poll nor will or can it be used to declare consensus. It's an informal mechanism to gauge WG sentiment, which is a precursor to determining consensus. I tried to make that clear in my email, and am sorry I wasn't successful.

> Envoyé : 14 décembre 2021 12:22 À : ECRIT <[email-masked]> Objet : 
> [EXT][Ecrit] TIMELY: Please answer: What to do with the 
> planned-changes draft
>
> WG Members,
>
> ----------------------------------------------------------------------
> -------- External Email: Please use caution when opening links and 
> attachments / Courriel externe: Soyez prudent avec les liens et 
> documents joints

---

From: "Randall Gellens" <[email-masked]>
Date: Wed, 15 Dec 2021 07:24:07 -0800

On 15 Dec 2021, at 7:14, Caron, Guy wrote:

> In procedural fairness, I would think the onus is on the proponent of 
> the late coming polling proposal to raise technical objections to the 
> notification mechanism that makes it inoperable.

In fairness, the chairs and document author are asking WG members to 
express a preference for one or the other mechanism, or no preference, 
and if they have a preference, to also say if they have a technical 
objection to the other mechanism, and if so, what could be done to 
alleviate that objection.

> I made my objections clear in my response.

I apologize, but I did not see a technical objection in your response. 
If you have one, please make it clear.

Thank you,

--Randall

>> In any event, I'm totally against this drastic change of operation 
>> for
>> this draft.
>>
> Thanks for sharing your views, I appreciate it. It's clear that you 
> are prefer the notification mechanism. For the other part of the 
> question, do you have a technical objection to the polling mechanism, 
> and what could be done to alleviate it?
>
>
> This is clearly not a formal poll nor will or can it be used to 
> declare consensus. It's an informal mechanism to gauge WG sentiment, 
> which is a precursor to determining consensus. I tried to make that 
> clear in my email, and am sorry I wasn't successful.
>
>
>

---

From: "Caron, Guy" <[email-masked]>
Date: Wed, 15 Dec 2021 15:25:15 +0000

In fairness, the chairs and document author are asking WG members to express a preference for one or the other mechanism, or no preference, and if they have a preference, to also say if they have a technical objection to the other mechanism, and if so, what could be done to alleviate that objection.

Guy

-----Message d'origine-----
Envoyé : 15 décembre 2021 10:24

> notification mechanism that makes it inoperable.

In fairness, the chairs and document author are asking WG members to express a preference for one or the other mechanism, or no preference, and if they have a preference, to also say if they have a technical objection to the other mechanism, and if so, what could be done to alleviate that objection.

Thank you,

--Randall

> De : Randall Gellens <[email-masked]> Envoyé : 14 décembre 
> 2021 17:39 À : Caron, Guy <[email-masked]> Cc : ECRIT 
> <[email-masked]> Objet : [EXT]Re: [Ecrit] TIMELY: Please answer: What 
> to do with the planned-changes draft
>
>> for this draft.
>> Also, the late coming proposal to change from a push notification to 
>> a pull does not resolve anything; the notification mechanism as in 
>> -04 works with a few tweaks discussed on the list.
>>
>> Please pick one of the first three choices, and, if applicable, 
>> either of the 3d and 4th choices and add a comment.
>>
>> If you have a technical objection to either mechanism, please vote 
>> for the 3d or 4th choice and enter a comment.
>>
>> https://doodle.com/poll/3krg2xh2yk3iww8r?utm_source=poll&utm_medium=l
>> i
>> nk
>>

---

From: "Randall Gellens" <[email-masked]>
Date: Wed, 15 Dec 2021 07:29:54 -0800

Hi Guy,

Did you accidentally send your message prematurely? I don't see any 
content from you.

--Randall

---

From: "Randall Gellens" <[email-masked]>
Date: Mon, 27 Dec 2021 10:14:55 -0800

Guy,

Thank you for voting in the poll. Please explain your technical 
objection to the polling option.

Thank you,

--Randall