Subject: [Ecrit] New draft to create registries for emergency services

From: Brian Rosen <[email-masked]>
Date: Wed, 22 Dec 2021 12:16:01 -0500

Today I submitted a draft: https://www.ietf.org/archive/id/draft-rosen-ecrit-emergency-registries-00.html <https://www.ietf.org/archive/id/draft-rosen-ecrit-emergency-registries-00.html>

This draft creates a new area in IANA registries and a whole bunch of registries.  This draft came about because prior to this effort, similar registries were created and maintained by the “NENA Registry System”.  NENA was approached by ETSI which is working on emergency standards similar to NENA’s.  They asked that the registries be renamed and maintained by IANA rather than NENA.  NENA agreed to pursue this as part of a goal to (eventually) create a single world wide standard for how emergency calls are handled.  

The registries defined here don’t have any content.  There are a few NENA documents that populate these registries.  It’s going to be difficult to actually modify the definitions we have in this document, because the NENA document assumes they look like this document describes them. So, suggestions for improvement are welcome, and we’ll work towards improving anything you find, but we may have to delay making any changes while we coordinate with the NENA documents that depend on them.

Also, FYI, IANA has reviewed a draft of this document, and we have made some changes in response to their comments, but you can assume they are okay with how we are proposing to handle these registries.  Note, in particular, that we expressly allow other emergency services standards organizations to create new registries and subregistries in this area, under IESG managed expert review.

If we find this document to be reasonable, I will ask that it be adopted by ecrit and completed as a standards-track RFC.

Brian

---

From: Victor Burton <[email-masked]>
Date: Tue, 28 Dec 2021 18:59:53 +0000

First read of the draft and noticed a couple editorials.

Section 4.4.5.1 - second paragraph spelling "Esternal" to "External"
Section 4.4.5.2 - grammar "creates" to "create"

Victor

From: Ecrit <[email-masked]> On Behalf Of Brian Rosen
Sent: Wednesday, December 22, 2021 9:16 AM
To: ECRIT <[email-masked]>
Subject: [Ecrit] New draft to create registries for emergency services

WARNING: External Email: Exercise Caution

Today I submitted a draft: https://www.ietf.org/archive/id/draft-rosen-ecrit-emergency-registries-00.html<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-rosen-ecrit-emergency-registries-00.html&data=04%7C01%7Cvictor.burton%40comtechtel.com%7C4f253b3155204286d00108d9c56ec2e3%7Ca9a26e696ae040c1bd801ca6cc677828%7C0%7C0%7C637757902360157252%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=LHSYkmTrFwi1ykKyCM9YpVST7a81fnyzehWkhCMzZNc%3D&reserved=0>

This draft creates a new area in IANA registries and a whole bunch of registries.  This draft came about because prior to this effort, similar registries were created and maintained by the "NENA Registry System".  NENA was approached by ETSI which is working on emergency standards similar to NENA's.  They asked that the registries be renamed and maintained by IANA rather than NENA.  NENA agreed to pursue this as part of a goal to (eventually) create a single world wide standard for how emergency calls are handled.

The registries defined here don't have any content.  There are a few NENA documents that populate these registries.  It's going to be difficult to actually modify the definitions we have in this document, because the NENA document assumes they look like this document describes them. So, suggestions for improvement are welcome, and we'll work towards improving anything you find, but we may have to delay making any changes while we coordinate with the NENA documents that depend on them.

Brian

NOTICE TO RECIPIENT: This email, including attachments, may contain information which is confidential, proprietary, attorney-client privileged and / or controlled under U.S. export laws and regulations and may be restricted from disclosure by applicable State and Federal law. Nothing in this email shall create any legal binding agreement between the parties unless expressly stated herein and provided by an authorized representative of Comtech Telecommunications Corp. or its subsidiaries. If you are not the intended recipient of this message, be advised that any dissemination, distribution, or use of the contents of this message is strictly prohibited. If you received this message in error, please notify us immediately by return email and permanently delete all copies of the original email and any attached documentation from any computer or other media.