Subject: AS2 returning EDI

From: "Jim Hurd" <[email-masked]>
Date: Mon, 8 Jan 2001 11:54:57 -0500

I would like a future AS2 to clarify how EDI should be returned in the http response. This is needed for healthcare transactions like eligibility checks. I assume that the generalized receipt mechanism could be used, but isn't this important enough to standardize? Are there already proposals to this effect that I am unaware of?

Jim

---

From: "Dick Brooks" <[email-masked]>
Date: Sat, 13 Jan 2001 16:33:30 -0600

Jim,

Using the Generalized Receipts approach you would do the following:

1. Construct a Receipt-type that contains a "eligibility-response", e.g.
HIPAA-ELIGIBILITY-RESPONSE
2. The sender should include a receipt-disposition-to header along with the
receipt-report-type set to HIPAA-ELIGIBILITY-RESPONSE
3. If you want the response signed then indicate this with the
receipt-security-selection header
4. Send these headers along with the HIPAA X12 eligibility inquiry in the
payload
5. The server should follow the proper behavior to produce the
HIPAA-ELIGIBILITY-RESPONSE

I've attached a simple HTML form to demonstrate this.

Dick Brooks
Group 8760
110 12th Street North
Birmingham, AL 35203
[email-masked]
205-250-8053
Fax: 205-250-8057
http://www.8760.com/

InsideAgent - Empowering e-commerce solutions

  -----Original Message-----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Jim Hurd
  Sent: Monday, January 08, 2001 10:55 AM
  To: [email-masked]
  Subject: AS2 returning EDI

  I would like a future AS2 to clarify how EDI should be returned in the
http response. This is needed for healthcare transactions like eligibility
checks. I assume that the generalized receipt mechanism could be used, but
isn't this important enough to standardize? Are there already proposals to
this effect that I am unaware of?

  Jim

---

From: "Jim Hurd" <[email-masked]>
Date: Sat, 13 Jan 2001 18:52:32 -0500

Dick,

This looks like a reasonable approach. If there is a weakness it's the "e.g.". It would be nice if the people behind AS2 would incorporate a standard way of returning a general EDI payload. (The eligibility response is just another edi payload in the reverse direction). So maybe a receipt type of "edi-x12-response" would be a standard way to request an inline edi response. 

Jim

  ----- Original Message ----- 
  From: Dick Brooks 
  To: Jim Hurd ; [email-masked] 
  Sent: Saturday, January 13, 2001 5:33 PM
  Subject: RE: AS2 returning EDI

  Jim,

  1. Construct a Receipt-type that contains a "eligibility-response", e.g. HIPAA-ELIGIBILITY-RESPONSE
  2. The sender should include a receipt-disposition-to header along with the receipt-report-type set to HIPAA-ELIGIBILITY-RESPONSE
  3. If you want the response signed then indicate this with the receipt-security-selection header
  4. Send these headers along with the HIPAA X12 eligibility inquiry in the payload
  5. The server should follow the proper behavior to produce the HIPAA-ELIGIBILITY-RESPONSE

  Dick Brooks
  Group 8760
  110 12th Street North
  Birmingham, AL 35203
  [email-masked]
  205-250-8053
  Fax: 205-250-8057
  http://www.8760.com/

    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]]On Behalf Of Jim Hurd
    Sent: Monday, January 08, 2001 10:55 AM
    To: [email-masked]
    Subject: AS2 returning EDI

    Jim

---

From: "Dick Brooks" <[email-masked]>
Date: Sun, 14 Jan 2001 16:38:21 -0600

Jim,

I'm willing to help flush out a design for the "edi-x12-response" receipt
type if there is consensus among the group for the functionality.
Anyone else interested in a "edi-x12-response" receipt type?
Dick Brooks
Group 8760
110 12th Street North
Birmingham, AL 35203
[email-masked]
205-250-8053
Fax: 205-250-8057
http://www.8760.com/

  -----Original Message-----
  From: Jim Hurd [mailto:[email-masked]]
  Sent: Saturday, January 13, 2001 5:53 PM
  To: Dick Brooks; [email-masked]
  Subject: Re: AS2 returning EDI

  Dick,

  This looks like a reasonable approach. If there is a weakness it's the
"e.g.". It would be nice if the people behind AS2 would incorporate a
standard way of returning a general EDI payload. (The eligibility response
is just another edi payload in the reverse direction). So maybe a receipt
type of "edi-x12-response" would be a standard way to request an inline edi
response.

  Jim

    ----- Original Message -----
    From: Dick Brooks
    To: Jim Hurd ; [email-masked]
    Sent: Saturday, January 13, 2001 5:33 PM
    Subject: RE: AS2 returning EDI

    Jim,

    1. Construct a Receipt-type that contains a "eligibility-response", e.g.
HIPAA-ELIGIBILITY-RESPONSE
    2. The sender should include a receipt-disposition-to header along with
the receipt-report-type set to HIPAA-ELIGIBILITY-RESPONSE
    3. If you want the response signed then indicate this with the
receipt-security-selection header
    4. Send these headers along with the HIPAA X12 eligibility inquiry in
the payload
    5. The server should follow the proper behavior to produce the
HIPAA-ELIGIBILITY-RESPONSE

    Dick Brooks
    Group 8760
    110 12th Street North
    Birmingham, AL 35203
    [email-masked]
    205-250-8053
    Fax: 205-250-8057
    http://www.8760.com/

      -----Original Message-----

      Jim