Subject: FW: AS2-To and AS2-From headers in returned response

From: "David Fischer" <[email-masked]>
Date: Mon, 18 Jun 2001 08:50:54 -0500

Hello EDIINT,

We are hip-deep in AS2 Interoperability Testing and we have come across a
small issue which needs to be resolved in the Draft Specification.  Before
we get to the point of changing the Draft, we probably need to discuss this
on the list.

Last test we found we needed a new MIME/HTTP header, AS2-From, to indicate
the Trading Partner identification at the transport level.  We also added
the header AS2-To as a compliment.  Now we are getting ready to test
Asynchronous MDNs and the question has come up concerning the REQUIRED
nature of these two headers in MDNs.  Note that these two headers only exist
in the AS1 style messages, not in the GISB profile.

If I may, I would like to solicit opinions/discussion on this point from the
list.  I have included some of the discussions from the testing group below.

A second side issue came up which we tabled but which might also be
mentioned on the list.  Is the value of these headers case sensitive?  We
decided that, unless it is enclosed in quotes, it is case in-sensitive.  Any
discussion on this point?

Regards,

David Fischer
Drummond Group

-----Original Message-----
From: Dale Moberg [mailto:[email-masked]]
Sent: Thursday, June 14, 2001 7:14 AM
To: [email-masked]
Cc: Rik Drummond
Subject: RE: AS2-To and AS2-From headers in returned response

I think that we need to make a decision here and
I am in favor of what will support interoperability.
The reasons David mentions sum up why we decided
to not re-use existing headers and instead cut
through some complexity with the new headers.
Strictly they are needed when constructing a
MDN style receipt, signed or unsigned. It is probably
useful, however, in a b2b messaging context to always
have sender and receiver metainformation available.
If you consider ebXML, for example, we have those
as mandatory fields. Because AS2 responses can
contain both MDNs and other data (in principle),
we need to either strongly recommend or mandate
having sender and receiver information both ways.
I think KISS favors just stating that the sender
and receiver information will always be present
in request or reply. Put it out on the IETF
list for comment, but I vote for always
having the information. (AS2 is supposed
to be for any business data -- lowercase edi--
and not just X12, EDIFACT or EDI, so I don't
think we should count on sender/receiver info being
in the data, nor on making the AS2 app dive
into the data to find the info somehow.)

-----Original Message-----
From: David Fischer [mailto:[email-masked]]
Sent: Wednesday, June 13, 2001 4:30 PM
To: Dale Moberg
Cc: Rik Drummond
Subject: FW: AS2-To and AS2-From headers in returned response

Dale, before we get too far on this, what do you think?

David.

-----Original Message-----
From: David Fischer [mailto:[email-masked]]
Sent: Wednesday, June 13, 2001 6:24 PM
To: Terry Harding; Phil Arcuri; B2b_Int_As2
Cc: David Walling
Subject: RE: AS2-To and AS2-From headers in returned response

I'm always an advocate of minimum specifications to get the job done.
AS2-From was added due to a conflict between the HTTP From and SMTP From
(both of which are to be specifically eMail addresses).  We wanted to
put the sending/POSTing Trading Partner ID (DUNS, other, etc.) somewhere and
we decided it should be required.

There is no To header in HTTP.  The SMTP To can always be included but
it would be an eMail address.  The AS2-To should always be the system being
posted to and this information will always be in the EDI data anyway.
This would be the same for every message you receive - not a differentiator
or dispatch field.  Why do we need it at all?  We added the AS2-To header
just to compliment the AS2-From.  I like the precedent of RFC2616 which
doesn't include this header.  While I am not advocating backing up, it seems
to
me now to require AS2-To would not be our best option.  IMO AS2-To should
remain optional.

Thoughts?

David.

-----Original Message-----
From: Terry Harding [mailto:[email-masked]]
Sent: Wednesday, June 13, 2001 1:46 PM
To: Phil Arcuri; [email-masked]; B2b_Int_As2
Cc: David Walling
Subject: Re: AS2-To and AS2-From headers in returned response

Lets make both fields required for mdns as they are required for all
outgoing documents and will be required for async mdns.

Terry
----- Original Message -----
From: "Phil Arcuri" <[email-masked]>
To: <[email-masked]>; "B2b_Int_As2"
<[email-masked]>
Cc: "David Walling" <[email-masked]>
Sent: Wednesday, June 13, 2001 11:35 AM
Subject: RE: AS2-To and AS2-From headers in returned response

Is the AS2-To field already REQUIRED for (all) MDN receipts?
If not, can we make it a REQUIRED field also?

- Phil
bTrade

-----Original Message-----
From: David Fischer [mailto:[email-masked]]
Sent: Wednesday, June 13, 2001 1:27 PM
To: B2b_Int_As2
Cc: David Walling
Subject: RE: AS2-To and AS2-From headers in returned response

I will be modifying the Draft AS2 specification (I will not submit until
at least the end of these tests in case there are other changes).  Changes
will be sent to the EDIINT Working Group and to the IETF.

The change will be to REQUIRE the AS2-From for (all) MDN receipts.  Any
final discussion before I make the change?

Regards,

David Fischer
Drummond Group.

-----Original Message-----
From: David Walling [mailto:[email-masked]]
Sent: Wednesday, June 13, 2001 12:44 PM
To: [email-masked]'
Subject: RE: AS2-To and AS2-From headers in returned response

David,

When you say that you were "outvoted," do you mean that the draft spec
is going to change to require AS2-From on synchronous MDNs? My preference
is to omit optional headers when possible, but as you can see from the email
from Terry, some vendors (or at least one vendor) are already requiring "AS2
headers" on synchronous responses. I do not want to be non-interoperable
with Cyclone, but simply including an AS2-From in the synchronous MDN to
satisfy one vendor is to establish a de facto requirement beyond the
draft spec, in my opinion. Either the draft spec needs to say that
synchronous
responses MUST include an AS2-From header or it needs to say that AS2
compliant systems MUST accept responses without the AS2-From header. I
would prefer the latter, but that would require Cyclone to change.

Respectfully,
Dave
iSoft

-----Original Message-----
From: David Fischer [mailto:[email-masked]]
Sent: Wednesday, June 13, 2001 12:36 PM
To: David Walling
Subject: RE: AS2-To and AS2-From headers in returned response

We discussed this on yesterday's call.  I thought the MDN could be
matched to the original message using the Original-Message-Id; however, I
was
told that programs did not want to have to parse that far down (something
about putting messages in queues based upon trading partners).

I thought AS2-From would be optional on synchronous MDNs but I was
outvoted.  AS2-To is optional anyway but everyone is using them all the
time.  The
AS2 Draft Spec does not specify.

David.

-----Original Message-----
From: David Walling [mailto:[email-masked]]
Sent: Tuesday, June 12, 2001 4:47 PM
To: [email-masked]'
Subject: FW: AS2-To and AS2-From headers in returned response

David,

Does the AS2 require AS2-To and AS2-From headers in synchronous MDNs? I
thought they were only required when the MDN was delivered
asynchronously.

Dave,
iSoft

-----Original Message-----
From: Terry Harding [mailto:[email-masked]]
Sent: Tuesday, June 12, 2001 4:43 PM
To: David Walling
Subject: AS2-To and AS2-From headers in returned response

Cyclone requires the AS2 headers be present in the returned mdn
response.

Can you please add these headers to your response message.

Thanks

Terry Harding
Cyclone Commerce

---

From: "David Fischer" <[email-masked]>
Date: Mon, 18 Jun 2001 12:53:42 -0500

Thanks Vince,

I took your comment to the testing group and the consensus was that HTTP
transfers should use AS2 rules and SMTP transfers should use AS1 rules.  In
the extremely odd case of an HTTP file transfer requesting an asynchronous
SMTP MDN, the AS1 rules should apply which do not include AS2-To/AS2-From.
Does that sound right to you?

Thanks again Vince.

David Fischer
Drummond Group.

-----Original Message-----
From: Ponko, Vince [mailto:[email-masked]]
Sent: Monday, June 18, 2001 9:55 AM
To: [email-masked]'
Subject: RE: AS2-To and AS2-From headers in returned response

My guess is that you will get in to trouble putting them in email messages
unless they
are registered email headers.  Otherwise, I would think they would have to
be x-headers.

If you are using email MDNS is there a need for these headers?  Do you ever
envision a
situation, I guess, where one of the parties in the exchange does not have
an email
address?  Would that be legal?  Doesn't an email message have to have both
from and
to addresses? Would it be reasonable to require that people doing
asynchronous MDNs
over email both have to have email addresses and that the receiver of the
MDN has to
expect to receive the MDN from the sender of the MDNs email address, which
would not
be the value of the AS2-From header unless that party is using its email
address in
that header anyway.

It seems to me anyone doing mailto MDNs is going to be constrained by the
rules for
internet email.

Vince

-----Original Message-----
From: David Fischer [mailto:[email-masked]]
Sent: Monday, June 18, 2001 9:51 AM
To: [email-masked]
Subject: FW: AS2-To and AS2-From headers in returned response

Hello EDIINT,

Regards,

David Fischer
Drummond Group

-----Original Message-----
From: David Fischer [mailto:[email-masked]]
Sent: Wednesday, June 13, 2001 4:30 PM
To: Dale Moberg
Cc: Rik Drummond
Subject: FW: AS2-To and AS2-From headers in returned response

David.

-----Original Message-----
From: David Fischer [mailto:[email-masked]]
Sent: Wednesday, June 13, 2001 6:24 PM
To: Terry Harding; Phil Arcuri; B2b_Int_As2
Cc: David Walling
Subject: RE: AS2-To and AS2-From headers in returned response

Thoughts?

David.

-----Original Message-----
From: Terry Harding [mailto:[email-masked]]
Sent: Wednesday, June 13, 2001 1:46 PM
To: Phil Arcuri; [email-masked]; B2b_Int_As2
Cc: David Walling
Subject: Re: AS2-To and AS2-From headers in returned response

Terry
----- Original Message -----
From: "Phil Arcuri" <[email-masked]>
To: <[email-masked]>; "B2b_Int_As2"

- Phil
bTrade

-----Original Message-----
From: David Fischer [mailto:[email-masked]]
Sent: Wednesday, June 13, 2001 1:27 PM
To: B2b_Int_As2
Cc: David Walling
Subject: RE: AS2-To and AS2-From headers in returned response

Regards,

David Fischer
Drummond Group.

-----Original Message-----
From: David Walling [mailto:[email-masked]]
Sent: Wednesday, June 13, 2001 12:44 PM
To: [email-masked]'
Subject: RE: AS2-To and AS2-From headers in returned response

David,

Respectfully,
Dave
iSoft

-----Original Message-----
From: David Fischer [mailto:[email-masked]]
Sent: Wednesday, June 13, 2001 12:36 PM
To: David Walling
Subject: RE: AS2-To and AS2-From headers in returned response

David.

-----Original Message-----
From: David Walling [mailto:[email-masked]]
Sent: Tuesday, June 12, 2001 4:47 PM
To: [email-masked]'
Subject: FW: AS2-To and AS2-From headers in returned response

David,

Dave,
iSoft

-----Original Message-----
From: Terry Harding [mailto:[email-masked]]
Sent: Tuesday, June 12, 2001 4:43 PM
To: David Walling
Subject: AS2-To and AS2-From headers in returned response

Thanks

Terry Harding
Cyclone Commerce