Subject: FW: New AS2 Draft

From: "David Fischer" <[email-masked]>
Date: Wed, 17 Apr 2002 15:34:09 -0500

Try Again...

David

-----Original Message-----
From: David Fischer [mailto:[email-masked]]
Sent: Wednesday, April 17, 2002 2:49 PM
To: Steve Lowery
Cc: IETF EDIINT
Subject: RE: New AS2 Draft

Sorry,

David.

-----Original Message-----
From: Steve Lowery [mailto:[email-masked]]
Sent: Wednesday, April 17, 2002 2:23 PM
To: [email-masked]
Subject: Re: New AS2 Draft

was the document to be attached?

>>> "David Fischer" <[email-masked]> 04/17/02 02:33PM >>>
This is the new draft AS2 spec with the new AS2-Version
header.

We also tightened up the definition of Message-Id (section
3.2.3) and AS2-To/AS2-From (section 4) to enhance
interoperability and backward compatibility.

This has not yet been sent to IETF.

Comments?

Regards,

David Fischer
Drummond Group.

---

From: "Dick Brooks" <[email-masked]>
Date: Wed, 17 Apr 2002 16:44:41 -0500

David,

In section 4.1 it states:

"To promote backward compatibility AS2 includes a version:

       AS2-Version: 1.0

    This header MUST be present on all AS2 messages and AS2
    MDNs, but not in a single line response (see section 2.4).
    Receiving systems MUST NOT fail due to the absence of the
    AS2-Version header.  This would indicate the message is from
    an older system."

I don't see the need for an AS2-Version if parties are using the "Version"
header described in section 2.1.2.1.

Dick Brooks
Systrends, Inc
7855 South River Parkway, Suite 111
Tempe, Arizona 85284
Web: www.systrends.com <http://www.systrends.com>
Phone:480.756.6777,Mobile:205-790-1542,eFax:240-352-0714

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of David Fischer
Sent: Wednesday, April 17, 2002 3:34 PM
To: IETF EDIINT
Subject: FW: New AS2 Draft

Try Again...

David

-----Original Message-----
From: David Fischer [mailto:[email-masked]]
Sent: Wednesday, April 17, 2002 2:49 PM
To: Steve Lowery
Cc: IETF EDIINT
Subject: RE: New AS2 Draft

Sorry,

David.

-----Original Message-----
From: Steve Lowery [mailto:[email-masked]]
Sent: Wednesday, April 17, 2002 2:23 PM
To: [email-masked]
Subject: Re: New AS2 Draft

Comments?

Regards,

David Fischer
Drummond Group.

---

From: "David Fischer" <[email-masked]>
Date: Wed, 17 Apr 2002 17:37:43 -0500

Oh, I thought the version attribute in 2.1.2.1 was a GISB version, not an AS2
version?

There is actually no need for this header right now.  This is being added in
anticipation of future AS2 interop needs.

Regards,

David.

-----Original Message-----
From: Dick Brooks [mailto:[email-masked]]
Sent: Wednesday, April 17, 2002 4:45 PM
To: David Fischer; IETF EDIINT
Subject: RE: New AS2 Draft

David,

       AS2-Version: 1.0

Dick Brooks
Systrends, Inc

-----Original Message-----

Try Again...

David

-----Original Message-----
From: David Fischer [mailto:[email-masked]]
Sent: Wednesday, April 17, 2002 2:49 PM
To: Steve Lowery
Cc: IETF EDIINT
Subject: RE: New AS2 Draft

Sorry,

David.

-----Original Message-----
From: Steve Lowery [mailto:[email-masked]]
Sent: Wednesday, April 17, 2002 2:23 PM
To: [email-masked]
Subject: Re: New AS2 Draft

Comments?

Regards,

David Fischer
Drummond Group.