Subject: FW: New AS2-Version Header

From: "David Fischer" <[email-masked]>
Date: Wed, 10 Apr 2002 14:27:08 -0500

The UCC AS2 Interoperability test is in progress and some
concerns have been raised about backward compatibility to
previous test rounds.  Specifically, this round includes the
new EDIINT Compression functionality.  The following
discussion has been in progress.  We would like to include
the EDIINT list in this discussion and solicit your
comments.

Best Regards,

David Fischer
Drummond Group.

-----Original Message-----
From: David Fischer [mailto:[email-masked]]
Sent: Wednesday, April 10, 2002 1:45 PM
To: AS2 Interoperability Test
Subject: New AS2-Version Header

We had another long discussion today about backward
compatibility.

We decided to look ahead to future tests and possible
concerns about backward compatibility to this test.  We
agreed to add a new header for this test round:

    AS2-Version: 1.1

Yesterday's test to all participants with this new header
did not reveal any failures.  Since no system was expecting
this header, and yet no one failed the message, this would
indicate that this header may be safely included in messages
sent to older systems.

This header will be included in the Final Interoperability
Report with an explanation that v1.1 means the sending
system supports all of the AS2 basic functionality and it
supports Compression as defined in the EDIINT Compression
Draft specification.  The version number MAY be incremented
in the future if the addition of new functionality warrants
such an action.

It will be REQUIRED, for this round and in the future, that
this header be included on any sent message, and any
returned MDN (but not with a single line HTTP status
response).  Receiving systems MUST NOT fail due to the
absence of this header.  The absence of this new header
would nominally indicate a system from a previous test
round.  At this time, the presence of this header is
informative in nature only and the receiving system may or
may not utilize this information at the discretion of the
implementer.

Before this new header can be added to the AS2
specification, we will need to request discussion from the
EDIINT list.  This header would be included in the AS2
specification with the value of:

    AS2-Version: 1.0

This header would also be inserted into the EDIINT
Compression specification with the value of:

    AS2-Version: 1.1

This header would be for AS2 systems only and would not be
included when Compression is performed on an AS1 message.

Does this meet with everyone's approval?

Regards,

David Fischer
Drummond Group.

---

From: "Steve Lowery" <[email-masked]>
Date: Thu, 11 Apr 2002 07:35:08 -0400

I apologize if I haven't been following along in the compression discussion but what happens if an older system (one that doesn't have compression) receives a compressed message. Maybe it doesn't matter, you should be able to elect if you want compressed messages or not. 

Is the AS2-Version field an indication that the message may be compressed?

Again I apologize for not following but what compression engine will be used?

>>> "David Fischer" <[email-masked]> 04/10/02 03:27PM >>>

Best Regards,

David Fischer
Drummond Group.

-----Original Message-----
From: David Fischer [mailto:[email-masked]] 
Sent: Wednesday, April 10, 2002 1:45 PM
To: AS2 Interoperability Test
Subject: New AS2-Version Header

    AS2-Version: 1.1

    AS2-Version: 1.0

    AS2-Version: 1.1

Regards,

David Fischer
Drummond Group.

---

From: "David Fischer" <[email-masked]>
Date: Thu, 11 Apr 2002 09:32:07 -0500

If an older system received a compressed message, it would try to unpackage the
message and fail because it did not understand all the fields in the
Content-Type.  They would also not understand the AS2-Version field but if they
follow HTTP rules, they should ignore the AS2-Version header.

Compression is typically a flag in the Trading Partner record of the Trading
Partner database.  Whether or not messages are compressed would typically be
negotiated out-of-band.  Exactly how this is accomplished is implementation
dependant.  When communicating to an older system, don't set this flag.

The AS2-Version header will not help with older versions.  We are considering
this header in anticipation of future tests interoperating with the current crop
of system.  The value 1.1 will indicate that the sending system supports all the
functionality in this test round -- basic functionality plus compression.

Regards,

David Fischer
Drummond Group.

-----Original Message-----
From: Steve Lowery [mailto:[email-masked]]
Sent: Thursday, April 11, 2002 6:35 AM
To: [email-masked]; [email-masked]
Subject: Re: FW: New AS2-Version Header

I apologize if I haven't been following along in the compression discussion but
what happens if an older system (one that doesn't have compression) receives a
compressed message. Maybe it doesn't matter, you should be able to elect if you
want compressed messages or not.

Best Regards,

David Fischer
Drummond Group.

-----Original Message-----
From: David Fischer [mailto:[email-masked]]
Sent: Wednesday, April 10, 2002 1:45 PM
To: AS2 Interoperability Test
Subject: New AS2-Version Header

    AS2-Version: 1.1

    AS2-Version: 1.0

    AS2-Version: 1.1

Regards,

David Fischer
Drummond Group.