Subject: Re: How do I send EDI file securely over Internet via FTP or HTTPS?

From: [email-masked]
Date: Wed, 05 Jun 2002 19:54:51 +0000

The best may to exchange secure messages over any 
communications or messaging platform including FTP, 
SMTP, HTTP, X25, X400, etc. is to incorporate ANSI X 
12.58 security. This powerful security standard is 
cerified by ANSI and ISO and has been implemented ans 
used by banks for years. When you implement in X 12.58 
security software (i.e. www.primefactors.com)you won't 
need to invest in and manage several weaker security 
systems including: S/MIME, PGP, SSL, and even Firewalls. 
Your transactions will be protected at the lowest level 
possible, no need to protect the channel (SSL) or the 
envelope (S/MIME).
Plus, your secured (wraped) transactions will be able 
travel freely between VANs, e-mail, and FTP exchanges.

Ricardo Johnson
Interdata, LLC
> 
> We have a few (3-5) clients who would like to receive
> EDI via FTP or HTTPS
> 
> We would send the file to them (from Unix or
> Windows), they would receive it.
> 
> Of course we could use standard FTP. However is
> there some way to send an encrpyted FTP?
> I have heard of Kermit, SSH, and PGP. Not sure
> which if any is the correct, low cost and easiest
> approach for us to first encrpyt and then FTP/HTTPS
> (not sure how) over the Internet to our 2-4 customers.
> 
> 
> 1. What is the best approach and how would one
> set-up  to run unattended?
> What software is needed on both ends?
> Note that we are the sender so we will not need much.
>  
> 
> 2. Supposedly the SAP Business Connector has the
> ability to send via SSL over the Internet. How
> does this work? We could then send our ship notice to
> the customer through this. Not sure of the mechanices,
> what is needed on each end, how we would send it,
> etc..
> 
> Thanks for any guidance.
> Peter
> [email-masked]
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Yahoo! - Official partner of 2002 FIFA World Cup
> http://fifaworldcup.yahoo.com

---

From: "Pae Choi" <[email-masked]>
Date: Wed, 5 Jun 2002 16:58:31 -0700

My appologies for being ignorant. But I am not familiar
with X12.58. So I'd like to ask some questions related
to your previous message.

1) Where can I can learn more about X12.58? Any URLs?
2) What are the security strengths of X12.58 over SSL v3 or
    TLS v1.0?
3) What are the security strength does X12.58 has over
    ebXML and/or SOAP with W3C/XML Signature?
4) What is the lowest level possible in an OSI 7-layer style?

Thank you,

Pae