Subject: RE: AS2-SMIME : has the certificate to be included inside thesignatu re?

From: "Rishel,Wes" <[email-masked]>
Date: Thu, 5 Jun 2003 10:23:46 -0400

What is the benefit of sending the cert with the message? If you truly want to authenticate the originator you have to acquire the cert by independent, trusted means, don't you?

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Jess Sightler
Sent: Thursday, June 05, 2003 6:36 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: AS2-SMIME : has the certificate to be included inside
thesignatu re?

I can't speak 100% from the spec on this, but I know that iSoft makes
sending the Certificate with a signature optional.

Based on that, I believe that it is an option to not send the cert.  I
believe that sending the Cert would be a good practice, however.

Thanks,
Jess

On Thu, 2003-06-05 at 09:58, [email-masked] wrote:
> Hello,
> 
>  
> 
> I am new on this list - and I need your help.
> 
>  
> 
> AS2: when sending a signed message (the original message which can
> also be signed, or a signed MDN), has the signer's certificate to be
> included inside of the signature MIME part?
> 
> Is it mandatory or should AS2 compliant products accept both? (signed
> messages containing the cert, or not containing it, in which case they
> would try to find a certificate on the local key store etc.) 
> 
>  
> 
> Regards,
> 
> -----------------------------------------
> Ludan STOECKLE
> DSI Groupe Casino - Etudes
> 
> 04 77 45 48 01
> 
> [email-masked]
> -----------------------------------------
> 
> 
>  
> 
> 
>  
-- 
=======================================
Jess Sightler
Senior Developer
Exim Technologies
131 Falls Street
Greenville SC 29601
Phone: 864-679-4651
=======================================

---

From: Jess Sightler <[email-masked]>
Date: 05 Jun 2003 10:54:54 -0400

I was primarily thinking to do so, because it seems like it is standard
convention with S/MIME to do that when used for email.

Anyway, as a side thought, of course, one certificate has to be acquired
through an independent, trusted means.  However, that certificate does
not necessarily have to be the certificate used for signing the message.

Ie, couldn't the trusted Cert be a signing authority, and the message
itself come with a separate Cert signed by that authority?

Thanks,
Jess