Subject: AS2-SMIME : has the certificate to be included inside the signatu re?

From: [email-masked]
Date: Thu, 5 Jun 2003 14:58:20 +0100

Hello,

I am new on this list - and I need your help.

AS2: when sending a signed message (the original message which can also be
signed, or a signed MDN), has the signer's certificate to be included inside
of the signature MIME part?

Is it mandatory or should AS2 compliant products accept both? (signed
messages containing the cert, or not containing it, in which case they would
try to find a certificate on the local key store etc.) 

Regards,

-----------------------------------------
Ludan STOECKLE
DSI Groupe Casino - Etudes

04 77 45 48 01

 <mailto:[email-masked]> [email-masked]
-----------------------------------------

---

From: Jess Sightler <[email-masked]>
Date: 05 Jun 2003 09:36:13 -0400

I can't speak 100% from the spec on this, but I know that iSoft makes
sending the Certificate with a signature optional.

Based on that, I believe that it is an option to not send the cert.  I
believe that sending the Cert would be a good practice, however.

Thanks,
Jess

On Thu, 2003-06-05 at 09:58, [email-masked] wrote:
> AS2: when sending a signed message (the original message which can
> also be signed, or a signed MDN), has the signer's certificate to be
> included inside of the signature MIME part?
> 
> messages containing the cert, or not containing it, in which case they
> would try to find a certificate on the local key store etc.) 
> 
>  
> 
> Regards,
> 
> [email-masked]
-- 
=======================================
Jess Sightler
Senior Developer
Exim Technologies
131 Falls Street
Greenville SC 29601
Phone: 864-679-4651
=======================================