Subject: Moving AS3 forward.

From: "Dale Moberg" <[email-masked]>
Date: Fri, 21 Oct 2005 09:13:17 -0700

Hi

It seems to me that AS3 draft is pretty stable. Is there anyone on the
list that either 

1. has concerns about it moving forward 

or 

2. would like to see it be moved forward in the standards process?

If you are an implementer or just an interested party, please post a
message to the list concerning your position on this. We need to get
some indication of the groups's consensus on this in the record.

We can then lobby Rik D.

Thanks

---

From: "Debra Petta" <[email-masked]>
Date: Fri, 21 Oct 2005 11:27:09 -0500

I'd like to see it moved forward in the standards process.
 
We've all put a lot of development and testing efforts into our AS3 products
and it would be nice to see some market acceptance for AS3.
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Dale Moberg
Sent: Friday, October 21, 2005 11:13 AM
To: [email-masked]
Subject: Moving AS3 forward.

Hi

It seems to me that AS3 draft is pretty stable. Is there anyone on the list that either 

or 

If you are an implementer or just an interested party, please post a message to the list concerning your position on this. We need to get some indication of the groups's consensus on this in the record.

We can then lobby Rik D.

Thanks

---

From: "Andy Merrill" <[email-masked]>
Date: Fri, 21 Oct 2005 09:41:05 -0700

We would like to see the standard move forward.  We have customers
looking at moving to AS3 in the next year.
 
Andy

________________________________

From: [email-masked]
[mailto:[email-masked]] On Behalf Of Dale Moberg
Sent: Friday, October 21, 2005 9:13 AM
To: [email-masked]
Subject: Moving AS3 forward.

Hi

or 

We can then lobby Rik D.

Thanks

---

From: "Andersson Tony" <[email-masked]>
Date: Fri, 21 Oct 2005 18:52:28 +0200

I second that.
 
Tony Andersson
A x w a y.

 
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Dale Moberg
Sent: Friday, October 21, 2005 11:13 AM
To: [email-masked]
Subject: Moving AS3 forward.

Hi

or 

We can then lobby Rik D.

Thanks

---

From: "Terry Harding" <[email-masked]>
Date: Fri, 21 Oct 2005 10:12:10 -0700

Here are the additional changes I am recommending to the AS3 draft to support your request for better

clarity to the spec.  

Lets start our discussions here.  Please respond to the list. 

Thanks

Terry Harding

Cyclone Commerce Inc.

7.2  Message Disposition Notifications (MDN) 

   The AS3-MDNs are returned on a separate FTP TCP/IP 

   connection and are a response to an AS3 message. 

   The following diagram illustrates the delivery of an 

   AS3-MDN delivery:

          AS3-MDN

         [S] ----( connect )----> [R]   [FTP Server]

         [S] ----( send )-------> [R]   [AS3-Message]

         [S] ----( disconnect )-> [R]   [FTP Server]

         [S] <---( connect )----- [R]   [FTP Server]

         [S] <---( send )-------- [R]   [AS3-MDN]]

         [S] <---( disconnect )-- [R]   [FTP Server]

    Note:  Refer to Section 7.4.4 for additional

           programming notes.

7.4.4  Additional AS3-MDN Programming Notes

    9.  An AS3 implementation MUST present to its trading partners

        an ftp compliant server interface where inbound documents

        and mdns are received.

   10.  An AS3 implementation MUST be able to retrieve inbound

        messages from it's currently configured ftp server interface.  

   Note: Programming Notes 9 and 10 do not imply any specific method

         for supplying the ftp server interface. But, does allow for 

         several different types of implementations.  Some vendors may

         choose to imbed an ftp compliant server interface within their  

         product and others may choose to utilize off-the-shelf ftp servers

         to supply the required ftp server interface. Some may choose to 

         utilize hosting services provide by their trading partner or by a 

         third party hosting service. Whichever method is utilized, an

         AS3 implementation MUST support rules 9 and 10.

    11.  AS3 implementations MAY imbed an ftp server interface within their

         product. 

    12.  AS3 implementations MUST be configurable to allow the use of 

         an external ftp hosting service. 

    Note: An external ftp hosting service may be hosted by a third-party 

          Or possibly hosted by your trading partner.

    13.  An AS3 implementation MUST be able to send business documents  

         and mdns to a trading partner's currently configured ftp server 

         interface. 

    14.  An AS3 implementation may imbed ftp client code into their product

         or use an third-party ftp client.

    15.  Example Configurations

         1. Peer to Peer

            TPA is using a local ftp server and TPB is using an imbedded ftp

            server. 

         [A Client] ----( connect )----> [B Server]

         [A Client] ----( send )-------> [B Server] [AS3-Message]

         [A Client] ----( disconnect )-> [B Server]

         [A Server] <---( connect )----- [B Client]

         [A Server] <---( send )-------- [B Client] [AS3-MDN]]

         [A Server] <---( disconnect )-- [B Server]

         [A Client] <---( GET )--------- [A Server]             

         2. Third Party Hosting

            Both parties are using the same third-party hosted ftp server.

         [A Client] ----( connect )----> [Hosted Server]

         [A Client] ----( send )-------> [Hosted Server] [AS3-Message]

         [A Client] ----( disconnect )-> [Hosted Server]

         [Hosted Server]( GET )--------> [B Client]

         [Hosted Server] <---( connect )----- [B Client]

         [Hosted Server] <---( send )-------- [B Client] [AS3-MDN]]

         [Hosted Server] <---( disconnect )-- [B Client]

         [A Client]      <---( GET )--------- [Hosted Server]             

         3. Trading Partner Hosting

            TPA is using the imbedded ftp server hosted by TPB.

         [A Client] ----( connect )----> [B Server]

         [A Client] ----( send )-------> [B Server] [AS3-Message]

         [A Client] ----( disconnect )-> [B Server]

         [B Server] <---( connect )----- [B Client]

         [B Server] <---( send )-------- [B Client] [AS3-MDN]]

         [B Server] <---( disconnect )-- [B Client]

         [A Client] <---( GET )--------- [B Server]  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Colombier Guillaume
Sent: Friday, October 21, 2005 9:54 AM
To: [email-masked]
Cc: Dale Moberg; Debra Petta
Subject: RE: Moving AS3 forward.

Hi,

Following the AS3 certification this year,  and especially our last conference call, I've been in touch with Terry
Harding to discuss scenarios that were part of the certification process but that, according to me, were not

detailed engough in the draft  (hosting,  not hosting the FTP server etc...).

I know that this is not directly linked to AS3 messages format but more to the binding with FTP, however I think

that this should be addressed in the standard which must be exhaustive enough for somebody implementing

AS3 to sucessfully go through the certification. This is my point and I would be very pleased to discuss this

with the group.

I know that Terry had worked on it but I don't know if he had time to publish a new draft (I haven't received any new

document through the e-list).

 By the way, I agree with Debra, we've all put a lot of development and testing effort into our product for the AS3

support and I'd like to see it moved forward in the standard process. 

	-----Original Message-----
	From: [email-masked] [mailto:[email-masked]]On Behalf Of Dale Moberg
	Sent: Friday, October 21, 2005 11:13 AM
	To: [email-masked]
	Subject: Moving AS3 forward.

		Hi

		or 

		We can then lobby Rik D.

		Thanks

---

From: "Richard Bigelow" <[email-masked]>
Date: Fri, 21 Oct 2005 12:32:02 -0700

Inovis would like to see it move forward.

Richard Bigelow

Hi

or 

We can then lobby Rik D.

Thanks