Subject: [Edm] s2n-quic compliance

From: "Christopher Wood" <[email-masked]>
Date: Sat, 19 Feb 2022 15:15:01 -0800

Hi folks,

In case you haven’t seen it yet, Amazon’s QUIC implementation (s2n-quic) comes with a very clever way of tracking compliance between the code and various specifications. Check it out here:

https://dnglbrstg7yg.cloudfront.net/08c33571ee8679775e810303f65c96c1d48e270d/compliance.html#/

I’m sharing here because I think it’s useful input to the program, especially as we consider how to track implementations for various specifications. 

Best,
Chris

---

From: Mirja Kuehlewind <[email-masked]>
Date: Wed, 23 Feb 2022 14:54:35 +0100

This is quite interesting. Thanks for sharing! 

I guess, while all MUST/SHOULD/MAY clearly indicate a normative requirement, I don’t think that necessarily all normative requirements are indicted by one of these keywords. So this is a nice compliance check but probably not complete.

> On 20. Feb 2022, at 00:15, Christopher Wood <[email-masked]> wrote:
> 
> Hi folks,
> 
> -- 
> Edm mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/edm