Subject: [edu-team] IPR Feeding Frenzy

From: "James Kempf" <[email-masked]>
Date: Fri, 16 Sep 2005 08:47:03 -0700

So anyone who is interested in seeing a feeding frenzy on IPR, please tune 
into the CAPWAP WG. They are currently in the first phase of Thomas's 7 step 
program. A large equipment vendor (who shall remain nameless) has decided to 
use IETF's declared and undeclared IPR policy as a way to influence the 
protocol selection process. This vendor has claimed IPR on all the protocol 
proposals, but agreed to a royalty free release only on the proposal in its 
products. If any of the others are selected, royalties would need to be 
paid.

            jak 

_______________________________________________
edu-team mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/edu-team

---

From: Thomas Narten <[email-masked]>
Date: Fri, 16 Sep 2005 11:50:35 -0400

Wow, even by IETF standards, this is pretty amazing!!!

Thomas

---

From: Radia Perlman <[email-masked]>
Date: Fri, 16 Sep 2005 09:19:58 -0700

Does this technically violate any of the rules as written?

James Kempf wrote:

> So anyone who is interested in seeing a feeding frenzy on IPR, please 
> tune into the CAPWAP WG. They are currently in the first phase of 
> Thomas's 7 step program. A large equipment vendor (who shall remain 
> nameless) has decided to use IETF's declared and undeclared IPR policy 
> as a way to influence the protocol selection process. This vendor has 
> claimed IPR on all the protocol proposals, but agreed to a royalty 
> free release only on the proposal in its products. If any of the 
> others are selected, royalties would need to be paid.
>
>            jak
>
>

---

From: "James Kempf" <[email-masked]>
Date: Fri, 16 Sep 2005 09:31:16 -0700

Well, as far as I can tell, no.

Basically, 3979 just requires RAND. Both releases - for the company's 
products and for the competitors' - are RAND, it's just that people would 
have to pay if the one of the competitors' proposals were adopted as a 
standard, and not if the company's proposal was adopted.

So the issue is the unwritten IETF preference for royalty free (at least) 
IPR in IETF standards. Theoretically, the strategy is designed to play to 
that. But, right now, people are so mad about it that I don't know what will 
happen.

But then I am not a lawyer.

            jak

----- Original Message ----- 
From: "Radia Perlman" <[email-masked]>
To: "James Kempf" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, September 16, 2005 9:19 AM
Subject: Re: [edu-team] IPR Feeding Frenzy

>> nameless) has decided to use IETF's declared and undeclared IPR policy as 
>> a way to influence the protocol selection process. This vendor has 
>> claimed IPR on all the protocol proposals, but agreed to a royalty free 
>> release only on the proposal in its products. If any of the others are 
>> selected, royalties would need to be paid.
>>
>>            jak
>>
>>

---

From: Radia Perlman <[email-masked]>
Date: Fri, 16 Sep 2005 09:46:00 -0700

OK. Suppose company X files two patents
a) general concept
b) very very specific...."a method of doing ... where the packet header 
looks
exactly like this and these are the specific packets that get exchanged 
under these rules..."

Says patent a) is RAND, and patent b) is RF.

Would that appear less objectionable?

Radia

James Kempf wrote:

> products and for the competitors' - are RAND, it's just that people 
> would have to pay if the one of the competitors' proposals were 
> adopted as a standard, and not if the company's proposal was adopted.
>
> So the issue is the unwritten IETF preference for royalty free (at 
> least) IPR in IETF standards. Theoretically, the strategy is designed 
> to play to that. But, right now, people are so mad about it that I 
> don't know what will happen.
>
> ----- Original Message ----- From: "Radia Perlman" 
> <[email-masked]>
>>> So anyone who is interested in seeing a feeding frenzy on IPR, 
>>> please tune into the CAPWAP WG. They are currently in the first 
>>> phase of Thomas's 7 step program. A large equipment vendor (who 
>>> shall remain nameless) has decided to use IETF's declared and 
>>> undeclared IPR policy as a way to influence the protocol selection 
>>> process. This vendor has claimed IPR on all the protocol proposals, 
>>> but agreed to a royalty free release only on the proposal in its 
>>> products. If any of the others are selected, royalties would need to 
>>> be paid.
>>>
>>>            jak
>>>
>>>

---

From: [email-masked] (Scott Bradner)
Date: Fri, 16 Sep 2005 12:51:04 -0400 (EDT)

> Basically, 3979 just requires RAND

actually it does not REQUIRE any particular offering - it permits anything
the IPR holder wants to say - but I agree with teh rest of what jak says

----
>From [email-masked]  Fri Sep 16 12:32:15 2005
From: "James Kempf" <[email-masked]>
To: "Radia Perlman" <[email-masked]>
Subject: Re: [edu-team] IPR Feeding Frenzy
Date: Fri, 16 Sep 2005 09:31:16 -0700
Cc: [email-masked]
Sender: [email-masked]

            jak

---

From: Radia Perlman <[email-masked]>
Date: Fri, 16 Sep 2005 09:52:20 -0700

Just making sure I don't get misinterpreted by my last email...I'm not 
arguing that what they're doing is
right, I'm just geekily trying to understand the rules, understand what 
the intent was
when writing the rules, and think of perhaps how the rules could be 
reworded to get
that intent.

Radia

Radia Perlman wrote:

> b) very very specific...."a method of doing ... where the packet 
> header looks
> exactly like this and these are the specific packets that get 
> exchanged under these rules..."
>
>>>> products. If any of the others are selected, royalties would need 
>>>> to be paid.
>>>>
>>>>            jak
>>>>
>>>>

---

From: "James Kempf" <[email-masked]>
Date: Fri, 16 Sep 2005 10:03:35 -0700

What do you mean by objectionable? Both are acceptable by the rules. I think 
WG reaction would really depend on the particular circumstances.

            jak

----- Original Message ----- 
From: "Radia Perlman" <[email-masked]>
To: "James Kempf" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, September 16, 2005 9:46 AM
Subject: Re: [edu-team] IPR Feeding Frenzy

>> that. But, right now, people are so mad about it that I don't know what 
>> will happen.
>>

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 19 Sep 2005 10:06:11 +0200

Radia,

I think the rules were based on the assumption that companies
would have the collective intelligence to realise that it is
not in their long term interests to game the system.

There is little we can do when somebody fails to realise this
(just as there is little we can do when a company that has not
contributed at all to the IETF claims IPR in an IETF technology).

But it does underline the need for a very clear explanation
for IETF participants, so that they don't get confused about what's
going on.

    Brian