Subject: [edu-team] A potential new tutorial for a future IETF

From: Radia Perlman <[email-masked]>
Date: Sun, 11 Sep 2005 23:11:50 -0700

Maybe we can discuss this tomorrow (today, by the time you guys get this)

Radia

Subject: Tutorial for consideration
From: Bijan Jabbari <[email-masked]>
To: Radia Perlman <[email-masked]>
Date: Mon, 12 Sep 2005 02:01:17 -0400

Hello Radia,

  Per our telephone discussion on Friday afternoon, I am sending a brief
description of a tutorial to demystify MPLS and related technologies. I 
will be
tied up with my classes during the IETF in Vancouver, BC, but should be
available for IETF 65 or 66.

Tutorial on MPLS and GMPLS

  This presentation will review the main attributes of MultiProtocol Label
Switching (MPLS) and discuss the major application of this protocol. 
These will
include layer 2 and layer 3 VPNs, Traffic Engineering, high availability and
security aspects. Subsequently, generalization of the MPLS (GMPLS) and
development of a control plane with applications to IP Optical Integration and
Layer 1 VPNS are discussed. The goal of this presentation is to provide a
pedagogic discussion of specific ways in which MPLS has evolved 
starting from a
simple notion of labels and label swapping to a framework for more useful
applications.

Presenter: Bijan Jabbari (Professor, GMU)

Thanks.

  Regards,
  - Bijan

_______________________________________________
edu-team mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/edu-team

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 12 Sep 2005 15:53:28 +0200

Emergency conf call number for the call coming up:

IETF Chair conference call

US Toll Free 1 866 295 1793
US Toll     +1 706 758 1804

Conference ID: 522 710 9841 #

International toll-free numbers (don't always work first time):

Argentina: 08006661402
Australia: 1800007589
Austria: 0800291783
Bahamas: 18003890387
Belgium: 080079440
China: 108007140725
Colombia: 018005180234
Denmark: 80881466
Dominican Republic: 18887514620
Finland: 0800116215
France: 0800902648
Germany: 08001825562
Greece: 0080016122031289
Hong Kong: 800967421
Hungary: 0680015979
Iceland: 8008251
Indonesia: 08800105588
Ireland: 1800685010
Israel: 1809451289
Italy: 800786366
Japan: 00531160430
Korea (South): 00308140533
Luxembourg: 80024449
Malaysia: 1800808209
Mexico: 0018005141289
Netherlands: 08000225934
New Zealand: 0800447613
Norway: 80013909
Poland: 008001114673
Portugal: 800819314
Russian Federation: 81080023671012
Saint Kitts and Nevis: 18007449298
Singapore: 8001011564
South Africa: 0800994920
Spain: 900931577
Sweden: 0200285751
Switzerland: 0800562314
Thailand: 0081001562031288
Trinidad and Tobago: 18002031300
United Kingdom: 08000327717

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 14 Sep 2005 10:05:02 +0200

Have we ever done a tutorial on handling IPR issues?

There's a constant level of confusion from people hitting
this for the first time, and it's clear that what is said
in the newcomer's training isn't enough and doesn't soak
in. And it concerns everybody, not just WG Chairs.

Scott Br* would be the candidate speakers (Bradner because
he wrote the base RFCs and Brim because he wrote RFC 3669).
David Black could also do a good job, I think.

    Brian

---

From: Avri Doria <[email-masked]>
Date: Wed, 14 Sep 2005 10:28:14 +0200

Hi,

It was done for the WG Chair's lunch but never for the community at  
large.

I think it is a good idea.  Another class that could be put into the  
process rotation.

At this point, though it is early still, I think the IETF65 schedule  
looks like:

Process:

Newcomers
RFC Editing
WG Leadership (2nd pass in rotation)

Technical

Security (2nd pass in rotation)
Open - MPLS/GMPLS ?
Open

Though, of course, there is no reason why the split needs to be 3+3,  
we could introduce the IPR class in IETF65 or wait until IETF66 if we  
have 2 new Technical topics - or put the routing back in for another  
pass.

a.

---

From: "Spencer Dawkins" <[email-masked]>
Date: Wed, 14 Sep 2005 07:19:27 -0500

About half of what we say about IPR in newcomers is "read the RFCs", and 
it's not clear that saying more in a 60-slide general presentation would 
help much. I agree that a separate tutorial would be useful.

When Scott updated the slides for IETF 63, he added some very important but 
subtle information ("if you can patent amusing a cat with a laser pointer, 
the IETF really can't limit its attention to unencumbered technologies"). 
But that was new, in IETF 63.

Spencer

---

From: Thomas Narten <[email-masked]>
Date: Wed, 14 Sep 2005 08:35:09 -0400

> help much. I agree that a separate tutorial would be useful.

IMO, if that is all we say, we are saying the wrong things. In my
experience, what chairs/folk need to hear on this topic more than
anything is:

1) understand the IPR seven-step program (denial, rage, ...,
   acceptance) that every WG goes through the first time it is
   confronted with IPR.

2) understand what the WG needs to make decisions on.

3) understand what is appropritae and not appropriate to talk about
   w.r.t. to IPR. Understand what engineers can talk about (and have
   opinions about) and where lawyers have the final word and where
   engineer opinions are completely irrelevant (and thus not a
   productive use of IETF time).

4) do not let FUD/uncertainty about IPR put work on hold indefinitely;
   we have processes for dealing with IPR, and IPR does not
   automatically stop all work on a document. Be sure the WG clearly
   understands what its options are, what decisions it needs to make,
   and put in place a game plan for working through the steps in a
   timely fashion.

Despite what the RFCs we have say, and much experience with IPR, I'm
constantly amazed/depressed how the existance/disclosure of IPR
becomes such a FUD magnet and how WGs so often act like deer caught in
the headlights.

Thomas

---

From: "Spencer Dawkins" <[email-masked]>
Date: Wed, 14 Sep 2005 08:38:29 -0500

> experience, what chairs/folk need to hear on this topic more than

Thomas's list is interesting... for background,

The IETF Overview presentation (target audience = anyone breathing) has 8 
slides on IPR.

- two are on issues

- two are on patents

- one is on copyright

- three are a detailed walkthrough of the Note Well statement, so people can 
ask questions about the details ("don't say you weren't warned").

The WG Leadership (target audience = current and future WG chairs/editors) 
has one slide on IPR, explaining what RFCs cover IPR and encouraging people 
to read RFC 3669.

Spencer

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 15 Sep 2005 12:02:32 +0200

I would say these are both largely insufficient, for the
reasons Thomas gave. Engineers do find this stuff disturbing
and need support in dealing with it. I think this tutorial would
be a sell-out.

     Brian

Spencer Dawkins wrote:
> The IETF Overview presentation (target audience = anyone breathing) has 
> 8 slides on IPR.
> 
> - two are on issues
> 
> - two are on patents
> 
> - one is on copyright
> 
> - three are a detailed walkthrough of the Note Well statement, so people 
> can ask questions about the details ("don't say you weren't warned").
> 
> The WG Leadership (target audience = current and future WG 
> chairs/editors) has one slide on IPR, explaining what RFCs cover IPR and 
> encouraging people to read RFC 3669.
> 
> Spencer
> 
>>