Subject: Re: [edu-team] DNS tutorial in Vancouver

From: Brian Carpenter <[email-masked]>
Date: Mon, 17 Sep 2007 09:25:15 +1200

That's fine, thanks.

Regards
    Brian Carpenter
    University of Auckland

P.S. About my address: it seems that DENIC runs a blacklist that
blocks gmail. It would be off-topic to explain why I think that is
really bad operational practice, but the result is that to write
to Peter, I need to use my new day job address. Please don't use
that for regular IETF communication!

On 2007-09-16 20:13, Peter Koch wrote:
> On Sun, Sep 16, 2007 at 04:26:24PM +1200, Brian Carpenter wrote:
> 
>> Do you plan to mention security issues and performance?
> 
> we'll talk about the lack of data origin authentication and integrity
> and will mention DNSSEC.  We'll also explain that DNSSEC still won't
> deliver data correctness.
> 
> For the performance aspect, some recent discussion shows that the protocol
> designers better do not try to optimize here, instead keep in mind
> 
>   o too many levels of indirection increase latency
>   o ... as do too many fallback (try NAPTR, else try SRV, else try A) schemes
>   o DNS was not designed to publish rapidly changing data
>     (caching is a feature, not a bug)
>   o (DNSSEC validation is "costly" in terms of CPU cycles)
> 
> Anything else you had in mind?
> 
> -Peter
> 

-- 
Regards
    Brian Carpenter
    University of Auckland

_______________________________________________
edu-team mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/edu-team

---

From: Peter Koch <[email-masked]>
Date: Sun, 16 Sep 2007 10:13:08 +0200

-Peter