Subject: Re: [edu-team] Remote participants, newcomers, and tutorials

From: Brian E Carpenter <[email-masked]>
Date: Sat, 27 Jul 2013 08:33:46 +1200

On 27/07/2013 03:32, John C Klensin wrote:
> Hi.
> 
> For a newcomer or someone expecting to write I-Ds, some of the
> most important sessions at the IETF are the various Sunday
> afternoon tutorials and introductions.  Many of them are (or
> should be) of as much interest to remote participants as to f2f
> attendees.   Until and unless a newcomer's tutorial can be
> prepared that is focused on remote participants, even that
> session should be of interest.
> 
> For this particular meeting all of the following seem relevant
> to at least some remote participants:
> 
> 	Newcomers' Orientation       
> 	Tools for Creating I-Ds and RFCs         
> 	IAOC Overview Session     
> 	Multipath TCP         
> 	Applying IP Flow Information Export (IPFIX) to Network
> Measurement and Management
> 
> So...
> 
> (1) The note below strongly implies that none of those sessions
> are being audiocast.    Why not and can that be fixed?

I think that would mean that the crew (partly volunteers) would
need to mobilise 24 hours earlier. Not impossible, I suppose,
but not free of costs either.

> 
> (2) There is no hint on the agenda or tools agenda about
> availability of presentation and related materials (slides,
> etc.) for those sessions.  Do those materials not exist? 

At the moment the various EDU tutorials usually get posted after
the event, and I agree that isn't ideal.

It would be useful for all these ancillary sessions to be included
in the "meeting materials" page and all agenda tools (official and
volunteer). Again, not impossible, in fact very desirable IMHO,
but not free.

    Brian
> I
> know, but a newcomer or remote participant might not, that I can
> find some tutorials by going to the IETF main page and going to
> "Tutorial" under "Resources", but I have no idea which of those
> links actually reflects what will be presented on Sunday.
> Assuming the presentation materials do exist for at least
> several of the sessions, finding them is much like the situation
> with subscribing to the 87all list.  It should no involve a
> treasure hunt at which only very experienced IETF participants
> can be expected to succeed.  
> 
> Specific suggestions:
> 
> (i) Let's get these open Sunday sessions audiocast and/or
> available over Meetecho or WebEx.  If that is impossible for
> IETF 87, it should be a priority for IETF 88 and later.
> 
> (ii) If there are presentation materials available, links from
> the tools agenda and an announcement to IETF-Announce as to
> where to find them would be desirable.
> 
> (iii) If presentation materials are not available, why not?
> And, more important, can this be made a requirement for IETF 88
> and beyond?
> 
> thanks,
>     john
> 
> 
> 
> --On Friday, July 26, 2013 12:00 +0200 Nick Kukich
> <[email-masked]> wrote:
> 
>> Greetings,
>>
>> For those interested in monitoring sessions or participating
>> remotely the following information may prove useful.
>> ...
>> All 8 parallel tracks at the IETF 87 meeting will be broadcast
>> starting with the commencement of working group sessions on
>> Monday, July 29, 2013 at 0900 CEST (UTC+2) and continue until
>> the close of sessions on Friday, August 2nd.
>> ...
> 
>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 27 Jul 2013 08:38:55 +1200

And there is a "Training" section in the meeting materials page.
It's empty... but thanks to somebody for putting it there.
All we need to do is figure out how to pre-load it.

Regards
   Brian

---

From: Jari Arkko <[email-masked]>
Date: Sat, 27 Jul 2013 09:04:56 +0300

John proposes that the edu team material should be visible in the usual meeting materials page. Could that be arranged? I see that we have a section for this in the meeting materials page, and with some content. That may be new, I had not seen it before. Can we upload the rest? Here's what there's currently:

> Newcomers' Orientation	- no 
> Multipath TCP	- yes
> Applying IP Flow Information Export (IPFIX) to Network Measurement and Management - yes
> German Students Orientation Session - no
> IAOC Overview Session	- no
> Tools for Creating I-Ds and RFCs - yes	

Also, this probably cannot be done for this time, but next time we should consider extending audiocasting to these sessions as well.

Jari

Begin forwarded message:

> From: John C Klensin <[email-masked]>
> Subject: Remote participants, newcomers, and tutorials (was: IETF87 Audio Streaming Info)
> Date: July 26, 2013 6:32:17 PM GMT+03:00
> To: [email-masked]
> Cc: [email-masked], [email-masked], [email-masked]
> 
> Hi.
> 
> etc.) for those sessions.  Do those materials not exist?  I

---

From: "Bradner, Scott" <[email-masked]>
Date: Sat, 27 Jul 2013 06:07:31 +0000

I sent in the newcomers presentation quite a while ago

Scott

Scott Bradner

Harvard University Information Technology
Innovation & Architecture
+1 617 495 3864
1350 Mass Ave., Room 760
Cambridge, MA 02138
www.harvard.edu/huit

On Jul 27, 2013, at 2:04 AM, Jari Arkko <[email-masked]> wrote:

> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team

---

From: Alexa Morris <[email-masked]>
Date: Fri, 26 Jul 2013 23:13:35 -0700

Inline:

> John proposes that the edu team material should be visible in the usual meeting materials page. Could that be arranged? I see that we have a section for this in the meeting materials page, and with…

Yes, this content is new -- I uploaded it about 5 hours ago. Unfortunately, the Newcomers' Orientation file is too large to upload (not sure why, I'm looking into that) and I don't have the others yet. As soon as I have copies, I will upload. 

> Also, this probably cannot be done for this time, but next time we should consider extending audiocasting to these sessions as well.

Yes, I can speak with the Meetecho team to see if we can arrange this. It's also the case that several of these sessions are available already as recordings on ietf.org (e.g. http://www.ietf.org/edu/process-oriented-tutorials.html#newcomers) and most of the tutorials do not change in content much between one or two meetings, so anyone could view the recorded version and feel that they were getting essentially the same tutorial. 

>>> the close of sessions on Friday, August 2nd.

----------
Alexa Morris / Executive Director / IETF
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
Phone: +1.510.492.4089 / Fax: +1.510.492.4001
Email: [email-masked]

Managed by Association Management Solutions (AMS)
Forum Management, Meeting and Event Planning
www.amsl.com <http://www.amsl.com/>

---

From: Jari Arkko <[email-masked]>
Date: Sat, 27 Jul 2013 09:17:16 +0300

I agree with John that audio and other things would be useful, but Brian is also correct that they do involve some work. Let us see what we can do on audio for IETF-88. Past recordings of the tutorials are available at http://www.ietf.org/edu/process-oriented-tutorials.html#newcomers.

The meeting materials page does now have a training section now - added a couple of hours ago, thanks Alexa! - and some of the materials are there. We're working on putting the rest there. 

(The newcomer's orientation file would already be there too but we're struggling with some bug in the system in the upload.) 

As for:

> The consensus of the IETF is that:
> 
>  "newcomers who attend Working Group meetings are encouraged to
>   observe and absorb whatever material they can, but should not
>   interfere with the ongoing process of the group"
> 
> It was also mentioned that:
> 
> "Working group meetings are not intended for the education of
>  individuals"
> 
> The first quote might discourage newcomers from participating.  I suggest discussing about the two quotes during the orientation as they could be misunderstood.

The second quote is valid in most cases, though we've had some sessions at times that were designed more as education than discussion. For instance, the IAB WCIT BOF last time.

But the first one is just plain wrong. Is this from RFC 3184? Many of the first time IETFers are here for a reason, are well-versed in the technology in question, and very much able to provide suggestions to the WG. Maybe RFC 3184 is in the need of an update. (It also says other things that may not be up to date, like that locating mailing list archives is hard. I don¨t think it has been hard ever since tools.ietf.org/wg/foo came about.)

Thanks for the feedback!

Jari

> Yes.
> POSH has not published a session agenda.  However, the BoF is listed on the meeting agenda.  Is the BoF cancelled or will this be one of those willful violations of IETF Best Current Practices?
> 
> Regards,
> -sm

---

From: Dave Crocker <[email-masked]>
Date: Sat, 27 Jul 2013 13:23:18 +0100

...
>>> The first quote might discourage newcomers from participating.  I
>>> suggest discussing about the two quotes during the orientation as
>>> they could be misunderstood.
...
> But the first one is just plain wrong. Is this from RFC 3184? Many of
> the first time IETFers are here for a reason, are well-versed in the
> technology in question, and very much able to provide suggestions to
> the WG.

It's not wrong.

It's badly worded, possibly bordering on rudeness.  It certainly lacks 
context.  And it probably doesn't apply to BOFs.  But it's not wrong.

WG face-to-face meetings are for resolving open issues.  Given 1-3 
hours, three times a year, these face to face meetings are not 
reasonable for any other purpose.  That's why doing the foundational 
work on the mailing list is essential.

We need to be /far/ more helpful to new folk who show up (on the mailing 
list or at the f2f) but having them take f2f time for education is 
simply not appropriate.  The time is too valuable.

If there really is an organizational shift towards making f2f wg 
meetings target education of new folk, then the meetings will cease to 
have /any/ utility for getting actual work done.  Really.

d/

ps. Small disclaimer: for ongoing work, it is often useful/necessary to 
start a status summary of the current situation.  Done well enough, 
these can look asymptotically similar to a tutorial.  But really, they 
are for the entire group, not (just) for new folk...

pps. and...
On 7/27/2013 11:02 AM, SM wrote:> At 23:17 26-07-2013, Jari Arkko wrote:
 > The following will be discussed in the DMARC BoF:
 >
 >    "a mechanism for protecting the <display-name> portion of the
 > RFC5322.From field"
 >
 > My guess is that it might be educational. :-)

    I'm involved with the DMARC effort.  I'm almost positive it won't be...

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Alejandro Acosta <[email-masked]>
Date: Fri, 26 Jul 2013 22:41:58 -0430

> IETF 87, it should be a priority for IETF 88 and later.

+1

---

From: John C Klensin <[email-masked]>
Date: Fri, 26 Jul 2013 11:32:17 -0400

Hi.

	Newcomers' Orientation       

So...

Specific suggestions:

thanks,
    john

---

From: John C Klensin <[email-masked]>
Date: Fri, 26 Jul 2013 18:10:32 -0400

--On Saturday, July 27, 2013 08:38 +1200 Brian E Carpenter
<[email-masked]> wrote:

> And there is a "Training" section in the meeting materials
> page. It's empty... but thanks to somebody for putting it
> there. All we need to do is figure out how to pre-load it.

And to remember that link appears on  the main meeting page
because it isn't on either of the agenda pages.  I suggest again
that these little treasure hunts work better for very
experienced participants and regular participants who are very
patient about searching for information, but much less well for
newcomers, remote-only participants, and the diverse and curious
potential participants we'd supposedly like to encourage.

I still believe that the agenda pages should be one-step
shopping for these types of meeting program-specific bits of
information, whether it be remote participation bits (or at lest
a pointer to whether they can be found) and meeting material
pages (ditto).  It is slightly extraneous information but I note
that we have had a list of Areas and ADs on the agenda pages
ever since I can remember.  That information is much more easily
located than most of the things I've been commenting on and, if
one locates it (IETF Home Page -> IESG -> Members) one even gets
contact information as a bonus.  And the listing of AD names is
pretty useless without contact info.

More inline.

>...
>>> (1) The note below strongly implies that none of those
>>> sessions are being audiocast.    Why not and can that be
>>> fixed?
>> 
>> I think that would mean that the crew (partly volunteers)
>> would need to mobilise 24 hours earlier. Not impossible, I
>> suppose, but not free of costs either.

Brian, there are two reasons I'm pushing on this set of issues.
One is that there are folks like you and me (and, since he
dropping into a different part of the thread, SM) who are
reasonably experienced participants but who are not likely to
attend most or all f2f meetings in the future.  To the extent to
which it is in the IETF's interest to keep us active --and I
hope that it is-- then a lot of this stuff ought to work (even
though  we will know about and, given enough patience, be able
to find meeting materials lists, mechanisms to subscribe to
slightly-hidden mailing lists, the actual names and locations of
incorrect links to drafts, names of BOF Chairs and responsible
ADs, etc.  If we are desperately concerned about hearing a
particular tutorial, I imagine that, with a little planning,
either of us could find someone to sit in the room and do a
Skype or equivalent if there was a functional network or get
someone to sit in the room with a voice recorder and make
something that could be converted into an MP3 file for
transmission after the network comes up.

I assume that, were the question posed, there would be general
IETF consensus that I run out of patience a lot faster than you
do.  I'm willing to concede that and agree that anything that
doesn't irritate you too is my problem and I should live with
it.  I certainly would have a lot of difficulty arguing for
folks going to a lot of extra trouble or expense on my account
(or even on yours).

However, the IETF has been having a lot of discussions about
newcomers, diversity, and attracting new folks to participate
and get work done.  I think those populations will be better
served if it is possible for people a lot less experienced than
the two of us can participate actively and constructively
without attending every meeting.  I also think that, especially
for many people from developing countries, universities, small
companies, and far-away places, we will be far more successful
in recruiting if we can encourage remote participation as a
starting point with the expectation of getting people physically
to meetings only after the value to them and their organizations
of doing so has been demonstrated.  I'd personally even favor
making remote participation at a could of meeting be a
prerequisite for most applications for ISOC's IETF Fellows
program.

But the above picture isn't going to happen unless we are
serious and treat that seriousness as an integral part of our
strategies about newcomers and diversity.  Seriousness to me
says that we get more careful about how experienced one has to
be to find critical information, that we make sure remote
participation works, and that we make any session that would be
relevant to remote participants accessible to them (and with
materials available as much as possible in advance and from
easy-to-find places).  Seriousness implies that, if there are
extra costs, we figure out how to cover them (or how to cut
somewhere else).  

Or, if we are not serious, it would probably be to the benefit
of the community for us to face that and stop wasting energy and
resources on outreach efforts that are expensive in one or the
other (or both).

best,
   john

---

From: SM <[email-masked]>
Date: Fri, 26 Jul 2013 11:29:07 -0700

Hello,
>to at least some remote participants:

[snip]

>can be expected to succeed.

It would be helpful to new people if everything in the IETF was not a 
treasure hunt or required an email broadcast for a person to find information.

Yes.

POSH has not published a session agenda.  However, the BoF is listed 
on the meeting agenda.  Is the BoF cancelled or will this be one of 
those willful violations of IETF Best Current Practices?

Regards,
-sm

---

From: SM <[email-masked]>
Date: Sat, 27 Jul 2013 00:43:59 -0700

>prerequisite for most applications for ISOC's IETF Fellows

Discussions that do not translation into actions are, well, 
discussions.  What is the easiest to enable the person from the 
university participate in the IETF meeting; what is the easiest way 
to enable the person from the small company to participate in the 
IETF meeting?  It is:

   (a) an audio stream

   (b) a jabber service

   (c) a jabber scribe

(a) and (b) are already available.  (c) is doable.  Will there be any 
results from that?  No.  Why should the IETF do that then?  Because 
it is simple, it is cheap, and if it works, who knows, there may be results.

>extra costs, we figure out how to cover them (or how to cut

Making information available is a first-step in getting things to 
work.  Please note that I do not see that as publishing some random 
web page.  I see that as making the information readily available to 
the target audience.

I'll quote part of a message from Benoit Claise:

   'Let me explain what the targeted audience is for those posters.

    It's not intended for the people who know about a specific BoF and plan on
    participating. It's intended for people who have not prepared for 
a specific
    BoF, but just come to listen to it, and in the end, go to mic. to provide
    some useful feedback: "pay attention to this!", "similar work was 
done ...",
    "don't forget that ...", "don't forget OPS" ;-)'

It is a down-to-earth explanation about how to get people interested 
in a specific BoF.

Two years ago (minus one day) Brian Carpenter objected to the fact 
that the regular
audio streaming is not available for the plenaries.  The link for the 
technical plenary audio stream is not available in the (tools) agenda.

>resources on outreach efforts that are expensive in one or the

It is a waste of energy and money to pursue outreach efforts if the 
IETF is not serious about how to lower the barriers for newcomers and 
its strategy about diversity.

Regards,
-sm

---

From: SM <[email-masked]>
Date: Sat, 27 Jul 2013 03:02:32 -0700

At 23:17 26-07-2013, Jari Arkko wrote:
>The second quote is valid in most cases, though we've had some 
>sessions at times that were designed more as education than 
>discussion. For instance, the IAB WCIT BOF last time.

I read the second quote as meaning that a WG session is not a how-to 
or a tutorial.  It might be help people understand if it is explained 
during the orientation session.

>But the first one is just plain wrong. Is this from RFC 3184? Many 
>of the first time IETFers are

Yes.

Regards,
-sm

---

From: Simon Pietro Romano <[email-masked]>
Date: Sat, 27 Jul 2013 16:15:53 +0200

Hello Jary and all,

for your information, the Meetecho team is going to record five tutorials on Sunday:

http://www.ietf.org/meeting/87/remote-participation.html#meetecho

We have already provided a URL for those who want to remotely attend the IAOC Overview Session. If you think this might be of interest, we can allow remotes to have access to the other tutorials as well. Just let us know, so we can advertise access URLs on the mentioned web page. As usual, we can provide a real-time, synchronized view of the sessions, involving audio, video and presentation slides.

Cheers,

Simon

>> POSH has not published a session agenda.  However, the BoF is listed on the meeting agenda.  Is the BoF cancelled or will this be one of those willful violations of IETF Best Current Practices?

                     					       _\\|//_
                           				      ( O-O )
   ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                    				Simon Pietro Romano
             				 Universita' di Napoli Federico II
                		     Computer Engineering Department 
	             Phone: +39 081 7683823 -- Fax: +39 081 7683816
                                           e-mail: [email-masked]

		    <<Molti mi dicono che lo scoraggiamento Ë l'alibi degli 
		    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
               			                     oooO
  ~~~~~~~~~~~~~~~~~~~~~~~(   )~~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
					                 \ (            (   )
			                                  \_)          ) /
                                                                       (_/

---

From: Jari Arkko <[email-masked]>
Date: Sat, 27 Jul 2013 16:43:40 +0200

Simon,

> We have already provided a URL for those who want to remotely attend the IAOC Overview Session. If you think this might be of interest, we can allow remotes to have access to the other tutorials as…

I think it would be useful. Thank you.

Jari

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 28 Jul 2013 08:37:15 +1200

> context.  And it probably doesn't apply to BOFs.  But it's not wrong.

It reads rudely when taken out of context. But try reading the whole
paragraph in RFC 3184:

      IETF participants who attend Working Group meetings read the
      relevant Internet-Drafts, RFCs, and e-mail archives beforehand, in
      order to familiarize themselves with the technology under
      discussion.  This may represent a challenge for newcomers, as e-
      mail archives can be difficult to locate and search, and it may
      not be easy to trace the history of longstanding Working Group
      debates.  With that in mind, newcomers who attend Working Group
      meetings are encouraged to observe and absorb whatever material
      they can, but should not interfere with the ongoing process of the
      group.  Working Group meetings run on a very limited time
      schedule, and are not intended for the education of individuals.
      The work of the group will continue on the mailing list, and many
      questions would be better expressed on the list in the months that
      follow.

Exactly. My experience back when I was a newcomer was that it was
easy enough to ask beginner's questions after the meeting, and obviously
wrong to do so during the session. This remains true years later, if I
drop into a WG that I'm not familiar with.

    Brian

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Sat, 27 Jul 2013 17:38:26 -0400

I think it would be really helpful/useful if working groups could provide short video overviews to help people understand the work.  This includes newcomers and also interested observers, who may include implementers.  Can that be accommodated, maybe at a future meeting?  I am happy to help if I can.

Thank you!
Kathleen 

Sent from my iPhone

---

From: Lorenzo Miniero <[email-masked]>
Date: Sun, 28 Jul 2013 08:58:36 +0200

Il giorno Sat, 27 Jul 2013 16:43:40 +0200
Jari Arkko <[email-masked]> ha scritto:

> > We have already provided a URL for those who want to remotely
> > attend the IAOC Overview Session. If you think this might be of
> > interest, we can allow remotes to have access to the other
> > tutorials as well. Just let us know, so we can advertise access
> > URLs on the mentioned web page. As usual, we can provide a
> > real-time, synchronized view of the sessions, involving audio,
> > video and presentation slides.
> 

We just updated our agenda page to include links to attend the tutorial
sessions remotely:

	http://ietf87.conf.meetecho.com/

not all are there yet but we'll add more later. The IAB Privacy
Tutorial link is already available, though and will become active in a
couple of minutes, as the session is about to start.

Lorenzo

---

From: John C Klensin <[email-masked]>
Date: Sun, 28 Jul 2013 05:06:15 -0400

--On Sunday, July 28, 2013 08:58 +0200 Lorenzo Miniero
<[email-masked]> wrote:

> 
> We just updated our agenda page to include links to attend the
> tutorial sessions remotely:
> 

Many thanks.
   john

---

From: Mirjam Kuehne <[email-masked]>
Date: Sun, 28 Jul 2013 12:46:04 +0200

Hi,

Sorry I am entering this discussion late (was en route to Berlin).
I see you already sorted out most of it. Great that the tutorials are 
now also listed under Meeting Materials (Thanks Alexa).

I'm not sure this was mentioned, but the tutorial descriptions and 
slides are also available on 
https://www.ietf.org/meeting/87/tutorials.html which is a direct link 
from "Agendas and Meeting Materials" (as soon as we get the slides, but 
usually before the tutorials start).

But maybe we can also link to that page from the Meeting Agenda 
(https://datatracker.ietf.org/meeting/87/agenda.html) so that you get to 
see the description and the slides of each tutorial when clicking on the 
tutorial name on the agenda.

And we also still use the edu-team wiki 
http://wiki.tools.ietf.org/group/edu/wiki/IETF87 which lists all the 
tutorials and slides. The link to the wikis is listed under Resources 
under the IETF home page (just under Tutorials actually).

As Alexa said, Meetecho doesn't always record all the tutorials. For 
this meeting, all tutorials will be recorded except for the Newcomers 
(because we recorded that last time, and even though Scott changed the 
slides for this meeting, we thought we'd wait until next time).

Over the last few meetings, we worked closely with the secretariat to 
make the tutorials more visible on the IETF meeting pages. Of course 
this can always be improved. If you have any other suggestions, please 
let us know!

Cheers,
Mirjam

---

From: Mirjam Kuehne <[email-masked]>
Date: Sun, 28 Jul 2013 12:54:51 +0200

Hi Kathleen,

The Edu Team tried to achieve this by providing a high-level overview of 
all the IETF areas (including a short description of the various WGs, 
current discussions and hot topics etc.). The RAI people offered to do 
that for the first time in Orlando:

https://www.ietf.org/edu/process-oriented-tutorials.html#raiinfrastructure

and we're planning to repeat this session at the next meeting (it will 
then also be recorded).

Unfortunately we didn't get a lot of response from other areas. So, any 
help in that respect would be appreciated!

Kind regards,
Mirjam Kuehne
(Edu Team)