Subject: Re: [edu-team] AAA tutorial for IETF 89

From: <[email-masked]>
Date: Sat, 1 Mar 2014 10:29:55 +0000

Hi,

Here is (pre) final version. The presentation is still under final review by other folks involved in AAA. But except minor correction/clarification, the content of the presentation will not change. You can consider the content as it is and let me know if you have additional comments.

I will send the final version before the end of this afternoon.

Lionel

-----Message d'origine-----
De : Benoit Claise [mailto:[email-masked]] 
Envoyé : vendredi 28 février 2014 15:56
À : Mirjam Kuehne; MORAND Lionel IMT/OLN
Cc : EDU Team
Objet : Re: AAA tutorial for IETF 89

On 28/02/2014 12:09, Mirjam Kuehne wrote:
> Thanks for sending the slides, Lionel. I think this is indeed going in 
> the right direction. Adding a section about criteria for when to use 
> RADIUS and Diameter would be useful.
Feedback was sent to Lionel in a different thread.

Regards, B.
>
> Let's see if others have any feedback.
>
> Please send the final version as soon as you can so we can upload them 
> to the web site before the tutorial.
>
> Regards,
> Mirjam
>
> P.S.: No, there is no official template for the tutorial slides.
>
>
> On 28/2/14 2:15 AM, [email-masked] wrote:
>> Hi Mirjam,
>>
>> Just to reassure you that something will be available for the tutorial.
>> Here is the draft of the presentation introducing RADIUS and 
>> Diameter. I tried to remain as much as possible far away from the 
>> technical details in the slides to keep a friendly approach. In the 
>> same line, I've tried to favour speech over two wordy slides when 
>> possible.
>>
>> The last part is under consolidation and will deal with key criteria 
>> for choice between RADIUS and Diameter when AAA functions are required.
>>
>> Of course, table of contents, inserts, references, etc. will be also 
>> added.
>>
>> I hope that it is in line with the goals we have set in Vancouver for 
>> this tutorial.
>>
>> Of course, feedbacks are more than welcome.
>>
>> Regards,
>>
>> Lionel
>>
>> PS: any "official" template for the slides?
>>
>>
>> -----Message d'origine-----
>> De : Mirjam Kuehne [mailto:[email-masked]]
>> Envoyé : mardi 25 février 2014 11:36
>> À : MORAND Lionel IMT/OLN
>> Cc : EDU Team
>> Objet : Re: AAA tutorial for IETF 89
>>
>> Hi Lionel,
>>
>> How is it going with the slides? Can you please send them as soon as
>> possible, so the Edu Team can review them before the end of the week.
>>
>> Thanks,
>> Mirjam
>>
>> On 3/2/14 11:20 AM, [email-masked] wrote:
>>> Hi Mirjam,
>>>
>>> Thank for the gentle reminder :)
>>> I'm working on the slide deck.
>>> When do you think the material should be available for the tutorial?
>>> I could distribute a pre-final version on the week of the Monday, 
>>> 17. For final check and possible adjustment before submission.
>>> Would it be OK for you?
>>>
>>> Regards,
>>>
>>> Lionel
>>>
>>> -----Message d'origine-----
>>> De : Mirjam Kuehne [mailto:[email-masked]]
>>> Envoyé : mercredi 22 janvier 2014 10:54
>>> À : MORAND Lionel IMT/OLN
>>> Cc : Radia Perlman
>>> Objet : Re: AAA tutorial for IETF 89
>>>
>>> Hi Lionel,
>>>
>>> This is just a gentle reminder to prepare slides for the AAA 
>>> tutorial in
>>> London. Radia offered to review them with you and others on the Edu 
>>> TEam
>>> might also have some feedback. Can you please et me know when you'll
>>> have something ready.
>>>
>>> Thank you,
>>> Mirjam
>>>
>>>
>>> _________________________________________________________________________________________________________________________ 
>>>
>>>
>>> Ce message et ses pieces jointes peuvent contenir des informations 
>>> confidentielles ou privilegiees et ne doivent donc
>>> pas etre diffuses, exploites ou copies sans autorisation. Si vous 
>>> avez recu ce message par erreur, veuillez le signaler
>>> a l'expediteur et le detruire ainsi que les pieces jointes. Les 
>>> messages electroniques etant susceptibles d'alteration,
>>> Orange decline toute responsabilite si ce message a ete altere, 
>>> deforme ou falsifie. Merci.
>>>
>>> This message and its attachments may contain confidential or 
>>> privileged information that may be protected by law;
>>> they should not be distributed, used or copied without authorisation.
>>> If you have received this email in error, please notify the sender 
>>> and delete this message and its attachments.
>>> As emails may be altered, Orange is not liable for messages that 
>>> have been modified, changed or falsified.
>>> Thank you.
>>>
>>
>>
>> _________________________________________________________________________________________________________________________ 
>>
>>
>> Ce message et ses pieces jointes peuvent contenir des informations 
>> confidentielles ou privilegiees et ne doivent donc
>> pas etre diffuses, exploites ou copies sans autorisation. Si vous 
>> avez recu ce message par erreur, veuillez le signaler
>> a l'expediteur et le detruire ainsi que les pieces jointes. Les 
>> messages electroniques etant susceptibles d'alteration,
>> Orange decline toute responsabilite si ce message a ete altere, 
>> deforme ou falsifie. Merci.
>>
>> This message and its attachments may contain confidential or 
>> privileged information that may be protected by law;
>> they should not be distributed, used or copied without authorisation.
>> If you have received this email in error, please notify the sender 
>> and delete this message and its attachments.
>> As emails may be altered, Orange is not liable for messages that have 
>> been modified, changed or falsified.
>> Thank you.
>>
>
> .
>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Radia Perlman <[email-masked]>
Date: Sat, 1 Mar 2014 11:24:51 -0800

I'm having trouble opening the slides.  Can you send it to me at just plain
ppt (or pptx) instead of a zip?

Thanks,

Radia

On Thu, Feb 27, 2014 at 5:15 PM, <[email-masked]> wrote:

> Here is the draft of the presentation introducing RADIUS and Diameter. I
> tried to remain as much as possible far away from the technical details in
> the slides to keep a friendly approach. In the same line, I've tried to
> favour speech over two wordy slides when possible.
>
> The last part is under consolidation and will deal with key criteria for
> choice between RADIUS and Diameter when AAA functions are required.
>
> Of course, table of contents, inserts, references, etc. will be also added.
>
> I hope that it is in line with the goals we have set in Vancouver for this
> tutorial.
>
> > I could distribute a pre-final version on the week of the Monday, 17.
> For final check and possible adjustment before submission.
> > Would it be OK for you?
> >
> > Regards,
> >
> > Lionel
> >
> > This is just a gentle reminder to prepare slides for the AAA tutorial in
> > London. Radia offered to review them with you and others on the Edu TEam
> > pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> > a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> > This message and its attachments may contain confidential or privileged
> information that may be protected by law;
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>
>

---

From: Radia Perlman <[email-masked]>
Date: Sat, 1 Mar 2014 11:27:22 -0800

Never mind.  I tried a different browser and that worked.

---

From: Radia Perlman <[email-masked]>
Date: Sat, 1 Mar 2014 11:43:02 -0800

Wow!  The slides are great.  Including humor...

You might want to expand "TLV"...a surprising number of people don't know
what that means.

You might want explicit slide numbers (sometimes questions at the end are
"I have a question about slide #35".

Slide number 28 has a weird cut and paste problem with some message about
Tuesdays.

Slide 30.  Might be nice to have another slide that lists the kinds of
capabilities...just so someone can imagine what a "capability" is

Not sure if everyone knows what DTLS is yet. You might want a parenthetical
remark (TLS over UDP).  Or just remember to say it.

Slide 32 ... What's AVP? (I did a quick Google, and found Avon Products,
Anti-violence, Beach Volleyball, Alien vs Predator, before I found
"attribute value pairs", which is presumably (?) what you meant?

Slide 33: What do diameter ids look like?  And again, might be nice to have
a slide after this with examples of ids and capabilities

Slide 34.  What's a realm? How do they get assigned? What does the ID of a
realm look like?  Slide 39 kind of talks about it, I think.

Have to rush off somewhere, but might send comments on the rest later.

Anyway, great slides!!

Radia

---

From: Radia Perlman <[email-masked]>
Date: Sat, 1 Mar 2014 13:10:38 -0800

Yes.  Please send the latest version. But I did find a later one.  I'd
gotten so distracted by having my browser not know how to open a .zip that
I had opened an earlier email once I went to a different machine in my
house to try there.

It's easy to add slide numbers (in ppt, select "insert" then "headers and
footers" then "slide number").

I was wondering about configuration.  Presumably the access point is
configured with the IP address of the RADIUS server.  Is the RADIUS server
configured with the IP addresses of all access points?  Is the access point
configured with multiple IP addresses, in case one RADIUS server is down?
Is there any cryptographic authentication between the access point and
RADIUS server?  Can anyone send queries to the RADIUS server saying "Is
this Radia's password?" a zillion times?

Slide 46: How can a session ID be globally and eternally unique if it's
based on the "peer identity initiated the session", since presumaly the
identities never change across sessions?  Presumably there is other
information in the session ID?  (Plus a typo perhaps "peer identity that
initiated the session")

Slide 50.  I'm confused by "or a kind of" in the title.  Presumably what
you are talking it won't be confusing

Thank you for slides 59 and 60!

And the deep question...what's a "new protocol" and what's a "new version
of an existing protocol"?  Why wasn't DIAMETER merely extending RADIUS?

Again...the slides look great.  I love the humor and clarity.

Radia

On Sat, Mar 1, 2014 at 11:47 AM, <[email-masked]> wrote:

>  In the plane for London :-)
>
> I think that you haven't taken the latest version of the slides.
> Anyway, some of your comments will remain valid. I will take them into account in revision tonight.
>
> Is it ok to send you a new version tomorrow morning?
>
> Lionel
>
> Envoyé depuis mon Sony Xperia SP d'Orange
>
> Radia Perlman <[email-masked]> a écrit :
>
>
>  You might want to expand "TLV"...a surprising number of people don't
> know what that means.
>
>  You might want explicit slide numbers (sometimes questions at the end
> are "I have a question about slide #35".
>
>  Slide number 28 has a weird cut and paste problem with some message
> about Tuesdays.
>
>  Not sure if everyone knows what DTLS is yet. You might want a
> parenthetical remark (TLS over UDP).  Or just remember to say it.
>
>  Slide 33: What do diameter ids look like?  And again, might be nice to
> have a slide after this with examples of ids and capabilities
>
>  Slide 34.  What's a realm? How do they get assigned? What does the ID of
> a realm look like?  Slide 39 kind of talks about it, I think.
>

---

From: <[email-masked]>
Date: Sat, 1 Mar 2014 15:12:01 +0000

Bonjour,

Here is the final set.
Both ppt and pdf are provided but I would prefer to see the pdf format online.

If you would like to see some changes before the presentation, I will be able to do it late tonight or tomorrow morning.
Otherwise, please upload the presentation.

Regards,

Lionel

-----Message d'origine-----
De : MORAND Lionel IMT/OLN 
Envoyé : samedi 1 mars 2014 11:29
À : 'Benoit Claise'; Mirjam Kuehne
Cc : EDU Team
Objet : RE: AAA tutorial for IETF 89

Hi,

Lionel

-----Message d'origine-----
De : Benoit Claise [mailto:[email-masked]] Envoyé : vendredi 28 février 2014 15:56 À : Mirjam Kuehne; MORAND Lionel IMT/OLN Cc : EDU Team Objet : Re: AAA tutorial for IETF 89

Regards, B.
>> De : Mirjam Kuehne [mailto:[email-masked]] Envoyé : mardi 25 février 
>> 2014 11:36 À : MORAND Lionel IMT/OLN Cc : EDU Team Objet : Re: AAA 
>> tutorial for IETF 89
>>
>> Hi Lionel,
>>
>>> De : Mirjam Kuehne [mailto:[email-masked]] Envoyé : mercredi 22 
>>> janvier 2014 10:54 À : MORAND Lionel IMT/OLN Cc : Radia Perlman 
>>> tutorial in London. Radia offered to review them with you and others 
>>> on the Edu TEam might also have some feedback. Can you please et me 
>>> know when you'll have something ready.
>>>
>>> Thank you,
>>> Mirjam
>>>
>>>
>>> ____________________________________________________________________
>>> _____________________________________________________
>>>
>>>
>>> confidentielles ou privilegiees et ne doivent donc pas etre 
>>> diffuses, exploites ou copies sans autorisation. Si vous avez recu 
>>> ce message par erreur, veuillez le signaler a l'expediteur et le 
>>> detruire ainsi que les pieces jointes. Les messages electroniques 
>>> etant susceptibles d'alteration, Orange decline toute responsabilite 
>>> si ce message a ete altere, deforme ou falsifie. Merci.
>>>
>>> privileged information that may be protected by law; they should not 
>>> be distributed, used or copied without authorisation.
>> _____________________________________________________________________
>> ____________________________________________________
>>
>>
>> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, 
>> exploites ou copies sans autorisation. Si vous avez recu ce message 
>> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi 
>> que les pieces jointes. Les messages electroniques etant susceptibles 
>> d'alteration, Orange decline toute responsabilite si ce message a ete 
>> altere, deforme ou falsifie. Merci.
>>
>> privileged information that may be protected by law; they should not 
>> be distributed, used or copied without authorisation.

---

From: <[email-masked]>
Date: Sat, 1 Mar 2014 19:47:53 +0000

Lionel

You might want to expand "TLV"...a surprising number of people don't know what that means.

You might want explicit slide numbers (sometimes questions at the end are "I have a question about slide #35".

Slide number 28 has a weird cut and paste problem with some message about Tuesdays.

Slide 30.  Might be nice to have another slide that lists the kinds of capabilities...just so someone can imagine what a "capability" is

Not sure if everyone knows what DTLS is yet. You might want a parenthetical remark (TLS over UDP).  Or just remember to say it.

Slide 32 ... What's AVP? (I did a quick Google, and found Avon Products, Anti-violence, Beach Volleyball, Alien vs Predator, before I found "attribute value pairs", which is presumably (?) what you meant?

Slide 33: What do diameter ids look like?  And again, might be nice to have a slide after this with examples of ids and capabilities

Slide 34.  What's a realm? How do they get assigned? What does the ID of a realm look like?  Slide 39 kind of talks about it, I think.

Anyway, great slides!!

Radia

On Thu, Feb 27, 2014 at 5:15 PM, <[email-masked]<mailto:[email-masked]>> wrote:
Hi Mirjam,

Just to reassure you that something will be available for the tutorial.
Here is the draft of the presentation introducing RADIUS and Diameter. I tried to remain as much as possible far away from the technical details in the slides to keep a friendly approach. In the same line, I've tried to favour speech over two wordy slides when possible.

The last part is under consolidation and will deal with key criteria for choice between RADIUS and Diameter when AAA functions are required.

I hope that it is in line with the goals we have set in Vancouver for this tutorial.

Regards,

Lionel

-----Message d'origine-----
De : Mirjam Kuehne [mailto:[email-masked]<mailto:[email-masked]>]
Envoyé : mardi 25 février 2014 11:36
À : MORAND Lionel IMT/OLN
Cc : EDU Team
Objet : Re: AAA tutorial for IETF 89

Hi Lionel,

Thanks,
Mirjam

On 3/2/14 11:20 AM, [email-masked]<mailto:[email-masked]> wrote:
> I could distribute a pre-final version on the week of the Monday, 17. For final check and possible adjustment before submission.
> Would it be OK for you?
>
> Regards,
>
> Lionel
>
> De : Mirjam Kuehne [mailto:[email-masked]<mailto:[email-masked]>]

_______________________________________________
edu-team mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/edu-team

---

From: <[email-masked]>
Date: Sun, 2 Mar 2014 11:00:25 +0000

Hi Radia, Mirjam

I have taken into account your comments in this last version of the presentation.
I have added two slides to highlight the security model in RADIUS and Diameter.
Some of the requested clarifications will be in the speech.

Please upload the pdf version.

I will be in the meeting room around 14:30. If there is any issue, my phone number is +33 6 0775 8936.

Regards,

Lionel

De : Radia Perlman [mailto:[email-masked]]
Envoyé : samedi 1 mars 2014 22:11
À : MORAND Lionel IMT/OLN
Cc : Mirjam Kuehne; Benoit Claise; EDU Team
Objet : Re: [edu-team] AAA tutorial for IETF 89

Yes.  Please send the latest version. But I did find a later one.  I'd gotten so distracted by having my browser not know how to open a .zip that I had opened an earlier email once I went to a different machine in my house to try there.

It's easy to add slide numbers (in ppt, select "insert" then "headers and footers" then "slide number").

I was wondering about configuration.  Presumably the access point is configured with the IP address of the RADIUS server.  Is the RADIUS server configured with the IP addresses of all access points?  Is the access point configured with multiple IP addresses, in case one RADIUS server is down? Is there any cryptographic authentication between the access point and RADIUS server?  Can anyone send queries to the RADIUS server saying "Is this Radia's password?" a zillion times?

Slide 46: How can a session ID be globally and eternally unique if it's based on the "peer identity initiated the session", since presumaly the identities never change across sessions?  Presumably there is other information in the session ID?  (Plus a typo perhaps "peer identity that initiated the session")

Slide 50.  I'm confused by "or a kind of" in the title.  Presumably what you are talking it won't be confusing

And the deep question...what's a "new protocol" and what's a "new version of an existing protocol"?  Why wasn't DIAMETER merely extending RADIUS?

Radia

On Sat, Mar 1, 2014 at 11:47 AM, <[email-masked]<mailto:[email-masked]>> wrote:

Lionel

Radia Perlman <[email-masked]<mailto:[email-masked]>> a écrit :

Anyway, great slides!!

Radia

Regards,

Lionel

-----Message d'origine-----
De : Mirjam Kuehne [mailto:[email-masked]<mailto:[email-masked]>]
Envoyé : mardi 25 février 2014 11:36
À : MORAND Lionel IMT/OLN
Cc : EDU Team
Objet : Re: AAA tutorial for IETF 89

Hi Lionel,

Thanks,
Mirjam

Thank you.

---

From: Mirjam Kuehne <[email-masked]>
Date: Sun, 02 Mar 2014 12:09:04 +0100

Thanks, Lionel. The slides will be up soon.

Mirjam

On 2/3/14 12:00 PM, [email-masked] wrote:
> *De :*Radia Perlman [mailto:[email-masked]]
> *Envoyé :* samedi 1 mars 2014 22:11
> *À :* MORAND Lionel IMT/OLN
> *Cc :* Mirjam Kuehne; Benoit Claise; EDU Team
> *Objet :* Re: [edu-team] AAA tutorial for IETF 89
>
> gotten so distracted by having my browser not know how to open a .zip
> that I had opened an earlier email once I went to a different machine in
> my house to try there.
>
> configured with the IP address of the RADIUS server.  Is the RADIUS
> server configured with the IP addresses of all access points?  Is the
> access point configured with multiple IP addresses, in case one RADIUS
> server is down? Is there any cryptographic authentication between the
> access point and RADIUS server?  Can anyone send queries to the RADIUS
> server saying "Is this Radia's password?" a zillion times?
>
> And the deep question...what's a "new protocol" and what's a "new
> version of an existing protocol"?  Why wasn't DIAMETER merely extending
> RADIUS?
>
> On Sat, Mar 1, 2014 at 11:47 AM, <[email-masked]
> <mailto:[email-masked]>> wrote:
>
> Radia Perlman <[email-masked]  <mailto:[email-masked]>> a écrit :
>
>
>
> On Thu, Feb 27, 2014 at 5:15 PM, <[email-masked]
> <mailto:[email-masked]>> wrote:
>
> Hi Mirjam,
>
> tried to remain as much as possible far away from the technical details
> in the slides to keep a friendly approach. In the same line, I've tried
> to favour speech over two wordy slides when possible.
>
> De : Mirjam Kuehne [mailto:[email-masked] <mailto:[email-masked]>]
>
>  > De : Mirjam Kuehne [mailto:[email-masked] <mailto:[email-masked]>]
> [email-masked] <mailto:[email-masked]>

---

From: Stephanie McCammon <[email-masked]>
Date: Sun, 2 Mar 2014 03:38:31 -0800

Hi Everyone,

These slides have been posted on the edu pages of the website.

Thanks!

Stephanie McCammon
IETF Project Manager
48377 Fremont Blvd, Ste. 117
Fremont, CA 94538
T: +1.510.492.4081
F: +1.510.492.4001

Association Management Solutions (AMS)
Forum Management, Meeting, and Event Planning
www.amsl.com

On Mar 2, 2014, at 03:09 , Mirjam Kuehne wrote:

Mirjam