Subject: [edu-team] Fwd: Rough 1st Draft of IETF Tutorial on Internet Measurements

From: Mirjam Kuehne <[email-masked]>
Date: Tue, 16 Jun 2015 11:37:16 +0200

Hi,

Please find below the first draft of the Measurements Tutorial for your
review.

Vinayak, we will send you any feedback we might have as soon as possible.

Cheers,
Mirjam

-------- Forwarded Message --------
Subject: Rough 1st Draft of IETF Tutorial on Internet Measurements
Date: Mon, 15 Jun 2015 17:26:13 +0530
From: Vinayak Hegde <[email-masked]>
To: Mirjam Kuehne <[email-masked]>, Al Morton <[email-masked]>

Hi,

I am attaching a rough draft of the IETF tutorial. As I have noted on
the first slide - the tutorial will have 4 parts

* Part 1 – Basics of Measurement (35 min)
* Part 2 – Basic Statistics primer (35 min)
* Part 3 – Measurement Case Studies (20 min)
* Part 4 – Overview of Tools (20 min)
* Q&A – (10 min)

The idea is to give an idea of possible type of measurements and their
uses. Then give an idea of the stats and the math behind it (to design
and understand good measurements of different types). Finally end it
with some case studies of measurement studies and Tool overview (I am
going to cover Ripe Atlas since I know that well).

Feedback/Suggestions needed on:
1. Good examples of Case studies of measurements (especially from CAIDA)
2. Coverage of Stats concepts (what should I add/remove ?)

The slides do not have a lot of graphics (TBD by this week in 2nd
draft) but it gives a good idea of the structure and content. I have
not spend much time on beautifying the slides. That will be done once
the content is finalised.

Final set of slides should look (stylistically) like the following
talks I have given:
https://github.com/vinayakh/talks/blob/master/the5el/RTutorial/presrc/RTutorial.pdf
https://github.com/vinayakh/talks/blob/master/the5el/data-stack-from-scratch/How_to_build_a_data_stack_from_scratch.pdf

I am planning to send the 2nd draft of this to:
1. Dan Romascanu
2. Benoit Claise
3. Robert Kisteleki
4. Brian Trammel

Thanks
Vinayak

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 17 Jun 2015 15:57:53 +1200

Hi Vinayak,

A few quick comments, shooting from the hip. The general outline looks
very logical to me. I'll be glad to review the next version too.

p. 2 Structure

The timing is tight. The session is scheduled officially for
1h50m and some people will be eager to leave before 5.

p.8 Passive Measurements

In the cons, maybe you need an extra bullet:

Full line speed data collection is often impossible.

I would say "Unbiased sampling is crucial".

p. 9 No mention of hardware (DAG cards etc.)?

p. 16 Distributions

From my experience teaching queueing theory to honours CS students,
many people completely lack the basics here. I think you need
a *lot* of pictures. In fact this comment applies to the next
several slides. You can easily spend half an hour explaining any
one of the concepts. Most people can't read a CDF graph at a
glance, either.

Good idea to cover the case studies - try to illustrate good and
bad practices. I think that's more important than the tools;
measurements design is the hard part. People can always pick up
the tools when they need them.

Nits:

I suggest adding page numbers to help people asking specific questions

p.7 s/mimicing/mimicking/

p. 11 Draft names need to be wrapped

p. 16 s/Poission/Poisson/

Regards
   Brian Carpenter

On 16/06/2015 21:37, Mirjam Kuehne wrote:
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>

---

From: Vinayak Hegde <[email-masked]>
Date: Thu, 18 Jun 2015 00:38:30 +0530

Thanks. Will fix these and send a new draft with more pictures by the weekend.

Is there any chance of using a whiteboard during the tutorial ? Might
be useful in quickly doing some illustrations on the board.

Thanks
Vinayak

---

From: Mirjam Kuehne <[email-masked]>
Date: Wed, 17 Jun 2015 21:55:17 +0200

Hi,

> be useful in quickly doing some illustrations on the board.

I'll ask the secretariat.

Mirjam

---

From: Nalini Elkins <[email-masked]>
Date: Wed, 17 Jun 2015 19:55:58 +0000 (UTC)

Vinayak,

Do you want to mention a "Hybrid" (both passive & active) measurement technique for a draft which has just been adopted by the IPPM WG?

Link is below:

http://datatracker.ietf.org/doc/draft-ietf-ippm-6man-pdm-option/
 
Thanks,

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

________________________________
From: Mirjam Kuehne <[email-masked]>
To: EDU Team <[email-masked]>; Vinayak Hegde <[email-masked]> 
Sent: Tuesday, June 16, 2015 2:37 AM
Subject: [edu-team] Fwd: Rough 1st Draft of IETF Tutorial on Internet    Measurements

Hi,

Cheers,
Mirjam

-------- Forwarded Message --------
Subject: Rough 1st Draft of IETF Tutorial on Internet Measurements
Date: Mon, 15 Jun 2015 17:26:13 +0530
From: Vinayak Hegde <[email-masked]>
To: Mirjam Kuehne <[email-masked]>, Al Morton <[email-masked]>

Hi,

Thanks
Vinayak