Subject: [edu-team] Sunday Tutorial Idea

From: "Jim Schaad" <[email-masked]>
Date: Mon, 10 Aug 2015 19:13:12 -0700

Given the fact that a number of groups are starting to use GitHub for doing
lots of things.  Tracking issues, doing document maintenance and so forth.
It might be a good idea to have a tutorial on the process of setup and using
GitHub for these items.

Things that would need to be covered:

Putting up a Note Well notice on the main page
The basics of using github - how to fork, do pull requests, synchronize my
fork with the master fork 
How to setup and use Travis to do integration builds to check that things
are correct for merges and to produce working copies in the middle.
How to make GitHub sent messages to WG mailing lists
A discussion of using a centralized issue tracker vs one issue tracker per
document.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 11 Aug 2015 15:16:24 +1200

> It might be a good idea to have a tutorial on the process of setup and using

Yes, this is worth considering. Maybe it could start as a WG Chairs lunch topic?
That often throws up overlooked points during the Q/A.

> Putting up a Note Well notice on the main page

Good point. You prompted me to add this to my readme:

This repository is for an IETF effort and falls under IETF rules: see http://www.ietf.org/about/note-well.html

Do you think that's sufficient?

> fork with the master fork 

And don't forget that more than one operating system is used in our
community. The tricks of the trade seem to differ.

> A discussion of using a centralized issue tracker vs one issue tracker per

And: when to use github and when to use trac/wiki.

    Brian

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 10 Aug 2015 20:52:23 -0700

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Monday, August 10, 2015 8:16 PM
> To: Jim Schaad; [email-masked]
> Subject: Re: [edu-team] Sunday Tutorial Idea
> 
> > Given the fact that a number of groups are starting to use GitHub for
> > doing lots of things.  Tracking issues, doing document maintenance and so
> forth.
> > It might be a good idea to have a tutorial on the process of setup and
> > using GitHub for these items.
> 

I was a bit more blatant, but that is because of the repository I copied things from. I have the actual text of the note well in my readme file.

Jim

> 
> > The basics of using github - how to fork, do pull requests,
> > synchronize my fork with the master fork
> 
> And don't forget that more than one operating system is used in our community.
> The tricks of the trade seem to differ.

> 
> > How to setup and use Travis to do integration builds to check that
> > things are correct for merges and to produce working copies in the middle.
> > How to make GitHub sent messages to WG mailing lists A discussion of
> > using a centralized issue tracker vs one issue tracker per document.
>

---

From: Radia Perlman <[email-masked]>
Date: Mon, 10 Aug 2015 21:44:57 -0700

It might be nice to have a bunch of 10-15 minute mini-tutorials, so one
could click on a particular topic and see that explained, rather than
having to watch a sequential 90 minute tutorial to find the thing you need
to review.  This could still be given as one tutorial, but it would be good
to break it up into separate topics when posting.

Radia

On Mon, Aug 10, 2015 at 8:16 PM, Brian E Carpenter <
[email-masked]> wrote:

> doing
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 11 Aug 2015 08:22:00 +0000

This seems a good and timely idea to me. Who can give such a tutorial? 

Regards,

Dan

> From: edu-team [mailto:[email-masked]] On Behalf Of Jim
> Schaad
> Sent: Tuesday, August 11, 2015 5:13 AM
> To: [email-masked]
> Subject: [edu-team] Sunday Tutorial Idea
> 
> Putting up a Note Well notice on the main page The basics of using github -
> how to fork, do pull requests, synchronize my fork with the master fork How
> to setup and use Travis to do integration builds to check that things are
> correct for merges and to produce working copies in the middle.
> How to make GitHub sent messages to WG mailing lists A discussion of using
> a centralized issue tracker vs one issue tracker per document.
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_edu-
> 2Dteam&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQz
> vlsiLQfucBXRucPvdrphpBsFA&m=rCEYKjuHXd_3KdDzE69sz21YL-
> 9XdvaHSQWesO2TsOA&s=Ou3t1Vm_iRh7aDe8iXLhq2yubYuebKG-
> 7RV6__8MXCY&e=

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 11 Aug 2015 08:23:13 +0000

> From: edu-team [mailto:[email-masked]] On Behalf Of Brian E
> Carpenter
> Sent: Tuesday, August 11, 2015 6:16 AM

The interest probably goes beyond WG chairs. 

Regards,

Dan

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 11 Aug 2015 08:24:48 +0000

Indeed. This was one of the ideas discussed at the BOF at IETF 93, also mentioned in the I-D. The planned updated NETCONF/YANG training at IETF 94 will be structured this way.

Regards,

Dan

From: edu-team [mailto:[email-masked]] On Behalf Of Radia Perlman
Sent: Tuesday, August 11, 2015 7:45 AM
To: Brian E Carpenter
Cc: Jim Schaad; EDU Team
Subject: Re: [edu-team] Sunday Tutorial Idea

It might be nice to have a bunch of 10-15 minute mini-tutorials, so one could click on a particular topic and see that explained, rather than having to watch a sequential 90 minute tutorial to find the thing you need to review.  This could still be given as one tutorial, but it would be good to break it up into separate topics when posting.

Radia

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 12 Aug 2015 08:48:02 +1200

> The interest probably goes beyond WG chairs. 

It certainly does, but we have often found that the collective wisdom of
the WG Chairs is useful when formulating a tutorial.

I agree that this could be a very good short-format tutorial. I managed to
teach myself elementary use of github in half an hour or so, but a quick-start
tutorial would have been very helpful.

    Brian

---

From: "Jim Schaad" <[email-masked]>
Date: Tue, 11 Aug 2015 15:00:21 -0700

I would start with Richard Barnes and Martin Thomson as the two people that
I learned from.  The only problem is that neither of them use windows and
that needs to be covered as well.

Jim

> From: Romascanu, Dan (Dan) [mailto:[email-masked]]
> Sent: Tuesday, August 11, 2015 1:22 AM
> Subject: RE: [edu-team] Sunday Tutorial Idea
> 
> > Putting up a Note Well notice on the main page The basics of using
> > github - how to fork, do pull requests, synchronize my fork with the
> > master fork How to setup and use Travis to do integration builds to
> > check that things are correct for merges and to produce working copies
in the
> middle.