Subject: Re: [edu-team] GitHub presentation at IETF 94 WG Chairs lunch

From: Richard Barnes <[email-masked]>
Date: Mon, 5 Oct 2015 13:23:27 -0400

Hey Mir,

Am I too late on this?  The answer is yes.

On Tuesday, September 8, 2015, Mirjam Kuehne <[email-masked]> wrote:

> Hi Richard, Hi Martin,
>
> It's been suggested to organise a GitHub presentation for IETF
> participants, initially for WG chairs and then later possibly as a
> Sunday tutorial, and your names came up :-)
>
> Would you be willing and available to do this at IETF 94 during the WG
> chairs lunch session on Wednesday?
>
> Here are a few things that would need to be covered:
>
> - Putting up a Note Well notice on the main page
> - The basics of using github - how to fork, do pull requests,
> synchronise my fork with the master fork
> - How to setup and use Travis to do integration builds to check that
> things are correct for merges and to produce working copies in the middle
> - How to make GitHub sent messages to WG mailing lists
> - A discussion of using a centralised issue tracker vs. one issue
> tracker per document
>
> What do you think?
>
> Kind regards,
> Mirjam Kuehne
> (on behalf of the IETF Edu Team)
>

---

From: Mirjam Kuehne <[email-masked]>
Date: Tue, 6 Oct 2015 09:50:47 +0200

Hi,

> Am I too late on this?  The answer is yes. 

Yay! Thanks! And no, you are not too late. I saw the short description
you sent to Naveen.

Are you ok with the list of things to cover below? Are you going to
prepare slides? Would be great if you could send them to the Edu Team
before the meeting.

I won't be in Yokohama myself, but we'll try to have one of the Edu Team
members at the WG lunch to introduce you and to take some notes during
the session. Any volunteers? :-)

Is there anything else you need at this point?

Mirjam

> On Tuesday, September 8, 2015, Mirjam Kuehne <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     Hi Richard, Hi Martin,
>

---

From: Karen O'Donoghue <[email-masked]>
Date: Tue, 6 Oct 2015 10:51:30 +0000

I’m willing to “shepherd” this wg chairs training session (introduce the topic, take notes, etc). 

Karen

> On Oct 6, 2015, at 3:50 AM, Mirjam Kuehne <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team

---

From: Mirjam Kuehne <[email-masked]>
Date: Tue, 6 Oct 2015 12:53:26 +0200

Thanks, Karen!

Mirjam