Subject: Re: [edu-team] GitHub Contributors Guide

From: Mirjam Kuehne <[email-masked]>
Date: Fri, 2 Oct 2015 09:30:04 +0200

Hi Naveen,

No, unfortunately I have not heard from Richard Barnes or Martin
Thomson. If Stephanie is in touch with Richard, maybe she could get him
to end us a response? :-)

We have a rough description Jim sent earlier, but I would like to
confirm with the speakers first.

Cheers,
Mirjam

On 1/10/15 23:59, Naveen Khan wrote:
> Hi Mrijam,
> 
> Have you heard from anyone regarding the WG chairs lunch? I believe
> Stephanie talked to Richard Barnes, and he agreed to do it. Just waiting
> on a description from him. 
> 
> 
> Sincerely,
> 
> Naveen Khan 
> IETF Administrative Coordinator
> 48377 Fremont Blvd. Suite 117 / Fremont, CA 94538
> Direct (510) 492-4028 / Fax (510) 492-4001
> Email: [email-masked] <mailto:[email-masked]> / URL:  http://www.ietf.org
>  
> Managed by Association Management Solutions (AMS)
> Forum Management Meeting, and Event Planning
> URL: http://www.amsl.com
> 
> On Sep 17, 2015, at 7:49 AM, Mirjam Kuehne <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>> Hi Jim,
>>
>> On 5/9/15 21:03, Jim Schaad wrote:
>>> I can contact them, it might be better to come from edu team though.
>>
>> I am not sure that statement was true ;-) I still haven't heard from
>> them. Any other suggestions for a speaker?
>>
>> Mirjam
>>
>>
>>>
>>> Jim
>>>
>>>
>>>> -----Original Message-----
>>>> From: Mirjam Kuehne [mailto:[email-masked] <http://ripe.net>]
>>>> Sent: Friday, September 04, 2015 1:34 AM
>>>> To: Jim Schaad <[email-masked]
>>>> <mailto:[email-masked]>>; 'Brian E Carpenter'
>>>> <[email-masked] <mailto:[email-masked]>>;
>>>> 'EDU Team' <[email-masked] <mailto:[email-masked]>>
>>>> Subject: Re: [edu-team] Fwd: GitHub Contributors Guide
>>>>
>>>> Hi,
>>>>
>>>> No, I don't think anyone has approached Linda about it recently, so
>>>> we can also
>>>> do that at a later IETF meeting. So, let's plan the GitHub Guide for
>>>> the WG Chairs
>>>> Lunch on Wednesday in Yokohama.
>>>>
>>>> Jim, you suggested Richard Barnes and Martin Thomson as presenters.
>>>> Do you
>>>> want to contact them?
>>>>
>>>> Regards,
>>>> Mirjam
>>>>
>>>>
>>>>
>>>> On 4/9/15 04:35, Jim Schaad wrote:
>>>>> I think that I would tend to go with Brian on this.  There are a
>>>>> number of things
>>>> that need to be learned and this is probably a good place to start.
>>>>>
>>>>> Jim
>>>>>
>>>>>
>>>>>> -----Original Message-----
>>>>>> From: Brian E Carpenter [mailto:[email-masked]
>>>>>> <http://gmail.com>]
>>>>>> Sent: Thursday, September 03, 2015 1:26 PM
>>>>>> To: Mirjam Kuehne <[email-masked] <mailto:[email-masked]>>; Jim Schaad
>>>>>> <[email-masked] <mailto:[email-masked]>>; EDU Team
>>>>>> <[email-masked] <mailto:[email-masked]>>
>>>>>> Subject: Re: [edu-team] Fwd: GitHub Contributors Guide
>>>>>>
>>>>>> On 03/09/2015 18:49, Mirjam Kuehne wrote:
>>>>>>> Hi Jim,
>>>>>>>
>>>>>>> I see there is a discussion on the WG chairs list about this. So,
>>>>>>> maybe this would indeed be a good topic for a WG chairs lunch (at
>>>>>>> IETF
>>>>>>> 94) as Brian suggested. We could then turn it into a (short)
>>>>>>> tutorial for the IETF meeting after that.
>>>>>>>
>>>>>>> Edu Team, we tentatively had Framework and Architecture Drafts
>>>>>>> (Linda
>>>>>>> Dunbar) scheduled as a WG chairs lunch, but this is not confirmed.
>>>>>>> What do you think should have priority?
>>>>>>
>>>>>> You mean, a running code topic vs a philosophical topic? ;-)
>>>>>>
>>>>>> I'd go for GitHub, unless Linda is already preparing materials.
>>>>>>
>>>>>>   Brian
>>>>>>
>>>>>>>
>>>>>>> Regards,
>>>>>>> Mirjam
>>>>>>>
>>>>>>>
>>>>>>> -------- Forwarded Message --------
>>>>>>> Subject: GitHub Contributors Guide
>>>>>>> Date: Wed, 2 Sep 2015 15:07:12 -0400
>>>>>>> From: Justin Richer <[email-masked] <mailto:[email-masked]>>
>>>>>>> To: [email-masked] <mailto:[email-masked]>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> I was just pointed to this article from GitHub about setting up a
>>>>>>> contributors guide for a repository:
>>>>>>>
>>>>>>> https://help.github.com/articles/setting-guidelines-for-repository-c
>>>>>>> on
>>>>>>> tributors/
>>>>>>>
>>>>>>> Essentially this creates a link to an in-repository document on the
>>>>>>> page every time someone creates a new issue or pull request. I’ve
>>>>>>> already added the IETF Note Well to the contribution document for
>>>>>>> the COSE
>>>>>>> repository:
>>>>>>>
>>>>>>> https://github.com/cose-wg/cose-issues/blob/master/CONTRIBUTING.md
>>>>>>>
>>>>>>> https://github.com/cose-wg/cose-issues/issues/new
>>>>>>>
>>>>>>>
>>>>>>> Those of you using GitHub to track code, specs, or issues for your
>>>>>>> groups will probably want to enable this feature. Feel free to steal
>>>>>>> the markdown-formatted Note Well from us if you like. :)
>>>>>>>
>>>>>>> — Justin
>>>>>>>
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> edu-team mailing list
>>>>>>> [email-masked]
>>>>>>> https://www.ietf.org/mailman/listinfo/edu-team
>>>>>>>
>>>>>
>>>
>>
>> _______________________________________________
>> edu-team mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/edu-team
>

---

From: Karen O'Donoghue <[email-masked]>
Date: Mon, 5 Oct 2015 13:52:53 +0000

Mirjam,

I can try to round up speakers if you wish.
I think this is a topic of interest to the chairs…

Karen

On Oct 2, 2015, at 3:30 AM, Mirjam Kuehne <[email-masked]<mailto:[email-masked]>> wrote:

Hi Naveen,

Cheers,
Mirjam

Sincerely,

Naveen Khan
IETF Administrative Coordinator
48377 Fremont Blvd. Suite 117 / Fremont, CA 94538
Direct (510) 492-4028 / Fax (510) 492-4001
Email: [email-masked]<mailto:[email-masked]> <mailto:[email-masked]> / URL:  http://www.ietf.org<http://www.ietf.org/>

Managed by Association Management Solutions (AMS)
Forum Management Meeting, and Event Planning
URL: http://www.amsl.com<http://www.amsl.com/>

On Sep 17, 2015, at 7:49 AM, Mirjam Kuehne <[email-masked]<mailto:[email-masked]>
<mailto:[email-masked]>> wrote:

Hi Jim,

Mirjam

Jim

-----Original Message-----
From: Mirjam Kuehne [mailto:[email-masked] <http://ripe.net<http://ripe.net/>>]
Sent: Friday, September 04, 2015 1:34 AM
To: Jim Schaad <[email-masked]<mailto:[email-masked]>
<mailto:[email-masked]>>; 'Brian E Carpenter'
<[email-masked]<mailto:[email-masked]> <mailto:[email-masked]>>;
'EDU Team' <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]>>
Subject: Re: [edu-team] Fwd: GitHub Contributors Guide

Hi,

Regards,
Mirjam

Jim

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]
<http://gmail.com<http://gmail.com/>>]
Sent: Thursday, September 03, 2015 1:26 PM
To: Mirjam Kuehne <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]>>; Jim Schaad
<[email-masked]<mailto:[email-masked]> <mailto:[email-masked]>>; EDU Team
<[email-masked]<mailto:[email-masked]> <mailto:[email-masked]>>
Subject: Re: [edu-team] Fwd: GitHub Contributors Guide

 Brian

Regards,
Mirjam

-------- Forwarded Message --------
Subject: GitHub Contributors Guide
Date: Wed, 2 Sep 2015 15:07:12 -0400
From: Justin Richer <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]>>
To: [email-masked]<mailto:[email-masked]> <mailto:[email-masked]>

— Justin

_______________________________________________
edu-team mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/edu-team

_______________________________________________
edu-team mailing list
[email-masked]<mailto:[email-masked]> <mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/edu-team

_______________________________________________
edu-team mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/edu-team

---

From: Mirjam Kuehne <[email-masked]>
Date: Mon, 5 Oct 2015 15:56:40 +0200

That would be wonderful. Thanks Karen!

Mirjam

On 5/10/15 15:52, Karen O'Donoghue wrote:
>>> Email: [email-masked] <mailto:[email-masked]> <mailto:[email-masked]>
>>> / URL:  http://www.ietf.org <http://www.ietf.org/>
>>>
>>> URL: http://www.amsl.com <http://www.amsl.com/>
>>>
>>> <mailto:[email-masked]>
>>>>>> To: Jim Schaad <[email-masked] <mailto:[email-masked]>
>>>>>> <[email-masked]
>>>>>> <mailto:[email-masked]> <mailto:[email-masked]>>;
>>>>>> 'EDU Team' <[email-masked]
>>>>>> <mailto:[email-masked]> <mailto:[email-masked]>>
>>>>>>>> <http://gmail.com <http://gmail.com/>>]
>>>>>>>> To: Mirjam Kuehne <[email-masked]
>>>>>>>> <mailto:[email-masked]> <mailto:[email-masked]>>; Jim Schaad
>>>>>>>> <[email-masked]
>>>>>>>> <mailto:[email-masked]> <mailto:[email-masked]>>; EDU
>>>>>>>> Team
>>>>>>>> <[email-masked]
>>>>>>>> <mailto:[email-masked]> <mailto:[email-masked]>>
>>>>>>>>> From: Justin Richer <[email-masked]
>>>>>>>>> <mailto:[email-masked]> <mailto:[email-masked]>>
>>>>>>>>> To: [email-masked]
>>>>>>>>> <mailto:[email-masked]> <mailto:[email-masked]>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>> [email-masked] <mailto:[email-masked]> <mailto:[email-masked]>