Subject: [edu-team] IETF 94 - Working Group Chairs Training Lunch

From: IETF Agenda <[email-masked]>
Date: Tue, 06 Oct 2015 11:28:24 -0700

Hello Everyone,

We will be holding a WG Chairs training lunch at IETF 94 in Yokohama.  All current WG chairs, BOF chairs, IRTF chairs, and IESG members are welcome to attend. The lunch training will take place on Wednesday, November 4th, 2015 at 11:30am and a complimentary lunch will be provided. The location of the lunch will be sent to those who RSVP and posted on the main meeting agenda.

Topic: GitHub (Richard Barnes & Martin Thompson)
Description: Learn how to build Internet protocol specifications just like the open source community builds software.

If you would like to attend this session, please RSVP using this registration page: 
https://www.ietf.org/registration/ietf94/rsvp.py?eventid=1&eventcode=23232582

Please RSVP prior to October 16, 2015.

If you have RSVP'd for the training lunch but will not be able to attend, or have any issues registering for the event, please send a message to [email-masked].  

Thank You!

Naveen Khan
(on behalf of Mirjam Kuehne, Radia Perlman, & the Edu Team)

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 6 Oct 2015 14:34:45 -0400

I hope that the subtitle is misleading.

Using github as a repository and development tool for internet-drafts is 
sensible, and I would like to understand better how to do it.

Developing specifications as if they were open source projects is a VERY 
different undertaking, and one which I would not want to see promoted as 
a desired operating mode for the IETF.

Yours,
Joel

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 6 Oct 2015 15:02:34 -0400

Is there any reason why WG secretaries aren't explicitly included in the
list of invitees? This training is as important to them (or even more so)
than it is for chairs.

Thanks,
Andy

On Tue, Oct 6, 2015 at 2:28 PM, IETF Agenda <[email-masked]> wrote:

> Hello Everyone,
>
> We will be holding a WG Chairs training lunch at IETF 94 in Yokohama.  All
> current WG chairs, BOF chairs, IRTF chairs, and IESG members are welcome to
> attend. The lunch training will take place on Wednesday, November 4th, 2015
> at 11:30am and a complimentary lunch will be provided. The location of the
> lunch will be sent to those who RSVP and posted on the main meeting agenda.
>
> Description: Learn how to build Internet protocol specifications just like
> the open source community builds software.
>
> If you have RSVP'd for the training lunch but will not be able to attend,
> or have any issues registering for the event, please send a message to
> [email-masked].
>
>
> Thank You!
>
> Naveen Khan

---

From: Robert Sparks <[email-masked]>
Date: Tue, 6 Oct 2015 14:19:37 -0500

I'm pretty sure they were. From 
https://www.ietf.org/mailman/listinfo/wgchairs:

"The wgchairs mailing list is for discussion by WG Chairs, Secretaries, 
the IESG, the IAB and BOF Chairs on any IETF related topic. Although 
only those listed above may subscribe, the mailing list has a public 
archive:
http://www.ietf.org/mail-archive/web/wgchairs."

On 10/6/15 2:02 PM, Andrew G. Malis wrote:
> Is there any reason why WG secretaries aren't explicitly included in 
> the list of invitees? This training is as important to them (or even 
> more so) than it is for chairs.
>
> Thanks,
> Andy
>
>
> On Tue, Oct 6, 2015 at 2:28 PM, IETF Agenda <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hello Everyone,
>
>     We will be holding a WG Chairs training lunch at IETF 94 in
>     Yokohama.  All current WG chairs, BOF chairs, IRTF chairs, and
>     IESG members are welcome to attend. The lunch training will take
>     place on Wednesday, November 4th, 2015 at 11:30am and a
>     complimentary lunch will be provided. The location of the lunch
>     will be sent to those who RSVP and posted on the main meeting agenda.
>
>     Description: Learn how to build Internet protocol specifications
>     just like the open source community builds software.
>
>     If you have RSVP'd for the training lunch but will not be able to
>     attend, or have any issues registering for the event, please send
>     a message to [email-masked] <mailto:[email-masked]>.
>
>
>     Thank You!
>
>     Naveen Khan

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 6 Oct 2015 15:23:20 -0400

Robert,

The invitation says "All current WG chairs, BOF chairs, IRTF chairs, and
IESG members are welcome to attend."

Cheers,
Andy

On Tue, Oct 6, 2015 at 3:19 PM, Robert Sparks <[email-masked]> wrote:

> the IESG, the IAB and BOF Chairs on any IETF related topic. Although only
> those listed above may subscribe, the mailing list has a public archive:
>> We will be holding a WG Chairs training lunch at IETF 94 in Yokohama.
>> All current WG chairs, BOF chairs, IRTF chairs, and IESG members are
>> welcome to attend. The lunch training will take place on Wednesday,
>> November 4th, 2015 at 11:30am and a complimentary lunch will be provided.
>> The location of the lunch will be sent to those who RSVP and posted on the
>> main meeting agenda.
>>
>> Description: Learn how to build Internet protocol specifications just
>> like the open source community builds software.
>>

---

From: Robert Sparks <[email-masked]>
Date: Tue, 6 Oct 2015 14:50:13 -0500

Ah - I see.

The secretaries _got_ the message (and see this conversation), but 
weren't included in the invitation text.

The template for the message should be adjusted.

RjS

On 10/6/15 2:23 PM, Andrew G. Malis wrote:
> Robert,
>
> The invitation says "All current WG chairs, BOF chairs, IRTF chairs, 
> and IESG members are welcome to attend."
>
> Cheers,
> Andy
>
>
> On Tue, Oct 6, 2015 at 3:19 PM, Robert Sparks <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     "The wgchairs mailing list is for discussion by WG Chairs,
>     Secretaries, the IESG, the IAB and BOF Chairs on any IETF related
>     topic. Although only those listed above may subscribe, the mailing
>     list has a public archive:
>>     Is there any reason why WG secretaries aren't explicitly included
>>     in the list of invitees? This training is as important to them
>>     (or even more so) than it is for chairs.
>>
>>     Thanks,
>>     Andy
>>
>>
>>         Yokohama.  All current WG chairs, BOF chairs, IRTF chairs,
>>         and IESG members are welcome to attend. The lunch training
>>         will take place on Wednesday, November 4th, 2015 at 11:30am
>>         and a complimentary lunch will be provided. The location of
>>         the lunch will be sent to those who RSVP and posted on the
>>         main meeting agenda.
>>
>>         Description: Learn how to build Internet protocol
>>         specifications just like the open source community builds
>>         software.
>>
>>         If you have RSVP'd for the training lunch but will not be
>>         able to attend, or have any issues registering for the event,
>>         please send a message to [email-masked]
>>         <mailto:[email-masked]>.
>>
>>
>>         Thank You!
>>
>>         Naveen Khan

---

From: Naveen Khan <[email-masked]>
Date: Tue, 6 Oct 2015 13:59:45 -0700

Hi All,

I will fix the text template to be inclusive of all participating parties. Andy, thank you for bringing this to our attention. 

Sincerely,

Naveen Khan 
IETF Administrative Coordinator
48377 Fremont Blvd. Suite 117 / Fremont, CA 94538
Direct (510) 492-4028 / Fax (510) 492-4001
Email: [email-masked] / URL:  http://www.ietf.org
 
Managed by Association Management Solutions (AMS)
Forum Management Meeting, and Event Planning
URL: http://www.amsl.com

On Oct 6, 2015, at 12:50 PM, Robert Sparks <[email-masked]> wrote:

> Ah - I see.
> 
> The secretaries _got_ the message (and see this conversation), but weren't included in the invitation text.
> 
>> The invitation says "All current WG chairs, BOF chairs, IRTF chairs, and IESG members are welcome to attend."
>> 
>> Cheers,
>> Andy
>> 
>> 
>> I'm pretty sure they were. From https://www.ietf.org/mailman/listinfo/wgchairs:
>> 
>> "The wgchairs mailing list is for discussion by WG Chairs, Secretaries, the IESG, the IAB and BOF Chairs on any IETF related topic. Although only those listed above may subscribe, the mailing list has a public archive: 
>>> Is there any reason why WG secretaries aren't explicitly included in the list of invitees? This training is as important to them (or even more so) than it is for chairs.
>>> 
>>> Thanks,
>>> Andy
>>> 
>>> 
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 6 Oct 2015 17:40:15 -0400

Naveen,

WG Secretaries should also be invited to the newcomers reception on Sunday
afternoon.

Thanks,
Andy

On Tue, Oct 6, 2015 at 4:59 PM, Naveen Khan <[email-masked]> wrote:

> Hi All,
>
> I will fix the text template to be inclusive of all participating parties.
> Andy, thank you for bringing this to our attention.
>
>
> Sincerely,
>
> Naveen Khan
>> On Tue, Oct 6, 2015 at 2:28 PM, IETF Agenda < <[email-masked]>
>> [email-masked]> wrote:
>>
>>> Hello Everyone,
>>>
>>> attend, or have any issues registering for the event, please send a message
>>> to [email-masked].
>>>
>>>
>>> Thank You!
>>>
>>> Naveen Khan

---

From: Mirjam Kuehne <[email-masked]>
Date: Wed, 7 Oct 2015 08:57:16 +0200

> I'm pretty sure they were. From

Yes, absolutely. Sorry if this wasn't clear.

Mirjam

---

From: Jari Arkko <[email-masked]>
Date: Thu, 15 Oct 2015 02:55:29 +0300

Joel, all, (adding Richard and Martin),

>> Description: Learn how to build Internet protocol specifications just like the open source community builds software.

…

> Using github as a repository and development tool for internet-drafts is sensible, and I would like to understand better how to do it.
> 
> Developing specifications as if they were open source projects is a VERY different undertaking, and one which I would not want to see promoted as a desired operating mode for the IETF.

You raise good questions about what the model of working on specifications is, or should be.

I think the reality of the working groups moving into this direction (such as HTTPBIS) is that there are somewhere between the two extremes. That is, they put internet-drafts and their versions in a repository. But they also typically put in issues and fixes, and do things like merging branches. Some of the nitty gritty stuff gets handled entirely there. But the majority of the discussion, or at least the substantive topics, still happens on an IETF mailing list, phone call, or a meeting.

But, I think we are exploring this and still finding the best ways to deal with stuff. Not sure there is one size fits all answer (yet). What’s your model on this development, Joel?

Maybe Richard and Martin can add their perspectives to this. I’m not the expert...

Jari

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 14 Oct 2015 20:24:45 -0400

My concern is with several aspects of open source-style development 
other than the use of github as a repository.  Some of these bleed into 
development style of course.  For example, I would be really unhappy 
with any working group that used the github ticket as the primary 
repository for discussion, instead of the email list.  (In addition is 
fine, as there may be some threading value.)  Similarly, I would have 
problems with approaches that moved substantive changes to the document 
to github without mailing list discussions.  (Having editorial changes 
be branches which are merged is understandable, and probably one of the 
benefits of using githib.)

The biggest difference I am aware of is the process by which the 
decision to merge changes is made.  In open source, it is up to the 
project committers.  In the IETF, it is up to the working group, as 
judged by the working group chairs.  I have had problems in the past 
with editors who substituted their vision for the working groups.

So "open source style" is not something I think we have a community 
agreement on how to use.  Which leads me to be uncomfortable with a 
proposal to teach all working group chairs how to use such a style.

Learning how to use github so that we have the ability to use it in ways 
that are consistent with IETF approaches would seem to me to be highly 
desirable.

Yours,
Joel

---

From: Martin Thomson <[email-masked]>
Date: Wed, 14 Oct 2015 18:35:32 -0700

On 14 October 2015 at 17:24, Joel M. Halpern <[email-masked]> wrote:
> My concern is with several aspects of open source-style development other
> than the use of github as a repository.  Some of these bleed into
> development style of course.  For example, I would be really unhappy with
> any working group that used the github ticket as the primary repository for
> discussion, instead of the email list.  (In addition is fine, as there may
> be some threading value.)  Similarly, I would have problems with approaches
> that moved substantive changes to the document to github without mailing
> list discussions.  (Having editorial changes be branches which are merged is
> understandable, and probably one of the benefits of using githib.)

Can you explain why these concern you?  I'll note that some of these
things have been strictly forbidden by working groups that use github
(merging of substantive changes without list discussion), others are
embraced fully (editorial changes are often made as direct commits to
the repo, without even a PR), others are the subject of ongoing
experiments (discussion in issues).

> The biggest difference I am aware of is the process by which the decision to
> merge changes is made.

I don't see this as a problem at all.  The actor making the decision
is different, yes, but no group using github that I know of has
changed the fundamental basis of the decision making process, namely:

> In the IETF, it is up to the working group, as judged by the working group
> chairs.
...
> I have had problems in the past with editors who substituted their
> vision for the working groups.

Actually, this is one area where github has improved the situation.
Editors are more directly accountable here, since changes can be
individually screened by participants.  I've had problems in the past
with editors who substituted their vision for that of the working
group too, and that is only aided by the fact that editors tend to
have sole change control, out of sight.

In all of this, I don't think that there is a good substitute for
finding editors that chairs and - more importantly - the working group
trust.

> that are consistent with IETF approaches would seem to me to be highly

That's part of what we intend to address during the training.  This
would not be as useful as it has been if it weren't for the added
transparency, the improved interaction tools (pull requests
primarily), better access to the github community, integration with
continuous integration tools.  All of which are things the same things
that the open source community uses.  At the same time, I don't think
we need to lose sight of the things that make the IETF different from
random groups of people working on common goals, which critically
include the IPR protections and the consensus process we follow.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 14 Oct 2015 21:39:27 -0400

Your answers sound like you are indeed doing what I had hoped.
The subtitle of the training did not lead to that conclusion.
It was precisely the misleading subtitle that confused me.

For example, if the subtitle had been "using modern source management 
and ticket tracking for IETF working groups" I would not even have blinked.

I will admit that part of my concern is that I have seen some working 
groups behave in ways I consider marginal in terms of IETF process.  I 
do not want to encourage folks to push the proces envelope.  I do 
support making things work better.

Yours,
Joel