Subject: [edu-team] Call for action: Transitioning Edu Team content to new IETF web site

From: Mirjam Kuehne <[email-masked]>
Date: Wed, 17 Feb 2016 17:14:01 +0100

Hi all,

Greg Wood called me yesterday and gave me an update on the new web site
and the plans for transitioning content to the appropriate new pages.
They would like to move the Edu Team content within the next week or so
and there are a number of actions for the Edu Team:

1) List of tutorials

We need to decide which tutorials we want to move to the new web site
and which ones can be removed because they are out of date:

http://www.ietf.org/edu/tutorials.html

Note that these tutorials will be linked from various places. For
instance the area overview tutorials will show up on the area pages
rather than on a "tutorials page".

In general I suggest to remove everything that has not been updated in
the last three years. Maybe except for the area overviews and the
newcomers tutorials in other languages? What do you think?

I discussed with Greg the possibility to create a "tutorial archives"
page where some of the older material could still be stored, but some of
it might clearly be outdated and not useful anymore at this stage.

2) List of WG Chairs lunch sessions

The same applies to the WG chairs lunch session. Here I suggest to keep
all those that actually have some information (slides, description,
notes) attached to them. For internal Edu Team administration we can
always refer back tot he wiki if we want to find out what has been
presented before. What do you think?

3) General Edu related material

This refers to the Tao and a couple of pages Brian maintains. See here
for the most recent discussion/decision about this:

https://mailarchive.ietf.org/arch/msg/edu-team/GfcQm3H13aVv-Qz_axWQoBfoI54

How to make progress? Do we need to discuss this with Jari? I think
having the Edu Team act as a directorate for these pages is fine. But at
this point I don't think we have enough resources to actively maintain
them. Any suggestions?

4) Team member pages

Greg suggested we add some more information about each Edu Team member:
a picture and a short bio. Could you please start collecting this
information.

Kind regards,
Mirjam

---

From: Scott Bradner <[email-masked]>
Date: Wed, 17 Feb 2016 11:23:14 -0500

not to harp but

maybe the site needs a section on introductory information (not specifically tagged as “newcomers”
but as information about the IETF

the page could have an overview
	history (brief)
	structure
	mailing lists
	meetings
		remote access to meetings
	lists of relevant materials
		process RFCs (including translations where they exist - I think some do)
		introductory videos
		tutorials (including translations

etc.

Scott

> On Feb 17, 2016, at 11:14 AM, Mirjam Kuehne <[email-masked]> wrote:
> 
> Hi all,
> 
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 18 Feb 2016 08:25:48 +1300

Hi Mirjam,

On 18/02/2016 05:14, Mirjam Kuehne wrote:
...
> newcomers tutorials in other languages? What do you think?

I'm not sure. I just looked over the slides on "NAT Traversal" presented
in July 2010. Most of them are still useful, except the last few on
current work at that time.

I'd be inclined to keep them all, but clearly dated in the index,
so that you would see

* Multipath TCP (July 2013)
* NAT Traversal (July 2010)
...

before clicking.

If not, an archive is essential.

    Brian

---

From: Alice Russo <[email-masked]>
Date: Wed, 17 Feb 2016 11:30:45 -0800

...
> If not, an archive is essential.

+1.

Thanks,
Alice

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 18 Feb 2016 08:31:22 +1300

>> this point I don't think we have enough resources to actively maintain

I think it should also relate to what you find under the "About the IETF" button
on www.ietf.org. A rewrite of that page including the things Scott mentions would
be a good idea.

     Brian

---

From: Alexa Morris <[email-masked]>
Date: Sun, 21 Feb 2016 11:03:21 -0800

As you think about the best way to organize content moving forward, keep in mind that all of the tutorials are now in the Datatracker and the EDU team has a profile there as well. See: https://datatracker.ietf.org/group/edu/about/ and https://datatracker.ietf.org/group/edu/materials/. 

For the uninitiated, finding the EDU team content within the Datatracker isn’t particularly easy (Groups > Other > Active Teams > edu). I’ve spoken with Robert about making the teams (EDU and Hackathon in particular) a bit easier to find, and I know that he’s thinking about how to best do that. Of course, adding links from static pages into the EDU Team Datatracker content would also be helpful. 

Alexa

> a picture and a short bio. Could you please start collecting this

----------
Alexa Morris / Executive Director / IETF
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
Phone: +1.510.492.4089 / Fax: +1.510.492.4001
Email: [email-masked]

Managed by Association Management Solutions (AMS)
Forum Management, Meeting and Event Planning
www.amsl.com <http://www.amsl.com/>

---

From: Greg Wood <[email-masked]>
Date: Mon, 22 Feb 2016 10:45:44 -0500

Hi All,

I’m replying to Alexa’s note, but I appreciate the comments by all.

Here’s what I’ve heard:

1) Be sure to have an archive of all tutorials

It seems the datatracker repository Alexa points to would be a very good way to do this. Peeking at the list of tutorials there now, it looks like there might be some additions/clean up to make this happen. 

The www.ietf.org pages would refer to the datatracker for the source files of the slides and to the IETF YouTube channel for the videos.

Of course the www.ietf.org tutorial and EDU Team pages would point to the datatracker pages. 

(Another advantage to this approach might be to provide another way to introduce newcomers to the datatracker.)

2) Rethink IETF background/introductory information (history, structure, work processes)

Use Scott’s topics as guide for this.

3) Have the EDU team as a directorate for the maintaining the Tao and the general “About IETF” content on the website. 

This is how I read Brian’s comment, but I may have mis-understood his intent so would especially appreciate his correction. (I think it’s a good idea nonetheless!)

Do those 3 things sound right?

Two other thoughts for the group:

A) I haven’t heard objections to creating an “EDU Team directory, so I’m hoping folks are OK with moving forward. I think something like that (similar to the current WG Chairs directory at: http://www.ietf.org/wg/chair-photos.html but with short bios) will help making the IETF community more relatable and welcoming to newcomers.

B) One question I have heard posed in various ways is “where do I find out what work is doing in a particular area?” For example, a recent post on Twitter was:

"@ietf <http://mandrillapp.com/track/click/30738685/twitter.com?p=eyJzIjoiTEt1WU9rNm1land0UkZ5cW52amxsREtvX0VVIiwidiI6MSwicCI6IntcInVcIjozMDczODY4NSxcInZcIjoxLFwidXJsXCI6XCJodHRwOlxcXC9cXFwvdHdpdHRlci5jb21cXFwvaWV0ZlwiLFwiaWRcIjpcIjQyNzY2MjNhYjllMjQ0YmZiZTBjNzdhYzFjMGUxM2I0XCIsXCJ1cmxfaWRzXCI6W1wiNzBlNmQxMmIyYWQ5MGQ4NmUzZDM4OTAyMTFkOGM4NzhlZGY1NGJiY1wiXX0ifQ> Are you working on an equivalent to href=“tel:” for zip/post codes?
Would be v handy for opening the default device maps app"

Of course HREF is a @W3C HTML attribute, but it was an opportunity to highlight HTTPbis.

I suspect this is a general issue, so I’d love to be able to provide some general guidance for folks new to the IETF about how to figure out what is going related to their topic of interest. 

The current webpages sort of answer this question indirectly. 

Most of the information I find tends to start with structure or process, and then leads to pointing to working group mailing lists. But what I don’t find is general guidance about how to figure out where to look at what the IETF is working on based on a technology interest. It seems like it would be great to use that as a hook and then lead them into the details of IETF specifics.

Now, I realize I’m not the target audience for this, so I’d appreciate someone pointing out if I’m looking at this the wrong way, or overlooking materials that address the issue. And/or thoughts about how to test whether or not this approach would resonate with newcomers.

Thanks again for the thoughts so far. Further comments encouraged!

Regards,
-Greg

> On Feb 21, 2016, at 2:03 PM, Alexa Morris <[email-masked]> wrote:
>

---

From: Robert Sparks <[email-masked]>
Date: Mon, 22 Feb 2016 10:14:34 -0600

On 2/22/16 9:45 AM, Greg Wood wrote:
> It seems the datatracker repository Alexa points to would be a very 
> good way to do this. Peeking at the list of tutorials there now, it 
> looks like there might be some additions/clean up to make this happen.
>
> The www.ietf.org <http://www.ietf.org> pages would refer to the 
> datatracker for the source files of the slides and to the IETF YouTube 
> channel for the videos.
>
> Of course the www.ietf.org <http://www.ietf.org> tutorial and EDU Team 
> pages would point to the datatracker pages.
>
> 3) Have the EDU team as a directorate for the maintaining the Tao and 
> the general “About IETF” content on the website.
>
> This is how I read Brian’s comment, but I may have mis-understood his 
> intent so would especially appreciate his correction. (I think it’s a 
> good idea nonetheless!)
>
> A) I haven’t heard objections to creating an “EDU Team directory, so 
> I’m hoping folks are OK with moving forward. I think something like 
> that (similar to the current WG Chairs directory at: 
> http://www.ietf.org/wg/chair-photos.html but with short bios) will 
> help making the IETF community more relatable and welcoming to newcomers.
Please do not create this as a yet another pile of chair data to 
maintain separately from what's in the tracker. Lets make sure we move 
towards only one authoritative set of data about who is currently a 
chair or an edu team member, and augment that with whatever additional 
data needs to be available.

>
> B) One question I have heard posed in various ways is “where do I find 
> out what work is doing in a particular area?” For example, a recent 
> post on Twitter was:
>
> "@ietf 
> <http://mandrillapp.com/track/click/30738685/twitter.com?p=eyJzIjoiTEt1WU9rNm1land0UkZ5cW52amxsREtvX0VVIiwidiI6MSwicCI6IntcInVcIjozMDczODY4NSxcInZcIjoxLFwidXJsXCI6XCJodHRwOlxcXC9cXFwvdHdpdHRlci5jb21cXFwvaWV0ZlwiLFwiaWRcIjpcIjQyNzY2MjNhYjllMjQ0YmZiZTBjNzdhYzFjMGUxM2I0XCIsXCJ1cmxfaWRzXCI6W1wiNzBlNmQxMmIyYWQ5MGQ4NmUzZDM4OTAyMTFkOGM4NzhlZGY1NGJiY1wiXX0ifQ> Are 
> you working on an equivalent to href=“tel:” for zip/post codes?
> I suspect this is a general issue, so I’d love to be able to provide 
> some general guidance for folks new to the IETF about how to figure 
> out what is going related to their topic of interest.
>
> Most of the information I find tends to start with structure or 
> process, and then leads to pointing to working group mailing lists. 
> But what I don’t find is general guidance about how to figure out 
> where to look at what the IETF is working on based on a technology 
> interest. It seems like it would be great to use that as a hook and 
> then lead them into the details of IETF specifics.
>
> Now, I realize I’m not the target audience for this, so I’d appreciate 
> someone pointing out if I’m looking at this the wrong way, or 
> overlooking materials that address the issue. And/or thoughts about 
> how to test whether or not this approach would resonate with newcomers.
>
>> On Feb 21, 2016, at 2:03 PM, Alexa Morris <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> As you think about the best way to organize content moving forward, 
>> keep in mind that all of the tutorials are now in the Datatracker and 
>> the EDU team has a profile there as well. See: 
>> https://datatracker.ietf.org/group/edu/about/ and 
>> https://datatracker.ietf.org/group/edu/materials/.
>>
>> For the uninitiated, finding the EDU team content within the 
>> Datatracker isn’t particularly easy (Groups > Other > Active Teams > 
>> edu). I’ve spoken with Robert about making the teams (EDU and 
>> Hackathon in particular) a bit easier to find, and I know that he’s 
>> thinking about how to best do that. Of course, adding links from 
>> static pages into the EDU Team Datatracker content would also be 
>> helpful.
>>
>> Alexa
>>
>> On Feb 17, 2016, at 8:14 AM, Mirjam Kuehne <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>>> Hi all,
>>>
>> Email: [email-masked] <mailto:[email-masked]>
>>
>> www.amsl.com <http://www.amsl.com> <http://www.amsl.com/>
>>
>> [email-masked] <mailto:[email-masked]>

---

From: Greg Wood <[email-masked]>
Date: Mon, 22 Feb 2016 11:27:40 -0500

Robert,

> On Feb 22, 2016, at 11:14 AM, Robert Sparks <[email-masked]> wrote:
> 
>> A) I haven’t heard objections to creating an “EDU Team directory, so I’m hoping folks are OK with moving forward. I think something like that (similar to the current WG Chairs directory at: http://www.ietf.org/wg/chair-photos.html <http://www.ietf.org/wg/chair-photos.html>but with short bios) will help making the IETF community more relatable and welcoming to newcomers.
> Please do not create this as a yet another pile of chair data to maintain separately from what's in the tracker. Lets make sure we move towards only one authoritative set of data about who is currently a chair or an edu team member, and augment that with whatever additional data needs to be available.

Excellent point. I will follow up directly to figure out the best way to proceed towards that goal.
Thank you,
-Greg