Subject: Re: [edu-team] I-D Action: draft-elkins-ietf-unwritten-rules-values-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Wed, 2 Mar 2016 16:09:42 +1300

Hi Nalini,

This got stuck in my reading queue; sorry. In general, I like it.
It's a useful complement to the Tao, in my opinion. We need a wider
debate, though.

> 1.3 The IETF is not just an RFC mill
...
>    ...There are ongoing
>    conversations between people, via email, on the email lists, by
>    conversations over lunch or at a bar.  Some of these will end up
>    changing a point of view which may result a year later in a published
>    document.

Plus: or in changing implementation choices made by vendors and open source
contributors, or changing operational practice at a major carrier, or
changing what is written in the technical press.

(In other words the ramifications are not always in IETF "work product".)

> 2 The IETF has values
>    What are these values?

One that's definitely missing is:

 -Respect all other participants

(and I'm sure you know how to expand that to a paragraph or two)

> Here is a case showing what not to do.
...
> Here is a technique not to follow.
...
> Here is a case study of what not to do.

I understand the reason for showing bad examples, but isn't it a principle
of child-rearing to show only good examples? :-)

> 2.2.4 How to get started in a new WG
> 
>    Before you get started on the path, you want to understand what is
>    going in whatever Working Group you are interested in.   You may want
>    to do the following steps:
> 
>    - Watch the email list for about 6 months to a year. 

That seems rather long to me. I would suggest

 - Watch the email list for at least one IETF meeting cycle (about 4 months).

Even that is a bit more prescriptive than I put on the newcomers page:
  "It's advisable to wait several weeks before starting to contribute to
   the mailing list. But when you feel comfortable that you have something
   new to say, go for it!"

> 2.2.5 How to get started contributing on the email lists

Another point from the newcomers page fits here, I think:

  "The IETF is normally very welcoming to newcomers, and tolerance is the rule.
   The technical level is quite high, so if you write something that turns out
   to be wrong, you may get some quite frank replies. Or sometimes you will get
   a reply from someone whose first language is not English, and they can be rude
   without intending it. (If someone is seriously offensive, the WG Chairs are
   supposed to deal with it.) Don't be discouraged; everybody started as a newcomer."

> 4.1 Logical fallacies
...
>    Appeal to tradition: Something is right because that is how we have
>    always done it

(However, sometimes it's impossible to fix a design error because the design
is already in operation at thousands or even millions of sites around the
world. So something stays wrong because that is how we have always done it!)

> 4.3 For cultures that respect their elders
> 
>    It is not disrespectful to disagree with your elders.

 It is not disrespectful to disagree politely with your elders.

> 4.6 Community and rough consensus

Mention RFC 7282.

Regards
    Brian

---

From: <[email-masked]>
Date: Wed, 2 Mar 2016 13:00:32 +0000 (UTC)

Thanks for your comments, Brian.
I posted this on the IETF discussion list & got quite a few supportive comments.  Also talked to Jari about it & he said that he would read it when he got a chance (which may take some time!).
I am trying to think how to go forward with this.   What do you suggest? Thanks,
Nalini ElkinsInside Products, Inc.www.insidethestack.com(831) 659-8360

      From: Brian E Carpenter <[email-masked]>
 To: Nalini Elkins <[email-masked]> 
Cc: EDU Team <[email-masked]>
 Sent: Tuesday, March 1, 2016 10:09 PM
 Subject: Re: I-D Action: draft-elkins-ietf-unwritten-rules-values-00.txt
   
Hi Nalini,

...

...
...

...

Mention RFC 7282.

Regards
    Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 23 Mar 2016 13:35:56 +1300

On 03/03/2016 02:00, [email-masked] wrote:
> I am trying to think how to go forward with this.   What do you suggest? 

I got distracted for a couple of weeks...

So, I think something like this needs to be socialized quite a bit before
the busy IETF Chair will sponsor it (which would be ideal). But any other
Area Director could theoretically sponsor it too. If you're going to be
in BA, I thinking talking about it with various ADs would be the best
thing to do. If you'll be at the WG Chairs lunch you could look for
a chance to mention it there.

Hope that helps a bit.

Rgds
   Brian

Thanks,