Subject: Re: [edu-team] IETF 99 tutorial proposal: IEEE 802.1 TSN

From: Mirjam Kuehne <[email-masked]>
Date: Sun, 4 Jun 2017 11:14:06 +0200

Hi János,

We would like to take up your offer and organise the IEEE 802.1 TSN
tutorial for IETF 99 in Prague.

Can you please send me a short description and the name of the speakers
for the web site.

For now we scheduled you for the second tutorial slot 13:45-14:45. Can
you please let us know if this doesn't work for you.

Kind regards,
Mirjam Kuhne
IETF Edu Team

On 29/05/17 23:11, János Farkas wrote:
> Dear EDU Team,
> 
> We would appreciate a status update whether or not a 802.1 TSN tutorial
> is possible at IETF 99 in Prague?
> The reason I'm asking is that we'd to start preparations soon if it is
> possible.
> 
> Dan, thank you for your support!
> 
> Best regards,
> Janos
> 
> 
> On 4/18/2017 8:18 PM, Dan Romascanu wrote:
>> Hi,
>>
>> (copying also Russ Housley who now owns the IETF - IEEE relationship)
>>
>> I actually believe that we had one tutorial about IEEE 802 that
>> included IEEE 802.1 new work at IETF 96. -
>> https://www.ietf.org/proceedings/96/train-11.html
>>
>> This being said, I support doing an update focused on TSN.
>>
>> Regards,
>>
>> Dan
>>  
>>
>> On Tue, Apr 18, 2017 at 6:03 PM, János Farkas
>> <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>     Dear EDU Team,
>>
>>     Could you please update us if there is any developments related to
>>     the IETF 99 tutorials?
>>
>>     I'm sorry for not pointing on the relevance of such tutorial at
>>     the first place. TSN is related to the DetNet WG; the two groups
>>     collaborate: https://datatracker.ietf.org/wg/detnet/charter
>>     <https://datatracker.ietf.org/wg/detnet/charter>. TSN is also
>>     mentioned in discussions of other IETF groups.
>>
>>     Another aspect is that we've been suggested to give an update on
>>     recent 802.1 developments as it has been a while since our last
>>     tutorial:
>>     www.ietf.org/meeting/86/tutorials/86-ieee-8021-thaler.pptx
>>     <http://www.ietf.org/meeting/86/tutorials/86-ieee-8021-thaler.pptx>
>>
>>     Best regards,
>>     Janos
>>
>>
>>     On 3/30/2017 8:25 PM, János Farkas wrote:
>>
>>         Thank you very much!
>>         Janos
>>
>>
>>         On 3/30/2017 8:11 PM, Mirjam Kuehne wrote:
>>
>>             Hi János,
>>
>>             Thanks for the offer. We'll discuss this with the team and
>>             will get back to.
>>
>>             Kind regards,
>>             Mirjam Kuhne
>>
>>
>>             On 30/03/17 19:30, János Farkas wrote:
>>
>>                 Dear EDU Team,
>>
>>                 We would like to give a tutorial on IEEE 802.1
>>                 Time-Sensitive Networking
>>                 (TSN) at IETF 99 in Prague.
>>                 Please advise on next steps.
>>
>>                 Best regards,
>>                 János Farkas
>>                 IEEE 802.1 TSN TG Chair
>>
>>                 _______________________________________________
>>                 edu-team mailing list
>>                 [email-masked] <mailto:[email-masked]>
>>                 https://www.ietf.org/mailman/listinfo/edu-team
>>                 <https://www.ietf.org/mailman/listinfo/edu-team>
>>
>>
>>
>>     _______________________________________________
>>     edu-team mailing list
>>     [email-masked] <mailto:[email-masked]>
>>     https://www.ietf.org/mailman/listinfo/edu-team
>>     <https://www.ietf.org/mailman/listinfo/edu-team>
>>
>>
>

---

From: János Farkas <[email-masked]>
Date: Wed, 7 Jun 2017 17:17:50 +0200

Dear Mirjam, EDU Team,

Thank you for providing a slot for the TSN tutorial in Prague!
The slot is good.
We are working on a short description, we will send it to you soon.

Kind regards,
Janos

On 6/4/2017 11:14 AM, Mirjam Kuehne wrote:
>>>      collaborate:https://datatracker.ietf.org/wg/detnet/charter

---

From: János Farkas <[email-masked]>
Date: Tue, 13 Jun 2017 20:01:26 +0200

Dear Mirjam, EDU Team,

The abstract of the IEEE 802.1 TSN tutorial:

"IEEE 802.1 Time-Sensitive Networking (TSN) provides transport of data 
packets with bounded low latency, low delay variation and zero 
congestion loss. TSN can also use redundant transmissions to make data 
loss due to malfunctioning equipment extremely rare. In order to provide 
these capabilities, TSN adds time synchronization, shaping and queuing 
mechanisms, packet replication and elimination, and resource management 
to Layer 2 bridges. The predecessor of TSN is Audio Video Bridging 
(AVB), which has been successfully deployed and is used today. AVB 
evolved into TSN in order to address an expanded scope of work, which 
includes automotive networks, industrial automation (Industry 4.0), 5G, 
and many other use cases. In order to define a common architecture, the 
TSN Task Group collaborates with the IETF Deterministic Networking 
Working Group, which focuses on Layer 3 routed segments providing 
similar features to TSN."

Speakers: János Farkas, Norman Finn, Patricia Thaler

What is the deadline for the presentation?

Best regards,
Janos

---

From: Mirjam Kuehne <[email-masked]>
Date: Wed, 14 Jun 2017 12:42:40 +0200

Thanks, János. If you could send the presentation early July, that would
be great.

Cheers,
Mirjam

---

From: János Farkas <[email-masked]>
Date: Fri, 23 Jun 2017 12:25:19 +0200

Dear Mirjam, EDU Team,

We are working on the presentation.

In addition to the presentation, we would like to have a short demo at 
the end of the tutorial. It is a research proof of concept demo, an 
implementation of IEEE 802.1CB Frame Replication and Elimination in a 
software switch. We first implemented it in Ethernet data plane. We are 
now adding the Multi-Segment PseudoWire based MPLS data plane solution 
that will be included in draft-dt-detnet-dp-sol-01.

Is it ok to have the demo at the end?

Regards,
Janos

On 6/14/2017 7:24 PM, János Farkas wrote:
> Hi Mirjam,
>
> OK. We have started to work on the presentation.
>
> Regards,
> Janos
>
>
> On 6/14/2017 12:42 PM, Mirjam Kuehne wrote:

---

From: Mirjam Kuehne <[email-masked]>
Date: Fri, 23 Jun 2017 15:36:54 +0200

Hi János,

Thanks for keeping us in the loop. I don't think it should be a problem
showing a demo at the end of the tutorial.

Alexa, do you know if we need to prepare anything in particular? Does
Meetecho need to know?

Kind regards,
Mirjam

---

From: Alexa Morris <[email-masked]>
Date: Fri, 23 Jun 2017 08:03:04 -0700

Mirjam,János,

I can’t imagine it will be an issue for Meetecho but I will check.

Alexa

> On Jun 23, 2017, at 6:36 AM, Mirjam Kuehne <[email-masked]> wrote:
> 
> Hi János,
> 
> [email-masked]

---

From: János Farkas <[email-masked]>
Date: Tue, 27 Jun 2017 14:55:54 +0200

Hi Mirjam,

We are actually thinking of a live demo not only a video. It is a stand 
alone set-up which only requires power nothing else. It is 4 PCs + a 
laptop + a balancing LEGO robot. The set up is that the 4 PCs are 4 
Ethernet/MPLS software switches, which interconnect the robot and the 
laptop. The balancing logic is moved remote from the robot, i.e., to the 
laptop and the data exchange bw the two goes through the switched 
network. In case of a network failure without the reliability solution, 
the robot falls over, whereas everything is fine if PREF/FRER is on. The 
whole demo fits on a table. We would set it up before the session. This 
is a research proof of concept not a vendor demo at all; I'm from 
Ericsson Research Hungary. Actually, the PCs are quite old, they are the 
spare ones we could find in our lab. Well, this is a reliability demo 
which just works fine even on those PCs, which perhaps enforces the 
proof of the reliability concept. There is no Ericsson logo or anything 
like that anywhere.

I'd be glad for a confirmation whether it ok this way?
If yes, then I'd start arranging the shipping of the equipment from 
Budapest to Prague.

Thank you,
Janos

---

From: János Farkas <[email-masked]>
Date: Thu, 29 Jun 2017 15:04:39 +0200

Hi Mirjam,

We have prepared initial draft deck on the demo / implementation report, 
so you can see what it is. The picture and the videos go away in case we 
can show the real demo. The deck is available at: 
https://www.dropbox.com/s/248rvc9clzxgor3/IETF99-PREF-demo-v00.pptx?dl=0

Actually we have hard deadline because of the shipping of the equipment, 
which has to leave our lab on July 7 the latest. We need to order the 
shipping July 5 the latest. July 4 is holiday in the US, July 3 too for 
many.

So, my understanding is that final decision is needed this week.

If we do not know whether or not we can show the demo, then we are not 
shipping the equipment.

Thanks and regards,
Janos

On 6/27/2017 2:55 PM, János Farkas wrote:
> Hi Mirjam,
>
> We are actually thinking of a live demo not only a video. It is a 
> stand alone set-up which only requires power nothing else. It is 4 PCs 
> + a laptop + a balancing LEGO robot. The set up is that the 4 PCs are 
> 4 Ethernet/MPLS software switches, which interconnect the robot and 
> the laptop. The balancing logic is moved remote from the robot, i.e., 
> to the laptop and the data exchange bw the two goes through the 
> switched network. In case of a network failure without the reliability 
> solution, the robot falls over, whereas everything is fine if 
> PREF/FRER is on. The whole demo fits on a table. We would set it up 
> before the session. This is a research proof of concept not a vendor 
> demo at all; I'm from Ericsson Research Hungary. Actually, the PCs are 
> quite old, they are the spare ones we could find in our lab. Well, 
> this is a reliability demo which just works fine even on those PCs, 
> which perhaps enforces the proof of the reliability concept. There is 
> no Ericsson logo or anything like that anywhere.
>
>>>>>>>>>>       collaborate: 
>>>>>>>>>> https://datatracker.ietf.org/wg/detnet/charter

---

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 29 Jun 2017 16:45:35 +0200

Hi Janos,

As you saw: Alessandro from Meetecho confirmed. So, I think you can go
ahead with setting up the demo.

Kind regards,
Mirjam

---

From: János Farkas <[email-masked]>
Date: Thu, 29 Jun 2017 17:54:50 +0200

Dear Mirjam,

Thank you very much for the confirmation!
I'm starting to work on arranging the shipping.
Could you help an item on the shipping? Could you suggest someone who 
could be the addressee for the shipping to receive our package? I'll be 
arriving on July 14, the package will arrive on the 13th or the 14th.

Just another question related to how to run the tutorial session and the 
demo.
The original idea is that the demo is for the people who are in the 
room, recording and remote attendance is not that important. So the 
original idea was to have the demo right after the end of the tutorial? 
Is it possible to stay a bit more in the room for the demo? Or should we 
have it as part of the one hour we've got for the tutorial?

Thank you!
Janos

---

From: János Farkas <[email-masked]>
Date: Thu, 29 Jun 2017 19:13:38 +0200

Dear Mirjam, EDU Team

The nearly final version of our presentation is attached.
We may make some minor updates if we find some nits.

It is assembled for an hour presentation.
Please note that real content is 29 slides, which fits in one hour and 
we can also adapt on the fly too.

Regards,
Janos

---

From: Mirjam Kuehne <[email-masked]>
Date: Fri, 30 Jun 2017 09:21:43 +0200

Thanks Janos,

We'll let you know if we have any comments. If not, we will upload the
slides to the datatracker before the meeting so people can find them.

Regarding your question if you can use the room a bit longer to show the
demo, I hope Naveen or Alexa can answer. I don't know if there is
anything else scheduled in that room. The only constraint I am aware of
is the speed mentoring session that starts at 15:00 (in a different
room). Some of the attendees might want to participate in that.

Kind regards,
Mirjam

On 29/06/17 19:13, János Farkas wrote:
>>>>>>>>>>> For now we scheduled you for the second tutorial slot
>>>>>>>>>>> 13:45-14:45.
>>>>>>>>>>> Can
>>>>>>>>>>>> The reason I'm asking is that we'd to start preparations
>>>>>>>>>>>> soon if
>>>>>>>>>>>> it is
>>>>>>>>>>>> possible.
>>>>>>>>>>>>
>>>>>>>>>>>>>        the first place. TSN is related to the DetNet WG;
>>>>>>>>>>>>> the two
>>>>>>>>>>>>> groups
>>>>>>>>>>>>>        collaborate:
>>>>>>>>>>>>>        recent 802.1 developments as it has been a while
>>>>>>>>>>>>> since our
>>>>>>>>>>>>> last
>>>>>>>>>>>>>        tutorial:
>>>>>>>>>>>>>                Thanks for the offer. We'll discuss this
>>>>>>>>>>>>> with the
>>>>>>>>>>>>> team and
>>>>>>>>>>>>>                will get back to.
>>>>>>>>>>>>>
>>>>>>>>>>>>>                Kind regards,
>>>>>>>>>>>>>                Mirjam Kuhne
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> <mailto:[email-masked]>

---

From: János Farkas <[email-masked]>
Date: Fri, 30 Jun 2017 09:39:15 +0200

Thank you Mirjam!

We checked the agenda, which does not shoe anything after the TSN 
Tutorial in Congress Hall III.
We will finish the presentation by 14:45.
The best would be if we could give the demo 14:45-15:00 if we can stay 
in Congress Hall III.
We would set-up the demo before the tutorial starts at 13:45. The 
preparations should be less than 30 mins.

Thanks,
Janos