Subject: [edu-team] Tutorials for IETF 100

From: Mirjam Kuehne <[email-masked]>
Date: Tue, 3 Oct 2017 16:56:52 +0200

Hi all,

We need to finalise our list of tutorials for IETF 100. So far we
brainstormed the following:

- Newcomers tutorial (plus a pre-meeting webinar?)
- Area overview (which one? Start at the beginning?)
- How to chair a WG? (based on suggestions at WG chairs lunch)
- TLS 1.3
- Possibly re-do QUIC? Maybe in two sessions: first for “beginners”,
then second slot for advanced?

All this is still pretty vague. If these are the tutorials we want to
offer we need to find speakers.

Did anything else come up in the meantime?

Possible topics for WG Chairs lunch:
- Jorge Contreras on IPR
- Michelle Cotton about IANA

Karen, will you approach Jorge and Michelle?

Kind regards,
Mirjam

---

From: Niels ten Oever <[email-masked]>
Date: Tue, 3 Oct 2017 17:39:26 +0200

Hi all,

I approached:
- Sean Turner for TLS1.3
- Jana Iyengar for beginner and advanced tutorial on QUIC
- Cullen Jennings for webRTC

Sean is availabe, Cullen offered replacements and haven't heard back
from Jana yet.

Shall we lock these options down when they signal that they are available?

Best,

Niels

Niels ten Oever
Head of Digital

Article 19
www.article19.org

PGP fingerprint    2458 0B70 5C4A FD8A 9488
                   643A 0ED8 3F3A 468A C8B3

On 10/03/2017 04:56 PM, Mirjam Kuehne wrote:
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>

---

From: Fred Baker <[email-masked]>
Date: Tue, 3 Oct 2017 09:53:27 -0700

> - Sean Turner for TLS1.3

I personally would be interested to hear Sean's comments on the enterprise issues with TLS 1.3. Stephen Farrell's comments to me were that he knew of kids in school that could address the issues raised, and US Bank at least has hired a consultant who worked something out. The enterprise group has filed draft-rhrd-tls-tls13-visibility, and there are several other drafts in xls suggesting static diffie-hellmen keying etc. But TLS 1.3 as proposed is being viewed as a showstopper, and is convincing enterprise that they can't simply depend on their vendors to represent them in the IETF.

---

From: Alexa Morris <[email-masked]>
Date: Tue, 3 Oct 2017 12:25:05 -0700

Hi Everyone,

> On Oct 3, 2017, at 7:56 AM, Mirjam Kuehne <[email-masked]> wrote:
> 
> Hi all,
> 

Regarding the pre-meeting newcomers webinar, we need to get that scheduled and announced. What about Monday (6 of Nov) or Tuesday (7 of Nov)? The bigger challenge will be finding a time that is not unduly painful for one or more timezones.

Alexa

---

From: Fred Baker <[email-masked]>
Date: Tue, 3 Oct 2017 12:29:16 -0700

> On Oct 3, 2017, at 12:25 PM, Alexa Morris <[email-masked]> wrote:
> 
> Hi Everyone,
> 

I personally will be unable to help after 25 October, as I will be in transit in various parts of the world.

---

From: Fred Baker <[email-masked]>
Date: Tue, 3 Oct 2017 12:33:09 -0700

On Oct 3, 2017, at 12:25 PM, Alexa Morris <[email-masked]> wrote:
> The bigger challenge will be finding a time that is not unduly painful for one or more timezones.

I would agree. I presume you know about https://www.timeanddate.com/worldclock/meeting.html, which I find useful for such things. What I generally do is list important cities (in a recent one, Beijing, Tokyo, San Francisco. New York, and Paris) and find a time when nobody has to be awake between midnight and 6:00 AM in their time zone (in that case, there was only one hour). If that doesn't work out, I would suggest two webinars timed for different regions. Yes, I have done a webinar at 2:00 AM in Toronto for the benefit of people in India...

---

From: Greg Wood <[email-masked]>
Date: Tue, 3 Oct 2017 15:43:55 -0400

Hi Alexa,

Thanks for keeping this going. A few thoughts and a question:

> On Oct 3, 2017, at 3:33 PM, Fred Baker <[email-masked]> wrote:
> 
> 
> 
> I would agree. I presume you know about https://www.timeanddate.com/worldclock/meeting.html, which I find useful for such things. What I generally do is list important cities (in a recent one, Beijing, Tokyo, San Francisco. New York, and Paris) and find a time when nobody has to be awake between midnight and 6:00 AM in their time zone (in that case, there was only one hour). If that doesn't work out, I would suggest two webinars timed for different regions. Yes, I have done a webinar at 2:00 AM in Toronto for the benefit of people in India…

We could also record the session(s) for on-demand playback. If we’re doing a live webinar, and especially with questions, it will probably pay to think about how to handle questions or other interactivity. Would capping the number of participants be a consideration?

IMHO, 6 or 7 November is about the latest possibility. If folks are aiming to use the info they get to prepare for the meeting, a week before would be even better.

Once the date/time is set, I’d be happy to help promote it beyond the usual IETF email lists. (Though some broad thinking about the email lists would be good, too.)

The question: What tool will be used for the webinar (?). If Meetecho, we can aim to also have the recording availalbe on the IETF YouTube channel.

-Greg

---

From: Michael StJohns <[email-masked]>
Date: Tue, 3 Oct 2017 18:03:32 -0400

> Regarding the pre-meeting newcomers webinar, we need to get that scheduled and announced. What about Monday (6 of Nov) or Tuesday (7 of Nov)? The bigger challenge will be finding a time that is not…

I start my travel on the Sunday the 5th and don't finish until the 
18th.  Maybe early the week before?  And have we got an idea of what is 
wanted as content?

Later, Mike

---

From: Alexa Morris <[email-masked]>
Date: Tue, 3 Oct 2017 20:37:25 -0700

Yes, Greg suggested that we hold the webinar sooner and I agree as well. So, the week of October 30. 

Alexa

> On Oct 3, 2017, at 3:03 PM, Michael StJohns <[email-masked]> wrote:
> 
> I start my travel on the Sunday the 5th and don't finish until the 18th.  Maybe early the week before?  And have we got an idea of what is wanted as content?
> 
> Later, Mike
> 
>> 
>> Alexa
>> 
>> 
>> 
>>

---

From: Karen O'Donoghue <[email-masked]>
Date: Wed, 4 Oct 2017 07:41:31 +0000

I like the idea of TLS1.3 and webRTC for technical topics although I do wonder about the TLS one wrt the current controversy. I would expect that a good portion of the tutorial would not be on that topic but more general to the currently accepted aspects of the spec. We are going to have an issue deciding which of these can conflict with the newcomer’s session. 

So… we are targeting… 
Newcomer’s
TLS1.3
webRTC

For the area overview, I wonder about Joel Jaeggli as a just rotated off OPS AD. He might be able to suggest someone to present with him. Perhaps he could also talk about other efforts to develop connections with the ops community including IEPG. The challenge with the Area overviews on Sunday is that it conflicts with the IESG/IAB Sunday meeting. 

Karen

> On Oct 3, 2017, at 11:39 AM, Niels ten Oever <[email-masked]> wrote:
> 
> Hi all,
> 
> I approached:
> - Sean Turner for TLS1.3

---

From: Mirjam Kuehne <[email-masked]>
Date: Wed, 4 Oct 2017 16:09:59 +0200

Hi,

Thank you Niels for finding speakers. Maybe Sean can take Karen's
comment below into account?

You are right, Karen: OPS hasn't been presented in quite some time. I'll
contact Joel.

Cheers,
Mirjam

---

From: Niels ten Oever <[email-masked]>
Date: Wed, 4 Oct 2017 16:10:28 +0200

Hi all,

I confirmed the TLS1.3 and webRTC speakers. It would be great if we
could let them know which time slot they have for Sunday.

Once I receive their presentations I will put them in the datatracker.

Best,

Niels

Niels ten Oever
Head of Digital

Article 19
www.article19.org

---

From: Mirjam Kuehne <[email-masked]>
Date: Wed, 4 Oct 2017 16:29:22 +0200

Brilliant. Thanks, Niels!

How about this for time slots:

Newcomers (12:30 - 13:30)
TLS1.3 (12:30 - 13:30)

OPS Area - TBD (13:45 - 14:45)
webRTC (13:45 - 14:45)

BTW, I cleaned up our spreadsheet a bit and added the proposed
sessions for IETF 100:

https://docs.google.com/spreadsheets/d/1hU9CRsoGUtYGp9Dy8HxgOZoUxYoZSIYq
O1IiE0weqcA/edit#gid=1462811485

Cheers,
Mirjam

On 04/10/2017 16:10, Niels ten Oever wrote:
> Hi all,
> 
> I confirmed the TLS1.3 and webRTC speakers. It would be great if
> we could let them know which time slot they have for Sunday.
> 
> Niels ten Oever Head of Digital
> 
> Article 19 www.article19.org
> 
> PGP fingerprint    2458 0B70 5C4A FD8A 9488 643A 0ED8 3F3A 468A
> C8B3
> 
>> I like the idea of TLS1.3 and webRTC for technical topics
>> although I do wonder about the TLS one wrt the current
>> controversy. I would expect that a good portion of the tutorial
>> would not be on that topic but more general to the currently
>> accepted aspects of the spec. We are going to have an issue
>> deciding which of these can conflict with the newcomer’s session.
>> 
>> 
>> So… we are targeting… Newcomer’s TLS1.3 webRTC
>> 
>> For the area overview, I wonder about Joel Jaeggli as a just
>> rotated off OPS AD. He might be able to suggest someone to
>> present with him. Perhaps he could also talk about other efforts
>> to develop connections with the ops community including IEPG. The
>> challenge with the Area overviews on Sunday is that it conflicts
>> with the IESG/IAB Sunday meeting.
>> 
>> Karen
>> 
>>> I approached: - Sean Turner for TLS1.3 - Jana Iyengar for
>>> beginner and advanced tutorial on QUIC - Cullen Jennings for
>>> webRTC
>>> 
>>> Sean is availabe, Cullen offered replacements and haven't heard
>>> back from Jana yet.
>>> 
>>> Niels ten Oever Head of Digital
>>> 
>>> Article 19 www.article19.org
>>> 
>>> PGP fingerprint    2458 0B70 5C4A FD8A 9488 643A 0ED8 3F3A 468A
>>> C8B3
>>> 
>>>> We need to finalise our list of tutorials for IETF 100. So
>>>> far we brainstormed the following:
>>>> 
>>>> - Newcomers tutorial (plus a pre-meeting webinar?) - Area
>>>> overview (which one? Start at the beginning?) - How to chair
>>>> a WG? (based on suggestions at WG chairs lunch) - TLS 1.3 -
>>>> Possibly re-do QUIC? Maybe in two sessions: first for
>>>> “beginners”, then second slot for advanced?
>>>> 
>>>> All this is still pretty vague. If these are the tutorials we
>>>> want to offer we need to find speakers.
>>>> 
>>>> Possible topics for WG Chairs lunch: - Jorge Contreras on
>>>> IPR - Michelle Cotton about IANA
>>>> 
>>>> Kind regards, Mirjam
>>>> _______________________________________________ edu-team
>>>> mailing list [email-masked] 
>>> _______________________________________________ edu-team
>>> mailing list [email-masked] 
> _______________________________________________ edu-team mailing
> list [email-masked]

---

From: Karen O'Donoghue <[email-masked]>
Date: Wed, 4 Oct 2017 14:30:53 +0000

Niels,

It would be good to ask for a draft in advance that we can circulate to the edu team for review. It doesn’t always happen, but we do try to do it…

Thanks,
Karen

> On Oct 4, 2017, at 10:10 AM, Niels ten Oever <[email-masked]> wrote:
> 
> Hi all,
>

---

From: Mirjam Kuehne <[email-masked]>
Date: Wed, 4 Oct 2017 16:34:26 +0200

Hi Niels,

And can you please ask the speakers to send a short description of the
tutorial so Naveen can update the main website/agenda.

Thanks,
Mirjam

---

From: Niels ten Oever <[email-masked]>
Date: Wed, 4 Oct 2017 16:55:04 +0200

Done and done!

Niels ten Oever
Head of Digital

Article 19
www.article19.org

---

From: Alice Russo <[email-masked]>
Date: Wed, 4 Oct 2017 09:25:52 -0700

Hi,
I suggest sending the presenters a link to 
https://trac.ietf.org/trac/edu/wiki/GuidelinesForPresenters
(and please feel free to edit it as you see fit).

Thanks,
Alice

---

From: Niels ten Oever <[email-masked]>
Date: Wed, 4 Oct 2017 18:30:21 +0200

I had already done that Alice, thanks for the tip (and thanks for
streamlining the doc!).

Best,

Niels

Niels ten Oever
Head of Digital

Article 19
www.article19.org

---

From: Alice Russo <[email-masked]>
Date: Wed, 4 Oct 2017 09:38:37 -0700

Excellent - thanks, Niels!

---

From: Michael StJohns <[email-masked]>
Date: Sat, 14 Oct 2017 22:07:18 -0400

> Yes, Greg suggested that we hold the webinar sooner and I agree as well. So, the week of October 30.

Did this fall off the table?   My week before is getting booked quickly.

Mike

---

From: Mirjam Kuehne <[email-masked]>
Date: Mon, 16 Oct 2017 21:25:15 +0200

Hi Mike,

Thanks for picking this up again.

What time would work best for you in the week of 30 October? I think we
should try to schedule an hour (with a possibly slightly shorter version
of the face-to-face tutorial followed by a Q&A session) and ideally find
a timeslot that works reasonably well for people in a couple of regions
- as much as possible.

Best regards,
Mirjam

On 15/10/2017 04:07, Michael StJohns wrote:
>>>> Regarding the pre-meeting newcomers webinar, we need to get that
>>>> scheduled and announced. What about Monday (6 of Nov) or Tuesday (7
>>>> of Nov)? The bigger challenge will be finding a time that is not
>>>> unduly painful for one or more timezones.
>>> 18th.  Maybe early the week before?  And have we got an idea of what
>>> is wanted as content?
>>>
>>> Later, Mike
>>>
>>>> Alexa
>>>>
>>>>
>>>>
>>>>