Subject: [edu-team] Quick summary of highlights and next steps from IETF 100 for EDU related activities

From: Karen O'Donoghue <[email-masked]>
Date: Wed, 6 Dec 2017 15:38:01 +0000

Folks,

This message is a bit long, but I wanted to provide a quick summary or the highlights of the EDU related activities at IETF 100, some preliminary post mortem thoughts, and an initial set of next steps (all from my perspective only). You will also get a doodle poll from Mirjam as we hope to schedule an EDU meeting next week to focus on EDU activities. Additionally, I’m planning a separate summary for EMO in general, and we’ll try to schedule a full EMO directorate meeting either the follow week or in early January. Thank you all for all your efforts. I personally think we are making good progress. (Also note there are a few specific ASKS for people scattered through this random set of notes.)

Newcomer’s Webinar
================
Mike, Alexa, and I were part of the first Newcomer’s Webinar. Mike did a short presentation, and then we did a question and answer session. We had roughly 25 participants. A few quick observations: we had some technical difficulties at the beginning that got us off to a bit of a rough start, we forgot to hit the record button until some time into the call. I think I would call it a mixed success

Sunday Tutorials:
=============
The Sunday tutorials all seemed to go well. We had roughly the following attendance (based on my rough count for each - the secretariat may have more accurate numbers, but these are close):
Newcomer’s - 75
TLS - 75
WebRTC - 50
Routing Area Overview - 25

Niels suggested (and implemented for TLS and WebRTC) doing a brief intro to the tutorial by an EDU team member (in this case Niels). I think this worked really well. Beyond being nice to provide a brief intro to the speakers and the topic, it had a few additional benefits: 1) It put a “face to a name” for EDU activities; and 2) it gave a change to provide EDU related reminders like “do the survey” and “give us ideas for additional tutorial topics”.

One downside was that we had some pretty significant AV issues for the beginning of the TLS tutorial. This also impacted the remote availability and I believe the recording. Also, we might want to consider a brief set of instructions for speakers (like bring your own dongle if possible, and presentations are done from your own laptop, etc). I think Alice has mentioned this previously.

Finally, on tutorials, you will have seen Mike’s note on the Newcomer’s tutorial. We will need to talk about next steps for that tutorial. Mirjam and I have talked about developing a team of people who could give this tutorial.

[ASK - Alexa] Can you send out links to the survey results in advance of next week’s (to be scheduled) meeting?
[ACTION - All] Ideas for future tutorials (with speakers!).

WG Chairs Forum
==============
The talks by Jorge and Michelle on IPR and IANA went very well. I liked the tutorial nature of the talks as well as the two way dialog that provided quality feedback from the WG chairs. We are now treating this as a session of the IETF complete with agenda, minutes, meet echo support, etc. After the session, Alexa and I set up a jabber room ([email-masked]<mailto:[email-masked]>) and a wiki page (https://trac.ietf.org/trac/wgchairs/wiki/WGChairsForum) to further track discussions and actions that come up in that forum as well as capture ideas for future topics.

I had a new working group chair approach me on Thursday about the difficulty in finding or digesting material that would be helpful for new working group chairs. She is willing to work with us to look specifically at WG Chairs information. I also had a couple of other conversations and potential volunteers related to this topic. My first thought is to gather the folks that have expressed an interest, have a brainstorming meeting about things that could be done (both near term and longer term), and establish a design/tiger team to go off to do some of this stuff (soliciting additional volunteers via the wg chairs list).

[ACTION: Karen to schedule brainstorming meeting on WG chairs training materials… maybe week after EDU meeting if possible]

Experiment on WG Overview/Intro videos
================================
Greg and Richard were able to get produce one video.
Here is the video on OAUTH. https://isoc.app.box.com/s/yc6dyjhw8u3meeiqx36odh42h0qkd54h
I wonder if this meets the original objectives and if it is scalable. I’d be curious what you all think.
Greg (and by extension Richard) have some feedback and lessons learned on the experiment.

EDU material on the new website
=========================
This is not directly related to IETF 100, but it is upon us. The new website will be rolling out in early January. There are pages that we (the EDU team) are responsible for. We need to take a look at what is currently proposed and discuss a process for more effectively and efficiently maintaining this content in the future.

[ACTION: Greg: Share details in advance of next week’s meeting. ]

So, as I said at the beginning… yeah EDU Team… There will be a second note coming with more EMO directorate related topics. Those topics include Mentoring, Speed mentoring, Outreach (Alia’s meeting plus draft status), Newcomer’s Feedback session, Newcomer’s Meet and Greet, ISOC related programs, metrics definition and measurement, and possibly a few more I’ve forgotten at the moment.

Comments and suggestions welcome.

Regards,
Karen

---

From: Alexa Morris <[email-masked]>
Date: Wed, 6 Dec 2017 12:21:17 -0800

Hi Everyone

Links to survey results (and some embedded survey comments) below:

1) Newcomers Orientation: https://www.surveymonkey.com/results/SM-S7QTWSVS8/
- 15 respondents

A few comments:
- Add a little about the life cycles of standards track and informational RFC, and how the decision is made which track is chosen, by whom it is chosen, and when the decision is made. 
- The presentation covered all the basic info for new attendees. Highly recommended for all fellows.
- I liked the humming demonstration 
- I had already read / watched ahead of meeting, but it was good to get an on-site intro
- The presentation gives an overview of all the basics and tips on how to prepare yourself for taking and contributing the most during the meetings.

2) Transport Layer Security (TLS) 1.3: https://www.surveymonkey.com/results/SM-37PZDSVS8/
- 24 responses 

Comments: 
- This needs promoting outside the IETF
- I did'nt understand "IANA Registry will include Recommended column".Please mail me the details at [email redacted]
- PFS deserves more time
- It is a taster. Those interested will follow up. [this was regarding tutorial length]
- Probably about right if there were more questions but there were mot many at all [also regarding tutorial length]
- Could get into a bit more detail on why 1.3 is more secure besides getting rid of too many cipher suites. Danced around the more controversial bits too much.

Specific suggestions for improvement:
- You could break up this topic into several levels -- a beginners tutorial (how does the protocol work) and maybe one that discusses "how does this version differ from the previous" (which is what this one seemed to be).
- You have shared the good side (Advantages) of TLS 1.3 and that is reasonable. Kindly share the details of disadvantages of TLS 1.3. List may include Impact of PFS on the decryption techniques in the data centers. Management of large numbers of Ephemeral keys Cost associated in the implementation Vs Security achieved. I may be asking too musch but please share the details at [email redacted]
- For the tutorials, it is not clear as to the expectations of the technical level of attendees. Perhaps a survey prior to IETF, asking if anyone with a non-technical background would be interested in learning about the "basics" of an area (such as TLS 1.3). If a high enough response is received (determined by EDU), a session could be held on a technology for "non-technical attendees".
- Fewer animations! The slides look like someone from Marketing did them (sorry, didn’t mean to be insulting).
- We have three more TLS sessions this week. Hopefully it gets covered there
- Further planned changes for final version, some current points of discussion.
- Wireshark Demo Docker Demo

3) WebRTC: https://www.surveymonkey.com/results/SM-Y9YGLRVS8/
- 9 responses

There were a couple of specific comments on technical content. In addition, a couple of responses indicated that the tutorial was more detailed than expected, e.g. “This was WAY more detailed than the TLS 1.3 tutorial. Might want to have a few keywords that say what kind of tutorial it is, or be more specific (eg WebRTC API overview vs WebRTC overview).”

4) Routing Area: https://www.surveymonkey.com/results/SM-5P885RVS8/
- 4 responses

Comments:
- I think that the material was pretty good. What I think will be interesting is to give the authors more time to give more details during the presentation.
- I feel that there should be links to websites for each working group, and a short roundup on what cool things are being discussed here in IETF100

-Alexa

> On Dec 6, 2017, at 7:38 AM, Karen O'Donoghue <[email-masked]> wrote:
> 
> Folks,
> 
> The talks by Jorge and Michelle on IPR and IANA went very well. I liked the tutorial nature of the talks as well as the two way dialog that provided quality feedback from the WG chairs. We are now treating this as a session of the IETF complete with agenda, minutes, meet echo support, etc. After the session, Alexa and I set up a jabber room ([email-masked] <mailto:[email-masked]>) and a wiki page (https://trac.ietf.org/trac/wgchairs/wiki/WGChairsForum <https://trac.ietf.org/trac/wgchairs/wiki/WGChairsForum>) to further track discussions and actions that come up in that forum as well as capture ideas for future topics. 
> 
> Here is the video on OAUTH. https://isoc.app.box.com/s/yc6dyjhw8u3meeiqx36odh42h0qkd54h <https://isoc.app.box.com/s/yc6dyjhw8u3meeiqx36odh42h0qkd54h>
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team

---

From: Michael StJohns <[email-masked]>
Date: Wed, 6 Dec 2017 15:39:40 -0500

On 12/6/2017 3:21 PM, Alexa Morris wrote:
> 1) Newcomers Orientation: 
> https://www.surveymonkey.com/results/SM-S7QTWSVS8/
> - 15 respondents
>
> A few comments:
> - Add a little about the life cycles of standards track and 
> informational RFC, and how the decision is made which track is chosen, 
> by whom it is chosen, and when the decision is made.
I keep pushing back on this as I think its a) not so much a newcomer's 
item and b) could be a 30-40 minute presentation on its own.  YMMV.  
Maybe think of this as a separate tutorial.

> - The presentation gives an overview of all the basics and tips on how 
> to prepare yourself for taking and contributing the most during the 
> meetings.

My last commentary ....

Nalani - please take a look at the responses for respondent #4 - this 
seems to be from someone who wasn't able to figure out how to contact 
anyone for being Mentor'd and mentioned that the front desk didn't have 
the information he wanted.  I don't think they were actually in the 
tutorial as i called out the mentoring program and i would have expected 
a question of "where do I go" from the floor in the Q&A section.

All - see the single comment for Q2 -

>     Q2
>     Would you recommend the IETF 100 Newcomers Orientation tutorial to
>     other attendees?
>
>       * Maybe (please explain):
>       * I hope you will give an opportunity to the membership of the
>         Arab world
>
I don't think this is a tutorial specific comment given his/her other 
responses, but may be useful to think about related to outreach.

Next go around I'd suggest adding Q7 as a comment question (needs 
wordsmithing):

"Do you have any other comments?  If you'd like us to contact you about 
your comments please leave us your email address."

Enjoy - Mike

---

From: Nalini J Elkins <[email-masked]>
Date: Wed, 6 Dec 2017 21:15:26 +0000 (UTC)

> My last commentary .... 
> Nalani - please take a look at the responses for respondent #4 - this seems to be from someone who wasn't able to figure out how to contact anyone for being Mentor'd and mentioned that the front desk didn't have the >information he wanted.  I don't think they were actually in the tutorial as i called out the mentoring program and i would have expected a question of "where do I go" from the floor in the Q&A section.
Mike, 
IETF Registration people used to have a little handout on mentoring & my email.  I will doublecheck with Alexa and make sure that the front desk still has that.
Thanks for bringing this to my notice.  Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

      From: Michael StJohns <[email-masked]>
 To: [email-masked] 
 Sent: Wednesday, December 6, 2017 12:39 PM
 Subject: Re: [edu-team] Quick summary of highlights and next steps from IETF 100 for EDU related activities

 Links to survey results (and some embedded survey comments) below: 
   1) Newcomers Orientation: https://www.surveymonkey.com/results/SM-S7QTWSVS8/ - 15 respondents 
  A few comments: - Add a little about the life cycles of standards track and informational RFC, and how the decision is made which track is chosen, by whom it is chosen, and when the decision is made. 
   
 I keep pushing back on this as I think its a) not so much a newcomer's item and b) could be a 30-40 minute presentation on its own.  YMMV.  Maybe think of this as a separate tutorial.  

 - The presentation covered all the basic info for new attendees. Highly recommended for all fellows. - I liked the humming demonstration 
 - I had already read / watched ahead of meeting, but it was good to get an on-site intro
 - The presentation gives an overview of all the basics and tips on how to prepare yourself for taking and contributing the most during the meetings.  
 
  My last commentary .... 
  Nalani - please take a look at the responses for respondent #4 - this seems to be from someone who wasn't able to figure out how to contact anyone for being Mentor'd and mentioned that the front desk didn't have the information he wanted.  I don't think they were actually in the tutorial as i called out the mentoring program and i would have expected a question of "where do I go" from the floor in the Q&A section.
  All - see the single comment for Q2 - 

   Q2  Would you recommend the IETF 100 Newcomers Orientation tutorial to other attendees?         
   -   Maybe (please explain):  
   -   I hope you will give an opportunity to the membership of the Arab world 

 I don't think this is a tutorial specific comment given his/her other responses, but may be useful to think about related to outreach.
 
 Next go around I'd suggest adding Q7 as a comment question (needs wordsmithing):
 
 "Do you have any other comments?  If you'd like us to contact you about your comments please leave us your email address."
 
 Enjoy - Mike

---

From: Alexa Morris <[email-masked]>
Date: Thu, 7 Dec 2017 16:25:54 -0800

Hi Nalini,

We do produce a Newcomer’s handout that is very similar to what you can find online (e.g. https://ietf.org/meeting/100/100-newcomers.html <https://ietf.org/meeting/100/100-newcomers.html>). It has a very brief description of the Mentoring Program, but it does not specifically mention you by name. And we don’t have any information at registration about who the active mentors / newcomers are, and who is matched with whom. 

Alexa

> On Dec 6, 2017, at 1:15 PM, Nalini J Elkins <[email-masked]> wrote:
> 
> > My last commentary .... 
> Thanks for bringing this to my notice. 
>  
> Nalini Elkins
> CEO and Founder
> Inside Products, Inc.
> www.insidethestack.com
> (831) 659-8360
> 
> 
>> 1) Newcomers Orientation: https://www.surveymonkey.com/results/SM-S7QTWSVS8/ <https://www.surveymonkey.com/results/SM-S7QTWSVS8/>
>> - 15 respondents
>> 
>> A few comments:
>> Would you recommend the IETF 100 Newcomers Orientation tutorial to other attendees?
>> Maybe (please explain):
>> I hope you will give an opportunity to the membership of the Arab world
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/edu-team <https://www.ietf.org/mailman/listinfo/edu-team>
> 
>

---

From: Nalini J Elkins <[email-masked]>
Date: Fri, 8 Dec 2017 00:42:29 +0000 (UTC)

Alexa,
Hmm.   Let's chat privately & see what information would be helpful for you. Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

      From: Alexa Morris <[email-masked]>
 To: Nalini J Elkins <[email-masked]> 
Cc: Michael StJohns <[email-masked]>; "[email-masked]" <[email-masked]>
 Sent: Thursday, December 7, 2017 4:22 PM
 Subject: Re: [edu-team] Quick summary of highlights and next steps from IETF 100 for EDU related activities
   
Hi Nalini,
We do produce a Newcomer’s handout that is very similar to what you can find online (e.g. https://ietf.org/meeting/100/100-newcomers.html). It has a very brief description of the Mentoring Program, but it does not specifically mention you by name. And we don’t have any information at registration about who the active mentors / newcomers are, and who is matched with whom. 
Alexa

Mike, 

  

 
  My last commentary .... 

 

 Enjoy - Mike

---

From: Fred Baker <[email-masked]>
Date: Thu, 7 Dec 2017 16:47:35 -0800

> On Dec 7, 2017, at 4:42 PM, Nalini J Elkins <[email-masked]> wrote:
> 

One thing I'd like to be careful of - we have at least two, maybe three if you squint, mentoring programs. Nalini's, ISOC Technical (Niel Harper), and ISOC Policy (KK & Elizabeth Oluoch). If we mention one in print, I'd like to mention the others. I'm involved in all of them to some degree.

---

From: Niels ten Oever <[email-masked]>
Date: Fri, 8 Dec 2017 17:18:30 +0100

I think we should also be very clear about 'newcomers lunches' and other events, and have it clear who organizes them. Whether it is an EDU team activity, or not so much.

Cheers,

Niels

-- 

Niels ten Oever
Head of Digital

Article 19
www.article19.org

PGP fingerprint	   2458 0B70 5C4A FD8A 9488  
                   643A 0ED8 3F3A 468A C8B3

---

From: Nalini J Elkins <[email-masked]>
Date: Fri, 8 Dec 2017 17:09:34 +0000 (UTC)

Niels,
IETF mentoring does the newcomer's lunch on Tuesday.  It is usually very well attended.  (Esp. when I have the "Make IPv4 Great Again" hat on so that people can recognize me at the IETF registration. Hat courtesy of John Levine!)
If we want to make the lunch an official EDU activity, that is great.   We can also leave it as a part of the mentoring program.   Whatever the group thinks is fine with me.
I was not thinking of joining the call coming up for EDU as I did not think it affected mentoring but I can certainly join if I can add anything. Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

      From: Niels ten Oever <[email-masked]>
 To: Fred Baker <[email-masked]> 
Cc: Nalini Elkins <[email-masked]>; Alexa Morris <[email-masked]>; "[email-masked]" <[email-masked]>
 Sent: Friday, December 8, 2017 8:18 AM
 Subject: Re: [edu-team] Quick summary of highlights and next steps from IETF 100 for EDU related activities

Cheers,

Niels

-- 

Niels ten Oever
Head of Digital

Article 19
www.article19.org

---

From: Niels ten Oever <[email-masked]>
Date: Mon, 11 Dec 2017 15:05:18 +0100

I might be confused, but mentoring is an EDU activity, right?

Best,

Niels

Niels ten Oever
Head of Digital

Article 19
www.article19.org

On 12/08/2017 06:09 PM, Nalini J Elkins wrote:
> Niels,
> 
> IETF mentoring does the newcomer's lunch on Tuesday.  It is usually very
> well attended.  (Esp. when I have the "Make IPv4 Great Again" hat on so
> that people can recognize me at the IETF registration. Hat courtesy of
> John Levine!)
> 
> If we want to make the lunch an official EDU activity, that is great. 
>  We can also leave it as a part of the mentoring program.   Whatever the
> group thinks is fine with me.
> 
> I was not thinking of joining the call coming up for EDU as I did not
> think it affected mentoring but I can certainly join if I can add anything.
>  
> Thanks,
> 
> Nalini Elkins
> CEO and Founder
> Inside Products, Inc.
> www.insidethestack.com
> (831) 659-8360
> 
> 
> ------------------------------------------------------------------------
> *From:* Niels ten Oever <[email-masked]>
> *To:* Fred Baker <[email-masked]>
> *Cc:* Nalini Elkins <[email-masked]>; Alexa Morris
> <[email-masked]>; "[email-masked]" <[email-masked]>
> *Sent:* Friday, December 8, 2017 8:18 AM
> *Subject:* Re: [edu-team] Quick summary of highlights and next steps
> from IETF 100 for EDU related activities
> 
> I think we should also be very clear about 'newcomers lunches' and other
> events, and have it clear who organizes them. Whether it is an EDU team
> activity, or not so much.
> 
> Cheers,
> 
> Niels
> 
> 
>> > On Dec 7, 2017, at 4:42 PM, Nalini J Elkins
> <[email-masked]
> <mailto:[email-masked]>> wrote:
>> >
>> > We do produce a Newcomer’s handout that is very similar to what you
> can find online (e.g. https://ietf.org/meeting/100/100-newcomers.html).
> It has a very brief description of the Mentoring Program, but it does
> not specifically mention you by name. And we don’t have any information
> at registration about who the active mentors / newcomers are, and who is
> matched with whom.
>>
>> One thing I'd like to be careful of - we have at least two, maybe
> three if you squint, mentoring programs. Nalini's, ISOC Technical (Niel
> Harper), and ISOC Policy (KK & Elizabeth Oluoch). If we mention one in
> print, I'd like to mention the others. I'm involved in all of them to
> some degree.
> 
>>
> 
> 
>

---

From: Mirjam Kuehne <[email-masked]>
Date: Mon, 11 Dec 2017 15:09:38 +0100

Hi,

While we usually distinguish between the edu activities (i.e. Sunday
tutorials, WG chairs training, training materials on the website) and
the mentoring activities, there is indeed a lot of overlap, especially
when it comes to newcomers.

So, if you have time, Nalini, it would be great if you could join.

Cheers,
Mirjam

On 11/12/2017 15:05, Niels ten Oever wrote:
> Niels ten Oever Head of Digital
> 
> Article 19 www.article19.org
> 
> PGP fingerprint    2458 0B70 5C4A FD8A 9488 643A 0ED8 3F3A 468A
> C8B3
> 
>> IETF mentoring does the newcomer's lunch on Tuesday.  It is
>> usually very well attended.  (Esp. when I have the "Make IPv4
>> Great Again" hat on so that people can recognize me at the IETF
>> registration. Hat courtesy of John Levine!)
>> 
>> If we want to make the lunch an official EDU activity, that is
>> great. We can also leave it as a part of the mentoring program.
>> Whatever the group thinks is fine with me.
>> 
>> I was not thinking of joining the call coming up for EDU as I did
>> not think it affected mentoring but I can certainly join if I can
>> add anything.
>> 
>> Thanks,
>> 
>> Nalini Elkins CEO and Founder Inside Products, Inc. 
>> www.insidethestack.com (831) 659-8360
>> 
>> 
>> ---------------------------------------------------------------------
- ---
>> *To:* Fred Baker <[email-masked]> *Cc:* Nalini Elkins
>> <[email-masked]>; Alexa Morris 
>> *Sent:* Friday, December 8, 2017 8:18 AM *Subject:* Re:
>> [edu-team] Quick summary of highlights and next steps from IETF
>> 100 for EDU related activities
>> 
>> I think we should also be very clear about 'newcomers lunches'
>> and other events, and have it clear who organizes them. Whether
>> it is an EDU team activity, or not so much.
>> 
>> Cheers,
>> 
>> Niels
>> 
>> 
>> can find online (e.g.
>> https://ietf.org/meeting/100/100-newcomers.html). It has a very
>> brief description of the Mentoring Program, but it does not
>> specifically mention you by name. And we don’t have any
>> information at registration about who the active mentors /
>> newcomers are, and who is matched with whom.
>>> 
>> three if you squint, mentoring programs. Nalini's, ISOC Technical
>> (Niel Harper), and ISOC Policy (KK & Elizabeth Oluoch). If we
>> mention one in print, I'd like to mention the others. I'm
>> involved in all of them to some degree.
>> 
>>> 
>> 
>> 
>> 
>>> _______________________________________________ edu-team
>>> mailing list [email-masked] <mailto:[email-masked]> 
>> Niels ten Oever Head of Digital
>> 
>> Article 19 www.article19.org
>> 
>> PGP fingerprint      2458 0B70 5C4A FD8A 9488 643A 0ED8 3F3A 468A
>> C8B3
>> 
>> 
>> 
> 
> 
> 
> _______________________________________________ edu-team mailing
> list [email-masked]

---

From: Nalini J Elkins <[email-masked]>
Date: Mon, 11 Dec 2017 14:19:05 +0000 (UTC)

Mirjam,
Can you unicast me the link again to join?
Niels, mentoring is an activity of the directorate but there are two different projects Mirjam heads one & I head the another.   There are also quite a few other projects in the directorate.
There is certainly overlap between Mirjam's project & mine, so I try to keep an eye on what is going on over there.
I think there is a list of all the projects somewhere.
Sorry to be so scattered, it is Monday morning here & am trying to get caught up! Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

      From: Mirjam Kuehne <[email-masked]>
 To: [email-masked] 
 Sent: Monday, December 11, 2017 6:09 AM
 Subject: Re: [edu-team] Quick summary of highlights and next steps from IETF 100 for EDU related activities

Hi,

Cheers,
Mirjam

- ---