Subject: [edu-team] Note taker for todays WG chairs Forum

From: Karen O'Donoghue <[email-masked]>
Date: Wed, 18 Jul 2018 11:11:26 +0000

Folks,

Are there any volunteers to take notes for today’s WG Chairs forum? I could use the help as I’m hoping we get some concrete actions out of the GitHub discussion. 

Karen

---

From: Niels ten Oever <[email-masked]>
Date: Wed, 18 Jul 2018 15:55:12 +0200

Hi Karen,

I can do that - wanted to do a Github write-up for EDU anyhow.

Cheers,

Niels

On 07/18/2018 01:11 PM, Karen O'Donoghue wrote:
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
> 

-- 
Niels ten Oever
Researcher and PhD Candidate
Datactive Research Group
University of Amsterdam

PGP fingerprint	   2458 0B70 5C4A FD8A 9488
                   643A 0ED8 3F3A 468A C8B3

---

From: Fred Baker <[email-masked]>
Date: Wed, 18 Jul 2018 13:20:15 -0400

Here are the notes I took. Most of what he said was in his slides, so if his slides are available additional notes don't accomplish much. I did note one action item: locating the tool used to forward discussion into email, and discussion of whether the Secretariat should be asked to maintain an instance of it.

> On Jul 18, 2018, at 7:11 AM, Karen O'Donoghue <[email-masked]> wrote:
> 
> Folks,
>

---

From: Niels ten Oever <[email-masked]>
Date: Wed, 18 Jul 2018 19:22:54 +0200

Here are the notes. Best, Niels

WG Chairs meeting July 18 12:15

Chair: Karen, Mirjam (Absent)

Presentation Martin Thomson on 'Github for Working Groups'
- Github is not perfect at all
- But it is where our adience is

- Allows a lot of transparency for change control
- Issue management is a nice plus
- Again, big plus is the audience
    - drive by typo fixes
    - many significant contributions from ppl who would not do so otherwise (v useful in QUIC and TLS)
    - audience is familiar with the tool

- Reviewing tools are quite awful
- Issues are threaded discussions, where a lot of discussions take place
- Pull Reviews also allow for comments and discussions
- Everything transparent

- Weekly Github digests can be useful to be sent to the list, firehose of notifications are not

Issues
- Managging discussions: 
    - Pull requests, mailinglists, issues => discussion fractures, chairs need to decide
    - Safest policy is doing all discussion on WG list, except for typos and editorial comments
    - Constant reminders are needed to keep people on mailinglist
    - Some WGs do discussions on Github, different way of working. 
    - Have clear expectation, monitor and steer as needed.
    - Use CONTRIBUTING.md

Some models:
    - Working Group as 'Organization', owned by WG chairs + AD, authors as collaborators
    - Seperate work items have seperate repositories
    - Teams are given commit access to their repository

Colin Perkins:
    - Should secretariat have priviledges?
Martin Thomson:
    - Recommended if you think that is important, would add continuity.
Lou Berger:
    - Should be discussed with secretariat, add costs. 
Carsten Borman:
    - Markdown is a stable input format while we change XML2RFC
Dave Thaler:
    - Is the design label a Github concept, or do we design it ourselves?
Martin Thomson:
    - It is an (emerging) convention
Carsten Borman:
    - We should agree on colors among WGs
[laughter]

    - Editors are responsible for maintaining the repository
    - Chairs should not commit changes, merge PRs, etc

    - Use markdown! (reading XML is terrible)
    - Use labels
    - Issues can be assigned, reviews can be requested for PRs
    - Milestones and project board might help.

    - Continuous integration allows to check whether draft is valid, and makes it!
    - Also maintains a preview of branches, diffs and all documents, creates archive

    - Toolchain can be found here:
        https://github.com/martinthomson/i-d-template
    
Pete Resnick:
    - Integrating back into the tracker, are there design choices there?
Martin Thomson:
    - Yes we wanted the branch to reflect the editors version. Tags are nice for that.
Barry Leiba:
    - Can editors use this offline
Martin Thomson:
    - This works reasonably well offline. Almost all of it. You can just use git push/pull.
Steward Bryant
    - How to get started?
Martin Thomson:
    - How to is here: https://github.com/martinthomson/i-d-template
Mahesh J:
    - Are there differences between MMark and Kramdown?
Martin Thomson:
    - Yes, now and then I have actually pasted code in draft.
Mahesh J:
    - We have found this useful in YANG. We have tools that allowed us to add documents in to the draft
Martin Thomson:
    - With automtic validation you can check that in the draft, then it can also check you YANG
Carsten Borman:
    - A lot of things can be done in CI, you don't need to write everything that goes into the RFC.
Martin Thomson:
    - I have a draft that is all test messages, that is all generated in CI, 60 pages of HEX
Andy Malis:
    - Is anyone concerned that this is a tool that is not under our control? Have we considered hosting this ourselves.
Martin Thomson:
    - Yes people are concerned. No they don't do v6. This tool is awful, but this is where everyone is. We could host this ourselves, like Gitlab. We would lose the ppl tho. We would also lose CI.
Aaron Falk:
    - Github is confusing because it is so open. There are 'design' and 'editorial' labels, but is this IETF or github specific? Is there a suggested list of tags? Is there a convention?
Martin Thomson:
    - We don't have a help page. We use IETF convention.
David Schinazi:
    - How do I get here? All authors have their own repos. Could we have some guidance from our lawyer on how to do this right?
Martin Thomson:
    - There has been discussion, there has been an IAB statement. This tool contains this text. It will create a README.md and a CONTRIBUTING.md thing, and LICENSE. A lot of the setup stuff is done for you.
Carsten Borman:
    - As WG you want to pull in drafts that are not yet WG drafts. The adoption is a moment where a lot of things happen. And you don't want to wait until then for the author to get comfortable with this.
    - What happens if an owner tries to destroy Github. But I am relatively happy about the situation at Gitlab or Bitbucket. IETF could run that itself and we could migrate there.
Martin Thomson:
    - This is why I copy issues into the repo, if Github would go away tomorrow, all authors have a code and docs.
Acee Lindem:
    - Have one repo per draft is the best thing, so it remain stable after WG adoption.

Karen:
    - Thank you Martin. We have four minutes for open mic.

Aaron Falk:
    - To recap message to WG chairs list: Sunday evenings we do hotRFC. We have a low bar for submissions to talk about ideas. I got some positive feedback, none negative yet. Seems pretty successfull. Sometimes random stuff shows up in WGs, this is the right place for ppl to find their community. This helps ppl find their place. 
No one reads ietf@ietf anymore, so if you want to reach a lot of people, this could help. 

David Schinazi:
    - Tim Chown is stepping down as co-chair, I need a new one. We haven't found a replacement yet in DNSSD.

-- 

Niels ten Oever