Subject: [edu-team] slides by Dan York: Writing I-Ds in Markdown

From: Alice Russo <[email-masked]>
Date: Tue, 17 Jul 2018 16:09:27 -0400

Hi EDU team,

FYI, here are some useful slides that Dan (CC'ed) made:
https://github.com/danyork/writing-internet-drafts-in-markdown/blob/master/writing-internet-drafts-in-markdown.pdf

I often field questions re: what is the easiest way to create an I-D (at the RFC Editor desk) and these slides are a good starting place for people interested in using markdown. (You may be surprised to know that there are more options than kramdown-rfc2629.) Sending to this list w/ the suggestion that we:
- link to the slides from relevant locations (I plan to add it on the RFC Editor's page about tools for creating I-Ds [1])
- incorporate the information and talk w/ Dan when working on future 'How to write an I-D' tutorials.

More information in Dan's mail to the rfc-markdown list [2].

Thanks,

Alice Russo
RFC Production Center

[1] https://www.rfc-editor.org/pubprocess/tools/
[2] https://mailarchive.ietf.org/arch/msg/rfc-markdown/fjgXfMkvjatnF6erhcH_4o7Eh1U

---

From: Dan York <[email-masked]>
Date: Tue, 17 Jul 2018 20:51:54 +0000

Alice,

Thank you for your kind words. I am glad you found the slides helpful. These were for an "IETF Hub Boston" event last month (June 2018). I did not record the session, but I've considered doing so.

I'd note that the larger Github repository in which I have this PDF also has "example-kramdown" and "example-mmark" directories that have very simple examples of what a markdown file would look like:

https://github.com/danyork/writing-internet-drafts-in-markdown <https://github.com/danyork/writing-internet-drafts-in-markdown>

I had grand plans to include in those sample files more examples of the various things you can do with markdown to create different elements of Internet-Drafts. I didn't have time before the Boston meeting, but would like to come back to that at some point. (And if anyone wants to collaborate on that, I'd welcome contributions.:-) )

Dan

P.S. As I note in that repo, the slides are also built in markdown using a program called Marp - https://yhatt.github.io/marp/ - which was fun to use.

P.P.S. Yes, I'm a markdown geek... 

--
Dan York
Director, Content & Web Strategy, Internet Society
[email-masked]   +1-802-735-1624 
Jabber: [email-masked]  Skype: danyork   http://twitter.com/danyork

http://www.internetsociety.org/

> On Jul 17, 2018, at 4:09 PM, Alice Russo <[email-masked]> wrote:
> 
> Hi EDU team,
>