Subject: Re: [edu-team] Proposal for a tutorial at IETF-103

From: Mirjam Kuehne <[email-masked]>
Date: Mon, 24 Sep 2018 09:06:52 +0200

(copying the Edu Team so everyone is in the loop)

Hi Adrian, Hi Haomian,

Thanks for confirming. Is it ok if we schedule this for 12:30? And yes,
this is a one-hour slot.

Can you please send me a short description that we can post on the website.

Cheers,
Mirjam

On 21/09/2018 18:48, Adrian Farrel wrote:
> Hi Mirjam,
> 
> Thanks, yes, doing a tutorial is still possible.
> 
> I'd like to do this as a double act with Haomian (cc'ed). Haomian has his finger on the pulse of transport networks and YANG modules used for controlling TE networks, so we should be able to cover all the material.
> 
> I assume a one hour slot, so we have to be pretty careful with the content.
> 
> Cheers,
> Adrian
> 
>> -----Original Message-----
>> From: Mirjam Kuehne [mailto:[email-masked]]
>> Sent: 19 September 2018 15:10
>> To: [email-masked]
>> Subject: Re: [edu-team] Proposal for a tutorial at IETF-103
>>
>> Hi Adrian,
>>
>> I am not sure we picked this already. We're now discussing tutorials for
>> IETF 103 and your suggestion to provide one on traffic engineering
>> sounds good.
>>
>> Are you still interested to organise such a tutorial for Bangkok? And
>> did you have any speakers in mind? You plus someone else?
>>
>> Kind regards,
>> Mirjam
>>
>>
>>
>> On 06/08/2018 19:21, Adrian Farrel wrote:
>>> Just a ping on this. No pressure.
>>>
>>> Adrian
>>>
>>>> -----Original Message-----
>>>> From: Adrian Farrel [mailto:[email-masked]]
>>>> Sent: 16 July 2018 16:48
>>>> To: 'EDU Team'
>>>> Subject: Proposal for a tutorial at IETF-103
>>>>
>>>> Hi guys,
>>>>
>>>> One of my roles is Technical Advisor to the TEAS WG, and I've already had
>>> several
>>>> conversations this week around "what is traffic engineering?" and "what is the
>>>> IETF doing around TE?"
>>>>
>>>> So I would like to propose a Sunday tutorial to pull together what the IETF
>>> has
>>>> done (quite a lot of history with RSVP, RSVP-TE, IGP tweaks, PCE, BGP-LS) and
>>> is
>>>> doing (some new architecture work such as ACTN, and a lot of YANG modules
>> to
>>>> define services, connectivity, and topology).
>>>>
>>>> What do you think?
>>>>
>>>> Cheers,
>>>> Adrian
>>>
>>> _______________________________________________
>>> edu-team mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/edu-team
>>>
>

---

From: Karen O'Donoghue <[email-masked]>
Date: Mon, 24 Sep 2018 16:50:28 +0000

Thanks Adrian, one quick question… do you have a time constraint… as in can we schedule in either of the two tutorial slots (12:30 or 13:45?)

Mirjam - I thought perhaps we should stay flexible until we have everyone else nailed down as well. 

Thanks!
Karen

> On Sep 24, 2018, at 2:06 AM, Mirjam Kuehne <[email-masked]> wrote:
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 25 Sep 2018 15:25:13 +0100

Assuming that the IESG/IAB don't summon the ISE to talk to them (unlikely as I saw them in Montreal), both times work for me.

A

> From: Karen O'Donoghue [mailto:[email-masked]]
> Sent: 24 September 2018 17:50
> To: Mirjam Kuehne
> Cc: [email-masked]; EDU Team; Zhenghaomian
> Thanks Adrian, one quick question… do you have a time constraint… as in can we
> schedule in either of the two tutorial slots (12:30 or 13:45?)
> 
> >> I'd like to do this as a double act with Haomian (cc'ed). Haomian has his finger
> on the pulse of transport networks and YANG modules used for controlling TE
> networks, so we should be able to cover all the material.
> >>

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 25 Sep 2018 15:55:23 +0100

Hi Mirjam,

> Thanks for confirming. Is it ok if we schedule this for 12:30? And yes,

Per mail to Karen, 12.30 or 13.45. Useful to know sooner rather than later.

> Can you please send me a short description that we can post on the website.

---

Traffic Engineering in the IETF

"Everyone knows what Traffic Engineering is," an IETF old-timer said recently. But TE is now so important as a glue for the Internet that it's worth stepping back to consider what it is, how it works, and what work the IETF is currently engaged in.

This tutorial will introduce the concept of Traffic Engineering, describe the basic techniques, run through the key TE technologies that have been developed in the IETF, and provide pointers to current IETF efforts to enhance Traffic Engineering. The talk will describe recent architectural models such as the Architecture for Application Based Network Operation (ABNO), PCE as a Central Controller (PCE-CC), and a Framework for Abstraction and Control of TE Networks (ACTN), and it will mention new approaches to Traffic Engineering delivered by Segment Routing (SR) and Deterministic Networking (DetNet). It will also preview the work on YANG models for the control of TE resources and virtual networks.

---

Too much like marketing blurb?

Best,
Adrian

---

From: Mirjam Kuehne <[email-masked]>
Date: Tue, 25 Sep 2018 17:13:03 +0200

Thanks, Adrian. We'll let you know asap which slot you'll have.

Cheers,
Mirjam