Subject: [edu-team] good entry points (directing people to specific drafts)

From: Alice Russo <[email-masked]>
Date: Thu, 8 Nov 2018 09:34:08 +0700

Hi,
On the topic of wanting "an easy way to pick something up" from this morning, some ideas below.

David Black mentioned at WG chairs forum yesterday that for his WG session he puts a 2nd slide (directly after the Note Well) that states "Read the drafts." Seems similar to the refrain of "Do your homework." Below are suggestions about how to guide people (including newcomers) to "useful" homework. a.k.a. good entry points -- where that may be defined by the WG chairs; it could include drafts in need of feedback.

1) For posting one week before: ask WG chairs to select a few drafts to highlight as entry points. Put those on a list (web page; sample below) that is distributed to newcomers. Also, could suggest that the chair's blog post "IETF 104 Preview" link to the list (reaching an audience wider than newcomers); I see it as related content. 

2) For WG session slides: encourage WG chairs to adopt David's slide. Addition: below "Read the drafts", put the list of specific drafts that are good entry points. Although the WG session is late in some respects, the slide deck is where some attendees/readers get their pointers to current work.

Alternatively: there are already tarballs of drafts for each WG session; this could be an effort to highlight those for newcomers in a better way -- e.g., planning to attend TCPINC, here's your homework!

Thanks,
Alice
--

sample:
ENTRY POINTS FOR IETF 104

[if it's by large topic]

If you're interested in ...
--> network management, read these drafts & attend this
--> Internet of Things, read these drafts & attend this
--> new transport technologies, read these drafts & attend MPTCP, TCPINC, and DTNWG

[if it's by specific WG]

If you're interested in ...
--> Traffic Engineering Architecture and Signaling (TEAS), read these drafts & join us Mon. morning
--> Measurement and Analysis for Protocols (MAPRG), read these drafts & join us Tues. afternoon
--> Network Modeling (NETMOD), read these drafts & join us Tues. morning

---

From: Fred Baker <[email-masked]>
Date: Thu, 8 Nov 2018 09:47:02 +0700

> On Nov 8, 2018, at 9:34 AM, Alice Russo <[email-masked]> wrote:
> 
> Hi,

Did EDU Team meet this morning? Missed that...

> 1) For posting one week before: ask WG chairs to select a few drafts to highlight as entry points. Put those on a list (web page; sample below) that is distributed to newcomers. Also, could suggest…

To my small mind, that's called "the agenda". I go through this in mentoring. I have attached a file that I create daily from datatracker information slightly reorganized and with one bit added - for documents still in the Working Group, the top asks whether it has been updated since a specified date, which is always the end of the last IETF meeting. When mentoring people, they usually ask about several working groups. I provide this, and tell them that if the agenda is not yet posted, read the individual and working group drafts that have been updated since that time. If there is an agenda, I ask them to read the drafts on the agenda.

For a protocol working group, there is often also a "problem to be solved" draft or RFC, and a base protocol draft or RFC. The list will usually include them.

> 2) For WG session slides: encourage WG chairs to adopt David's slide. Addition: below "Read the drafts", put the list of specific drafts that are good entry points. Although the WG session is late…

Is David's slide somewhere obvious? I don't know what you're talking about.

> Alternatively: there are already tarballs of drafts for each WG session; this could be an effort to highlight those for newcomers in a better way -- e.g., planning to attend TCPINC, here's your hom…

--------------------------------------------------------------------------------
The fact that there is a highway to hell and a stairway to heaven is an interesting comment on projected traffic volume...

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 8 Nov 2018 02:55:07 +0000

The very word, agenda, implies it's the plan for the meeting.  Overloading that seems like a bad idea.

I think a separate "if you're new to the group..." and it could be a couple of paragraphs written by the chair. It shouldn't be long-term thing, but only associated with a single meeting so it gets refreshed (or not carried over) for each meeting.

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 8 Nov 2018 03:36:08 +0000

And also, if there's a specific spot in the meeting materials for this kind of thing then it could show up on the "splash page" for each WG like the Agenda link does.

On 11/8/18, 9:55 AM, "Salz, Rich" <[email-masked]> wrote:

---

From: Alice Russo <[email-masked]>
Date: Thu, 8 Nov 2018 18:03:46 +0700

Hi Fred,

On the agenda, for a given WG, it links to a bunch of drafts (e.g., 14 for teas; 14 for netmod for this meeting). Was brainstorming on the intersection of what I was hearing the past 2 days: the earnest desire to "do the homework" (from newcomers) and "Read the drafts" (from WG chairs).  I wonder about marking drafts on the web-based agenda w/ a star or other symbol -- i.e., marking ones the WG chair recommends as good, for some value of 'good' (perhaps good for people who are new-ish to the WG and want an entry point for participation).

Thanks,
Alice

> On Nov 8, 2018, at 9:47 AM, Fred Baker <[email-masked]> wrote:
> 
> 
> 
> <raw-agenda-data-v6ops.html>

---

From: Fred Baker <[email-masked]>
Date: Thu, 8 Nov 2018 19:01:30 +0700

> On Nov 8, 2018, at 6:03 PM, Alice Russo <[email-masked]> wrote:
> 

Well, so let me put this in my context.

We had four drafts on our agenda, plus two that wanted to be (and the author brought slides in case there was time), and one that accused me of personal bias in not putting it on the agenda. However, on that last we asked, and intended to ask, who had read it, who found it valuable, and who therefore wanted the chairs to change their minds. Putting it on that list constitutes recommending people read a draft that I view as out of charter and in any event we don't plan to further discuss, and not putting it on that list opens me to a charge of bias.

Which should I do?

---

From: Mirjam Kuehne <[email-masked]>
Date: Fri, 9 Nov 2018 16:18:30 +0100

Hi Alice,

Thanks for bringing this up. Maybe we can add a slide to the Newcomers
tutorial with some more concrete suggestions:
 "What you can do *before* going to the IETF meeting"

At the moment we might focus a bit much on what to expect when you get
there (which is also important of course).

I am curious to hear what else was mentioned in the Newcomers feedback
session.

Mirjam

On 08/11/2018 03:34, Alice Russo wrote:
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>

---

From: Alice Russo <[email-masked]>
Date: Mon, 26 Nov 2018 07:45:37 -0800

Hi Fred, Mirjam,

Thanks for your replies. 

Fred, I see your point; thanks for this explanation.

Mirjam wrote:
> Maybe we can add a slide to the Newcomers

Perhaps it's already covered in the pre-meeting webinar? Along the lines of "Read the drafts that are on the agendas of the WG sessions you plan to attend." (I haven't attended the webinar.)

Thanks,
Alice

---

From: Mirjam Kuehne <[email-masked]>
Date: Tue, 27 Nov 2018 08:32:46 +0100

Hi Alice,

The slides for the webinar are the same we use in the face-to-face
tutorial. And yes, the importance of having read the relevant drafts is
in there. Is there anything else you think attendees could do to prepare
- apart from reading the Tao, studying the agenda, reading relevant drafts?

Kind regards,
Mirjam