Subject: [Emu] GPSK issue - KDF Data

From: "Joseph Salowey \(jsalowey\)" <[email-masked]>
Date: Tue, 3 Oct 2006 15:18:49 -0700

The current GPSK draft includes the capability for the client and server
to combine data into the KDF.  This is currently incompletely described
in the GPSK draft.  The question has been raised as to whether we need
this functionality.  Unless there is a reason to support this it should
be removed from the specification.  Is there a good reason to keep this?

Thanks,

Joe

_______________________________________________
Emu mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/emu

---

From: "Bernard Aboba" <[email-masked]>
Date: Tue, 03 Oct 2006 22:38:52 -0700

Can you be a bit more specific?  Are you talking about mixing of client and 
server nonces or something else?

>From: "Joseph Salowey (jsalowey)" <[email-masked]>
>To: <[email-masked]>
>Subject: [Emu] GPSK issue - KDF Data
>Date: Tue, 3 Oct 2006 15:18:49 -0700
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 04 Oct 2006 11:41:34 +0200

Hi Joe,

this refers to issue#3:

http://www.tschofenig.com:8080/eap-gpsk/issue3

I personally think we should remove it.

Ciao
Hannes

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 04 Oct 2006 11:47:30 +0200

Hi Bernard,

this aspect refers to the ability to put arbitrary data exchanged 
between the end points into the key derivation function.

It is therefore not about the nonces, identities etc. that is typically 
incorporated into the key derivation function.

Why would someone want todo this? I don't think it is useful.

Ciao
Hannes

Bernard Aboba schrieb:
> Can you be a bit more specific?  Are you talking about mixing of client 
> and server nonces or something else?
> 
>

---

From: "Bernard Aboba" <[email-masked]>
Date: Wed, 04 Oct 2006 10:00:00 -0700

>this aspect refers to the ability to put arbitrary data exchanged between 
>the end points into the key derivation function.
>

Channel Bindings?

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 04 Oct 2006 19:29:17 +0200

For channel bindings you don't need to incorporate something into the 
KDF. Checking whether the identities seen by the three parties is enough.

Ciao
Hannes

PS: Btw, what is the status of the channel binding work? Totally stalled?

Bernard Aboba schrieb:
>> It is therefore not about the nonces, identities etc. that is 
>> typically incorporated into the key derivation function.
>>

---

From: Lakshminath Dondeti <[email-masked]>
Date: Wed, 04 Oct 2006 11:01:39 -0700

Agree with Hannes on this.

Lakshminath

At 10:29 AM 10/4/2006, Hannes Tschofenig wrote:
>For channel bindings you don't need to incorporate something into 
>the KDF. Checking whether the identities seen by the three parties is enough.
>
>Ciao
>Hannes
>

---

From: Charles Clancy <[email-masked]>
Date: Thu, 05 Oct 2006 21:17:47 -0400

It was originally added for channel binding purposes, for those in the 
"add stuff to the KDF" camp of channel bindings.  I'm personally not all 
that attached to it, so if the consensus is to remove it, that's fine 
with me.

-- 
t. charles clancy, ph.d.  |  [email-masked]  |  www.cs.umd.edu/~clancy