Subject: [Emu] Consensus call on EAP-GPSK key lengths

From: Alan DeKok <[email-masked]>
Date: Tue, 05 Aug 2008 12:09:49 +0200

The current draft assumes that key lengths for MAC are the same as the
MAC output length, and states this as a constraint.  The counter-example
is AES-CMAC-256, which has a 256 bit key for AES, and a 128 bit output.

  The question for the WG is whether or not this is relevant.  The feel
of the room at IETF was that the lengths should be independent.  We are
looking for WG consensus on this issue.

  Please respond FOR or AGAINST making the input and output lengths
independent.  This consensus call will last until August 19.

  Alan DeKok.

_______________________________________________
Emu mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/emu

---

From: Stefan Winter <[email-masked]>
Date: Tue, 05 Aug 2008 14:00:12 +0200

Hi,

> independent.  This consensus call will last until August 19.

I vote FOR independence.

Stefan Winter

-- 
Stefan WINTER
Ingenieur de Recherche
Fondation RESTENA - Réseau Téléinformatique de l'Education Nationale et de la Recherche
6, rue Richard Coudenhove-Kalergi
L-1359 Luxembourg

Tel: +352 424409 1
Fax: +352 422473

---

From: David McGrew <[email-masked]>
Date: Tue, 5 Aug 2008 08:50:40 -0700

Hi Alan,

I vote FOR independent lengths, because it will promote algorithm  
agility.

David

---

From: "Stephen Hanna" <[email-masked]>
Date: Tue, 5 Aug 2008 12:35:31 -0400

I also vote FOR independent lengths.

Thanks,

Steve 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of David McGrew
> Sent: Tuesday, August 05, 2008 11:51 AM
> To: Alan DeKok
> Cc: [email-masked]
> Subject: Re: [Emu] Consensus call on EAP-GPSK key lengths
> 
> Hi Alan,
> 
> I vote FOR independent lengths, because it will promote 
> algorithm agility.
> 
> David
> 
> >  The current draft assumes that key lengths for MAC are the same as 
> > the MAC output length, and states this as a constraint.  
> The counter- 
> > example is AES-CMAC-256, which has a 256 bit key for AES, and a 128 
> > bit output.
> >
> > of the room at IETF was that the lengths should be independent.  We 
> > are looking for WG consensus on this issue.
> >

---

From: "Dan Harkins" <[email-masked]>
Date: Wed, 6 Aug 2008 08:29:35 -0700 (PDT)

I vote FOR independent input and output lengths (and algorithm agility).

  Dan.

---

From: "Glen Zorn" <[email-masked]>
Date: Fri, 8 Aug 2008 11:19:19 +0700

Alan DeKok <mailto://[email-masked]> writes:

...

> independent.  This consensus call will last until August 19.

FOR

...

---

From: "Katrin Höper" <[email-masked]>
Date: Mon, 11 Aug 2008 10:41:55 -0400

I also vote for independent lengths to support crypto agility.

Katrin

---

From: "Gene Chang (genchang)" <[email-masked]>
Date: Mon, 11 Aug 2008 11:14:11 -0400

----------------------------------------------------------------------------
Eugene Chang (genchang)
Cisco Systems

Office:   603-559-2978
Mobile:  781-799-0233

Skype:  gene02421

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of Katrin Höper
Sent: Monday, August 11, 2008 10:42 AM
To: Glen Zorn
Cc: [email-masked]
Subject: Re: [Emu] Consensus call on EAP-GPSK key lengths

Katrin

...

FOR

...

---

From: Klaas Wierenga <[email-masked]>
Date: Mon, 11 Aug 2008 17:15:13 +0200

FOR

---

From: [email-masked]
Date: Mon, 11 Aug 2008 18:46:26 +0200 (CEST)

I am FOR

Best regards
Badra