Subject: Re: [Emu] Suggestion: draft-arkko-eap-aka-kdf-09

From: "yogendra pal" <[email-masked]>
Date: Mon, 5 Jan 2009 12:37:04 +0530

Russ, Could you let us know whether we can include the these test
vectors or not ?

Thanks
Yogendra

On Sun, Dec 21, 2008 at 1:57 AM, Jari Arkko <[email-masked]> wrote:
> Wonderful. Are we ready to include these values in an appendix of the RFC?
> Russ, would you mind if we do that?
>
> Jari
>
> Jouni Malinen wrote:
>>
>> On Sat, Dec 20, 2008 at 06:05:41PM +0530, yogendra pal wrote:
>>
>>
>>>
>>> I hope Jouni can test the case-2, case-3, case-4 with his
>>> implementation for further verification.
>>>
>>
>> I can confirm that I get the same key derivation results (IK', CK',
>> K_encr, K_aut, K_re, MSK, EMSK) for these cases.
>>
>>
>
>
_______________________________________________
Emu mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/emu

---

From: Russ Housley <[email-masked]>
Date: Mon, 05 Jan 2009 11:42:33 -0500

I like test vectors that have two independent implementations.  That 
seems to be the case here, so please proceed.

Russ

---

From: "yogendra pal" <[email-masked]>
Date: Mon, 19 Jan 2009 10:38:27 +0530

Jari,

Case-3, and Case-4 of test vectors for EAP-AKA'  provided by me
w.r.t draft-eap-aka-kdf-XX.txt lacks the SQN and long term secret
as pointed by Jari.

I have option for Jari to either replace the {case-3, case-4}  with
{case-5, case-6}. (see below for case-5,6) . Since I don't have the
SQN and the long term secret for case-3, case-4. However, I have
case-5, case-6 for which I have all the details which you needed
and explained similar to case-1,case-2.

I have tested cases 5 and 6 with in full authentication mode w.r.t
draft.

I have used the 3GPP TS 35.208 v6.0.0 4.3.20 Test Set 19 for
generating these test vectors.

See below case-5 and case-6 details:

Common items for {case-5, case-6}
===========================

Test USIM with parameters from 3GPP TS 35.208 v6.0.0 4.3.20
Test Set 19 (Milenage):

IMSI="555444333222111"
Ki=5122250214c33e723a5dd523fc145fc0
OPc=981d464c7c52eb6e5036234984ad0bcf
AMF=c3ab

Identity: "0555444333222111"
RAND=0x81e92b6c0ee0e12ebceba8d92a99dfa5
AUTN=0xbb52e91c747ac3ab2a5c23d15ee351d5
IK=0x9744871ad32bf9bbd1dd5ce54e3e2e5a
CK=0x5349fbe098649f948f5d2e973a81c00f
RES=0x28d7b0f2a2ec3de5

SQN=0x16f3b3f70fc2
AK=0xada15aeb7bb8

Case-5: Identity: "0555444333222111"  and
       Access network identity as  "WLAN"
       RAND=0x81e92b6c0ee0e12ebceba8d92a99dfa5
       AUTN=0xbb52e91c747ac3ab2a5c23d15ee351d5
       IK=0x9744871ad32bf9bbd1dd5ce54e3e2e5a
       CK=0x5349fbe098649f948f5d2e973a81c00f
       RES=0x28d7b0f2a2ec3de5

       Based on the 33402_CR0033_(Rel-8)_S3-081100 revised
       S3-081071 PCR 33402 Annex A KDF.doc

       CK' generated as:
       00000000: 0093 962d 0dd8 4aa5 684b 045c 9edf fa04  ...-..J.hK.\....

       IK' generated as:
       00000000: ccfc 230c a74f cc96 c0a5 d611 64f5 a76c  ..#..O......d..l

       MK = PRF'(IK'|CK',"EAP-AKA'"|Identity) generated and the
       keys are as follows:

       K_encr:
         00000000: 766f a0a6 c317 174b 812d 52fb cd11 a179  vo.....K.-R....y

       K_aut:
         00000000: 0842 ea72 2ff6 835b fa20 3249 9fc3 ec23  .B.r/..[. 2I...#
         00000010: c2f0 e388 b4f0 7543 ffc6 77f1 696d 71ea  ......uC..w.imq.

       K_re:
         00000000: cf83 aa8b c7e0 aced 892a cc98 e76a 9b20  .........*...j.
         00000010: 95b5 58c7 795c 7094 715c b339 3aa7 d17a  ..X.y\p.q\.9:..z

       MSK:
         00000000: 67c4 2d9a a56c 1b79 e295 e345 9fc3 d187  g.-..l.y...E....
         00000010: d42b e0bf 818d 3070 e362 c5e9 67a4 d544  .+....0p.b..g..D
         00000020: e8ec fe19 358a b303 9aff 03b7 c930 588c  ....5........0X.
         00000030: 055b abee 58a0 2650 b067 ec4e 9347 c75a  .[..X.&P.g.N.G.Z

       EMSK:
         00000000: f861 703c d775 590e 16c7 679e a387 4ada  .ap<.uY...g...J.
         00000010: 8663 11de 2907 64d7 60cf 76df 647e a01c  .c..).d.`.v.d~..
         00000020: 313f 6992 4bdd 7650 ca9b ac14 1ea0 75c4  1?i.K.vP......u.
         00000030: ef9e 8029 c0e2 90cd bad5 638b 63bc 23fb  ...)......c.c.#.

Case-6: Identity: "0555444333222111"  and
       Access network identity as  "HRPD"
       RAND=0x81e92b6c0ee0e12ebceba8d92a99dfa5
       AUTN=0xbb52e91c747ac3ab2a5c23d15ee351d5
       IK=0x9744871ad32bf9bbd1dd5ce54e3e2e5a
       CK=0x5349fbe098649f948f5d2e973a81c00f
       RES=0x28d7b0f2a2ec3de5

       Based on the 33402_CR0033_(Rel-8)_S3-081100 revised
       S3-081071 PCR 33402 Annex A KDF.doc

       CK' generated as:
       00000000: 3820 f027 7fa5 f777 32b1 fb1d 90c1 a0da  8 .'...w2.......

       IK' generated as:
       00000000: db94 a0ab 557e f6c9 ab48 619c a05b 9a9f  ....U~...Ha..[..

       MK = PRF'(IK'|CK',"EAP-AKA'"|Identity) generated and the
       keys are as follows:

       K_encr:
         00000000: 05ad 73ac 915f ce89 ac77 e152 0d82 187b  ..s.._...w.R...{

       K_aut:
         00000000: 5b4a caef 62c6 ebb8 882b 2f3d 534c 4b35  [J..b....+/=SLK5
         00000010: 2773 37a0 0184 f20f f25d 224c 04be 2afd  's7......]"L..*.

       K_re:
         00000000: 3f90 bf5c 6e5e f325 ff04 eb5e f653 9fa8  ?..\n^.%...^.S..
         00000010: cca8 3981 94fb d00b e425 b3f4 0dba 10ac  ..9......%......

       MSK:
         00000000: 87b3 2157 0117 cd6c 95ab 6c43 6fb5 073f  ..!W...l..lCo..?
         00000010: f15c f855 05d2 bc5b b735 5fc2 1ea8 a757  .\.U...[.5_....W
         00000020: 57e8 f86a 2b13 8002 e057 5291 3bb4 3b82  W..j+....WR.;.;.
         00000030: f868 a961 17e9 1a2d 95f5 2667 7d57 2900  .h.a...-..&g}W).

       EMSK:
         00000000: c891 d5f2 0f14 8a10 0755 3e2d ea55 5c9c  .........U>-.U\.
         00000010: b672 e967 5f4a 66b4 bafa 0273 79f9 3aee  .r.g_Jf....sy.:.
         00000020: 539a 5979 d0a0 042b 9d2a e28b ed3b 17a3  S.Yy...+.*...;..
         00000030: 1dc8 ab75 072b 80bd 0c1d a612 466e 402c  ...u.+......Fn@,

Moreover, I appreciate you thought of providing everything from the basics.

See below the 3GPP TS 35.208 v6.0.0 4.3.20 Test Set 19 and Test Set 20 values:

4.3.19 Test Set 19
Variable Value
K 51222502 14c33e72 3a5dd523 fc145fc0
RAND 81e92b6c 0ee0e12e bceba8d9 2a99dfa5
SQN 16f3b3f7 0fc2
AMF c3ab
OP c9e87632 86b5b9ff bdf56e12 97d0887b
OPC 981d464c 7c52eb6e 50362349 84ad0bcf
f1 2a5c23d1 5ee351d5
f1* 62dae385 3f3af9d2
f2 28d7b0f2 a2ec3de5
f5 ada15aeb 7bb8
f3 5349fbe0 98649f94 8f5d2e97 3a81c00f
f4 9744871a d32bf9bb d1dd5ce5 4e3e2e5a
f5* d461bc15 475d

Test Set 20 is used for Case-1 and Case-2
4.3.20 Test Set 20
Variable Value
K 90dca4ed a45b53cf 0f12d7c9 c3bc6a89
RAND 9fddc720 92c6ad03 6b6e4647 89315b78
SQN 20f813bd 4141
AMF 61df
OP 3ffcfe5b 7b111158 9920d352 8e84e655
OPC cb9cccc4 b9258e6d ca476037 9fb82581
f1 09db94ea b4f8149e
f1* a29468aa 9775b527
f2 a95100e2 760952cd
f5 83cfd54d b913
f3 b5f2da03 883b69f9 6bf52e02 9ed9ac45
f4 b4721368 bc16ea67 875c5598 688bb0ef
f5* 4f203939 2ddc

I think jari you can incorporate them in the "Appendix C" of your latest
draft version.

Jari do you need any other details or it is adequate for updating the
Appendix C ?

Regards
Yogendra

On Mon, Jan 5, 2009 at 10:12 PM, Russ Housley <[email-masked]> wrote:
> I like test vectors that have two independent implementations.  That seems
> to be the case here, so please proceed.
>
> Russ
>