Subject: [Emu] Issue #15: Algorithm agility and certs

From: "Joseph Salowey (jsalowey)" <[email-masked]>
Date: Thu, 6 Aug 2009 12:15:47 -0700

Issue:

Sec. 4.1.1 has requirements on algorithm agility. They are important,
but insufficient. I propose to mention that when the tunnel method uses
certificates, it MUST be possible to migrate to new algorithms for such
certificates as well. (This possibly belongs in 4.2.1). 

Comment:

 Proposed Text in section 4.1.1:

 " The tunnel method MUST NOT be tied to any single cryptographic
    algorithm.  Instead, it MUST support run-time negotiation to select
    among an extensible set of cryptographic algorithms.  This includes
algorithms used with certificates presented during tunnel establishment.
 ..."

--
Ticket URL: <http://trac.tools.ietf.org/wg/emu/trac/ticket/15#comment:1>
emu <http://tools.ietf.org/wg/emu/>

---

From: Yaron Sheffer <[email-masked]>
Date: Thu, 6 Aug 2009 23:26:16 +0300

I'm fine with this text.

Thanks,
	Yaron

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Joseph Salowey (jsalowey)
> Sent: Thursday, August 06, 2009 22:16
> To: [email-masked]
> Subject: [Emu] Issue #15: Algorithm agility and certs
> 
> 
> Issue:
> 
> _______________________________________________
> Emu mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/emu
> 
> Scanned by Check Point Total Security Gateway.