Subject: [Emu] Issue #21: Mandatory Vs. Optional

From: "Joseph Salowey (jsalowey)" <[email-masked]>
Date: Thu, 6 Aug 2009 13:05:48 -0700

#21: Mandatory Vs. Optional

 > Section 4.3.3
 >
 > "   The payload MUST support marking of mandatory and optional
 >    attributes, as well as an attribute used for rejecting mandatory
 >    attributes."
 >
 > Why is it necessary for mandatory and optional attributes to
 > be explicitly marked?  Is it be sufficient for the attributes
 > to be divided into standardized and vendor-specific spaces,
 > with the latter optional?
 >

-- 
Ticket URL: <http://wiki.tools.ietf.org/wg/emu/trac/ticket/21>
emu <http://tools.ietf.org/wg/emu/>

---

From: Yaron Sheffer <[email-masked]>
Date: Thu, 6 Aug 2009 23:52:26 +0300

I support the current text. Having explicit marking for mandatory attributes
(a "Critical bit") adds power to protocol extensions, in that you can ensure
that negotiation will fail if the other side doesn't understand you.

Thanks,
	Yaron

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Joseph Salowey (jsalowey)
> Sent: Thursday, August 06, 2009 23:06
> To: [email-masked]
> Subject: [Emu] Issue #21: Mandatory Vs. Optional
> 
> 
> _______________________________________________
> Emu mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/emu
> 
> Scanned by Check Point Total Security Gateway.

---

From: Stephen Hanna <[email-masked]>
Date: Thu, 6 Aug 2009 17:06:10 -0400

I agree with Yaron. Being able to define optional IETF standard
attributes is also useful since you sometimes DON'T want to fail
the negotiation if the other side doesn't understand the extension.
So optional/mandatory is orthogonal to standard/vendor-defined.

Thanks,

Steve

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Yaron Sheffer
> Sent: Thursday, August 06, 2009 4:52 PM
> To: Joseph Salowey (jsalowey); [email-masked]
> Subject: Re: [Emu] Issue #21: Mandatory Vs. Optional
>