Subject: [Emu] TLV type layout

From: "Dan Harkins" <[email-masked]>
Date: Tue, 23 Aug 2011 13:03:53 -0700 (PDT)

Hello,

  I noticed that the initial registry for TLV types starts out with
three reserved numbers which is pretty odd. It says in the IANA
Considerations (similar verbage is in the General TLV Format of
section 4.2.1):

       A summary of the EAP-FAST TLV types is given below:

             0  Reserved
             1  Reserved
             2  Reserved
             3  Result TLV
             4  NAK TLV
             5  Error TLV
          et cetera

Since this is the initial layout of a new registry it doesn't serve
a purpose to have 1 and 2 "reserved". Zero I can understand, but not
1 and 2.

  I propose this get changed to move everything from 3 on up by 2 so
"Result TLV" becomes 1, "NAK TLV" becomes 2, et cetera.

  regards,

  Dan.

---

From: Glen Zorn <[email-masked]>
Date: Thu, 25 Aug 2011 13:02:11 +0700

On 8/24/2011 3:03 AM, Dan Harkins wrote:
> a purpose to have 1 and 2 "reserved". Zero I can understand, 

Can you explain it to me, because I don't ;-).  All numbers except those
specifically assigned are by definition reserved, right?

> but not

I would prefer to start at 0.

> 
>   regards,
> 
>   Dan.
> 
> 
> _______________________________________________
> Emu mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/emu

---

From: "Dan Harkins" <[email-masked]>
Date: Thu, 25 Aug 2011 14:25:04 -0700 (PDT)

> specifically assigned are by definition reserved, right?

  That's a general convention. And zero is generally more special than
the other numbers because it's in a class by itself (zero) whereas all
there numbers are in the same class (non-zero).

> I would prefer to start at 0.

  I would be perfectly happy with starting at 0. I'm just not happy
starting at 3.

  Dan.