Subject: [Entmib] Entity State MIB Status

From: "Sharon Chisholm" <[email-masked]>
Date: Thu, 22 Jul 2004 09:31:54 -0400

hi

Ok. I just finished doing the math and while I was able to move a number of
the issues to resolved, the following issues had either small portions of
the proposed edit that I missed in -04 or had small bits where I want to
double check something before closing.

 307 'notSupported' is semantically wrong 
	- This has been changed to 'unavailable'. Some people had wanted
'unknown'. Should
		I have changed this to unknown?

 311 DateAndTimeOrZero   
	- Didn't really have proposed resolution or rather we had a couple
comments after 
		the proposed resolution

 322 Textual Convention Names (Prefix) 
	- I just missed the prefix during the edit. It is in a separate
module though.
	- I will update with an 'Entity' prefix

 325  <MIB OID values>
	- I thought I made this change, but apparently didn't. I will make
it.
  
 333 Relationship with Alarm MIB open entity-state
	- The open bit of this is whether the Alarm MIB should be a
normative or 
		informative reference. I think it's a bit of a grey area so
propose leaving
	      it where it is for now.

 334 Table, Index Descriptions open entity-state
	- I think the changes reflect what people were looking for, but I
wasn't sure. 

 354 More Editorial Changes (2)  
	- I'm not sure what is wrong with the term 'reports' so I can't
suggest a 
		replacement
      - We haven't yet discussed this one, but adding X.731 to the Reference
clause was 
	 a previous editing instruction based either on consensus or a
suggestion from the
	area director - I forget which. I propose keeping it.

Sharon Chisholm
Portfolio Integration
Nortel Networks
Ottawa, Canada

_______________________________________________
Entmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/entmib

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 22 Jul 2004 13:08:07 -0700

Hi -

> From: "Sharon Chisholm" <[email-masked]>
> To: <[email-masked]>
> Sent: Thursday, July 22, 2004 6:31 AM
> Subject: [Entmib] Entity State MIB Status
...
> I have changed this to unknown?

Part of the difficulty in naming this one is that it seems to be doing
triple-duty for notApplicable as well as notSupported and notAvailable.
It's unclear whether the distinction would actually be useful, so as long
as everyone agrees that "unavailable" includes these cases, I'd be happy.

> - Didn't really have proposed resolution or rather we had a couple
...

Since DateAndTime is already used this way (and has been for a long time)
I don't see the value of adding a new TC.  However, it might make sense
to see if we could agree on an erratum for RFC 2579.

Randy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 23 Jul 2004 02:04:31 +0200

> as everyone agrees that "unavailable" includes these cases, I'd be happy.

So "unknown" would IMHO be the better choice as it is clearly vague.
 
> to see if we could agree on an erratum for RFC 2579.

I agree. See my statement to this effect from Mon, 22 Mar 2004 22:31:31
+0100. If nobody objects, I will submit an errata with the following 
simple change:

OLD:
              2       3    month                     1..12
              3       4    day                       1..31

NEW:
              2       3    month                     0..12
              3       4    day                       0..31

For those interested: '0000000000000000'H appears 58 times in the set
of published IETF MIB modules. So there is some clear evidence that 
this "zero" value has been used before without introducing a new TC.

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 22 Jul 2004 19:38:23 -0700

Hi -

> From: "Juergen Schoenwaelder" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Thursday, July 22, 2004 5:04 PM
> Subject: Re: [Entmib] Entity State MIB Status
...
...

It might be worthwhile to also add some text that explains that 0 is used
in the month and day fields in conjunction with sentinel values, whose
exact semantics are specific to usages of the TC.

Randy