Subject: RE: [Entmib] Entity State MIB Status - DateAndTime Erratum

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Fri, 23 Jul 2004 14:28:08 +0200

Why don't you send me the exact text for the erratum and I will 
feel the waters with IESG. 

Thanks,
Bert 

> -----Original Message-----
> From: Juergen Schoenwaelder [mailto:[email-masked]]
> Sent: vrijdag 23 juli 2004 14:00
> To: Wijnen, Bert (Bert)
> Cc: Randy Presuhn; [email-masked]
> Subject: Re: [Entmib] Entity State MIB Status - DateAndTime Erratum
> 
> 
> On Fri, Jul 23, 2004 at 11:45:33AM +0200, Wijnen, Bert (Bert) wrote:
> 
> > I can agree with the erratum submission.
> 
> > However, this is not something we should just decide on the 
> EntMIB mailing
> > list or WG. It is wider. And it does change the spec. So 
> I'd like to at
> > least have IESG approval. The risk is that they may suggest 
> a 4 week IETF
> > Last Call to make sure we have IETF consensus. After all it 
> is a change
> > (in my view a well justified, accaptable, and apparently 
> used in practice)
> > to a full STD document.
> 
> So tell me what the procedure is to make it happen and then I 
> will make
> up a calculation how much of my time it will cost and then I 
> will decide
> whether I engage in this or just let things continue the way they are.
> 
> [It the costs of getting this erratum in place is close to publishing
>  an RFC on this subject, then I might conclude that other things are 
>  more important.]
> 
> /js
> 
> -- 
> Juergen Schoenwaelder		    International University Bremen
> <http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 
> 28725 Bremen, Germany
> 

_______________________________________________
Entmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/entmib

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 23 Jul 2004 18:54:10 +0200

> feel the waters with IESG. 

The DateAndTime TC does not define a special value which can be used
in situations where a DateAndTime value is unknown and for some other
reason not available. Several standards-track MIB modules use the
value '0000000000000000'H in such situations. In order to formally
legalize this established practice, the following errata to the
DESCRIPTION clause of the DateAndTime TC is proposed:

OLD:
              2       3    month                     1..12
              3       4    day                       1..31

NEW:
              2       3    month                 0 | 1..12
              3       4    day                   0 | 1..31

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 23 Jul 2004 19:43:06 +0200

> feel the waters with IESG. 

Here is version 1.1 with a bug fix applied:

in situations where a DateAndTime value is unknown or for some other

OLD:
              2       3    month                     1..12
              3       4    day                       1..31

NEW:
              2       3    month                 0 | 1..12
              3       4    day                   0 | 1..31

/js