Subject: Re: [Extra] I-D Action: draft-ietf-extra-sieve-special-use-01.txt

From: Stephan Bosch <[email-masked]>
Date: Thu, 8 Feb 2018 21:57:31 +0100

Op 1/17/2018 om 12:14 AM schreef Stephan Bosch:
> I hope I have time make a new version by the end of this week. We'll see. 

All is taking a bit longer. Addressed one point so far (see Git).

Regards,

-- 
Stephan Bosch
Senior Developer 

Phone: +49 2761 75252 00  Fax: +49 2761 75252 30
Email: [email-masked]

-------------------------------------------------------------------------------------
Open-Xchange AG,  Rollnerstr. 14, 90408 Nuremberg, District Court Nuremberg HRB 24738
Managing Board: Rafael Laguna de la Vera, Carsten Dirks, Michael Knapstein 
Chairman of the Board: Richard Seibt

Dovecot Oy, Lars Sonckin Kaari 10, 02600 Espoo, Finland
Managing Director: Markku Kentta
Chairman of the Board: Timo Sirainen
Board Member: Carsten Dirks

-------------------------------------------------------------------------------------

---

From: Stephan Bosch <[email-masked]>
Date: Thu, 15 Feb 2018 23:30:00 +0100

Op 1/17/2018 om 12:14 AM schreef Stephan Bosch:
> Hi Ned,
>
> Op 1/9/2018 om 10:44 PM schreef Ned Freed:

Slowly making progress on this one.

I just gave the point below a fresh look:

>>>> The other aspect of the many-many mapping is the fact that a single mailbox can
>>>> have multiple special use attributes. The draft supports this in the context of
>>>> specialuse_exists but not in the context of fileinto. I think this is fine, but
>>>> I want to make sure everyone is happy with this limitation, including the fact
>>>> that because of this you won't be able to create mailbox with fileinto with
>>>> multiple special use attributes.
>>> Good point. For sake of discussion, let's assume we allow a string list
>>> for the :specialuse parameter. The semantics for creation of a mailbox
>>> would be quite clear: all of those flags are assigned to the new
>>> mailbox.
>> Seems reasonable.
>>
>>> But what would that mean for the mailbox lookup? Are we looking
>>> for a mailbox that has all of these flags, one of these flags or just
>>> the first flag listed?
>> The convention elsewhere seems pretty clearly to be for it to be an AND rather
>> than an OR.
> I agree.
>
>>> Another question is whether mailboxes with several special-use flags are
>>> really that useful.
>> Apart from \All, which I would hope is not up to clients to set, I don't see
>> them as being useful. But I may be missing some use cases, which is why I 
>> brought it up.
> Ok.

Now my question to everyone is: do I need to change anything or is the
fileinto limitation acceptable?

Regards,

-- 
Stephan Bosch
Senior Developer