Subject: [Extra] Revised draft: UNAUTHENTICATE

From: "Chris Newman" <[email-masked]>
Date: Thu, 22 Mar 2018 11:40:50 +0000

I've posted revision 2 of UNAUTHENTICATE:

   https://www.ietf.org/id/draft-newman-imap-unauth-02.txt

This has no changes from revision 1. During the EXTRA face to face 
meeting, I asked for this to be adopted by the WG and there were no 
objections in the room. Two independent server implementations were 
noted in the room.

I'm not presently aware of any open issues with the proposal.

		- Chris

---

From: Ned Freed <[email-masked]>
Date: Thu, 22 Mar 2018 05:14:19 -0700 (PDT)

Do we want to specify a comparable extension for SUBMIT? I can whip up a draft
if we do.

				Ned

> _______________________________________________
> Extra mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/extra

---

From: Sean Leonard <[email-masked]>
Date: Thu, 22 Mar 2018 05:30:57 -0700

Ned,

Sorry but I am not sure what SUBMIT you are referring to. Is this related to IMAP BURL (RFC 4468)? I also found draft-kundrat-imap-submit-02 and draft-ietf-lemonade-submit-01 but they appear to be long-expired.

Sean

> On Mar 22, 2018, at 5:14 AM, Ned Freed <[email-masked]> wrote:
>

---

From: "Chris Newman" <[email-masked]>
Date: Thu, 22 Mar 2018 13:42:13 +0000

For SMTP Submission, I think it would be more useful to standardize 
XCLIENT which should include UNAUTHENTICATE functionality.

		- Chris

---

From: Bron Gondwana <[email-masked]>
Date: Fri, 23 Mar 2018 02:04:45 +1100

I've also worked on a standard for SUBMIT, but I didn't want to open
that can of worms just yet!
Bron.

On Thu, 22 Mar 2018, at 23:14, Ned Freed wrote:
> Do we want to specify a comparable extension for SUBMIT? I can whip
> up a draft> if we do.
> 
> Ned
> 
> 
>> _________________________________________________
>> Extra mailing list
>> [email-masked]
> _________________________________________________
> Extra mailing list
> [email-masked]

--
  Bron Gondwana, CEO, FastMail Pty Ltd
  [email-masked]

---

From: "Chris Newman" <[email-masked]>
Date: Thu, 22 Mar 2018 15:39:49 +0000

> that can of worms just yet!

Ned was probably talking about SMTP Submission (RFC 6409).

Now there's a mature JMAP submission model to copy, an IMAP submission 
extension may be less of a can of worms than you think. Of course it 
does beg the question if JMAP does it do we really need IMAP to do it?

		- Chris

---

From: Bron Gondwana <[email-masked]>
Date: Fri, 23 Mar 2018 02:45:40 +1100

On Fri, 23 Mar 2018, at 02:39, Chris Newman wrote:
>> I've also worked on a standard for SUBMIT, but I didn't want to open>> that can of worms just yet!
> 
> Now there's a mature JMAP submission model to copy, an IMAP submission> extension may be less of a can of worms than you think. Of course it
Yep, hence my happiness to avoid opening that wormfarm right now!

---

From: Ned Freed <[email-masked]>
Date: Thu, 22 Mar 2018 09:10:08 -0700 (PDT)

> Sorry but I am not sure what SUBMIT you are referring to. Is this related to
> IMAP BURL (RFC 4468)? I also found draft-kundrat-imap-submit-02 and
> draft-ietf-lemonade-submit-01 but they appear to be long-expired.

RFC 6409, STD 72.

				Ned