Subject: Re: [Extra] AD review of draft-ietf-extra-specialuse-important-02

From: Neil Jenkins <[email-masked]>
Date: Tue, 01 May 2018 17:11:06 +1000

On Tue, 1 May 2018, at 2:09 PM, Barry Leiba wrote:
> Neil, please make sure that the "not used by JMAP" asterisks are still> accurate with the addition of the three new attributes.

I think Subscribed also needs an asterisk – this is not a concept in
JMAP. Other than that, looks good.
Cheers,
Neil.

---

From: Barry Leiba <[email-masked]>
Date: Tue, 1 May 2018 09:22:47 -0400

>> Neil, please make sure that the "not used by JMAP" asterisks are still
>> accurate with the addition of the three new attributes.
>
> I think Subscribed also needs an asterisk – this is not a concept in JMAP.

How does JMAP handle situations where it's used to access things like
IETF mailing lists or usenet news groups, where there can be tens or
hundreds of thousands of mailboxes, and the user is only interested in
a few of them?

b

---

From: Neil Jenkins <[email-masked]>
Date: Fri, 11 May 2018 01:30:34 -0400

> hundreds of thousands of mailboxes, and the user is only interested in

Sorry for the late reply to this. The answer in the current spec is it was presumed individual clients would keep track of which mailboxes they are interested in. However, we can easily add an isSubscribed: Boolean property to the JMAP Mailbox object, as a direct equivalent to the \Subscribed IMAP attribute, so this can be synchronised between clients. This could then be used with Mailbox/query to just return subscribed mailboxes etc. in much the same was as you can with various LIST options in IMAP. I've created a GitHub issue <https://github.com/jmapio/jmap/issues/204> for this.

This does highlight the slight weirdness of sharing this registry between IMAP and JMAP. The mailbox attributes in IMAP are a mix of things that are analogous to individual properties on the JMAP object (so need to be marked as not relevant), and mailbox roles (which is what we do want to reuse). Hence the need to mark quite a few as not relevant.

Neil.