Subject: [Extra] Opsdir last call review of draft-ietf-extra-imap-status-size-01

From: Linda Dunbar <[email-masked]>
Date: Sun, 13 May 2018 18:57:52 -0700

Reviewer: Linda Dunbar
Review result: Not Ready

Reviewer: Linda Dunbar
Review result: need more complete description

After reading through the document, I find the description is not very clear.
For example:
Section 1 Introduction:
Is the “mailbox” referring to the IMAP client’s mailbox or the server mailbox
where all emails are stored?

Why do Webmail clients need to know the server side mailbox size?

Does the “mailbox size” change overtime?

Thanks. Linda Dunbar

---

From: Bron Gondwana <[email-masked]>
Date: Mon, 14 May 2018 12:20:19 +1000

On Mon, 14 May 2018, at 11:57, Linda Dunbar wrote:
> After reading through the document, I find the description is not
> very clear.> For example:
> Section 1 Introduction:
> Is the “mailbox” referring to the IMAP client’s mailbox or the
> server mailbox> where all emails are stored?
> 
> 

Thanks Linda.  I admit that none of these questions occurred to me,
clearly I'm too embedded in the IMAP world already, so I would say that
the answers to your questions are:
1) like all STATUS responses, this is the state of the mailbox on
   the server.
2) any clients which don't keep a full copy of the IMAP mailbox may
   still wish to be able to quickly identify the mailboxes using the
   most amount of storage - for example to allow the the user to remove
   large messages when they are approaching their storage quota.
3) as defined in this document, "mailbox size" is based on the storage
   used by the messages in the mailbox, so it will naturally change if
   the set of messages in the mailbox change, either through adding new
   messages, or expunging existing messages.
I will send this back to the author and request clarifying language be
added to address these three questions.
Regards,

Bron.

--
  Bron Gondwana, CEO, FastMail Pty Ltd
  [email-masked]

---

From: Bron Gondwana <[email-masked]>
Date: Mon, 14 May 2018 12:22:52 +1000

> added to address these three questions.
Tracking as https://github.com/ietfextra/tracking/issues/31

---

From: Stephan Bosch <[email-masked]>
Date: Mon, 14 May 2018 16:03:05 +0200

Op 14-5-2018 om 4:22 schreef Bron Gondwana:
>
>> I will send this back to the author and request clarifying language 
>> be added to address these three questions.
>

Ok, will do that in the next few days.

Regards,

Stephan.

-- 

Stephan Bosch
Senior Developer

Phone: +49 2761 75252 00  Fax: +49 2761 75252 30
Email: [email-masked]

-------------------------------------------------------------------------------------
Open-Xchange AG,  Rollnerstr. 14, 90408 Nuremberg, District Court Nuremberg HRB 24738
Managing Board: Rafael Laguna de la Vera, Carsten Dirks, Uwe Reumuth
Chairman of the Board: Richard Seibt

Dovecot Oy, Lars Sonckin Kaari 10, 02600 Espoo, Finland
Managing Director: Markku Kenttä
Chairman of the Board: Timo Sirainen
Board Member: Carsten Dirks

-------------------------------------------------------------------------------------

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 14 May 2018 15:33:31 +0100

Hi Linda,

On 14/05/2018 03:20, Bron Gondwana wrote:

>> very clear.
> clearly I'm too embedded in the IMAP world already, so I would say 
> that the answers to your questions are:
>
> 1) like all STATUS responses, this is the state of the mailbox on the 
> server.

There might be some terminology issue here. The term "mailbox" has a 
special meaning in IMAP. It is also frequently called "folder" in other 
context. An IMAP user has at least one mailbox called "INBOX" (where 
mail arrives), but will typically have multiple other mailboxes, like 
"Trash", "Sent", "Drafts", as well as the one explicitly created by the 
user.
An IMAP client is only caching a representation of server's state. So 
this extension is concerned with server state only.

> still wish to be able to quickly identify the mailboxes using the most 
> amount of storage - for example to allow the the user to remove large 
> messages when they are approaching their storage quota.

Right. Many clients are able to show quota, but when they need to 
calculate how much of the quota is used, they need to calculate mailbox 
size. That is what this extension provides.

---

From: Barry Leiba <[email-masked]>
Date: Mon, 14 May 2018 12:00:19 -0400

> Thanks Linda.  I admit that none of these questions occurred to me, clearly
> I'm too embedded in the IMAP world already, so I would say that the answers
> to your questions are:
>
> 2) any clients which don't keep a full copy of the IMAP mailbox may still
> wish to be able to quickly identify the mailboxes using the most amount of
> storage - for example to allow the the user to remove large messages when
> they are approaching their storage quota.
>
> 3) as defined in this document, "mailbox size" is based on the storage used
> by the messages in the mailbox, so it will naturally change if the set of
> messages in the mailbox change, either through adding new messages, or
> expunging existing messages.
>
> I will send this back to the author and request clarifying language be added
> to address these three questions.

Really?  I don't think there's anything the author needs to do: all of
this is clear to people familiar with the relevant IMAP specs, and
people implementing this have to be familiar with the relevant IMAP
specs.

It doesn't hurt to have a look and see whether there are reasonable
clarifications to make, but I don't think we should spend too much
time on that for these issues.

Barry