Subject: [Extra] imap4rev2: STATUS DELETED

From: "Bron Gondwana" <[email-masked]>
Date: Thu, 08 Nov 2018 06:30:39 -0500

This is one of the open issues from imap4rev2 - which extensions should be part of the mandatory baseline. 
 
This was a discussion about a way to easily see if there are messages with \Deleted in a mailbox, maybe to see how much quota can be freed up. General agreement in the room was "IMAP4rev2 is for a baseline of existing standards, maybe this should be a new document, but not part of IMAP4rev2" 
 
Discussion on whether we think the general concept is useful, and whether it's so useful we should make it part of IMAP4rev2 in response to this please. 
 
Cheers, 
 
Bron. 
 
-- 
 Bron Gondwana, CEO, FastMail Pty Ltd 
 [email-masked]

---

From: "Chris Newman" <[email-masked]>
Date: Tue, 20 Nov 2018 13:19:36 -0800

On 8 Nov 2018, at 3:30, Bron Gondwana wrote:
> This is one of the open issues from imap4rev2 - which extensions 
> should be part of the mandatory baseline.
>
> This was a discussion about a way to easily see if there are messages 
> with \Deleted in a mailbox, maybe to see how much quota can be freed 
> up. General agreement in the room was "IMAP4rev2 is for a baseline of 
> existing standards, maybe this should be a new document, but not part 
> of IMAP4rev2"
>
> Discussion on whether we think the general concept is useful, and 
> whether it's so useful we should make it part of IMAP4rev2 in response 
> to this please.

We've implemented a custom 'status counts' extension that provides 
counts based on each configured message type including:
  * total, seen, deleted, seen-deleted
the intention of this extension was to help support voicemail and 
similar unified messaging features. We implemented quota & quota-usage 
by message type via a quota root naming convention.

I don't think we should delay IMAP4rev2 to include something like this, 
but I can see it being helpful for some use cases.

		- Chris

---

From: Michael Slusarz <[email-masked]>
Date: Wed, 21 Nov 2018 11:24:42 -0700 (MST)

> On November 20, 2018 at 2:19 PM Chris Newman <[email-masked]> wrote:
> 
> 

Not much support from us on this.  We question its usefulness, as proposed.

Timo pointed out this somewhat related former proposal: https://tools.ietf.org/html/draft-neystadt-imap-status-counters-01

Maybe this makes sense if status checking is more extensible, and not limited to a single attribute?  But it also seems that this kind of solution is not something to cram into rev2 at this stage.

michael