Subject: [Extra] imap4rev2: draft-ietf-extra-imap-replace

From: "Bron Gondwana" <[email-masked]>
Date: Thu, 08 Nov 2018 06:44:17 -0500

This is one of the open issues from imap4rev2 - which extensions should be part of the mandatory baseline. 
 
This one isn't even standard yet, but it's a nice pair with MOVE as a way to avoid running into intermittent issues near QUOTA when you're doing things like editing Drafts, and it's similarly easy to implement on top of existing actions. 
 
Arguments for and against in response to this please. 
 
Cheers, 
 
Bron. 
 
-- 
 Bron Gondwana, CEO, FastMail Pty Ltd 
 [email-masked]

---

From: "Chris Newman" <[email-masked]>
Date: Tue, 20 Nov 2018 13:43:56 -0800

On 8 Nov 2018, at 3:44, Bron Gondwana wrote:
> This is one of the open issues from imap4rev2 - which extensions 
> should be part of the mandatory baseline.
>
> This one isn't even standard yet, but it's a nice pair with MOVE as a 
> way to avoid running into intermittent issues near QUOTA when you're 
> doing things like editing Drafts, and it's similarly easy to implement 
> on top of existing actions.
>

I'm neutral on inclusion of this extension. We've not implemented it 
yet, but it should be straightforward to implement. If enough client 
authors are interested in making use of it, I'd consider implementing 
it.

		- Chris

---

From: Michael Slusarz <[email-masked]>
Date: Wed, 21 Nov 2018 11:52:30 -0700 (MST)

> On November 20, 2018 at 2:43 PM Chris Newman <[email-masked]> wrote:
> 
> 

Neutral/slightly agree on inclusion.

No support yet in Dovecot.

Internally this is tricky for us due to our quota system design, so it's not a straightforward implementation.

michael