Subject: [Extra] imap4rev2: RFC5182 SEARCHRES

From: "Bron Gondwana" <[email-masked]>
Date: Thu, 08 Nov 2018 06:27:56 -0500

This is one of the open issues from imap4rev2 - which extensions should be part of the mandatory baseline. 
 
In favour - it's useful to compose actions. 
 
Against - it's not widely implemented or used. 
 
Arguments for and against in response to this please. 
 
Cheers, 
 
Bron. 
 
-- 
 Bron Gondwana, CEO, FastMail Pty Ltd 
 [email-masked]

---

From: "Chris Newman" <[email-masked]>
Date: Tue, 20 Nov 2018 13:12:07 -0800

We've implemented this extension and it's not difficult to implement on 
the server side so I'm in favor of including this. I'd be interested in 
a client implementer's perspective.

		- Chris

On 8 Nov 2018, at 3:27, Bron Gondwana wrote:

> This is one of the open issues from imap4rev2 - which extensions 
> should be part of the mandatory baseline.
>

> _______________________________________________
> Extra mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_extra&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=K_BObr5Kfkr3rxt1oBPF9KFiEU3xl9LcD2OOJG3TXfI&m=6krI1FgmWhZv2LqblI2h4VuwuAN9JX254RcYg-ZMIGE&s=tOzMc_3golA1EPLg7hmfq0_-klVUFWcd4k9fF17iwwU&e=

---

From: Michael Slusarz <[email-masked]>
Date: Wed, 21 Nov 2018 11:16:37 -0700 (MST)

[FYI: I'll be replying to all of Bron's imap4rev2 messages with the "official" Dovecot response.  Don't worry - the feedback is from people much smarter than me - I'm mainly in charge of being the messenger!]

SEARCHRES is already implemented by Dovecot (has been for awhile).  No objection to including in imap4rev2.

Only question - similar to Chris' - is what the usage is on the client side?  SEARCHRES doesn't seem useful for non-pipelining clients, which is the way the vast majority of IMAP libraries are implemented, at least the ones I have looked at.  e.g. code that programatically calls a search() function, then uses the response from search() and does a fetch() function or whatever.

FWIW, I included a SEARCHRES example in PREVIEW draft in hopes of demonstrating how this extension can be practically useful.  See https://tools.ietf.org/html/draft-ietf-extra-imap-fetch-preview-00#page-8

michael

> On November 20, 2018 at 2:12 PM Chris Newman <[email-masked]> wrote:
> 
> 
>     We've implemented this extension and it's not difficult to implement on the server side so I'm in favor of including this. I'd be interested in a client implementer's perspective.
> 
>     - Chris
> 
>     https://www.ietf.org/mailman/listinfo/extra
>