Subject: [Extra] imap4rev2: RFC8474 OBJECTID

From: "Bron Gondwana" <[email-masked]>
Date: Thu, 08 Nov 2018 06:32:20 -0500

This is one of the open issues from imap4rev2 - which extensions should be part of the mandatory baseline. 
 
In favour - it's very useful for client efficiency, and maps to very popular Gmail extensions. 
 
Against - it's very new, and not widely implemented yet. 
 
Arguments for and against in response to this please. 
 
Cheers, 
 
Bron. 
 
-- 
 Bron Gondwana, CEO, FastMail Pty Ltd 
 [email-masked]

---

From: "Chris Newman" <[email-masked]>
Date: Tue, 20 Nov 2018 13:41:40 -0800

We've implemented an extension equivalent to MAILBOXID already; no 
objections to that part. As THREADID is optional, no objections to that. 
We've not implemented EMAILID yet. I believe FETCH of EMAILID is 
reasonably straightforward, but SEARCH by EMAILID may add significant 
complexity, particularly with respect to search index version migration 
issues. As a result of the latter issue, it will be difficult for us to 
find cycles to implement and test OBJECTID, so I oppose mandatory 
inclusion of OBJECTID in IMAP4rev2.

		- Chris

On 8 Nov 2018, at 3:32, Bron Gondwana wrote:
> This is one of the open issues from imap4rev2 - which extensions 
> should be part of the mandatory baseline.
>

---

From: Michael Slusarz <[email-masked]>
Date: Wed, 21 Nov 2018 11:48:02 -0700 (MST)

> On November 20, 2018 at 2:41 PM Chris Newman <[email-masked]> wrote:
> 

We have the internal support for much of this already - it's just a matter of exposing this via the standard API.

We are working on a project now that essentially requires THREADID for performance reasons, but it's also the hardest to implement since it requires implementation of a thread tracking database to efficiently handle these queries.  I can't think of any other "optional" items in base imap4 at the moment, so this would be a bit of an outlier.

And I would think that we see more use cases for thread based access models going forward, as messaging in general has moved in that direction in the last decade.

But with THREADID being the most interesting part of this, and it being optional, there doesn't seem much difference between having in rev2 or having as an extension since there is no guarantee it will exist either way.  So this seems better left as an extension at this time.

michael