Subject: [Extra] 4rev2. implementation notes for

From: Arnt Gulbrandsen <[email-masked]>
Date: Mon, 22 Jun 2020 15:45:29 +0200

Hi,

4rev2 should contain two lists. One list titled roughly "as server authors, 
check all of these when you update 4rev1 code", the other for client 
authors, and this second would IMO arguably the most important part of this 
document.

Appendix D isn't far from this in substance, but quite different in 
wording.

Agreed? I can suggest wording.

Arnt

---

From: "Bron Gondwana" <[email-masked]>
Date: Tue, 23 Jun 2020 21:34:27 +1000

> Agreed? I can suggest wording.

I had a similar thought about a third list which would be titled something like "interactions with RFC3501 extensions" which lists each of the documents that extend RFC3501 and says things like:

* "is merged in and part of THISRFC"
* "is partially required by THISRFC"
* "works exactly the same as before"
* "works slightly differently in these ways"
* "is not compatible at all, you can't do them together"

I'm happy to help with wording, though it will probably require some workshopping!

Cheers,

Bron.

--
 Bron Gondwana, CEO, Fastmail Pty Ltd
 [email-masked]