Subject: [Extra] 4rev2, PREAUTH

From: Arnt Gulbrandsen <[email-masked]>
Date: Mon, 22 Jun 2020 15:41:29 +0200

Hi,

how about dropping that? It seems to be little used and is presumably 
poorly tested.

Arnt

---

From: Timo Sirainen <[email-masked]>
Date: Mon, 22 Jun 2020 17:12:38 +0300

On 22. Jun 2020, at 16.41, Arnt Gulbrandsen <[email-masked]> wrote:
> 
> Hi,
> 
> how about dropping that? It seems to be little used and is presumably poorly tested.

It's not used much, but I know there are a bunch of people using that with Dovecot. Mutt, Pine and Evolution at least supports it (not sure about Evolution nowadays). I'm also very commonly using it while developing Dovecot, so I think it's pretty well tested in Dovecot at least.

I'm not necessarily against removing it, but I wouldn't say it's entirely useless.

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Tue, 23 Jun 2020 09:46:14 +0200

On second reflection, I don't think PREAUTH can be removed. IMAP4rev2 can 
easily deprecate things from the point where the client enables imap4rev2, 
but PREAUTH is before that point. Deprecation before that point would 
require very good justification.

Arnt

---

From: Lyndon Nerenberg <[email-masked]>
Date: Wed, 24 Jun 2020 08:09:18 -0700

Timo Sirainen writes:

> It's not used much

> I'm not necessarily against removing it, but I wouldn't say it's entirely use

I'll just note that I've used PREAUTH in the past on IMAP servers dedicated
to serving up mailing list archives, and found it quite useful.  Think of it
as the IMAP version of anonymous FTP.

--lyndon