Subject: [Extra] Reverting draft-ietf-extra-imap-fetch-preview to an earlier design

From: "Bron Gondwana" <[email-masked]>
Date: Wed, 24 Jun 2020 16:16:52 +1000

Hi All,

I've been in contact with the authors of draft-ietf-extra-imap-fetch-preview, and they're not happy with the current state. We ended up with something over-complicated.

The suggestion from the interim meeting last week was to pare it right back to a very basic thing - just a single fetch item called PREVIEW which is plain text of up to 255 characters or so, server defined, no fancy algorithms, no nothing else. If we want to add something more complex later, we can always do a separate extension for that.

Value MAY change over time as server algorithms are updated, but it's fine to keep the previous version cached.

*Michael* - do you agree with that characterisation? Everyone in the meeting last week was in favour of doing that. Are you happy to update the wording and submit a new draft?

*Barry* - do we need to bring the document back from "submitted to the IESG" into the working group, or is it OK just to have a new draft submitted? I'm sure we'll review it here either way.

Thanks,

Bron.

--
 Bron Gondwana, CEO, Fastmail Pty Ltd
 [email-masked]

---

From: Barry Leiba <[email-masked]>
Date: Wed, 24 Jun 2020 10:14:18 -0400

I think it's best to bring it back to the working group, so I will do
that.  Because it wasn't in "Approved" state before March it will need
more ballots from the new ADs anyway, and with the changes we're
talking about it should get a new last call anyway.

Barry

On Wed, Jun 24, 2020 at 2:17 AM Bron Gondwana <[email-masked]> wrote:
> Michael - do you agree with that characterisation?  Everyone in the meeting last week was in favour of doing that.  Are you happy to update the wording and submit a new draft?
>
> Barry - do we need to bring the document back from "submitted to the IESG" into the working group, or is it OK just to have a new draft submitted?  I'm sure we'll review it here either way.
>
> Thanks,
>
> Bron.
>
> --

---

From: Michael Slusarz <[email-masked]>
Date: Thu, 25 Jun 2020 17:12:54 -0600 (MDT)

Hi all,

Sorry I was unable to attend the call last week.

>     On 06/24/2020 12:16 AM Bron Gondwana <[email-masked]> wrote:
> 
> 
>     Hi All,
> 
Thanks Bron - you've accurately relayed my thoughts on the current draft (-07).

For Dovecot we've now had something like 3 years of experience with some form of this draft.  Users of this preview functionality care about 1 thing: what does the output look like?  They don't care what that output is - there is no desire to control preview text generation with client-side parameters - just as long as they have a description of the boundaries of what the data will look like.

So agreed that we shouldn't make this overly complicated.  There is a confirmed need/desire for preview generation for FETCH that has a tightly defined data semantics.  If we stick with that narrow scope for now, this is the correct goal.

I'll submit a new draft - my guess is it will look VERY similar to -06 minus the extensibility stuff.

michael