Subject: [Extra] sieve-mailboxid: should specialuse override mailboxid?

From: "Bron Gondwana" <[email-masked]>
Date: Mon, 07 Sep 2020 11:04:52 +1000

Hi All,

This is extracting one point from Barry's review - I'd like feedback on it.

Right now with this case, it will file into the folder F1234567 even if there is a DIFFERENT folder with the specialuse \Archive and this folder does not have that specialuse:

   require "fileinto";
   require "mailboxid";
   require "mailbox";
   require "special-use";

   fileinto :mailboxid "F1234567"
            :specialuse "\\Archive"
            :create
            "INBOX.Archive";
               # creates INBOX.Archive with use \Archive but
               # with a different mailboxid.

Barry proposed that we switch the order, and the specialuse takes priority over the mailboxid.  I am happy to make this change and can see that it makes sense.  Does anybody else have any strong opinions about this?  I will make the change in -04, but if there's more discussion to have then I'm happy to revert it.

Cheers,

Bron.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Rich Hamman <[email-masked]>
Date: Sun, 6 Sep 2020 18:24:45 -0700

Hello  Bron and Barry,

What triggered Barry’s proposal?

Best Regards
Rich

> On Sep 6, 2020, at 6:05 PM, Bron Gondwana <[email-masked]> wrote:
> 
> 
> Hi All,
> 
> _______________________________________________
> Extra mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/extra

---

From: Rich Hamman <[email-masked]>
Date: Sun, 6 Sep 2020 18:28:20 -0700

Never mind, found the discussion, carry on.

> On Sep 6, 2020, at 6:25 PM, Rich Hamman <[email-masked]> wrote:
> 
> Hello  Bron and Barry,
>

---

From: "Bron Gondwana" <[email-masked]>
Date: Mon, 07 Sep 2020 11:44:07 +1000

> Barry proposed that we switch the order, and the specialuse takes priority over the mailboxid.  I am happy to make this change and can see that it makes sense.  Does anybody else have any strong op…

Actually I looked at the text, and it's going to be significantly more complex to switch it :(  By doing mailboxid first, we can then just fall through to the process in RFC8579 including the special behaviour for :create which adds the special-use.

If we intersperse mailboxid then we're going to have to define the process again, and the possibility for confusion is much worse.

Based on that, I think I'd like to keep the existing behaviour - have mailboxid be resolved first and then fall back to specialuse.  If you don't want that, then don't specify a mailboxid at all!  It's not as if it will be created with that ID anyway.

Bron.