Subject: [Extra] Martin Duke's No Objection on draft-ietf-extra-imap-fetch-preview-09: (with COMMENT)

From: Martin Duke via Datatracker <[email-masked]>
Date: Tue, 22 Sep 2020 11:57:57 -0700

Martin Duke has entered the following ballot position for
draft-ietf-extra-imap-fetch-preview-09: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-extra-imap-fetch-preview/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I don't understand the purpose of the phrase "and that decision won't change
later" in Section 3.2. Even if the decision were to change later, if there is
nothing to present there will still be an empty response, no?

---

From: Michael Slusarz <[email-masked]>
Date: Tue, 22 Sep 2020 21:38:32 -0600 (MDT)

> On 09/22/2020 12:57 PM Martin Duke via Datatracker <[email-masked]> wrote:
>

Agreed that this is confusing phrasing.  What if we just dropped "and the decision won't change later"?  So that section becomes:

    It is possible that the server has determined that no meaningful preview text can be
    generated for a particular message.  Examples of this involve encrypted messages, content
    types the server does not support previews of, and other situations where the server is not
    able to extract information for a preview.

I think the "and the decision won't change later" was originally added to distinguish between the case where a server cannot create a preview based on the current message data vs. the case where the server has not yet finished creating the preview due to resource limitations.  However, I think the language in the rest of the document make clear that NIL is only returned if 1) the LAZY modifier is used and 2) the preview has not yet been generated.  Otherwise, a server will always return an empty string indicating that it cannot develop a meaningful preview from the message data.

michael

---

From: Martin Duke <[email-masked]>
Date: Tue, 22 Sep 2020 21:11:29 -0700

That would be fine.

On Tue, Sep 22, 2020, 20:38 Michael Slusarz <
[email-masked]> wrote:

> Agreed that this is confusing phrasing.  What if we just dropped "and the
> decision won't change later"?  So that section becomes:
>
> I think the "and the decision won't change later" was originally added to
> distinguish between the case where a server cannot create a preview based
> on the current message data vs. the case where the server has not yet
> finished creating the preview due to resource limitations.  However, I
> think the language in the rest of the document make clear that NIL is only
> returned if 1) the LAZY modifier is used and 2) the preview has not yet
> been generated.  Otherwise, a server will always return an empty string
> indicating that it cannot develop a meaningful preview from the message
> data.
>
> michael
>