Subject: Re: [Extra] AD review of draft-ietf-extra-sieve-mailboxid-03

From: "Bron Gondwana" <[email-masked]>
Date: Mon, 02 Nov 2020 16:00:06 +1100

On Mon, Sep 7, 2020, at 11:01, Bron Gondwana wrote:
> 
> 
> On Sat, Sep 5, 2020, at 03:23, Barry Leiba wrote:
>> Here's my AD review of the subject document.  I have some issues to
>> discuss about the specification, so please read my comments and let's
>> have the discussion.  I'll set the substrate to "AD Followup".

[...]

>> — Section 4.2 —
>> 
>> What’s the use case for prioritising the mailboxid over the special
>> use?  That also seems an odd choice, given the context of special use
>> mailboxes.  The combination just seems strange — I would normally
>> specify *either* the special use of the mailbox *or* the name, but not
>> both.  Adding mailboxid to that just adds more weirdness.
> 
> That's fair - I would be willing to change the order there.  I expect that nobody will do it, but I don't want to forbid it either, and I want to define a fixed order that works the same across servers.
> 
> I will write an email to the list about this particular issue, so it doesn't get lost in this.

I ran into too much complexity with this in the end.  It means we can't just say "follow the process in the other doc" and instead have to create a big messy state machine that replicates it - for no real benefit.

If you don't want delivery to stick with the mailboxid, then in this case you would indeed create a rule that is just "fileinto by specialuse" and not specify a mailboxid - so the only reason to specify the ID is if you wanted to stick with the mailbox even if the specialuse was moved.  Maybe it doesn't make sense to allow both, but I also don't think it hurts to allow both, and having the ID bind more tightly is clean, because the ID can never be moved to another mailbox.

Bron.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Barry Leiba <[email-masked]>
Date: Mon, 2 Nov 2020 15:28:17 -0500

I'm not sure what complexity you're talking about here.  The real
issue is that I don't see that it's meaningful in any way to specify
both a special use and a mailbox ID.  The mailbox ID is looking for a
specific mailbox, and the special use is looking for whatever mailbox
has the special use.  It seems to me that they're contradictory
options.  So correct me here: what does it *mean* to specify both, and
how does that make any sense?

Once you allow specifying both, THEN you get into complexity because
you're trying to make sense of something that simply doesn't make
sense.

Barry