Subject: [Extra] I-D Action: draft-ietf-extra-quota-04.txt

From: [email-masked]
Date: Mon, 22 Feb 2021 02:43:45 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Email mailstore and eXtensions To Revise or Amend WG of the IETF.

        Title           : IMAP QUOTA Extension
        Author          : Alexey Melnikov
	Filename        : draft-ietf-extra-quota-04.txt
	Pages           : 18
	Date            : 2021-02-22

Abstract:
   The QUOTA extension of the Internet Message Access Protocol (RFC
   3501) permits administrative limits on resource usage (quotas) to be
   manipulated through the IMAP protocol.

   This memo obsoletes RFC 2087, but attempts to remain backwards
   compatible whenever possible.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-extra-quota/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-extra-quota-04
https://datatracker.ietf.org/doc/html/draft-ietf-extra-quota-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-extra-quota-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Timo Sirainen <[email-masked]>
Date: Mon, 22 Feb 2021 12:53:09 +0100

> 	Filename        : draft-ietf-extra-quota-04.txt

This </t> looks like a bug:

                S: A003 NO [OVERQUOTA] APPEND Failed</t>

Also it's not very clear to me what clients should do about soft quota. If they receive untagged OVERQUOTA response, should they do something?

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 22 Feb 2021 13:35:02 +0000

Hi Timo,

>                  S: A003 NO [OVERQUOTA] APPEND Failed</t>
Thanks, I've noticed that after I posted it. I will fix in the next update.
> Also it's not very clear to me what clients should do about soft quota. If they receive untagged OVERQUOTA response, should they do something?

I think they should check the current usage and display it with a 
warning (different text, colour, icon).

Best Regards,

Alexey

---

From: "Bron Gondwana" <[email-masked]>
Date: Tue, 23 Feb 2021 14:13:47 +1100

Thanks Alexey,

Other than the syntax error there, we've already had a working group last call on this document, and there's been no other feedback.

Do you need to add some "advice for clients" to capture your response to Timo in the draft?

I guess you won't be uploading the updated draft until IETF110 starts, so we can chat then about submitting it for publication then.

Cheers,

Bron.

On Tue, Feb 23, 2021, at 00:35, Alexey Melnikov wrote:
> _______________________________________________
> Extra mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/extra
> 

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]